UNPKG

1.03 kBMarkdownView Raw
1# Block library
2
3Block library for the WordPress editor.
4
5## Installation
6
7Install the module
8
9```bash
10npm install @wordpress/block-library --save
11```
12
13_This package assumes that your code will run in an **ES2015+** environment. If you're using an environment that has limited or no support for ES2015+ such as lower versions of IE then using [core-js](https://github.com/zloirock/core-js) or [@babel/polyfill](https://babeljs.io/docs/en/next/babel-polyfill) will add support for these methods. Learn more about it in [Babel docs](https://babeljs.io/docs/en/next/caveats)._
14
15## API
16
17<!-- START TOKEN(Autogenerated API docs) -->
18
19### registerCoreBlocks
20
21[src/index.js#L70-L132](src/index.js#L70-L132)
22
23Function to register core blocks provided by the block editor.
24
25**Usage**
26
27```js
28import { registerCoreBlocks } from '@wordpress/block-library';
29
30registerCoreBlocks();
31```
32
33
34<!-- END TOKEN(Autogenerated API docs) -->
35
36<br/><br/><p align="center"><img src="https://s.w.org/style/images/codeispoetry.png?1" alt="Code is Poetry." /></p>