关于

前言

    这里收集的是汉化新世纪论坛中有关 Inno Setup 的帖子。

    Inno Setup 是一个免费的、功能强大的安装制作软件。通过正确地使用脚本，特别是 [CODE] 段的脚本，你可以给你自己制作的安装程序增添意想不到的功能。

    热心网友 xihua 费尽心血将分散在论坛上的相关资料进行收集、整理和归纳，做成了这个 CHM 格式的帮助文件，方便大家查询和学习。在此我代表大家对 xihua 朋友的辛勤劳动表示衷心的感谢。同时也希望有更多的朋友效法他的做法，把论坛上与某个主题相关的资料进行类似的整理，做成更多的论坛精华。

    该 CHM 文件相当与汉化新世纪论坛的一个镜像，因此与汉化新世纪论坛中的相应帖子具有相同的版权。

    与该论坛精华有关的问题，请到汉化新世纪的论坛上提出，地址见《关于汉化新世纪》。

    gnatix
    汉化新世纪
    2004年8月25日


inno问题

汉化新世纪 -- 自由汉化新天地

> inno问题
订阅此主题 | 邮寄此主题 | 打印此主题
jiangshen | [楼主] 发帖时间 2004年06月24日 17时52分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 怎么样让文件安装在当前目录？？，例如安装文件在D:\abc\下，那么安装的时候不选则路径，自动安装在D:\abc\下？？？ 还有，怎么让安装程序不出现那个欢迎界面，和安装结束界面，点击直接就安装？？
莫名 | [第1楼] 发帖时间 2004年06月24日 18时09分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1328 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | DefaultDirName=D:\abc DisableDirPage=yes DisableReadyPage=yes DisableFinishedPage=yes 帮助文件中都有说明
jiangshen | [第2楼] 发帖时间 2004年06月24日 18时17分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 我不是说指定安装到D盘，我得意思是让他安装到安装程序所在文件夹！！
莫名 | [第3楼] 发帖时间 2004年06月24日 18时30分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1328 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | DefaultDirName={src}\abc
jiangshen | [第4楼] 发帖时间 2004年06月24日 18时44分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | [_ISTool] EnableISX=false 这段代码什么意思，在示例中是不是些错了，反映出来都是很黑色的。。 还有，如果想把升级文件下载到{app}目录下，怎么实现？？ 再有，我如果升级程序直接用带密码FTP来连接，会不会用破解软件查处准确地址？？？
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3072 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


请教大家一个在 inno 中提取安装目录的问题

> 请教大家一个在 inno 中提取安装目录的问题
liangjh | [楼主] 发帖时间 2004年06月23日 10时51分
精灵王 * * * * 组别： 认证用户 帖子数量： 332 用户编号： 11213 注册时间： 2003年02月19日 Member 离线 | 请教大家一个问题，在 inno 中能不能把 在安装时选择的目录提取出来 比如我在安装时选择安装 目录为 “C:\dddd”，那么怎么把这个 “C:\dddd” 提取出来，做为 inno 执行外部程序的一个变量，另外inno中是否能够调用外部程序 如果这个不行，还有哪些安装程序有类似功能 哪位兄弟做过类似的功能，请给点建议 对 inno 的理解比较少 一尘不染，两袖清风！
OFA
[第1楼] 发帖时间 2004年06月23日 11时21分

天使
* * * * * *

组别： 认证用户
帖子数量： 1443
用户编号： 13575
注册时间： 2003年04月13日

Member 离线

{app} 就是安装目录的变量。
调用外部程序用命令需添加 [Run] 段，例如:
代码
[Run]
Filename: "{app}\INIT.EXE"; Parameters: "/x"
Filename: "{app}\README.TXT"; Description: "查看自述文件"; Flags: postinstall shellexec skipifsilent
Filename: "{app}\MYPROG.EXE"; Description: "运行应用程序"; Flags: postinstall nowait skipifsilent unchecked

对于每个 Flag 详细的意义及使用方法请参考说明文件。莫名兄汉化的说明十分出色！

user posted image
愿为汉化事业贡献自己的一份微薄之力。
欢迎您访问我的净土 http://www.cokemouse.com/
liangjh | [第2楼] 发帖时间 2004年06月23日 11时50分
精灵王 * * * * 组别： 认证用户 帖子数量： 332 用户编号： 11213 注册时间： 2003年02月19日 Member 离线 | 谢谢 OFA 兄弟 我试试能不能传递过去参数 Filename: "{app}\INIT.EXE"; Parameters: "/x" 莫名兄汉化的帮助的确费了很多心力，很是佩服 一尘不染，两袖清风！
liangjh | [第3楼] 发帖时间 2004年06月23日 14时40分
精灵王 * * * * 组别： 认证用户 帖子数量： 332 用户编号： 11213 注册时间： 2003年02月19日 Member 离线 | Filename: "{app}\INIT.EXE"; Parameters: "/x" 在这里 inno 把 "/x" 做为一个整体传递给外部程序了 比如： Filename: "{app}\CHANGE.EXE"; Parameters: "/i setting.ini /from """"D:\aaaa"""" /to {app}" 我想把 D:\aaa 替换成 c:\aaa（安装时选择的目录），但是这时传递的{app}自然不能被程序识别 这个功能应该算是一个特例，如果作者在inno离加一个判断应该很容易实现了 一尘不染，两袖清风！
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.6037 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


还是 inno setup 的问题

> 还是 inno setup 的问题
yagas | [楼主] [image] 发帖时间 2004年03月01日 10时59分
侠客 * 组别： 认证用户 帖子数量： 38 用户编号： 21498 注册时间： 2004年02月21日 Member 离线 | 同于对inno setup的脚本不熟！请问如何知道软本件早期版本的安装目录，就将新版本的安装路径指向那个目录进行安装？ 就像 inno setup 会自己找到前一个版本的安装目录一样？？
chenmy | [第1楼] 发帖时间 2004年03月01日 11时15分
天使 * * * * * * 组别： 超级版主 帖子数量： 1468 用户编号： 1794 注册时间： 2002年04月28日 Member 离线 | 从注册表中获得早期版本的安装目录。 我爱自然之家！—我爱汉化！ user posted image user posted image 我是中国人·最爱是中文！ user posted image
gnatix | [第2楼] 发帖时间 2004年03月01日 14时44分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2667 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 如果那个软件把安装目录纪录在注册表中的话，是可以做到的，只要使用常数，比如： {reg:HKLM\Software\My Program,Path|{pf}\My Program} 不过有些软件并不纪录，那就没有办法了。 user posted image Tervetuloa!
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.2964 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


Inno Setup的文件目录问题！谢谢

> Inno Setup的文件目录问题！谢谢, Inno Setup的文件目录问题！谢谢
zjj1988101 | [楼主] 发帖时间 2004年03月06日 19时45分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 就是搜索以前的安装目录的脚本应该是怎么样的~ 论坛上有但是我不知道应该修改哪个地方才可以变成自己的东西~达到自己想要的目的 谢谢！
gnatix | [第1楼] 发帖时间 2004年03月06日 20时07分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 如果你已经用 Inno Setup 安装过某个软件，那么可以用下面的语句把新的版本安装到以前的安装目录中： [Setup] DefaultDirName={reg:HKLM\Software\Microsoft\windows\CurrentVersion\Uninstall\XXXXX_is1,Inno Setup: App Path|{pf}\YYYYY} 这里 XXXXX 表示软件的名称 YYYYY 表示在找不到原来的安装目录时应该使用的替代安装目录。 user posted image
zjj1988101 | [第2楼] 发帖时间 2004年03月06日 21时10分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 万分感谢
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3008 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


Inno Setup记录安装目录的问题~

> Inno Setup记录安装目录的问题~, 如题~请高手指点~！
订阅此主题 | 邮寄此主题 | 打印此主题
zjj1988101 | [楼主] 发帖时间 2004年03月21日 13时54分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 请问怎么才可以用Inno Setup打包的程序在安装的时候记录安装目录的位置~ 以便以后删除后再装或升级的时候自动找的以前版本的安装目录安装~ 请指点~
zjj1988101 | [第1楼] 发帖时间 2004年03月21日 16时55分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 请帮忙哦
莫名 | [第2楼] 发帖时间 2004年03月21日 20时45分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1322 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 只要前后两个安装程序制作时将 [Setup] 段 AppId 设置相同，并将 [Setup] 段的 UsePreviousAppDir 设为 yes 即可。
莫名 | [第3楼] 发帖时间 2004年03月21日 20时47分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1322 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 卸载后再装就没有办法了。
zjj1988101 | [第4楼] 发帖时间 2004年03月21日 21时03分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 那QQ做比方怎么样才可以在安装前自动搜索到这个目录？象木子版的QQ就做到的~ 我查了很长时间才查到这个~ 但是不知道脚本该怎么写 这个注册表位置是 HKEY_LOCAL_MACHINE\SOFTWARE\Tencent\QQ 下面的Install 请再次指点 附图 附图
莫名 | [第5楼] 发帖时间 2004年03月21日 21时15分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1322 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 感觉 QQ 不是用 INNO 做的程序吧，以前记得是 NSIS，我从未用过 QQ。 下面是我已经做的一个 NSIS 脚本中的一部分： Function .onInit ReadRegStr $INSTDIR HKCR "MagicISO.Document\shell\open\command" "" StrCmp $INSTDIR "" Nopath ; 下面一句是由于读取的注册表值长了 16个字符(包括了文件名和执行参数共16个字符)，所以切去 16 个字符。 StrCpy $INSTDIR $INSTDIR -16 Goto Yespath Nopath: StrCpy $INSTDIR 你好象没有安装原版程序！ Yespath: FunctionEnd
zjj1988101 | [第6楼] 发帖时间 2004年03月22日 16时14分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 那木子版的QQ是用INNO做的哦~ NSIS我不会用~不好意思~
gnatix
[第7楼] 发帖时间 2004年03月23日 03时29分

天使
* * * * * *

组别： 超级版主
帖子数量： 2407
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (zjj1988101 @ 2004年03月21日 21时03分)
那QQ做比方怎么样才可以在安装前自动搜索到这个目录？象木子版的QQ就做到的~
我查了很长时间才查到这个~
但是不知道脚本该怎么写
这个注册表位置是
HKEY_LOCAL_MACHINE\SOFTWARE\Tencent\QQ
下面的Install
请再次指点

DefaultDirName={reg:HKLM\Software\Tencent\QQ,Install|{pf}\YourProgDir}
表示如果找到注册表里的值，则安装到 Install 里面的文件夹，否则安装到默认文件夹，比如：
C:\Program files\YourProgrDir
user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3320 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


【求助】

> 【求助】, 这种安装哪种安装制作软件能做到?
订阅此主题 | 邮寄此主题 | 打印此主题
吴山天风 | [楼主] 发帖时间 2004年07月12日 10时13分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 1899 注册时间： 2002年05月03日 Member 离线 | 有一个 Adobe 的软件有几个文件汉化后需要安装到以下目录: "%systemdrive%\Documents and Settings\%username%\Application Data\Adobe\" 试了一些安装制作软件都不行, 哪种安装制作软件能做到? (属于多目录安装, 另外的文件还需要安装到二个目录)
gnatix | [第1楼] 发帖时间 2004年07月12日 13时19分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2686 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 用 Inno 就可以： [Files] Source: "F:\sourcefiles\*.*"; DestDir: "{userappdata}\Adobe" user posted image
吴山天风 | [第2楼] 发帖时间 2004年07月12日 20时05分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 1899 注册时间： 2002年05月03日 Member 离线 | 用 Wise Installation System 或 Wise for Windows Installer 可以实现吗,试了不行, 不知要如何设置, 其它部分已经用这二个做好了.
刘波 | [第3楼] 发帖时间 2004年07月13日 00时21分
版主 * * * * * 组别： 认证用户 帖子数量： 786 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | Wise 肯定行的。不过具体怎么弄我也忘记了。早没用它了。现在投入 INNO SETUP 的怀抱！ 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3024 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


【问题】请教该用什么补丁制作工具

> 【问题】请教该用什么补丁制作工具
东北虎 | [楼主] 发帖时间 2004年06月05日 10时40分
侠客 * 组别： 用户 帖子数量： 18 用户编号： 24569 注册时间： 2004年05月11日 Member 离线 | 有多个目录的文件需要汉化，而且有长文件名（＞8），试过用 Wise Installation System，但发现在98下安装后长文件名文件变成了xxxxxx~1.xxx，导致软件不能运行，请问该用什么样的补丁制作工具能解决这个问题？
OFA | [第1楼] 发帖时间 2004年06月05日 14时22分
天使 * * * * * * 组别： 认证用户 帖子数量： 1443 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | 几乎每个软件都支持多目录吧？ Inno Setup 简单易用 user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
pk4321 | [第2楼] 发帖时间 2004年06月05日 15时37分
圣骑士 * * * 组别： 认证用户 帖子数量： 170 用户编号： 770 注册时间： 2002年01月10日 Member 离线 | 今天试用了InnoSetup + Patch Factory 来制作补丁安装程序！ 提供一段提取原软件的安装目录的ISS脚本示例： [Setup] AppName=PrevInst AppVerName=PrevInst DefaultDirName={code:GetOldPath|{pf}\API-Guide} DisableStartupPrompt=true Uninstallable=false UsePreviousAppDir=false EnableDirDoesntExistWarning=true DirExistsWarning=no AppendDefaultDirName=false [Code] function GetOldPath(Default: String): String; var sPath: String; begin RegQueryStringValue( HKCU, 'Software\KPD-Team\API-Guide', 'InstallDirectory', sPath ); Result := sPath; end;
gnatix
[第3楼] 发帖时间 2004年06月05日 16时14分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2686
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (pk4321 @ 2004年06月05日 15时37分)
今天试用了InnoSetup + Patch Factory 来制作补丁安装程序！

提供一段提取原软件的安装目录的ISS脚本示例：

[Setup]
AppName=PrevInst
AppVerName=PrevInst
DefaultDirName={code:GetOldPath|{pf}\API-Guide}
DisableStartupPrompt=true
Uninstallable=false
UsePreviousAppDir=false
EnableDirDoesntExistWarning=true
DirExistsWarning=no
AppendDefaultDirName=false

[Code]
function GetOldPath(Default: String): String;
var
sPath: String;
begin
RegQueryStringValue( HKCU, 'Software\KPD-Team\API-Guide', 'InstallDirectory', sPath );
Result := sPath;
end;

不必这么麻烦，直接这样就行了：
[Setup]
DefaultDirName={reg:HKCU\Software\KPD-Team\API-Guide,InstallDirectory|{pf}\API-Guide}

user posted image
? 上一个主题 | Windows 软件汉化 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3820 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


Inno Setup 变量的问题

> Inno Setup 变量的问题
莫尼卡 | [楼主] 发帖时间 2004年07月29日 10时01分
圣骑士 * * * 组别： 认证用户 帖子数量： 246 用户编号： 4599 注册时间： 2002年08月26日 Member 离线 | 如果我要把文件复制到系统的安装目录的 System、System32 下要怎么写。是 {sys} 就可以了吗？ I love you! (you=emulator) user posted image
gnatix | [第1楼] 发帖时间 2004年07月29日 13时57分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 是的。 user posted image
pk4321 | [第2楼] 发帖时间 2004年07月31日 10时39分
圣骑士 * * * 组别： 认证用户 帖子数量： 170 用户编号： 770 注册时间： 2002年01月10日 Member 离线 | 我想问一下： 安装脚本中定义了一些的组件，还加了任务想让用户选择将组件安装在系统目录还是程序目录。 目前的实现方法是在脚本中将所有的组件文件复制一次，然后再设置不同的任务。 但是这样在选择安装组件页面时，又显示不出组件的大小。有没有更好的解决办法？ 另外，有人知道如何将安装目录变量{app}中的“\”改成“\\”吗？ 我用下面代码出错了！ [Code] function strAppx(Default: String): String; begin Result :=StringChange( ExpandConstant('{app}') , '\' , '\\' ); end; 还有一点感觉是，如果觉得用InnoSetup的脚本不好实现的东西，可以试试结合Wise 9.02来做。
gnatix
[第3楼] 发帖时间 2004年07月31日 13时40分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用
安装脚本中定义了一些的组件，还加了任务想让用户选择将组件安装在系统目录还是程序目录。
目前的实现方法是在脚本中将所有的组件文件复制一次，然后再设置不同的任务。
但是这样在选择安装组件页面时，又显示不出组件的大小。有没有更好的解决办法？

试试这样：
先将那些文件安装到临时文件夹，然后根据用户的选择再将这些文件复制到程序文件夹或者系统文件夹。
在下面的示例脚本中，如果用户选择了组件“库文件”，将让用户选择是将库文件安装到程序目录还是系统目录。最后根据用户的选择将这些库文件复制到相当的目标。

代码
; 示例脚本 made by gnatix

[Setup]
AppName=test001
AppVerName=test001
DefaultDirName={pf}\test001
DefaultGroupName=test001

[Types]
Name: "full"; Description: "完全安装"; Flags: iscustom
Name: "compact"; Description: "精简安装"
Name: "custom"; Description: "自定义安装"

[Components]
Name: "program"; Description: "主文件（必需）"; Types: full compact custom; Flags: fixed
Name: "manual"; Description: "使用手册"; Types: full compact custom
Name: "sound"; Description: "媒体文件"; Types: full custom
Name: "dll"; Description: "运行库文件"; Types: full custom

[Files]
Source: "C:\test\prog\*.*"; DestDir: "{app}"; Flags: ignoreversion; Components: program
Source: "C:\test\manual\*.*"; DestDir: "{app}"; Flags: ignoreversion; Components: manual
Source: "C:\test\sound\*.*"; DestDir: "{app}\sound"; Flags: ignoreversion; Components: sound
Source: "C:\test\dll\abc.dll"; DestDir: "{tmp}"; Flags: ignoreversion; Components: dll

[Tasks]
Name: "dlltowhere/app"; Description: "程序文件夹"; GroupDescription: "你想要将库文件安装到哪里？"; Flags: exclusive; Components: dll
Name: "dlltowhere/sys"; Description: "系统文件夹"; GroupDescription: "你想要将库文件安装到哪里？"; Flags: unchecked exclusive; Components: dll

[Run]
Filename: "{cmd}"; Parameters: "/c copy ""{tmp}\abc.dll"" ""{app}"""; Description: "复制文件"; Flags: nowait hidewizard runhidden; Tasks: "dlltowhere/app"
Filename: "{cmd}"; Parameters: "/c copy ""{tmp}\abc.dll"" ""{sys}"""; Description: "复制文件"; Flags: nowait hidewizard runhidden; Tasks: "dlltowhere/sys"

user posted image
gnatix
[第4楼] 发帖时间 2004年07月31日 13时50分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用
另外，有人知道如何将安装目录变量{app}中的“\”改成“\\”吗？
我用下面代码出错了！
[Code]
function strAppx(Default: String): String;
begin
Result :=StringChange( ExpandConstant('{app}') , '\' , '\\' );
end;

函数 StringChange(XXX, '\', '\\') 中的 XXX 必须是一个变量，因为它要保存修改后的结果。你现在放入的是一个常量（固定不变的东西），所以出错。

改成这样就没有问题了：
function strAppx(Default: String): String;
begin
Result := ExpandConstant('{app}');
StringChange(Result, '\' , '\\' );
end;

user posted image
pk4321
[第5楼] 发帖时间 2004年07月31日 16时52分

圣骑士
* * *

组别： 认证用户
帖子数量： 170
用户编号： 770
注册时间： 2002年01月10日

Member 离线

引用 (gnatix @ 2004年07月31日 13时40分)
试试这样：
先将那些文件安装到临时文件夹，然后根据用户的选择再将这些文件复制到程序文件夹或者系统文件夹。
在下面的示例脚本中，如果用户选择了组件“库文件”，将让用户选择是将库文件安装到程序目录还是系统目录。最后根据用户的选择将这些库文件复制到相当的目标。

这样还是解决得不够好，如果要安装的文件比较多，这样通过tmp来中转会浪费比较多的时间，而且占用更多的临时空间。

看看能不能通过类似下面的方法来做：
[Tasks]
Name: inapp; Description: 安装在程序目录; Flags: exclusive
Name: insys; Description: 安装在系统目录; Flags: exclusive

[Files]
...
Source: OCX\COMCTL32.OCX; DestDir: {code:usrSelDir|{sys}}; Flags: regserver; Components: oth\ComCtl32;
...

[code]
function usrSelDir(Default: String): String;
begin
if then //“用户选择的Tasks为inapp”的条件语句什么写？
Result :=ExpandConstant('{app}');
else
Result :=ExpandConstant('{sys}');
end;

gnatix | [第6楼] 发帖时间 2004年07月31日 17时35分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 用 Code 代码，实现的可能性当然就多了。 调用函数 WizardSelectedTasks(false) 可以获取用户选择的安装任务。所以你上面的代码可以是： function usrSelDir(Default: String): String; begin if Pos('inapp',WizardSelectedTasks(false))>0 then Result := ExpandConstant('{app}') else Result :=ExpandConstant('{sys}'); end; user posted image
pk4321
[第7楼] 发帖时间 2004年07月31日 19时52分

圣骑士
* * *

组别： 认证用户
帖子数量： 170
用户编号： 770
注册时间： 2002年01月10日

Member 离线

引用 (gnatix @ 2004年07月31日 17时35分)
用 Code 代码，实现的可能性当然就多了。
调用函数 WizardSelectedTasks(false) 可以获取用户选择的安装任务。所以你上面的代码可以是：
function usrSelDir(Default: String): String;
begin
if Pos('inapp',WizardSelectedTasks(false))>0 then
Result := ExpandConstant('{app}')
else
Result :=ExpandConstant('{sys}');
end;

多心赐教！

不嫌弃的话，试试我制作的“VB6精装版”！

12M
http://powerkit.vicp.net/vb6expr.exe
leyan22 | [第8楼] 发帖时间 2004年08月01日 22时36分
骑士 * * 组别： 认证用户 帖子数量： 51 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | VB6 还不错！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3311 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


inno setup制作安装程序的问题

> inno setup制作安装程序的问题
bcff2002 | [楼主] 发帖时间 2004年03月24日 07时23分
侠客 * 组别： 认证用户 帖子数量： 49 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 如何设置，使安装的时候检测程序是否正在使用，从而不重复安装呢。看帮助文件，就是在setup段加上AppMutex=MyProgramsMutexName，但是我加上后还是不能检测到程序在运行。 输入法大全 http://www.bcff2002.com
gnatix | [第1楼] 发帖时间 2004年03月24日 18时19分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 如果你的程序中没有创建 “MyProgramsMutexName” 这样一个互斥的应用程序，那么当然是检测不到的。帮助文件中已经讲得很清楚了。 附图 附图 user posted image
莫名 | [第2楼] 发帖时间 2004年03月24日 21时09分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1322 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 请到 INNO 的网站下载 INNO SETUP 的安装脚本看看。
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.4194 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


用inno setup制作安装程序时，如何检测到程序已经安装了

> 用inno setup制作安装程序时，如何检测到程序已经安装了
bcff2002 | [楼主] 发帖时间 2004年05月08日 20时39分
侠客 * 组别： 认证用户 帖子数量： 49 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 我用inno制作了一个安装程序，当程序安装完后，再次安装时仍然可以继续安装。我想能否自动检测出程序已经安装过呢，这样就不用再次安装了。 输入法大全 http://www.bcff2002.com
gnatix
[第1楼] 发帖时间 2004年05月08日 21时55分

天使
* * * * * *

组别： 超级版主
帖子数量： 2406
用户编号： 377
注册时间： 2001年10月17日

Member 离线

关键要看你是怎样来判断程序是否已经安装了。参考以下例子：
假如你的程序将要安装到 {pf}\MyProgDir，如果在该文件夹中已经有你想要安装的文件 MyProg.exe，那么你认为该程序算是已经安装了。在这种情况下你可以用以下脚本实现你的想法：

[Code]
function InitializeSetup(): boolean;
begin
Result := true;
if FileExists(ExpandConstant('{pf}\MyProgDir\MyProg.exe')) then
begin
MsgBox('程序已经安装在你的系统中了！', mbInformation, MB_OK );
Result := false;
end;
end;

user posted image
bcff2002 | [第2楼] 发帖时间 2004年05月08日 23时29分
侠客 * 组别： 认证用户 帖子数量： 49 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 谢谢，按高手的指点，问题已经解决了。再次感谢了！！！ 输入法大全 http://www.bcff2002.com
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3040 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


【求助】

> 【求助】, Inno Setup 安装判断问题
吴山天风
[楼主] 发帖时间 2004年07月21日 09时17分

侠客
*

组别： 用户
帖子数量： 26
用户编号： 1899
注册时间： 2002年05月03日

Member 离线

用 Inno setup 制作一个在原版基础上部分文件覆盖安装的安装程序, 在选择安装目录时需要判断所选择的安装目录中原版主程序是否存在, 如果不存在提示重新选择安装目录, 若存在继续下一步安装.

我参考了搜索到的旧贴:
function InitializeSetup(): boolean;
begin
Result := true;
if FileExists(ExpandConstant('{pf}\MyProgDir\MyProg.exe')) then
begin
MsgBox('程序已经安装在你的系统中了！', mbInformation, MB_OK );
Result := false;
end;
end;

稍改了一下:
function InitializeSetup(): boolean;
begin
Result := true;
if FileExists(ExpandConstant('{app}\MyProgDir\MyProg.exe'))=false then
begin
MsgBox('安装目录不正确！', mbInformation, MB_OK );
Result := false;
end;
end;

但是安装程序在一开始运行时就使用"默认安装目录"进行了判断, 而并不是在选择安装目录时再判断, 请教这要如何写代码.
youth9999 | [第1楼] 发帖时间 2004年07月21日 13时23分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 按你上所的修改，肯定是通不过的，偶试过了，偶也想知道！
gnatix | [第2楼] 发帖时间 2004年07月21日 13时31分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2687 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 你这个脚本只是在安装程序运行前进行检查的，而这个时候用户还根本没有选择安装目录，只是你自己设置了一个默认安装目录而已。所以如果用户的程序没有安装在你说的默认目录中，那么检查永远是通不过的，也就是说用户永远不能使用你的安装程序。 最好是在用户选择了安装目录，按下一步时进行检查，如果检查不通过，弹出信息后又回到那个选择安装目录的页面。 另外： if FileExists(ExpandConstant('{app}\MyProgDir\MyProg.exe'))=false then 应该是 if FileExists(ExpandConstant('{pf}\MyProgDir\MyProg.exe'))=false then user posted image
gnatix | [第3楼] 发帖时间 2004年07月21日 13时39分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2687 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 这是正确的脚本： function NextButtonClick(CurPage: Integer): Boolean; begin Result:= true; if CurPage=wpSelectDir then if not FileExists(ExpandConstant('{app}\汉化说明.txt')) then begin MsgBox('安装目录不正确！', mbInformation, MB_OK ); Result := false; end; end; user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3036 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


如何让 Inno Setup 做的安装程序-不创建程序菜单？谢谢！

> 如何让 Inno Setup 做的安装程序-不创建程序菜单？谢谢！
订阅此主题 | 邮寄此主题 | 打印此主题
青青 | [第5楼] [image] 发帖时间 2004年06月24日 01时34分
侠客 * 组别： 认证用户 帖子数量： 40 用户编号： 25599 注册时间： 2004年05月31日 Member 离线 | 新的问题！ 用右键点击做好的安装程序，在出现的菜单中选择“属性”回出现下面的窗口面板，问题如图所示。 期待解答！ 谢谢！ 附图 附图
jiangshen | [第6楼] 发帖时间 2004年06月24日 06时59分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 用eXeScope等汉化软件可以修改
青青
[第7楼] [image] 发帖时间 2004年06月25日 09时43分

侠客
*

组别： 认证用户
帖子数量： 40
用户编号： 25599
注册时间： 2004年05月31日

Member 离线

引用 (jiangshen @ 2004年06月24日 06时59分)
用eXeScope等汉化软件可以修改

谢谢你的提醒！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.6631 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


关于 Inno Setup 的汉化细节

> 关于 Inno Setup 的汉化细节
Colin | [楼主] 发帖时间 2004年03月16日 18时28分
新手上路 * 组别： 用户 帖子数量： 7 用户编号： 22385 注册时间： 2004年03月16日 Member 离线 | 莫名君汉化的 Inno Setup 比较全面，有个问题想请教一下。那个“关于安装程序”的内容在哪里呢？用 eXeScope 和 ResHack 都找不到这个细节。我并不是也想汉化 Inno Setup ，自认为不会比莫名君做得更好了。只是最近想用 Inno Setup 做一个安装程序，却发现这个细节无论如何也无法汉化到。恳请各位朋友多多指点迷津。 附图 附图
gnatix | [第1楼] 发帖时间 2004年03月16日 19时57分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2667 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 可能是 ASCII 非标准资源。你用 UltraEdit 先检查一下看看。 ASCII 非标准资源的汉化，请参考汉化宝典。 user posted image Tervetuloa!
Colin | [第2楼] 发帖时间 2004年03月16日 20时22分
新手上路 * 组别： 用户 帖子数量： 7 用户编号： 22385 注册时间： 2004年03月16日 Member 离线 | 好的，谢谢！经过 UltraEdit 的搜索，已经发现相关信息，尝试根据安装程序的实际需要进行修改。
Colin | [第3楼] 发帖时间 2004年03月16日 21时15分
新手上路 * 组别： 用户 帖子数量： 7 用户编号： 22385 注册时间： 2004年03月16日 Member 离线 | 奇怪，即使 Inno Setup 主程序已经汉化，默认的语言文件 Default.isl 也已经根据需要进行了特别汉化，最后编译完成的安装程序还是英文。 附图 附图
莫名 | [第4楼] 发帖时间 2004年03月16日 21时28分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1328 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 这幅图是什么时候出现的？找了半天还没有找到。
pk4321 | [第5楼] 发帖时间 2004年03月16日 21时42分
圣骑士 * * * 组别： 认证用户 帖子数量： 170 用户编号： 770 注册时间： 2002年01月10日 Member 离线 | 这个是在编译后的安装程序中在窗口的左上角的图标处鼠标点击的系统菜单about...后出现的～
Colin | [第6楼] 发帖时间 2004年03月16日 21时45分
新手上路 * 组别： 用户 帖子数量： 7 用户编号： 22385 注册时间： 2004年03月16日 Member 离线 | 安装程序的选单栏右键单击，选择“关于安装程序”这项。
Colin | [第7楼] 发帖时间 2004年03月16日 21时59分
新手上路 * 组别： 用户 帖子数量： 7 用户编号： 22385 注册时间： 2004年03月16日 Member 离线 | 我尝试了一下，即便把 Compil32.exe 里面 UltraEdit 能够搜到的 php 网址更改为其他名字，最后编译完成的安装程序在这个位置还是显示为原有的 ...ifps3.php 。难道说相关文件信息不在这个文件里面？ 附图 附图
莫名 | [第8楼] 发帖时间 2004年03月16日 22时14分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1328 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 你找错地方了，在 Setup.e32 中，注意用点睛查 delphi 字符。
Colin | [第9楼] 发帖时间 2004年03月16日 22时24分
新手上路 * 组别： 用户 帖子数量： 7 用户编号： 22385 注册时间： 2004年03月16日 Member 离线 | 果然，找错了地方。
Colin | [第10楼] 发帖时间 2004年03月17日 11时58分
新手上路 * 组别： 用户 帖子数量： 7 用户编号： 22385 注册时间： 2004年03月16日 Member 离线 | “点睛”试用版感觉限制多多，最后还是用 UltraEdit 修改了相关信息，应该说已经符合标准了。谢谢诸位朋友指点。 附图 附图
« 上一个主题 | Windows 软件汉化 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 2.3090 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


【求助】InnoSetup使用问题

> 【求助】InnoSetup使用问题, 关于打包文件信息
youth9999 | [楼主] 发帖时间 2004年07月01日 16时13分
侠客 * 组别： 用户 帖子数量： 18 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 哪位大侠能告知如何在用InnoSetup打包时修改如下图中偶用红框标示的部分中的信息？先谢过了！ 附图 附图
fenghua | [第1楼] 发帖时间 2004年07月01日 17时23分
骑士 * * 组别： 用户 帖子数量： 55 用户编号： 4465 注册时间： 2002年08月22日 Member 离线 | 改这里 附图 附图 user posted image 欢迎光临国内最大的 CAD 专业论坛【晓东 CAD 论坛】
fenghua | [第2楼] 发帖时间 2004年07月01日 17时24分
骑士 * * 组别： 用户 帖子数量： 55 用户编号： 4465 注册时间： 2002年08月22日 Member 离线 | 效果 附图 附图 user posted image 欢迎光临国内最大的 CAD 专业论坛【晓东 CAD 论坛】
youth9999 | [第3楼] 发帖时间 2004年07月02日 19时36分
侠客 * 组别： 用户 帖子数量： 18 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 如果是直接修改资源偶知道啊，偶想知道的是如何在Inno Setup的脚本里实现，也就是在打包的时候控制啊！
ah47sm | [第4楼] 发帖时间 2004年07月02日 20时03分
圣骑士 * * * 组别： 认证用户 帖子数量： 112 用户编号： 15774 注册时间： 2003年07月01日 Member 离线 | ;文件属性里的备注（描述） VersionInfoDescription=产品的描述信息 >>> Welcome to My Website China Serials 2000 <<<
youth9999 | [第5楼] 发帖时间 2004年07月02日 20时13分
侠客 * 组别： 用户 帖子数量： 18 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 先谢谢楼上的，偶再仔细研读一下帮助文件！但上面Quote的这些是针对Inno的吗(难道不是NSIS的 [image] )？如果是又是放在哪一部分的呢？偶愚钝！请再指教！谢谢！
gnatix | [第6楼] 发帖时间 2004年07月03日 04时20分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 在安装脚本文件中添加： [Setup] VersionInfoCompany=汉化新世纪 VersionInfoDescription=Floppy Image 2.2.5 注册汉化版安装程序 VersionInfoVersion=2.2.5 其它地方必须通过修改 SetupLdr.e32 文件来实现。 附图 附图 user posted image
youth9999 | [第7楼] 发帖时间 2004年07月03日 08时19分
侠客 * 组别： 用户 帖子数量： 18 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 谢谢老虎板板和楼上的几位，看来还得要修改资源！ 但版权信息、产品名称和产品版本这几个项目也只能通过修改资源的方法实现吗？老虎板板知否？
大番茄 | [第8楼] 发帖时间 2004年07月03日 09时48分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 又学了一点!! 番茄花园: http://tomatolei.com
ah47sm
[第9楼] 发帖时间 2004年07月03日 09时56分

圣骑士
* * *

组别： 认证用户
帖子数量： 112
用户编号： 15774
注册时间： 2003年07月01日

Member 离线

引用 (youth9999 @ 2004年07月03日 08时19分)
谢谢老虎板板和楼上的几位，看来还得要修改资源！
但版权信息、产品名称和产品版本这几个项目也只能通过修改资源的方法实现吗？老虎板板知否？

到目前为止，是这样的，作者没有把这几项加入可自定义的行列里

>>> Welcome to My Website China Serials 2000 <<<
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3306 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


一个很菜的问题

> 一个很菜的问题
潇潇公子 | [楼主] [image] 发帖时间 2004年03月11日 22时29分
新手上路 * 组别： 用户 帖子数量： 6 用户编号： 22191 注册时间： 2004年03月11日 Member 离线 | 怎么我用 inno setup 制作的安装程序运行的时候不会出现 现在将安装****。是否继续？ 这个提示啊？
gnatix | [第1楼] 发帖时间 2004年03月12日 03时11分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2667 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 因为你的脚本文件里面有以下语句： [Setup] DisableStartupPrompt=yes 如果你希望出现那个提示对话框，只要把这个语句删除就行了。 user posted image Tervetuloa!
潇潇公子 | [第2楼] 发帖时间 2004年03月12日 08时58分
新手上路 * 组别： 用户 帖子数量： 6 用户编号： 22191 注册时间： 2004年03月11日 Member 离线 | 非常感谢
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.8026 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


Inno Setup 4.1.5 的问题

> Inno Setup 4.1.5 的问题
心魔 | [楼主] 发帖时间 2004年02月12日 21时58分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 19462 注册时间： 2003年12月06日 Member 离线 | Inno Setup 4.1.5这个安装制作程序能不能像Installer VISE 3.6一样做一个安装背景图之类的？或像Wise Installation System 9.02一样，做一个启动画面和安装背景音乐？请高手指教一下~~~
雷骏 | [第1楼] 发帖时间 2004年02月12日 23时13分
天使 * * * * * * 组别： 认证用户 帖子数量： 1339 用户编号： 2835 注册时间： 2002年06月12日 Member 离线 | 你说的这些都不支持呢吧！ user posted image user posted image user posted image user posted image
OFA | [第2楼] 发帖时间 2004年02月13日 03时30分
天使 * * * * * * 组别： 认证用户 帖子数量： 1443 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | Inno Setup 跟 wise 这些专业软件相比，还是简单了一些。 user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com/
奡纛 | [第3楼] 发帖时间 2004年02月13日 22时16分
新手上路 * 组别： 用户 帖子数量： 3 用户编号： 21256 注册时间： 2004年02月13日 Member 离线 | 安装背景好像借助istool可以的吧
mapeng
[第4楼] 发帖时间 2004年02月13日 22时32分

精灵王
* * * *

组别： 认证用户
帖子数量： 297
用户编号： 19595
注册时间： 2003年12月11日

Member 离线

也可以在脚本中设置，但是不是楼主想要的那种，是用一个兰色背景（可改颜色）。

在脚本中加入，看例图：
BackColor=$FF0000
BackColor2=$000000
; 老式安装界面的全屏背景色彩。这里的色彩值是BBGGRR, 而不是网页中所常用的RRGGBB. 或者使用预定义的颜色名称: clBlack, clMaroon, clGreen, clOlive, clNavy, clPurple, clTeal, clGray, clSilver, clRed, clLime, clYellow, clBlue, clFuchsia, clAqua, clWhite.
WindowShowCaption=yes
; 是否显示老式安装界面的窗口标题
WindowVisible=no
; 是否出现老式安装界面的窗口。win2000风格应设为no，而win95老风格一般设为yes
WizardStyle=modern
; 选择安装界面风格。一般设为modern，是win2000现代风格；设为classic则是win95老风格
;WizardImageFile=compiler:WizModernImage.bmp
; 设定安装界面可显示的自定义图片（大）。不用此命令时系统采用默认图片。现代风格图片尺寸164x314像素，老风格为117x263
;WizardSmallImageFile=compiler:WizModernSmallImage.bmp
; 设定安装界面可显示的自定义图片（小）。不用此命令时系统采用默认图片。图片尺寸55x55
WizardImageBackColor=$000000
; 安装界面图片背景色

附图
附图

我的外表很传统,我的内心很反叛;我的行动很规矩,我的思想却激进;我的语言很尖刻,我的性情很温柔;我的眼光很挑剔,我的能力却有限;我的理想很伟大,我的现状很平凡;我的头脑很灵活,我的双手却笨拙;我的睡眠很踏实,我的美梦很有限;我的长相很酷毙,我的女友却没影。 user posted image
bioggi | [第5楼] 发帖时间 2004年02月16日 14时36分
新手上路 * 组别： 用户 帖子数量： 1 用户编号： 21325 注册时间： 2004年02月16日 Member 离线 | 在IsTool中的Option可以添加此类信息。 附图 附图
softsword | [第6楼] 发帖时间 2004年02月16日 21时04分
精灵王 * * * * 组别： 认证用户 帖子数量： 367 用户编号： 17697 注册时间： 2003年09月28日 Member 离线 | 呵呵，世纪里面就有 IsTool 的汉化版啊！bioggi 怎么还用英文版啊？ 夏天来了，天气热了，一群“BT”往北飞，一会儿排成“B”字，一会儿排成“T”字 …… user posted image 孔子东游，遇二小儿辩斗，问其故。 一小儿曰：我以日本生自山东，故属东。 一小儿曰：夕阳西下，日本归山西也明矣，是以属西。 孔子不能决，后以问老子（本人也）。 老子笑曰：孰为汝多知乎？日本无根基，岂能算东西 ！ user posted image
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3156 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


Inno Setup v4.1.4 怎样用语句定义安装文件生成的图标?

> Inno Setup v4.1.4 怎样用语句定义安装文件生成的图标?
订阅此主题 | 邮寄此主题 | 打印此主题
心魔 | [楼主] 发帖时间 2004年02月11日 21时10分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 19462 注册时间： 2003年12月06日 Member 离线 | Inno Setup v4.1.4 怎样用语句定义安装文件生成的图标?我改不了，总是默认的××××弄了半天都没有个所以然，望高手指教，先谢谢了。。
莫名 | [第1楼] 发帖时间 2004年02月12日 08时12分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1328 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 软件本身没有这个功能，可以查阅软件目录中的常见问题解答文件，里面有这个的说明，我都翻译了。
fenghua
[第2楼] 发帖时间 2004年02月12日 10时47分

骑士
* *

组别： 用户
帖子数量： 55
用户编号： 4465
注册时间： 2002年08月22日

Member 离线

引用 (莫名 @ 2004年02月12日 08时12分)
软件本身没有这个功能，可以查阅软件目录中的常见问题解答文件，里面有这个的说明，我都翻译了。

Inno Setup 从 4.1.3 就提供了自定义安装文件图标的功能

要实现此功能只需在 [Setup] 段加入如下语句：
; 安装文件图标
SetupIconFile=X:\*.ico
; 卸载文件图标
UninstallIconFile=X:\*.ico

注：X:\*.ico 为源图标存放路径

user posted image
欢迎光临国内最大的 CAD 专业论坛【晓东 CAD 论坛】
OFA | [第3楼] 发帖时间 2004年02月12日 10时57分
天使 * * * * * * 组别： 认证用户 帖子数量： 1443 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | 不是从 4.1.3, 从 4.1.0 开始就支持了. 我做的 PDF2HTML 1.6 就是用这个功能更改图标的. 至于 "Inno Setup 常见问题解答",是作者在 4.0.X 时代写的,有些过时了. PS: Inno Setup 4.1.5 已经出炉. user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com/
weidong | [第4楼] 发帖时间 2004年02月12日 13时43分
侠客 * 组别： 用户 帖子数量： 11 用户编号： 20841 注册时间： 2004年01月30日 Member 离线 | 更新得很快啊。
莫名 | [第5楼] 发帖时间 2004年02月12日 14时04分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1328 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 原来看ＦＡＱ也会看出问题了，受教了。 新版本不错，主要增加了 7-zip 压缩支持。
心魔 | [第6楼] 发帖时间 2004年02月12日 16时22分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 19462 注册时间： 2003年12月06日 Member 离线 | 我也看到了4.1.5版出来了，据说加入了7-zip压缩支持，但是怎么使用那个压缩功能啊？具体怎么调节压缩率？怎么写语句呢？ 是不是在[Setup]语句中的CompressLevel换成Compression？？
心魔
[第7楼] 发帖时间 2004年02月12日 16时42分

侠客
*

组别： 用户
帖子数量： 49
用户编号： 19462
注册时间： 2003年12月06日

Member 离线

4.1.5 (2004-02-11)

A new compression method has been implemented: lzma. LZMA is the algorithm that Igor Pavlov's excellent 7-Zip archiver uses by default. Typically it compresses at least 20% better than the existing bzip method. (By using LZMA compression, the installer for Inno Setup itself is now 150 KB smaller than before, despite the inclusion of two new DLLs!)
LZMA compression may activated using the Compression [Setup] section directive. For maximum compression, also set SolidCompression=yes. See the help file for full details.
Note: Since the support for LZMA compression is brand new, it hasn't undergone widespread testing yet. Use with caution in production installations.
Compiler IDE improvements:
Added new Build | Low Priority During Compile option. When checked, the IDE will run as a low-priority process during compilation, which helps prevent the compile process from monopolizing CPU resources.
Now shows an animated icon during compilation, as well as a progress bar that shows the percentage of files that have been compressed thus far.
The obsolete CompressLevel [Setup] section directive is no longer recognized by the compiler. Use Compression instead.
Minor tweaks.

4.1.5新特性，谁来翻译一下啊？
莫名
[第8楼] 发帖时间 2004年02月12日 19时56分

天使
* * * * * *

组别： 汉化新世纪成员
帖子数量： 1328
用户编号： 1716
注册时间： 2002年04月24日

Member 离线

引用 (心魔 @ 2004年02月12日 16时22分)
我也看到了4.1.5版出来了，据说加入了7-zip压缩支持，但是怎么使用那个压缩功能啊？具体怎么调节压缩率？怎么写语句呢？
是不是在[Setup]语句中的CompressLevel换成Compression？？

Compression=lzma/max
SolidCompression=yes
心魔 | [第9楼] 发帖时间 2004年02月12日 20时04分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 19462 注册时间： 2003年12月06日 Member 离线 | 谢了,在你发贴之前自己研究了一下,和你写的这个语句一样，呵呵~~恩^压缩率瞒不错的^^好极了....
心魔 | [第10楼] 发帖时间 2004年02月12日 20时08分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 19462 注册时间： 2003年12月06日 Member 离线 | Inno Setup 4.1.5这个安装制作程序能不能像Installer VISE 3.6一样做一个安装背景图之类的？或像Wise Installation System 9.02一样，做一个启动画面和安装背景音乐？请高手指教一下~~~
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.7629 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


【问题】在Inno Setup中如何更改这个?

> 【问题】在Inno Setup中如何更改这个?
订阅此主题 | 邮寄此主题 | 打印此主题
ulij | [楼主] 发帖时间 2004年06月23日 21时26分
圣骑士 * * * 组别： 认证用户 帖子数量： 186 用户编号： 22258 注册时间： 2004年03月13日 Member 离线 | 在Inno Setup中如何更改图中显示的链接名为自己需要的链接名(实际的链接已经更改了,但还是显示"www.innosetup.com") 附图 附图 经历重重打击，依然勇往直前！ user posted image
ulij | [第1楼] 发帖时间 2004年06月23日 21时37分
圣骑士 * * * 组别： 认证用户 帖子数量： 186 用户编号： 22258 注册时间： 2004年03月13日 Member 离线 | 不好意思,找到了,已经解决! 附图 附图 经历重重打击，依然勇往直前！ user posted image
刘波 | [第2楼] 发帖时间 2004年06月23日 23时31分
版主 * * * * * 组别： 认证用户 帖子数量： 623 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 下面的关于按钮和链接怎么搞出来的哦？ 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
青青
[第3楼] [image] 发帖时间 2004年06月24日 01时37分

侠客
*

组别： 认证用户
帖子数量： 40
用户编号： 25599
注册时间： 2004年05月31日

Member 离线

引用 (ulij @ 2004年06月23日 21时37分)
不好意思,找到了,已经解决!

请问您是怎么做的？可以分享吗？谢谢！
莫名 | [第4楼] 发帖时间 2004年06月24日 08时21分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1321 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 软件示例中有一个脚本可以研究
cbhhch
[第5楼] 发帖时间 2004年06月24日 09时29分

侠客
*

组别： 用户
帖子数量： 12
用户编号： 24855
注册时间： 2004年05月17日

Member 离线

URLLabel := TNewStaticText.Create(WizardForm);

// 调整 x 坐标
; URLLabel.Left := WizardForm.ClientWidth - (WizardForm.CancelButton.Left + WizardForm.CancelButton.Width);
URLLabel.Left := 100+ WizardForm.ClientWidth - (WizardForm.CancelButton.Left + WizardForm.CancelButton.Width);
// 调整 y 坐标
URLLabel.Top := WizardForm.CancelButton.Top + 2;

URLLabel.Caption := '灵感 [image] ';
URLLabel.Font.Color := clBlue;
URLLabel.Parent := WizardForm;
EnableWindow(URLLabel.Handle, false); // 这样文字就会出现3D效果了
ulij
[第6楼] 发帖时间 2004年06月24日 12时02分

圣骑士
* * *

组别： 认证用户
帖子数量： 186
用户编号： 22258
注册时间： 2004年03月13日

Member 离线

在旧贴中找到的
代码如下：
[Code]
procedure AboutButtonOnClick(Sender: TObject);
begin
MsgBox('欢迎您使用由小U制作的程序，该程序来自U乐园－自U软件：）', mbInformation, mb_Ok);
end;

procedure URLLabelOnClick(Sender: TObject);
var
Dummy: Integer;
begin
InstShellExec('http://ule.126.com', '', '', SW_SHOWNORMAL, Dummy);
end;

procedure InitializeWizard();
var
AboutButton, CancelButton: TButton;
URLLabel: TNewStaticText;
BackgroundBitmapImage: TBitmapImage;
BackgroundBitmapText: TNewStaticText;
begin
CancelButton := WizardForm.CancelButton;

AboutButton := TButton.Create(WizardForm);
AboutButton.Left := WizardForm.ClientWidth - CancelButton.Left - CancelButton.Width;
AboutButton.Top := CancelButton.Top;
AboutButton.Width := CancelButton.Width;
AboutButton.Height := CancelButton.Height;
AboutButton.Caption := '关于(&A)';
AboutButton.OnClick := @AboutButtonOnClick;
AboutButton.Parent := WizardForm;

URLLabel := TNewStaticText.Create(WizardForm);
URLLabel.Top := AboutButton.Top + AboutButton.Height - URLLabel.Height - 2;
URLLabel.Left := AboutButton.Left + AboutButton.Width + 20;
URLLabel.Caption := 'U乐园-自U软件';
URLLabel.Font.Style := URLLabel.Font.Style + [fsUnderLine];
URLLabel.Font.Color := clBlue;
URLLabel.Cursor := crHand;
URLLabel.OnClick := @URLLabelOnClick;
URLLabel.Parent := WizardForm;

BackgroundBitmapImage := TBitmapImage.Create(MainForm);
BackgroundBitmapImage.AutoSize := True;
BackgroundBitmapImage.Bitmap := WizardForm.WizardBitmapImage.Bitmap;
BackgroundBitmapImage.Left := 50;
BackgroundBitmapImage.Top := 100;
BackgroundBitmapImage.Parent := MainForm;

BackgroundBitmapText := TNewStaticText.Create(MainForm);
BackgroundBitmapText.Caption := 'TBitmapImage';
BackgroundBitmapText.Left := BackGroundBitmapImage.Left;
BackgroundBitmapText.Top := BackGroundBitmapImage.Top + BackGroundBitmapImage.Height + 8;
BackgroundBitmapText.Parent := MainForm;

经历重重打击，依然勇往直前！
user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 2.0219 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


怎样用Inno Setup做这个图片里的关于这个

> 怎样用Inno Setup做这个图片里的关于这个
shiri | [楼主] 发帖时间 2004年03月29日 16时09分
侠客 * 组别： 用户 帖子数量： 39 用户编号： 2000 注册时间： 2002年05月08日 Member 离线 | 怎样用Inno Setup做这个图片里的关于这个 附图 附图
Sage_Fly | [第1楼] 发帖时间 2004年03月29日 17时32分
侠客 * 组别： 用户 帖子数量： 28 用户编号： 19570 注册时间： 2003年12月10日 Member 离线 | 是啊，我也正想知道呢。 还有的在『关于』按钮旁边还有个可以点击的网址链接，这些都是怎么实现的啊？
briankuo | [第2楼] 发帖时间 2004年03月29日 18时06分
侠客 * 组别： 用户 帖子数量： 14 用户编号： 22320 注册时间： 2004年03月15日 Member 离线 | 可以用INNO的PASCAL SCRIPT 实现：(把以下的代码放在安装脚本的[Code]片段中): [Code] {关于按钮单击后执行的过程 注意:一定要写在InitializeWizard()过程之前} procedure ButtonAboutOnClick(Sender: TObject); begin MsgBox('关于对话框。'+#13#10+'另起一行', mbInformation, MB_OK);//显示对话框 end; {初始化安装向导时会触发的过程,这个过程的名字是INNO内部定义的，不能修改} procedure InitializeWizard(); begin with TButton.Create(WizardForm) do//在WizardForm上面创建一个按钮 begin Left := 32;//按钮距WizardForm左边的距离 Top := 326;//按钮距WizardForm上边的距离 Width := WizardForm.CancelButton.Width;//按钮的宽度，这里定义跟'取消'按钮等宽 Height := WizardForm.CancelButton.Height;//按钮的高度 Caption := '关于(&A)...';//按钮上的文字 Font.Name:='宋体';//按钮文字的字体 Font.Size:=9;//9号字体 OnClick := @ButtonAboutOnClick;//单击按钮触发的过程，就是前面的'ButtonAboutOnClick'过程，注意前面不要漏掉'@' Parent := WizardForm;//按钮的父组件，也就是按钮'载体',这里是WizardForm（安装向导窗体） end; end;
briankuo | [第3楼] 发帖时间 2004年03月29日 18时11分
侠客 * 组别： 用户 帖子数量： 14 用户编号： 22320 注册时间： 2004年03月15日 Member 离线 | 忘了，以上脚本在InnoSetup4.20上调试通过 另：如何上传图片啊？我想上传个效果图都不成
briankuo
[第4楼] 发帖时间 2004年03月29日 18时31分

侠客
*

组别： 用户
帖子数量： 14
用户编号： 22320
注册时间： 2004年03月15日

Member 离线

引用 (Sage_Fly @ 2004年03月29日 17时32分)
是啊，我也正想知道呢。 还有的在『关于』按钮旁边还有个可以点击的网址链接，这些都是怎么实现的啊？

应该这样做：
可以用INNO的PASCAL SCRIPT 实现：(把以下的代码放在安装脚本的[Code]片段中):
[Code]
{关于按钮单击后执行的过程
注意:一定要写在InitializeWizard()过程之前}
procedure LabelUrlOnClick(Sender: TObject);
var ErrorCode:Integer;
begin
if not InstShellExec('http://www.xxx.com', '', '', SW_SHOWNORMAL, ErrorCode) then
MsgBox('不能打开该URL: ''' + SysErrorMessage(ErrorCode) + '''.', mbError, mb_Ok);
end;

{初始化安装向导时会触发的过程,这个过程的名字是INNO内部定义的，不能修改}
procedure InitializeWizard();
begin
with TLabel.Create(WizardForm) do//在WizardForm上面创建一行静态文字Label
begin
Left := 32;//Label距WizardForm左边的距离
Top := 326;//Label距WizardForm上边的距离
AutoSize:=True;//自动大小
Caption := 'http://www.xxx.com';//Lebel上的文字
Font.Name:='宋体';//按钮文字的字体
Font.Size:=9;//9号字体
OnClick := @LabelURLOnClick;//单击Lebel触发的过程，就是前面的'LabelURLOnClick'过程，注意前面不要漏掉'@'
Parent := WizardForm;//Lebel的父组件，也就是按钮'载体',这里是WizardForm（安装向导窗体）
end;
end;

注意：上面的引号都是单引号(')
zjj1988101
[第5楼] 发帖时间 2004年03月29日 19时21分

圣骑士
* * *

组别： 认证用户
帖子数量： 108
用户编号： 17968
注册时间： 2003年10月09日

Member 离线

[Code]
procedure AboutButtonOnClick(Sender: TObject);
begin
MsgBox('这个演示显示一些 WizardForm 对象的功能和各种 VCL 类。', mbInformation, mb_Ok);
end;

procedure URLLabelOnClick(Sender: TObject);
var
Dummy: Integer;
begin
InstShellExec('http://www.innosetup.com', '', '', SW_SHOWNORMAL, Dummy);
end;

procedure InitializeWizard();
var
AboutButton, CancelButton: TButton;
URLLabel: TNewStaticText;
BackgroundBitmapImage: TBitmapImage;
BackgroundBitmapText: TNewStaticText;
begin
CancelButton := WizardForm.CancelButton;

AboutButton := TButton.Create(WizardForm);
AboutButton.Left := WizardForm.ClientWidth - CancelButton.Left - CancelButton.Width;
AboutButton.Top := CancelButton.Top;
AboutButton.Width := CancelButton.Width;
AboutButton.Height := CancelButton.Height;
AboutButton.Caption := '关于(&A)...';
AboutButton.OnClick := @AboutButtonOnClick;
AboutButton.Parent := WizardForm;

URLLabel := TNewStaticText.Create(WizardForm);
URLLabel.Top := AboutButton.Top + AboutButton.Height - URLLabel.Height - 2;
URLLabel.Left := AboutButton.Left + AboutButton.Width + 20;
URLLabel.Caption := 'www.innosetup.com';
URLLabel.Font.Style := URLLabel.Font.Style + [fsUnderLine];
URLLabel.Font.Color := clBlue;
URLLabel.Cursor := crHand;
URLLabel.OnClick := @URLLabelOnClick;
URLLabel.Parent := WizardForm;

BackgroundBitmapImage := TBitmapImage.Create(MainForm);
BackgroundBitmapImage.AutoSize := True;
BackgroundBitmapImage.Bitmap := WizardForm.WizardBitmapImage.Bitmap;
BackgroundBitmapImage.Left := 50;
BackgroundBitmapImage.Top := 100;
BackgroundBitmapImage.Parent := MainForm;

BackgroundBitmapText := TNewStaticText.Create(MainForm);
BackgroundBitmapText.Caption := 'TBitmapImage';
BackgroundBitmapText.Left := BackGroundBitmapImage.Left;
BackgroundBitmapText.Top := BackGroundBitmapImage.Top + BackGroundBitmapImage.Height + 8;
BackgroundBitmapText.Parent := MainForm;
end;
Sage_Fly | [第6楼] 发帖时间 2004年03月29日 19时43分
侠客 * 组别： 用户 帖子数量： 28 用户编号： 19570 注册时间： 2003年12月10日 Member 离线 | 谢谢上面两位大侠，我明白了， 实验通过。
shiri | [第7楼] 发帖时间 2004年03月29日 20时55分
侠客 * 组别： 用户 帖子数量： 39 用户编号： 2000 注册时间： 2002年05月08日 Member 离线 | 谢谢！太谢谢了！ 我终于搞懂了。
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3242 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


关于 Inno Setup 汉化版安装程序面板的建议！

> 关于 Inno Setup 汉化版安装程序面板的建议！
订阅此主题 | 邮寄此主题 | 打印此主题
青青 | [楼主] 发帖时间 2004年06月29日 19时04分
侠客 * 组别： 认证用户 帖子数量： 45 用户编号： 25599 注册时间： 2004年05月31日 Member 离线 | 莫名老师汉化的 Inno Setup 非常棒！我一直在使用它。 汉化版唯一美中不足的就是：做出来的安装程序面板高度不一样。 这在一般来讲，是无关紧要的。但是如果想在面板左侧放上自己的图片的话，问题随之就出来了：图片被上下压缩了！ 如图所示（点击看大图） 附图 附图
青青 | [第1楼] 发帖时间 2004年06月29日 19时10分
侠客 * 组别： 认证用户 帖子数量： 45 用户编号： 25599 注册时间： 2004年05月31日 Member 离线 | 做个试验：比如左侧换上下面这个图片，看看最后的效果……。（大家可以下载这个图片试一试） 附图 附图
青青 | [第2楼] 发帖时间 2004年06月29日 19时12分
侠客 * 组别： 认证用户 帖子数量： 45 用户编号： 25599 注册时间： 2004年05月31日 Member 离线 | 效果 附图 附图
青青 | [第3楼] 发帖时间 2004年06月29日 19时14分
侠客 * 组别： 认证用户 帖子数量： 45 用户编号： 25599 注册时间： 2004年05月31日 Member 离线 | 希望莫名老师可以在未来做的 Inno Setup 汉化版可以改进这一点。使得与英文原版做的安装程序面板大小一致，那就太完美了！ 一点点小的建议，请莫名老师批评指点。
pk4321 | [第4楼] 发帖时间 2004年06月29日 21时36分
圣骑士 * * * 组别： 认证用户 帖子数量： 170 用户编号： 770 注册时间： 2002年01月10日 Member 离线 | 汉化版的左边图片尺寸为：164×290 上面小图片的尺寸为：55×51
刘波 | [第5楼] 发帖时间 2004年06月29日 22时31分
版主 * * * * * 组别： 认证用户 帖子数量： 786 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 自己修改语言文件，把宋体 9改为Tahoma 8 就可以了 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
OFA
[第6楼] 发帖时间 2004年06月29日 22时36分

天使
* * * * * *

组别： 认证用户
帖子数量： 1443
用户编号： 13575
注册时间： 2003年04月13日

Member 离线

引用 (刘波 @ 2004年06月30日 02时31分)
自己修改语言文件，把宋体 9改为Tahoma 8 就可以了

这样在98系统上，可能显示不正常。

user posted image
愿为汉化事业贡献自己的一份微薄之力。
欢迎您访问我的净土 http://www.cokemouse.com
刘波
[第7楼] 发帖时间 2004年06月29日 22时53分

版主
* * * * *

组别： 认证用户
帖子数量： 786
用户编号： 691
注册时间： 2001年12月27日

Member 离线

引用 (OFA @ 2004年06月29日 22时36分)
引用 (刘波 @ 2004年06月30日 02时31分)
自己修改语言文件，把宋体 9改为Tahoma 8 就可以了

这样在98系统上，可能显示不正常。

恩。我也知道。不过现在很少人用98了吧。如果不这么修改的话好像无法让窗口大小正常吧？
还有NSIS也是这样。用了宋体后窗口大小变化很大。实在难看

欢迎来到汉化新世纪论坛之分论坛游戏天地
user posted image
OFA | [第8楼] 发帖时间 2004年06月29日 23时26分
天使 * * * * * * 组别： 认证用户 帖子数量： 1443 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | 以前很长几个帖子专门对宋体和Tohama进行了激烈争辩。最后还是宋体打败了Tohama user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
刘波 | [第9楼] 发帖时间 2004年06月30日 02时14分
版主 * * * * * 组别： 认证用户 帖子数量： 786 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 是啊。不过再过几年可能就真的没人用98了。那时候就是TAHOMA的天下了。不过要是微软针对98做个字体方面的补丁就爽了。 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
ksxuxu | [第10楼] 发帖时间 2004年06月30日 07时55分
版主 * * * * * * 组别： 认证用户 帖子数量： 1778 用户编号： 1469 注册时间： 2002年04月07日 Member 离线 | 微软不是不在为98提供支持了么？还会发补丁？ 彻底消失ing~
蓝色网际
[第11楼] 发帖时间 2004年06月30日 09时49分

精灵王
* * * *

组别： 认证用户
帖子数量： 438
用户编号： 3348
注册时间： 2002年07月08日

Member 离线

引用 (刘波 @ 2004年06月29日 22时53分)
引用 (OFA @ 2004年06月29日 22时36分)
引用 (刘波 @ 2004年06月30日 02时31分)
自己修改语言文件，把宋体 9改为Tahoma 8 就可以了

这样在98系统上，可能显示不正常。

恩。我也知道。不过现在很少人用98了吧。如果不这么修改的话好像无法让窗口大小正常吧？
还有NSIS也是这样。用了宋体后窗口大小变化很大。实在难看

我觉得 NSIS 用宋体后窗口很好啊，反而用 Tahoma 后窗口太大

ACDSee 3.1 SR1 美化版下载页面
我的 NSIS 小站

chenmy | [第12楼] 发帖时间 2004年06月30日 09时57分
天使 * * * * * * 组别： 超级版主 帖子数量： 1471 用户编号： 1794 注册时间： 2002年04月28日 Member 离线 | 只要你注意调整左侧图片的宽高比，使之与控件的宽高比相同，就不会有“压缩”的现象存在。 我爱自然之家！—我爱汉化！ user posted image user posted image 我是中国人·最爱是中文！ user posted image
OFA
[第13楼] 发帖时间 2004年06月30日 14时38分

天使
* * * * * *

组别： 认证用户
帖子数量： 1443
用户编号： 13575
注册时间： 2003年04月13日

Member 离线

引用 (ksxuxu @ 2004年06月30日 11时55分)
微软不是不在为98提供支持了么？还会发补丁？

微软延长了对98的支持期限，到2006年。

user posted image
愿为汉化事业贡献自己的一份微薄之力。
欢迎您访问我的净土 http://www.cokemouse.com
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3639 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


请教 Inno Setup 界面颜色问题？

> 请教 Inno Setup 界面颜色问题？, 附图
添加新的投票 | 订阅此主题 | 邮寄此主题 | 打印此主题
xihua | [楼主] [image] 发帖时间 2004年08月22日 01时48分
精灵王 * * * * 组别： 认证用户 帖子数量： 341 用户编号： 17836 注册时间： 2003年10月05日 Member 在线 | 不知道是否可以实现，请各位高手指教！谢谢！ 附图 附图 山河大地，已属微尘；血肉身躯，且归泡影；非上上智，无了了心。
gnatix | [第1楼] 发帖时间 2004年08月22日 02时30分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2667 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 解决这个问题有两种方法： 1. 像你说的那样，让窗口背景的颜色变成白色。缺点是窗口的颜色搭配可能会变得不协调。 2. 让那个小图像的背景颜色变成和窗口的背景颜色一样，即让小图像变成透明。透明其实就是把小图像的某种颜色（这里是白色）替换成窗口的颜色。 本人认为第二种方法可能比较好。 user posted image Tervetuloa!
gnatix | [第2楼] 发帖时间 2004年08月22日 02时32分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2667 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 第一种方法的脚本： [Code] procedure InitializeWizard(); begin WizardForm.MainPanel.Color:= clWhite; //设置窗格的颜色为白色 end; 这个帖子已被 gnatix 于 2004年08月22日 03时22分 编辑 user posted image Tervetuloa!
gnatix | [第3楼] 发帖时间 2004年08月22日 02时36分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2667 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 第2种方法的脚本： [Code] procedure InitializeWizard(); begin WizardForm.WizardSmallBitmapImage.ReplaceColor:= clWhite; //要替换的颜色 WizardForm.WizardSmallBitmapImage.ReplaceWithColor:= WizardForm.MainPanel.Color; //替换成颜色 end; user posted image Tervetuloa!
bcff2002 | [第4楼] 发帖时间 2004年08月22日 07时22分
骑士 * * 组别： 认证用户 帖子数量： 54 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 整体的颜色是怎么变成这样的。 输入法大全 http://www.bcff2002.com/
雷骏 | [第5楼] 发帖时间 2004年08月22日 07时51分
天使 * * * * * * 组别： 认证用户 帖子数量： 1339 用户编号： 2835 注册时间： 2002年06月12日 Member 离线 | 那个是Windows的主题啊 user posted image user posted image user posted image user posted image
xihua | [第6楼] [image] 发帖时间 2004年08月22日 12时08分
精灵王 * * * * 组别： 认证用户 帖子数量： 341 用户编号： 17836 注册时间： 2003年10月05日 Member 在线 | 附图 附图 山河大地，已属微尘；血肉身躯，且归泡影；非上上智，无了了心。
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3171 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


【求助】Inno setup 制作安装文件帮助

> 【求助】Inno setup 制作安装文件帮助
wuguole | [楼主] 发帖时间 2004年07月16日 14时38分
骑士 * * 组别： 认证用户 帖子数量： 58 用户编号： 25371 注册时间： 2004年05月28日 Member 离线 | 请大家帮忙看下 如图所示的划红线处信息是怎么加上去的？ 附图 附图 欢迎访问偶的论坛 欢迎访问偶的博客
青青 | [第1楼] 发帖时间 2004年07月16日 15时27分
侠客 * 组别： 认证用户 帖子数量： 45 用户编号： 25599 注册时间： 2004年05月31日 Member 离线 | [Messages] BeveledLabel=你想要的文字
wuguole | [第2楼] 发帖时间 2004年07月16日 16时27分
骑士 * * 组别： 认证用户 帖子数量： 58 用户编号： 25371 注册时间： 2004年05月28日 Member 离线 | 谢谢！ 欢迎访问偶的论坛 欢迎访问偶的博客
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3343 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


请教一个inno setup的问题

> 请教一个inno setup的问题
luckyboy | [楼主] 发帖时间 2004年02月11日 15时14分
侠客 * 组别： 用户 帖子数量： 12 用户编号： 19650 注册时间： 2003年12月14日 Member 离线 | 请教如何在inno setup做出的安装向导左下角加字，如图红圈内的字。 我把[setup]字段里的参数几乎都看过了，可是还找不到，请帮帮忙，谢谢！ user posted image
OFA | [第1楼] 发帖时间 2004年02月11日 22时45分
天使 * * * * * * 组别： 认证用户 帖子数量： 1418 用户编号： 13575 注册时间： 2003年04月13日 Member 在线 | 不知道是不是用reshacker加的.. user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
fenghua | [第2楼] 发帖时间 2004年02月12日 00时06分
骑士 * * 组别： 用户 帖子数量： 55 用户编号： 4465 注册时间： 2002年08月22日 Member 离线 | 在脚本中加入以下字段： [Messages] BeveledLabel=亚风工作室 汉化作品（YaFeng Studio） user posted image 欢迎光临国内最大的 CAD 专业论坛【晓东 CAD 论坛】
fenghua | [第3楼] 发帖时间 2004年02月12日 00时13分
骑士 * * 组别： 用户 帖子数量： 55 用户编号： 4465 注册时间： 2002年08月22日 Member 离线 | 效果 附图 附图 user posted image 欢迎光临国内最大的 CAD 专业论坛【晓东 CAD 论坛】
luckyboy | [第4楼] 发帖时间 2004年02月12日 00时59分
侠客 * 组别： 用户 帖子数量： 12 用户编号： 19650 注册时间： 2003年12月14日 Member 离线 | 多谢fenghua！ 没注意[messages]字段 //blush
mapeng
[第5楼] 发帖时间 2004年02月12日 01时11分

精灵王
* * * *

组别： 认证用户
帖子数量： 297
用户编号： 19595
注册时间： 2003年12月11日

Member 离线

楼上小东前辈说的很对，但是我另一种方法，只需修改一次，就可以打造自己的签名了，而不用每次都在脚本文件里添加
[Messages]
BeveledLabel=

这个太麻烦了~~~~简单方法，用记事本打开 Default.isl 找到，不想打字了，自己看图吧，很简单

附图
附图

我的外表很传统,我的内心很反叛;我的行动很规矩,我的思想却激进;我的语言很尖刻,我的性情很温柔;我的眼光很挑剔,我的能力却有限;我的理想很伟大,我的现状很平凡;我的头脑很灵活,我的双手却笨拙;我的睡眠很踏实,我的美梦很有限;我的长相很酷毙,我的女友却没影。 user posted image
CDLH | [第6楼] 发帖时间 2004年02月12日 03时14分
侠客 * 组别： 用户 帖子数量： 12 用户编号： 5438 注册时间： 2002年09月24日 Member 离线 | luckyboy，你的 Theme（主题） 很漂亮，叫什么名字？在哪儿下的？能发给我一个吗？
luckyboy
[第7楼] 发帖时间 2004年02月12日 13时35分

侠客
*

组别： 用户
帖子数量： 12
用户编号： 19650
注册时间： 2003年12月14日

Member 离线

引用 (CDLH @ 2004年02月12日 03时14分)
luckyboy，你的 Theme（主题） 很漂亮，叫什么名字？在哪儿下的？能发给我一个吗？

从stylexp 2.0里rip出来的，这个是Corona-Violet
Aeolus | [第8楼] 发帖时间 2004年02月16日 00时18分
侠客 * 组别： 用户 帖子数量： 18 用户编号： 19260 注册时间： 2003年11月29日 Member 离线 | 帮助文档里由关于Default.isl 的说明，可以参考。 你来自云南元谋 我来自北京周口 我握住你长满绒毛的手 亲了一口 爱情 让我们直立行走
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.5844 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


【求助】向 Inno Setup 的高手请教。

> 【求助】向 Inno Setup 的高手请教。
订阅此主题 | 邮寄此主题 | 打印此主题
飞龙 | [楼主] 发帖时间 2004年06月18日 08时39分
圣骑士 * * * 组别： 认证用户 帖子数量： 201 用户编号： 4704 注册时间： 2002年08月29日 Member 离线 | 请问图中的文件夹列表和驱动哭器选择框的脚本是怎么写的？ 附图 附图 轻轻地我走了，正如我轻轻地来；我挥一挥衣袖，不带走一版云彩。
gnatix | [第1楼] 发帖时间 2004年06月18日 19时07分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 这个跟脚本没有关系。如果你一定要这种形式，那么就要使用 Inno Setup 的旧版本了，比如 3.x。 user posted image
飞龙
[第2楼] 发帖时间 2004年06月20日 08时05分

圣骑士
* * *

组别： 认证用户
帖子数量： 201
用户编号： 4704
注册时间： 2002年08月29日

Member 离线

引用 (gnatix @ 2004年06月18日 19时07分)
这个跟脚本没有关系。如果你一定要这种形式，那么就要使用 Inno Setup 的旧版本了，比如 3.x。

谢谢解答，我以前用的4.09就能创建这种样式。

轻轻地我走了，正如我轻轻地来；我挥一挥衣袖，不带走一版云彩。
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3210 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


请教inno setup的问题

> 请教inno setup的问题
bcff2002 | [楼主] 发帖时间 2004年07月12日 19时02分
骑士 * * 组别： 认证用户 帖子数量： 55 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 用inno制作安装程序的时候，能不能把信息页上的字变成别的颜色。 user posted image user posted image 输入法大全 http://www.bcff2002.com
刘波 | [第1楼] 发帖时间 2004年07月13日 00时25分
版主 * * * * * 组别： 认证用户 帖子数量： 786 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 不行。至少用常规的方法是不行的！ 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
gnatix | [第2楼] 发帖时间 2004年07月13日 03时16分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2694 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 不能只更改某个页面的标题和描述的颜色，也就是说你只能更改所有页面的标题和描述的颜色，见图。 附图 附图 user posted image
gnatix | [第3楼] 发帖时间 2004年07月13日 03时19分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2694 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 同样道理，你不能只更改欢迎页面上个别文字的颜色，要更改就全更改，见图。 附图 附图 user posted image
bcff2002 | [第4楼] 发帖时间 2004年07月13日 06时28分
骑士 * * 组别： 认证用户 帖子数量： 55 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 全改的脚本是什么，请教老大。 输入法大全 http://www.bcff2002.com
bcff2002 | [第5楼] 发帖时间 2004年07月13日 12时28分
骑士 * * 组别： 认证用户 帖子数量： 55 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | tt 输入法大全 http://www.bcff2002.com
gnatix
[第6楼] 发帖时间 2004年07月13日 12时30分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2694
用户编号： 377
注册时间： 2001年10月17日

Member 在线

上面两个例子的脚本是：

[Code]
procedure InitializeWizard();
begin
//图1
WizardForm.PAGENAMELABEL.Font.Color:= clred;
WizardForm.PAGEDESCRIPTIONLABEL.Font.Color:= clBlue;
//图2
WizardForm.WELCOMELABEL1.Font.Color:= clGreen;
WizardForm.WELCOMELABEL2.Font.Color:= clOlive;
end;

user posted image
bcff2002 | [第7楼] 发帖时间 2004年07月13日 13时46分
骑士 * * 组别： 认证用户 帖子数量： 55 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 在有关于选项的脚本中如何实现这个颜色呢。我在有关于的脚本中添加这一段代码时，因为他的里面有procedure InitializeWizard();这一句了，所以无法编译成功。 user posted image 输入法大全 http://www.bcff2002.com
OFA | [第8楼] 发帖时间 2004年07月13日 13时52分
天使 * * * * * * 组别： 认证用户 帖子数量： 1443 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | 你的关于是用 msgbox 显示的吗？如果是，那么颜色不能改。 你把两段代码都放在 InitializeWizard() 下不就可以了吗？ user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
gnatix | [第9楼] 发帖时间 2004年07月13日 13时56分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2694 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 把下面的代码直接插入到现有的 procedure InitializeWizard(); 后面的第一个 begin 行后面就行了： WizardForm.PAGENAMELABEL.Font.Color:= clRed; WizardForm.PAGEDESCRIPTIONLABEL.Font.Color:= clBlue; WizardForm.WELCOMELABEL1.Font.Color:= clGreen; WizardForm.WELCOMELABEL2.Font.Color:= clOlive; 正在通过你的作品学习物理： 附图 附图 user posted image
bcff2002 | [第10楼] 发帖时间 2004年07月13日 19时28分
骑士 * * 组别： 认证用户 帖子数量： 55 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 感谢老虎，已经成功，不过颜色有很多程序都不认的。 输入法大全 http://www.bcff2002.com
bcff2002
[第11楼] 发帖时间 2004年07月13日 19时31分

骑士
* *

组别： 认证用户
帖子数量： 55
用户编号： 22017
注册时间： 2004年03月06日

Member 离线

引用 (gnatix @ 2004年07月13日 13时56分)
把下面的代码直接插入到现有的 procedure InitializeWizard(); 后面的第一个 begin 行后面就行了：
WizardForm.PAGENAMELABEL.Font.Color:= clRed;
WizardForm.PAGEDESCRIPTIONLABEL.Font.Color:= clBlue;
WizardForm.WELCOMELABEL1.Font.Color:= clGreen;
WizardForm.WELCOMELABEL2.Font.Color:= clOlive;

正在通过你的作品学习物理：

这个课件不是我的作品，是别人的。

输入法大全
http://www.bcff2002.com
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3276 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


Inno Setup 怎么替换ICO界面等图片等呢

> Inno Setup 怎么替换ICO界面等图片等呢
独孤残剑 | [楼主] 发帖时间 2004年07月16日 12时43分
新手上路 * 组别： 用户 帖子数量： 6 用户编号： 27976 注册时间： 2004年07月16日 Member 离线 | Inno Setup 怎么替换ICO界面等图片等呢 希望高手给句代码
gnatix | [第1楼] 发帖时间 2004年07月16日 13时02分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2694 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 设置图标用： [Setup] SetupIconFile = YourIconFile.ico WizardImageFile = YourBigImageFile.bmp WizardSmallImageFile = YourSmallImageFile.bmp 或者把 Inno Setup 目录中的文件 WizModernImage.bmp WizModernSmallImage.bmp 更换成你自己的图像文件就行了。 建议楼主看看程序的帮助文件（中文）。 user posted image
softsword | [第2楼] 发帖时间 2004年07月16日 13时41分
精灵王 * * * * 组别： 认证用户 帖子数量： 367 用户编号： 17697 注册时间： 2003年09月28日 Member 离线 | 可惜 INNO 不能和 NSIS 一样支持长一点的图片。 宽度太窄了。 夏天来了，天气热了，一群“BT”往北飞，一会儿排成“B”字，一会儿排成“T”字 …… user posted image 孔子东游，遇二小儿辩斗，问其故。 一小儿曰：我以日本生自山东，故属东。 一小儿曰：夕阳西下，日本归山西也明矣，是以属西。 孔子不能决，后以问老子（本人也）。 老子笑曰：孰为汝多知乎？日本无根基，岂能算东西 ！ user posted image
独孤残剑 | [第3楼] 发帖时间 2004年07月16日 15时09分
新手上路 * 组别： 用户 帖子数量： 6 用户编号： 27976 注册时间： 2004年07月16日 Member 离线 | 真是多谢了
yxl | [第4楼] 发帖时间 2004年07月17日 16时58分
侠客 * 组别： 用户 帖子数量： 14 用户编号： 28052 注册时间： 2004年07月17日 Member 离线 | 还是Setup2GO 比较好用 ☆爱 ║.....╔╬╗...◢◣◢◣ ☆ ★║★ ╚╬╝..【LOVE你】 ☆语 ╝....═╩═╝.◥██◤ ........︸︸﹊︸︸﹊︸ ◥◤ QQ 64890833
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3094 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


Inno Setup 的 Default.isl 中的打字错误

> Inno Setup 的 Default.isl 中的打字错误
pk4321 | [第2楼] 发帖时间 2004年05月23日 16时42分
圣骑士 * * * 组别： 认证用户 帖子数量： 151 用户编号： 770 注册时间： 2002年01月10日 Member 离线 | 我发现4.2.x之后，向导的图片的高度不同了～ 现在的大图片的大小是：164x290，小图片的大小是：55x51
OFA
[第4楼] 发帖时间 2004年05月24日 17时53分

天使
* * * * * *

组别： 认证用户
帖子数量： 1417
用户编号： 13575
注册时间： 2003年04月13日

Member 离线

引用 (pk4321 @ 2004年05月23日 20时42分)
我发现4.2.x之后，向导的图片的高度不同了～
现在的大图片的大小是：164x290，小图片的大小是：55x51

我用一直都很正常呀。分别是164*314和55*55。

user posted image
愿为汉化事业贡献自己的一份微薄之力。
欢迎您访问我的净土 http://www.cokemouse.com
? 上一个主题 | 汉化质量问题及测试 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3577 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


[求救]Inno Setup 4

> [求救]Inno Setup 4, 怎样在安装脚本中自定义输出安装文件的图标?
订阅此主题 | 邮寄此主题 | 打印此主题
心魔 | [楼主] 发帖时间 2003年12月06日 16时57分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 19462 注册时间： 2003年12月06日 Member 离线 | 今天看了看安装制作软件Inno Setup 4,觉得很不错,但是有一问题不明白,也查过很多资料,但都是一无所获,请高手指点一下,请问:怎样在安装脚本中自定义输出安装文件的图标?老是同一个安装图标,真的一点都不个性化.
大番茄 | [第1楼] 发帖时间 2003年12月06日 17时25分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 我也是,最喜欢inno了~! 里面的一个'图标顶制器"替换了以后压缩包就坏了 有没有编写脚本~用 ICO 作为输出的图标! 或者有没有什么工具软件可以替换安装程序的图标! 番茄花园: http://tomatolei.com
莫名 | [第2楼] 发帖时间 2003年12月06日 21时27分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1322 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | exescope 就行。
心魔 | [第3楼] 发帖时间 2003年12月06日 23时02分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 19462 注册时间： 2003年12月06日 Member 离线 | 不行啊^生成的安装文件是加了壳的，不能修改啊！
雷骏 | [第4楼] 发帖时间 2003年12月07日 00时09分
天使 * * * * * * 组别： 认证用户 帖子数量： 1319 用户编号： 2835 注册时间： 2002年06月12日 Member 离线 | 修改安装程序中Setup.e32 SetupLdr.e32 Uninst.e32三个文件里的图标，然后制作的安装程序就是你自己制订好的。 Setup.e32 SetupLdr.e32生成的安装程序的图标，Uninst.e32里的是卸载图标。 user posted image user posted image user posted image user posted image
大番茄 | [第5楼] 发帖时间 2003年12月07日 00时42分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | Setup.e32 SetupLdr.e32 Uninst.e32 这3个文件用什么打开修改啊? 番茄花园: http://tomatolei.com
雷骏 | [第6楼] 发帖时间 2003年12月07日 01时55分
天使 * * * * * * 组别： 认证用户 帖子数量： 1319 用户编号： 2835 注册时间： 2002年06月12日 Member 离线 | exescope,PE Explorer,ResHacker等等 user posted image user posted image user posted image user posted image
心魔 | [第7楼] 发帖时间 2003年12月07日 07时45分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 19462 注册时间： 2003年12月06日 Member 离线 | 真麻烦,不能用安装脚本自定义的吗?
大番茄 | [第8楼] 发帖时间 2003年12月07日 18时51分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 怎么自定义 脚本? 强烈要求 心魔 同志说说~! 谢谢啊`! 番茄花园: http://tomatolei.com
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3217 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


就差这一环了。请求高手帮帮忙！

> 就差这一环了。请求高手帮帮忙！
订阅此主题 | 邮寄此主题 | 打印此主题
dragonwang | [楼主] 发帖时间 2002年11月12日 20时26分
侠客 * 组别： 用户 帖子数量： 16 用户编号： 7081 注册时间： 2002年11月12日 Member 离线 | 有一个原版软件，安装后会在桌面上生成二个图标，一个就是主程序exe的快捷键；另一个图标双击后打开的是发行商的主页。就是这个图标我无法用Inno Setup打包封装，我应该怎么写脚本呢？
天秤雨 | [第1楼] 发帖时间 2002年11月12日 20时42分
踽踽独行 * * * * * * * 组别： 管理员 帖子数量： 3533 用户编号： 470 注册时间： 2001年11月10日 Member 离线 | 参照主程序快捷方式的语句写…… 出走意味着抛弃、逃离、孑然一身、踽踽独行，是茫然却又微存希望的寻找~ BeOS 中国 —— 内容丰富的 BeOS 资讯站点
simon
[第2楼] 发帖时间 2002年11月13日 11时19分

版主
* * * * * *

组别： 认证用户
帖子数量： 2271
用户编号： 658
注册时间： 2001年12月19日

Member 离线

引用
下面引用由天秤雨在 2002/11/12 08:42pm 发表的内容：
参照主程序快捷方式的语句写……

同意，就是建立一个指向那个网址的快捷方式嘛
dragonwang | [第3楼] 发帖时间 2002年11月13日 12时04分
侠客 * 组别： 用户 帖子数量： 16 用户编号： 7081 注册时间： 2002年11月12日 Member 离线 | 请问我该如何在Inno Setup里写这些脚本呢？如果不是很复杂能不能写出来？我实在太笨了！是不是还有其它更好的安装制作程序？
天秤雨
[第4楼] 发帖时间 2002年11月13日 14时19分

踽踽独行
* * * * * * *

组别： 管理员
帖子数量： 3533
用户编号： 470
注册时间： 2001年11月10日

Member 离线

引用
下面引用由dragonwang在 2002/11/13 12:04pm 发表的内容：
请问我该如何在Inno Setup里写这些脚本呢？如果不是很复杂能不能写出来？我实在太笨了！是不是还有其它更好的安装制作程序？

向导结束后，不要立即编译，找到那个语句，复制一条，修改为网站的项目阿
更好的？Wise 安装系统…… more and more

出走意味着抛弃、逃离、孑然一身、踽踽独行，是茫然却又微存希望的寻找~
BeOS 中国 —— 内容丰富的 BeOS 资讯站点
炎之川
[第5楼] 发帖时间 2002年11月13日 14时21分

最近比较烦哪！
* * * * * * * *

组别： 管理员
帖子数量： 6095
用户编号： 3
注册时间： 2001年06月15日

Member 离线

引用
下面引用由dragonwang在 2002/11/13 12:04pm 发表的内容：
请问我该如何在Inno Setup里写这些脚本呢？如果不是很复杂能不能写出来？我实在太笨了！是不是还有其它更好的安装制作程序？

和写其他的是一样的,把这个快捷方式链接指向Internet链接文件即可

user posted image

访问 炎之川的blog
dragonwang | [第6楼] 发帖时间 2002年11月14日 12时07分
侠客 * 组别： 用户 帖子数量： 16 用户编号： 7081 注册时间： 2002年11月12日 Member 离线 | 感谢各位为我这个新手解答问题，可是我还有问题，也是和那个问题有关的。我现在知道那个桌面快捷方式的目标文件的属性为“Internet快捷方式”，问题是这二个文件的图标却不一样，我就是不知道怎样生成这个图标和目标文件不一致的桌面快捷方式？Inno Setup能做得到吗？ 另一个软件，也是同一公司的相关产品，只是版本不同，在这个软件中，甚至连目标文件都找不到，我只能从桌面快捷方式的属性中得知它的目标位置为"Internet Explore"，目标类型以及目标都是该公司的主页，且都无法更改。 这二个软件的桌面快捷方式的图标是一样的。 拜托了！
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 2.0770 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


如何让 Inno Setup 做的安装程序-不创建程序菜单？谢谢！

> 如何让 Inno Setup 做的安装程序-不创建程序菜单？谢谢！
订阅此主题 | 邮寄此主题 | 打印此主题
青青 | [楼主] 发帖时间 2004年06月23日 20时58分
侠客 * 组别： 认证用户 帖子数量： 40 用户编号： 25599 注册时间： 2004年05月31日 Member 离线 | 相信这个问题对 Inno Setup 的老鸟是不成问题的！哈哈！谢谢！ 比如：脚本如何操作？ 附图 附图
jiangshen | [第1楼] 发帖时间 2004年06月23日 21时02分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | [Setup] DisableProgramGroupPage=yes [Icons]中不要出现{group}项
刘波 | [第2楼] 发帖时间 2004年06月23日 23时24分
版主 * * * * * 组别： 认证用户 帖子数量： 623 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 用向导创建新脚本的时候不是有个选项可以选择么？把那个选项选中就行了。记得好像叫：本程序不需要创建开始菜单项 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
青青
[第3楼] 发帖时间 2004年06月24日 01时26分

侠客
*

组别： 认证用户
帖子数量： 40
用户编号： 25599
注册时间： 2004年05月31日

Member 离线

引用 (刘波 @ 2004年06月23日 23时24分)
用向导创建新脚本的时候不是有个选项可以选择么？把那个选项选中就行了。记得好像叫：本程序不需要创建开始菜单项

谢谢你的回答！

光取消这个选项是不行的，不信你可以试试

青青
[第4楼] 发帖时间 2004年06月24日 01时29分

侠客
*

组别： 认证用户
帖子数量： 40
用户编号： 25599
注册时间： 2004年05月31日

Member 离线

引用 (jiangshen @ 2004年06月23日 21时02分)
[Setup]
DisableProgramGroupPage=yes

[Icons]中不要出现{group}项

谢谢你的解答！

问题圆满解决，问题就出在脚本里。

非常感谢！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.6631 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


Inno Setup的问题

> Inno Setup的问题
zjj1988101 | [楼主] 发帖时间 2004年03月21日 16时31分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 请问写脚本才能象红方框里的一样 附图 附图
大番茄 | [第1楼] 发帖时间 2004年03月21日 16时40分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 是什么意思呢? 是不是呀默认选择? 还是要不选择? ======================== 关键在最后面的 Flags: unchecked,如果去掉了,就默认选择了 [Tasks] ; 注意: 下面的条目包含一个中文用语 (“创建桌面快捷方式”和“添加快捷方式”)。如果需要你可以翻译为其它语言。 Name: "desktopicon"; Description: "创建桌面快捷方式"; GroupDescription: "添加快捷方式:"; Flags: unchecked 番茄花园: http://tomatolei.com
zjj1988101 | [第2楼] 发帖时间 2004年03月21日 16时46分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 就是让他有这个东西在~也就是说可以选择不添加程序组
莫名 | [第5楼] 发帖时间 2004年03月21日 21时05分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1321 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | [Setup]: AllowNoIcons 有效值: yes 或 no 默认值: no 描述: 这用于确定安装程序是否显示一个不创建任何图标选择框，让用户可以选择跳过程序图标的创建。如果设为 no，将不显示选择框；如果设为 yes，将显示选择框。
莫名 | [第6楼] 发帖时间 2004年03月21日 21时06分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1321 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 去看帮助文档吧，4.2.0 帮助文档已汉化了大部分。
zjj1988101 | [第7楼] 发帖时间 2004年03月22日 16时17分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 具体该看哪个部位呢？
linglingling
[第9楼] 发帖时间 2004年03月22日 23时37分

新手上路
*

组别： 用户
帖子数量： 7
用户编号： 22417
注册时间： 2004年03月17日

Member 离线

引用 (zjj1988101 @ 2004年03月22日 16时17分)
具体该看哪个部位呢？

那不是告诉你了么，在setup里面阿
zjj1988101 | [第10楼] 发帖时间 2004年03月23日 18时09分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 明白~谢谢各位的帮助！
donkey89
[第11楼] 发帖时间 2004年05月11日 09时36分

新手上路
*

组别： 用户
帖子数量： 5
用户编号： 24574
注册时间： 2004年05月11日

Member 离线

引用 (莫名 @ 2004年03月21日 21时06分)
去看帮助文档吧，4.2.0 帮助文档已汉化了大部分。

在哪里下载汉化的帮助?
chenmy
[第12楼] 发帖时间 2004年05月11日 10时12分

天使
* * * * * *

组别： 超级版主
帖子数量： 1380
用户编号： 1794
注册时间： 2002年04月28日

Member 离线

引用
在哪里下载汉化的帮助?

你下载 4.2.0 以后的汉化版，安装后就自然有了！

我爱自然之家！—我爱汉化！
user posted image
user posted image
我是中国人·最爱是中文！
user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.5685 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


【问题】请问innosetup的技巧!

> 【问题】请问innosetup的技巧!
订阅此主题 | 邮寄此主题 | 打印此主题
大番茄 | [楼主] 发帖时间 2004年05月25日 00时21分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 请问,如果我想默认情况打勾,改怎么改? 也就是想默认情况不创建开始程序菜单! 附图 附图 番茄花园: http://tomatolei.com
gnatix | [第1楼] 发帖时间 2004年05月25日 00时40分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | [Setup] AllowNoIcons=yes user posted image
刘波 | [第2楼] 发帖时间 2004年05月25日 04时48分
版主 * * * * * 组别： 认证用户 帖子数量： 623 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 楼主的意思是说默认把那个选项勾选上吧？好像没这个功能吧。至少我专门为你找了一遍没找到 老虎回复的那个只是是否出现那个选项而已。那个标记并不能让那个选项默认选中！ 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
gnatix | [第3楼] 发帖时间 2004年05月25日 05时32分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | very sorry! 没有看清题意：（ 楼主的要求可能只能用 Code 代码来实现了，而且很容易的： [Code] procedure InitializeWizard(); begin WizardForm.NoIconsCheck.Checked:= True; end; user posted image
gnatix | [第4楼] 发帖时间 2004年05月26日 01时29分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 你甚至可以改变字体大小、颜色、位置等等 附图 附图 user posted image
刘波
[第5楼] 发帖时间 2004年05月26日 10时45分

版主
* * * * *

组别： 认证用户
帖子数量： 623
用户编号： 691
注册时间： 2001年12月27日

Member 离线

引用 (gnatix @ 2004年05月25日 05时32分)
very sorry! 没有看清题意：（

楼主的要求可能只能用 Code 代码来实现了，而且很容易的：

[Code]
procedure InitializeWizard();
begin
WizardForm.NoIconsCheck.Checked:= True;
end;

老虎，到底CODE区段的那些函数什么的是在哪里找到的啊？在帮助里没看到啊！

比如这里的 WizardForm.NoIconsCheck.Checked:= True;
怎么知道那个复选框的名字是NoIconsCheck的啊？

欢迎来到汉化新世纪论坛之分论坛游戏天地
user posted image
gnatix | [第6楼] 发帖时间 2004年05月26日 12时01分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 我也没有找到这方面的资料，否则早拿出来共享了：） 目前我基本上是根据英文信息来猜想控件可能的名称。仔细研究一下软件的示例脚本文件，还是可以得到一些启发的，前提当然是要对 Delphi 编程熟悉。 user posted image
pk4321 | [第7楼] 发帖时间 2004年06月04日 18时54分
圣骑士 * * * 组别： 认证用户 帖子数量： 151 用户编号： 770 注册时间： 2002年01月10日 Member 离线 | 有谁知道如何在安装完成界面中，加网址超级链接？
gnatix | [第8楼] 发帖时间 2004年06月04日 18时57分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 旧帖子中已经讲过，搜索一下。 user posted image
gnatix | [第9楼] 发帖时间 2004年06月04日 19时03分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 这个帖子中有一些你要的东西： http://bbs.hanzify.org/index.php?showtopic=17878 user posted image
OFA
[第10楼] 发帖时间 2004年06月04日 19时28分

天使
* * * * * *

组别： 认证用户
帖子数量： 1417
用户编号： 13575
注册时间： 2003年04月13日

Member 离线

仔细读说明，其实这些都写了。
看这段:

TWizardForm = class(TUIStateForm)
property CANCELBUTTON: TBUTTON; read;
property NEXTBUTTON: TBUTTON; read;
property BACKBUTTON: TBUTTON; read;
property NOTEBOOK1: TNOTEBOOK; read;

property NOTEBOOK2: TNOTEBOOK; read;
property DISKSPACELABEL: TNewStaticText; read;
property DIREDIT: TEDIT; read;
property GROUPEDIT: TEDIT; read;
property NOICONSCHECK: TCHECKBOX; read;
property PASSWORDLABEL: TNewStaticText; read;
property PASSWORDEDIT: TPasswordEdit; read;
property PASSWORDEDITLABEL: TNewStaticText; read;
property READYMEMO: TMEMO; read;
property TYPESCOMBO: TCOMBOBOX; read;
property BEVEL: TBEVEL; read;
property WizardBitmapImage: TBitmapImage; read;

property WELCOMELABEL1: TNewStaticText; read;
property INFOBEFOREMEMO: TRICHEDITVIEWER; read;
property INFOBEFORECLICKLABEL: TNewStaticText; read;
property MAINPANEL: TPANEL; read;
property BEVEL1: TBEVEL; read;
property PAGENAMELABEL: TNewStaticText; read;
property PAGEDESCRIPTIONLABEL: TNewStaticText; read;
property WizardSmallBitmapImage: TBitmapImage; read;
property READYLABEL: TNewStaticText; read;
property FINISHEDLABEL: TNewStaticText; read;

property YESRADIO: TRADIOBUTTON; read;
property NORADIO: TRADIOBUTTON; read;
property WizardBitmapImage2: TBitmapImage; read;
property WELCOMELABEL2: TNewStaticText; read;
property LICENSELABEL1: TNewStaticText; read;
property LICENSEMEMO: TRICHEDITVIEWER; read;
property INFOAFTERMEMO: TRICHEDITVIEWER; read;
property INFOAFTERCLICKLABEL: TNewStaticText; read;
property COMPONENTSLIST: TNEWCHECKLISTBOX; read;
property COMPONENTSDISKSPACELABEL: TNewStaticText; read;

property BEVELEDLABEL: TNewStaticText; read;
property STATUSLABEL: TNewStaticText; read;
property FILENAMELABEL: TNewStaticText; read;
property PROGRESSGAUGE: TNEWPROGRESSBAR; read;
property SELECTDIRLABEL: TNewStaticText; read;
property SELECTSTARTMENUFOLDERLABEL: TNewStaticText; read;
property SELECTCOMPONENTSLABEL: TNewStaticText; read;
property SELECTTASKSLABEL: TNewStaticText; read;
property LICENSEACCEPTEDRADIO: TRADIOBUTTON; read;

property LICENSENOTACCEPTEDRADIO: TRADIOBUTTON; read;
property USERINFONAMELABEL: TNewStaticText; read;
property USERINFONAMEEDIT: TEDIT; read;
property USERINFOORGLABEL: TNewStaticText; read;
property USERINFOORGEDIT: TEDIT; read;
property PreparingErrorBitmapImage: TBitmapImage; read;
property PREPARINGLABEL: TNewStaticText; read;
property FINISHEDHEADINGLABEL: TNewStaticText; read;
property SCRIPTDLGPANEL: TPANEL; read;
property USERINFOSERIALLABEL: TNewStaticText; read;

property USERINFOSERIALEDIT: TEDIT; read;
property TASKSLIST: TNEWCHECKLISTBOX; read;
property RUNLIST: TNEWCHECKLISTBOX; read;
property DirBrowseButton: TButton; read;
property GroupBrowseButton: TButton; read;
property SelectDirBitmapImage: TBitmapImage; read;
property SelectGroupBitmapImage: TBitmapImage; read;
property SelectDirBrowseLabel: TNewStaticText; read;
property SelectStartMenuFolderBrowseLabel: TNewStaticText; read;
property CURPAGE: TWIZARDPAGE; read;

function ADJUSTLABELHEIGHT(ALABEL:TNewStaticText):INTEGER;
procedure INCTOPDECHEIGHT(ACONTROL:TCONTROL;AMOUNT:INTEGER);
end;

对象 WizardForm 所支持的所有属性都在这里。

TCheckBox = class(TCustomCheckBox)

property ALIGNMENT: TAlignment; read write;
property ALLOWGRAYED: Boolean; read write;
property CAPTION: String; read write;
property CHECKED: Boolean; read write;
property COLOR: Longint; read write;
property FONT: TFont; read write;
property STATE: TCheckBoxState; read write;
property ONCLICK: TNotifyEvent; read write;
end;

对象 CheckBox 所支持的所有属性都在这里。

user posted image
愿为汉化事业贡献自己的一份微薄之力。
欢迎您访问我的净土 http://www.cokemouse.com
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3649 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


请教INNO SETUP的问题

> 请教INNO SETUP的问题, 关于默认选择~!
订阅此主题 | 邮寄此主题 | 打印此主题
大番茄 | [楼主] 发帖时间 2004年03月09日 15时26分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 我用ISTOOL配合inno setup做的程序 安装的时候没有默认选择创建快捷方式, 怎样才可以让它默认选择呢? 附图 附图 番茄花园: http://tomatolei.com/
大番茄
[第1楼] 发帖时间 2004年03月09日 15时27分

圣骑士
* * *

组别： 认证用户
帖子数量： 127
用户编号： 15345
注册时间： 2003年06月05日

Member 离线

我的代码

代码
[Icons]
Name: {group}\TS银行系统; Filename: {app}\TS_Bank.exe; WorkingDir: {app}; IconIndex: 0
; 注意: 下列条目包含一个中文用语 (“网站”)。如果需要你可以翻译为其它语言。
Name: {group}\TS银行系统 网站; Filename: {app}\TS_Bank.url
; 注意: 下面的条目包含一个中文用语 (“卸载”)。如果需要你可以翻译为其它语言。
Name: {group}\卸载 TS银行系统; Filename: {uninstallexe}
Name: {group}\TS银行系统 说明; Filename: {app}\ReadMe.txt

Name: {userdesktop}\TS银行系统; Filename: {app}\TS_Bank.exe; WorkingDir: {app}; IconIndex: 0; Tasks: desktopicon
Name: {userappdata}\Microsoft\Internet Explorer\Quick Launch\TS银行系统; Filename: {app}\TS_Bank.exe; Tasks: quicklaunchicon; WorkingDir: {app}; IconIndex: 0

番茄花园:
http://tomatolei.com/
mapeng
[第2楼] 发帖时间 2004年03月09日 15时52分

精灵王
* * * *

组别： 认证用户
帖子数量： 297
用户编号： 19595
注册时间： 2003年12月11日

Member 离线

例如：
1.默认选择
Name: "desktopicon"; Description: "Create a &desktop icon"; GroupDescription: "Additional icons:"; MinVersion: 4,4
2.默认不选择
Name: "quicklaunchicon"; Description: "Create a &Quick Launch icon"; GroupDescription: "Additional icons:"; MinVersion: 4,4;
Flags: unchecked
其实默认选择或者不选择，就是去掉Flags: unchecked这个语句，去掉了为默认选择，不去掉反之。明白了吧！

我的外表很传统,我的内心很反叛;我的行动很规矩,我的思想却激进;我的语言很尖刻,我的性情很温柔;我的眼光很挑剔,我的能力却有限;我的理想很伟大,我的现状很平凡;我的头脑很灵活,我的双手却笨拙;我的睡眠很踏实,我的美梦很有限;我的长相很酷毙,我的女友却没影。 user posted image
大番茄 | [第3楼] 发帖时间 2004年03月09日 16时42分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | OK了 非常感谢楼上的朋友! 番茄花园: http://tomatolei.com/
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 3.8692 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


各位懂INNO的高手来啊！

> 各位懂INNO的高手来啊！, 看图。。
订阅此主题 | 邮寄此主题 | 打印此主题
leyan22 | [楼主] 发帖时间 2004年05月10日 00时46分
侠客 * 组别： 认证用户 帖子数量： 39 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | 这个是INNO SETUP汉化版安装后的快捷方式属性和用INNO做的ICONDIY的快捷方式属性 附图 附图
leyan22 | [第1楼] 发帖时间 2004年05月10日 00时47分
侠客 * 组别： 认证用户 帖子数量： 39 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | ICONDIY的快捷方式属性 附图 附图
leyan22 | [第2楼] 发帖时间 2004年05月10日 00时49分
侠客 * 组别： 认证用户 帖子数量： 39 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | 我就是想问 如何能在快捷方式中定义“起始位置”呢 ？ 是哪个段的语句，具体是什么，我试了好几次，安装出来这里都是空的啊！ 怎么定义？各位帮帮忙了，我有用的
gnatix | [第3楼] 发帖时间 2004年05月10日 04时59分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 看图中的绿色部分！ 附图 附图 user posted image
leyan22 | [第4楼] 发帖时间 2004年05月10日 09时16分
侠客 * 组别： 认证用户 帖子数量： 39 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | 啊 真是谢谢老虎斑竹了，呵呵！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3274 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


Inno Setup 的问题

> Inno Setup 的问题, Inno Setup 安装程序的"起始位置"怎样定义?
订阅此主题 | 邮寄此主题 | 打印此主题
心魔 | [楼主] 发帖时间 2004年04月18日 15时05分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 19462 注册时间： 2003年12月06日 Member 离线 | 我用Inno Setup 做了一个安装程序,但是它在桌面创建的"快捷方式"没有定义"起始位置",无法运行,必须手动加入,请问,怎样在安装脚本中加入桌面快捷方式的"起始位置"?
gnatix | [第1楼] 发帖时间 2004年04月18日 15时49分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 如果不是默认起始位置，你必须使用 WorkingDir 来设置。参考示例： [Tasks] Name: "desktopicon"; Description: "创建桌面快捷方式(&D)"; GroupDescription: "添加快捷方式:" ...... [Icons] Name: "{userdesktop}\TNT 屏幕捕捉"; Filename: "{app}\TNT.exe"; Tasks: desktopicon; WorkingDir: "{app}\ABCDE" user posted image
心魔 | [第2楼] 发帖时间 2004年04月18日 15时56分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 19462 注册时间： 2003年12月06日 Member 离线 | 如果是默认"安装位置"的"起始位置"呢?怎么编辑?怎么设置?
gnatix | [第3楼] 发帖时间 2004年04月18日 16时26分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 默认的起始位置就是所运行程序的位置。你可以把脚本文件帖上来看看。 user posted image
gnatix
[第4楼] 发帖时间 2004年04月18日 16时42分

天使
* * * * * *

组别： 超级版主
帖子数量： 2407
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (心魔 @ 2004年04月18日 15时56分)
如果是默认"安装位置"的"起始位置"呢?怎么编辑?怎么设置?

设置为：
WorkingDir: "{app}"

user posted image
心魔 | [第5楼] 发帖时间 2004年04月21日 15时49分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 19462 注册时间： 2003年12月06日 Member 离线 | 谢谢~问题解决了
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.6966 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


【求助】如何创建可选择性卸载快捷方式

> 【求助】如何创建可选择性卸载快捷方式, 请教：如何创建可选择性卸载快捷方式
xihua
[楼主] [image] 发帖时间 2004年07月18日 22时16分

精灵王
* * * *

组别： 认证用户
帖子数量： 343
用户编号： 17836
注册时间： 2003年10月05日

Member 在线

一个学习脚本：

[Setup]
AppName=DX-Ball 2 v1.2 完全版
AppVerName=DX-Ball 2 v1.2 完全版
AppPublisher=Longbow Digital Arts
AppPublisherURL=http://www.LongbowDigitalArts.com/
DefaultDirName={pf}\DX-Ball 2
DefaultGroupName=DX-Ball 2
AllowNoIcons=yes
Compression=lzma/ultra
OutputBaseFilename=DX-Ball2
OutputDir=C:\
SolidCompression=yes
DirExistsWarning=yes
DisableReadyPage=yes
UninstallDisplayIcon={app}\DXBall2.exe,0
DisableStartupPrompt=no
SetupIconFile=C:\DXBall 2\DXBall.ico
UninstallIconFile=C:\DXBall 2\UNDXBall.ico

[Tasks]
Name: "desktopicon"; Description: "{cm:CreateDesktopIcon}"; GroupDescription: "{cm:AdditionalIcons}"; Flags: exclusive
Name: "quicklaunchicon"; Description: "{cm:CreateQuickLaunchIcon}"; GroupDescription: "{cm:AdditionalIcons}"; Flags: unchecked

[Dirs]
Name: "{app}"; Flags: uninsalwaysuninstall

[Files]
Source: "C:\DXBall2\DXBall2.exe"; DestDir: "{app}"; Flags: ignoreversion
Source: "C:\DXBall2\*"; DestDir: "{app}"; Flags: ignoreversion recursesubdirs

[Icons]
Name: "{group}\DX-Ball 2"; Filename: "{app}\DXBall2.exe"; WorkingDir: "{app}"; Flags: runmaximized
Name: "{group}\{cm:UninstallProgram,DX-Ball 2}"; Filename: "{uninstallexe}"
Name: "{userdesktop}\DX-Ball 2"; Filename: "{app}\DXBall2.exe"; Tasks: desktopicon; WorkingDir: "{app}"; Flags: runmaximized
Name: "{userappdata}\Microsoft\Internet Explorer\Quick Launch\DX-Ball 2"; Filename: "{app}\DXBall2.exe"; Tasks: quicklaunchicon; WorkingDir: "{app}"; Flags: runmaximized

我想在“选择附加任务窗口”中创建一个可选择项，名为“在"开始/程序"下创建卸载快捷方式”。当选定时，创建卸载快捷方式；未选定时，不创建快捷方式，可从"添加/删除"里卸载。

在帮助中看到 Uninstallable=no 是不包含卸载程序，但还是不知这个可选择的脚本项应该怎么写？

昨天用了几个小时，看完论坛里所有与 Inno 四个字母相关的贴子，一共 8 页，但没有找到答案。

请高手指点一下，谢谢各位！

  山河大地，已属微尘；血肉身躯，且归泡影；非上上智，无了了心。

ah47sm | [第1楼] 发帖时间 2004年07月18日 23时20分
版主 * * * * 组别： 认证用户 帖子数量： 324 用户编号： 15774 注册时间： 2003年07月01日 Member 离线 | 将 Uninstallable=yes 或 no 放在 [Setup] 下就可以啦 如果该值是 yes，则包含卸载程序； 如果该值是 no，则不包含卸载程序，需要最终用户手工移除应用程序目录里的文件。 >>> Welcome to My Website China Serials 2000 <<<
xihua
[第2楼] [image] 发帖时间 2004年07月18日 23时27分

精灵王
* * * *

组别： 认证用户
帖子数量： 343
用户编号： 17836
注册时间： 2003年10月05日

Member 在线

引用 (ah47sm @ 2004年07月18日 23时20分)
将 Uninstallable=no 放在 [Setup] 下就可以啦

[Setup]
Uninstallable=no
是不包含卸载程序。

但我需要可选择性的安装卸载或不卸载的快捷方式，如果安装时选择了安装卸载快捷方式，而上面这句根本没把卸载程序放进去，那选择安装卸载快捷方式不是根本没有意义？

  山河大地，已属微尘；血肉身躯，且归泡影；非上上智，无了了心。

刘波 | [第3楼] 发帖时间 2004年07月19日 01时40分
版主 * * * * * 组别： 认证用户 帖子数量： 786 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | [Tasks] Name: "uninstallicon"; Description: "在开始菜单创建卸载图标(&U)"; GroupDescription: "添加快捷方式：" [Icons] Name: "{group}\卸载XXX"; Filename: "{uninstallexe}"; Tasks: uninstallicon 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
xihua | [第4楼] [image] 发帖时间 2004年07月19日 01时56分
精灵王 * * * * 组别： 认证用户 帖子数量： 343 用户编号： 17836 注册时间： 2003年10月05日 Member 在线 | 多谢刘波兄指点！ 山河大地，已属微尘；血肉身躯，且归泡影；非上上智，无了了心。
gnatix
[第5楼] 发帖时间 2004年07月19日 02时36分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2694
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用 (刘波 @ 2004年07月19日 01时40分)
[Tasks]
Name: "uninstallicon"; Description: "在开始菜单创建卸载图标(&U)"; GroupDescription: "添加快捷方式："

[Icons]
Name: "{group}\卸载XXX"; Filename: "{uninstallexe}"; Tasks: uninstallicon

这个只是选择是否创建卸载的快捷方式，但是楼主要的是是否复制卸载程序和卸载数据。

user posted image
gnatix | [第6楼] 发帖时间 2004年07月19日 02时59分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2694 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 既然用户可能会选择安装卸载程序，所以在编译安装包时必须把卸载程序加进出。这样楼主的意思其实就是用户选择在安装文件夹中要不要出现那两个文件 unins000.* 以及是否要创建卸载程序的快捷方式而已。在不使用 Pascal 脚本的情况下，我估计只有用下面的所谓“方法”了： [Tasks] Name: createuninstall/yes; Description: "安装"; GroupDescription: "是否安装卸载程序？"; Flags: exclusive Name: createuninstall/no; Description: "不安装"; GroupDescription: "是否安装卸载程序？"; Flags: unchecked exclusive [Icons] Name: "{group}\卸载 XXXXX 汉化版"; Filename: "{uninstallexe}"; Tasks: createuninstall/yes [Run] Filename: "{cmd}"; Parameters: "/c del ""{app}\unins000.*"""; Description: "运行"; Flags: nowait hidewizard runhidden; Tasks: createuninstall/no user posted image
xihua | [第7楼] [image] 发帖时间 2004年07月19日 11时04分
精灵王 * * * * 组别： 认证用户 帖子数量： 343 用户编号： 17836 注册时间： 2003年10月05日 Member 在线 | 多谢 gnatix 兄点拨！ 原来还可以这样，我想了半天硬是没想出......... 山河大地，已属微尘；血肉身躯，且归泡影；非上上智，无了了心。
youth9999 | [第8楼] 发帖时间 2004年08月05日 19时44分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 今天才看到这个帖子，又学习了！
xihua
[第9楼] [image] 发帖时间 2004年08月05日 20时26分

精灵王
* * * *

组别： 认证用户
帖子数量： 343
用户编号： 17836
注册时间： 2003年10月05日

Member 在线

引用 (youth9999 @ 2004年08月05日 19时44分)
今天才看到这个帖子，又学习了！

阁下是"天天精品论坛" / "操作系统运用技术"版块 的斑竹！

附图
附图

  山河大地，已属微尘；血肉身躯，且归泡影；非上上智，无了了心。

? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3308 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


求助Inno Setup高手

> 求助Inno Setup高手
jiangshen | [楼主] 发帖时间 2004年06月07日 21时07分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 我的安装程序如下图，现在有个问题，我假如安装时选择那个IP数据库，怎么能实现把选择的那个文件安装到桌面快捷方式，不选则则不安装 附图 附图
莫尼卡 | [第1楼] 发帖时间 2004年06月07日 21时22分
圣骑士 * * * 组别： 认证用户 帖子数量： 246 用户编号： 4599 注册时间： 2002年08月26日 Member 离线 | icons 段后也定义组件~ I love you! (you=emulator) user posted image
jiangshen | [第2楼] 发帖时间 2004年06月07日 21时32分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 能具体点么，谢谢
jiangshen | [第3楼] 发帖时间 2004年06月07日 21时39分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 做好了，谢谢指点
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3044 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


【求助】请教INNOSETUP能不能实现这个功能

> 【求助】请教INNOSETUP能不能实现这个功能, 如图
leyan22 | [楼主] 发帖时间 2004年07月12日 18时18分
侠客 * 组别： 认证用户 帖子数量： 39 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | 定义的安装路径是X：/XXX/QQ 安装完了以后在X：/XXX/下面却有 QQ TT QQGAME 3个文件夹 这个是我在TENCENT的QQ里看到的 但它是用NSIS 做的（以前的QQ是WISE） 请问在INNO中是否能实现？如果可以，应该怎么弄？ 附图 附图
OFA
[第1楼] 发帖时间 2004年07月12日 18时39分

天使
* * * * * *

组别： 认证用户
帖子数量： 1417
用户编号： 13575
注册时间： 2003年04月13日

Member 离线

当然可以。你指定文件安装路径的时候只需要加上 DestDir: "{app}\Name";
例如:
代码
Source: "C:\example.exe"; DestDir: "{app}\example_dir";

这样在用户指定的安装目录下就会生成 example_dir 子目录，并将 example.exe 放入该子目录中。

user posted image
愿为汉化事业贡献自己的一份微薄之力。
欢迎您访问我的净土 http://www.cokemouse.com
tracky
[第2楼] 发帖时间 2004年07月12日 18时48分

精灵王
* * * *

组别： 认证用户
帖子数量： 322
用户编号： 21516
注册时间： 2004年02月21日

Member 离线

引用 (OFA @ 2004年07月12日 18时39分)
当然可以。你指定文件安装路径的时候只需要加上 DestDir: "{app}\Name";
例如:
代码
Source: "C:\example.exe"; DestDir: "{app}\example_dir";

这样在用户指定的安装目录下就会生成 example_dir 子目录，并将 example.exe 放入该子目录中。

我也只会这样建立目录
但是如果是空目录 那要怎么建立?

╭∩╮（︶︿︶）╭∩╮
OFA
[第3楼] 发帖时间 2004年07月12日 18时52分

天使
* * * * * *

组别： 认证用户
帖子数量： 1417
用户编号： 13575
注册时间： 2003年04月13日

Member 离线

那用以下代码:
代码
[Dirs]
Name: "{app}\name_dir"

name_dir 为你需要建立的目录，还有很多其他的参数，比如 Attribs 可以指定目录的属性，Permissions 可以指定目录的访问权限；Flags 下可以指定不同的删除规则。
这些在 Inno Setup 的帮助中都解释的很详尽。

user posted image
愿为汉化事业贡献自己的一份微薄之力。
欢迎您访问我的净土 http://www.cokemouse.com
tracky
[第4楼] 发帖时间 2004年07月12日 18时55分

精灵王
* * * *

组别： 认证用户
帖子数量： 322
用户编号： 21516
注册时间： 2004年02月21日

Member 离线

引用 (OFA @ 2004年07月12日 18时52分)
那用以下代码:
代码
[Dirs]
Name: "{app}\name_dir"

name_dir 为你需要建立的目录，还有很多其他的参数，比如 Attribs 可以指定目录的属性，Permissions 可以指定目录的访问权限；Flags 下可以指定不同的删除规则。
这些在 Inno Setup 的帮助中都解释的很详尽。

谢谢了 我去看帮助去

╭∩╮（︶︿︶）╭∩╮
leyan22
[第5楼] 发帖时间 2004年07月12日 19时10分

侠客
*

组别： 认证用户
帖子数量： 39
用户编号： 24384
注册时间： 2004年05月06日

Member 离线

引用 (OFA @ 2004年07月12日 18时39分)
当然可以。你指定文件安装路径的时候只需要加上 DestDir: "{app}\Name";
例如:
代码
Source: "C:\example.exe"; DestDir: "{app}\example_dir";

这样在用户指定的安装目录下就会生成 example_dir 子目录，并将 example.exe 放入该子目录中。

但是TT 和 QQGAME 并不是QQ 的子目录

这个代码好象行不通啊！
leyan22 | [第6楼] 发帖时间 2004年07月12日 19时14分
侠客 * 组别： 认证用户 帖子数量： 39 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | OFA再来看看吧！
tracky | [第7楼] 发帖时间 2004年07月12日 19时20分
精灵王 * * * * 组别： 认证用户 帖子数量： 322 用户编号： 21516 注册时间： 2004年02月21日 Member 离线 | [Files] Source: 那个你要建立目录下的文件; DestDir: {app}\目录名\; 如果是新建空目录 [Dirs] Name: "{app}\目录名称" 还有其他参数值你自己看下帮助 ╭∩╮（︶︿︶）╭∩╮
OFA
[第8楼] 发帖时间 2004年07月12日 19时23分

天使
* * * * * *

组别： 认证用户
帖子数量： 1417
用户编号： 13575
注册时间： 2003年04月13日

Member 离线

你可以用上面我举例的第二段代码，即
代码
[Dirs]
Name: "XXX\QQ"
Name: "XXX\TT"
Name: "XXX\QQGAME"

另外请注意，在本地驱动器中，应使用“\”而非“/”。

user posted image
愿为汉化事业贡献自己的一份微薄之力。
欢迎您访问我的净土 http://www.cokemouse.com
leyan22 | [第9楼] 发帖时间 2004年07月12日 19时47分
侠客 * 组别： 认证用户 帖子数量： 39 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | 谢谢 我再试试 不行再来！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3577 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


求教，如何在inno setup里添加子文件夹？

> 求教，如何在inno setup里添加子文件夹？
订阅此主题 | 邮寄此主题 | 打印此主题
kgbboss | [楼主] 发帖时间 2003年07月22日 11时45分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 1291 注册时间： 2002年03月17日 Member 离线 | 求教，如何在inno setup里添加子文件夹？我使用向导，添加目录时指向目标目录，但做出来的安装文件却没有目标目录。我不懂写脚本。
gnatix | [第1楼] 发帖时间 2003年07月22日 19时13分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 光使用向导没法做到，必须在脚本文件的 [Files] 区段中添加 Source: "E:/MyHanhua/SubDir/*.*"; DestDir: "{app}/SubDir"; Flags: ignoreversion 这里 SubDir 表示你的子文件夹。 user posted image
kgbboss | [第2楼] 发帖时间 2003年07月22日 20时24分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 1291 注册时间： 2002年03月17日 Member 离线 | 谢谢！
思忆 | [第3楼] [image] 发帖时间 2003年07月22日 22时00分
侠客 * 组别： 用户 帖子数量： 29 用户编号： 1456 注册时间： 2002年04月05日 Member 离线 | 以上方法只能对于子文件夹有内容的时候使用。 如果你要创建空的子文件夹需加入以下代码： [Dirs] Name: "{app}SubDir1" Name: "{app}SubDir2" Name: "{app}SubDir3"
西风狂诗曲 | [第4楼] 发帖时间 2003年07月23日 20时29分
圣骑士 * * * 组别： 认证用户 帖子数量： 199 用户编号： 3829 注册时间： 2002年07月31日 Member 离线 | [Files] Source: D:SoftOfficeISToolISTool.exe; DestDir: {app}; Flags: recursesubdirs 编译时可同时编译D:SoftOfficeISTool下的子目录及文件
netgc | [第5楼] 发帖时间 2003年07月26日 02时15分
侠客 * 组别： 用户 帖子数量： 18 用户编号： 16151 注册时间： 2003年07月17日 Member 离线 | 用ISTools配合使用
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3298 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


[求助]请教高手一个问题？怎样用Inno Setup实现往system32文件夹和注册表中

> [求助]请教高手一个问题？怎样用Inno Setup实现往system32文件夹和注册表中
leyan | [楼主] 发帖时间 2002年09月04日 00时11分
精灵王 * * * * 组别： 认证用户 帖子数量： 460 用户编号： 1393 注册时间： 2002年03月31日 Member 离线 | 汉化游戏和汉化软件是两码事!!!
炎之川
[第1楼] 发帖时间 2002年09月04日 08时52分

最近比较烦哪！
* * * * * * * *

组别： 管理员
帖子数量： 6095
用户编号： 3
注册时间： 2001年06月15日

Member 离线

添加注册表项
[Registry] section
This section is optional. It defines any registry entries you would like Setup to create on the user's system after it has copied the files.
The following is an example of a [Registry] section.
[Registry]
Root: HKCU; Subkey: "Software\My Company"; Flags: uninsdeletekeyifempty
Root: HKCU; Subkey: "Software\My Company\My Program"; Flags: uninsdeletekey
Root: HKLM; Subkey: "Software\My Company"; Flags: uninsdeletekeyifempty
Root: HKLM; Subkey: "Software\My Company\My Program"; Flags: uninsdeletekey
Root: HKLM; Subkey: "Software\My Company\My Program"; ValueType: string; ValueName: "InstallPath"; ValueData: "{app}"
The following is a list of the supported parameters:
Root (Required)
Description:
The root key. This must be one of the following:
HKCR(HKEY_CLASSES_ROOT)
HKCU(HKEY_CURRENT_USER)
HKLM(HKEY_LOCAL_MACHINE)
HKU(HKEY_USERS)
HKCC(HKEY_CURRENT_CONFIG)
Example:
Root: HKCU
Subkey (Required)
Description:
The subkey name, which can include constants.
Example:
Subkey: "Software\My Company\My Program"
ValueType
Description:
The data type of the value. This must be one of the following:
none
string
expandsz
multisz
dword
binary
If none (the default setting) is specified, Setup will create the key but not a value. In this case the ValueName and ValueData parameters are ignored.
If string is specified, Setup will create a string (REG_SZ) value.
If expandsz is specified, Setup will create an expand-string (REG_EXPAND_SZ) value. This data type is primarily used on Windows NT, but is supported by Windows 95/98.
If multisz is specified, Setup will create an multi-string (REG_MULTI_SZ) value.
If dword is specified, Setup will create an integer (REG_DWORD) value.
If binary is specified, Setup will create a binary (REG_BINARY) value.
Example:
ValueType: string
ValueName
Description:
The name of the value to create, which can include constants. If this is blank, it will write to the "Default" value. If the ValueType parameter is set to none, this parameter is ignored.
Example:
ValueName: "Version"
ValueData
Description:
The data for the value. If the ValueType parameter is string, expandsz
, or multisz, this is a string that can include constants. If the data type is
dword, this can be a decimal integer (e.g. "123") or a hexadecimal integer (e.g. "$7B"). If the data type is binary, this is a sequence of hexadecimal bytes in the form: "00 ff 12 34". If the data type is none, this is ignored.
On a string, expandsz, or multisz type value, you may use a special constant called {olddata} in this parameter. {olddata} is replaced with the previous data of the registry value. The {olddata} constant can be useful if you need to append a string to an existing value, for example,
{olddata};{app}. If the value does not exist or the existing value isn't a string type, the {olddata} constant is silently removed. {olddata} will also be silently removed if the value being created is a multisz type but the existing value is not a multi-string type (i.e. it's REG_SZ or REG_EXPAND_SZ), and vice versa.
On a multisz type value, you may use a special constant called {break} in this parameter to embed line breaks (nulls).
Example:
ValueData: "1.0"
Flags
Description:
This parameter is a set of extra options. Multiple options may be used by separating them by spaces. The following options are supported:
createvalueifdoesntexist
When this flag is specified, Setup will create the value only if a value of the same name doesn't already exist. This flag has no effect if the data type is none, or if you specify the deletevalue flag.
deletekey
When this flag is specified, Setup will first try deleting the entire key if it exists, including all values and subkeys in it. If ValueType is not none, it will then create a new key and value.
deletevalue
When this flag is specified, Setup will first try deleting the value if it exists. If ValueType is not none, it will then create the key if it didn't already exist, and the new value.
dontcreatekey
When this flag is specified, Setup will not attempt to create the key or any value if the key did not already exist on the user's system. No error message is displayed if the key does not exist.
Typically this flag is used in combination with the uninsdeletekey flag, for deleting keys during uninstallation but not creating them during installation.
noerror
Don't display an error message if Setup fails to create the key or value for any reason.
preservestringtype
This is only applicable when the ValueType parameter is string or
expandsz. When this flag is specified and the value did not already exist or the existing value isn't a string type (REG_SZ or REG_EXPAND_SZ), it will be created with the type specified by ValueType. If the value did exist and is a string type, it will be replaced with the same value type as the pre-existing value.
uninsclearvalue
When the program is uninstalled, set the value's data to a null string (type REG_SZ). This flag cannot be combined with the uninsdeletekey flag.
uninsdeletekey
When the program is uninstalled, delete the entire key, including all values and subkeys in it. It obviously wouldn't be a good idea to use this on a key that is used by Windows itself. You should only use this on keys private to your application.
uninsdeletekeyifempty
When the program is uninstalled, delete the key if it has no values or subkeys left in it. This flag can be combined with uninsdeletevalue.
uninsdeletevalue
Delete the value when the program is uninstalled. This flag can be combined with uninsdeletekeyifempty.
NOTE: In Inno Setup versions prior to 1.1, you could use this flag along with the data type none and it would function as a "delete key if empty" flag. This technique is no longer supported. You must now use the uninsdeletekeyifempty flag to accomplish this.
Example:
Flags: uninsdeletevalue

user posted image

访问 炎之川的blog
炎之川 | [第2楼] 发帖时间 2002年09月04日 08时56分
最近比较烦哪！ * * * * * * * * 组别： 管理员 帖子数量： 6095 用户编号： 3 注册时间： 2001年06月15日 Member 离线 | 往system目录下添加文件 [Files] section This section is optional, but is necessary for most installations. It defines all of the files Setup will copy to the user's system. During Setup, the uninstaller program and data is automatically copied to the application directory, so you do not need to manually add it to the [Files] section. Here is an example of a [Files] section: [Files] Source: "CTL3DV2.DLL"; DestDir: "{sys}"; CopyMode: onlyifdoesntexist; Flags: uninsneveruninstall Source: "MYPROG.EXE"; DestDir: "{app}" Source: "MYPROG.HLP"; DestDir: "{app}" Source: "README.TXT"; DestDir: "{app}"; Flags: isreadme user posted image 访问 炎之川的blog
leyan | [第3楼] 发帖时间 2002年09月04日 14时49分
精灵王 * * * * 组别： 认证用户 帖子数量： 460 用户编号： 1393 注册时间： 2002年03月31日 Member 离线 | 谢谢炎老前辈!!! 汉化游戏和汉化软件是两码事!!!
炎之川 | [第4楼] 发帖时间 2002年09月04日 15时44分
最近比较烦哪！ * * * * * * * * 组别： 管理员 帖子数量： 6095 用户编号： 3 注册时间： 2001年06月15日 Member 离线 | 都是帮助文件里面的，看英文帮助确实很累，所以要学会如何找到自己需要的内容... user posted image 访问 炎之川的blog
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.2990 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


inno 求助

> inno 求助
jiangshen | [楼主] 发帖时间 2004年06月27日 00时29分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | [Setup] AppName=更新升级文件 AppVerName=更新升级文件 CreateAppDir=no DisableDirPage=yes DisableProgramGroupPage=yes DisableReadyPage=yes DisableFinishedPage=yes DisableStartupPrompt=yes Compression=lzma SolidCompression=yes Uninstallable=no [Files] Source: "C:\Documents and Settings\Owner\My Documents\ip\QQwry.Dat"; DestDir: "{src}"; Flags: ignoreversion 1:为什么DisableStartupPrompt=yes不起作用，还是有欢迎界面！！ 2:Flags: ????是始终不覆盖现有文件??
ah47sm
[第2楼] 发帖时间 2004年06月27日 10时26分

圣骑士
* * *

组别： 认证用户
帖子数量： 112
用户编号： 15774
注册时间： 2003年07月01日

Member 离线

引用 (jiangshen @ 2004年06月27日 00时29分)
DisableStartupPrompt=yes

删除这行试试看。

>>> Welcome to My Website China Serials 2000 <<<
jiangshen
[第3楼] 发帖时间 2004年06月27日 10时34分
*

组别： 用户
帖子数量： 74
用户编号： 24005
注册时间： 2004年04月27日

Member 离线

引用 (ah47sm @ 2004年06月27日 10时26分)
引用 (jiangshen @ 2004年06月27日 00时29分)
DisableStartupPrompt=yes

删除这行试试看。

那就更没有了！！！
gnatix
[第4楼] 发帖时间 2004年06月27日 13时31分

天使
* * * * * *

组别： 超级版主
帖子数量： 2406
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (jiangshen @ 2004年06月27日 00时29分)
[Setup]
AppName=更新升级文件
AppVerName=更新升级文件
CreateAppDir=no
DisableDirPage=yes
DisableProgramGroupPage=yes
DisableReadyPage=yes
DisableFinishedPage=yes
DisableStartupPrompt=yes
Compression=lzma
SolidCompression=yes
Uninstallable=no

[Files]
Source: "C:\Documents and Settings\Owner\My Documents\ip\QQwry.Dat"; DestDir: "{src}"; Flags: ignoreversion

1:为什么DisableStartupPrompt=yes不起作用，还是有欢迎界面！！
2:Flags: ????是始终不覆盖现有文件??

前面已经说了，DisableStartupPrompt=yes 只是不显示启动时的提示屏幕。

Flags: onlyifdoesntexist 则始终不覆盖现有文件

PS：其实这些东西帮助文件中都说得很清楚了，莫名兄辛辛苦苦把帮助文件翻译成中文，就是为了方便大家阅读的啊。

user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.2980 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


Inno Setup使用问题？？？

> Inno Setup使用问题？？？
订阅此主题 | 邮寄此主题 | 打印此主题
jiangshen | [楼主] 发帖时间 2004年06月20日 07时30分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 新世纪很多汉化软件在安装的时候都会询问：是否安装3721上网助手，打家可以选择安装，这个怎么实现？？？ 注意，我不是要安装3721，我是问这种安装方法怎么实现？？ 还有一个问题，怎么将某些文件安装到临时文件夹？？？
飞龙 | [第1楼] 发帖时间 2004年06月20日 08时07分
圣骑士 * * * 组别： 认证用户 帖子数量： 201 用户编号： 4704 注册时间： 2002年08月29日 Member 离线 | 要用另外的软件实现，你在论坛搜一下，用这方法的主题。 轻轻地我走了，正如我轻轻地来；我挥一挥衣袖，不带走一版云彩。
OFA | [第2楼] 发帖时间 2004年06月20日 08时29分
天使 * * * * * * 组别： 认证用户 帖子数量： 1443 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | 3721 给的专用工具，一般是找不到的。不具有普遍应用价值。 user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
gnatix
[第3楼] 发帖时间 2004年06月20日 16时47分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用 (jiangshen @ 2004年06月20日 07时30分)
还有一个问题，怎么将某些文件安装到临时文件夹？？？

用这个：
[Files]
Source: "F:\YourFile.DLL"; DestDir: "{%TEMP}"

user posted image
jiangshen
[第4楼] 发帖时间 2004年06月20日 18时13分

骑士
* *

组别： 用户
帖子数量： 74
用户编号： 24005
注册时间： 2004年04月27日

Member 离线

[Code]
var
MyProgChecked: Boolean;
MyProgCheckResult: Boolean;
FinishedInstall: Boolean;
这是安装提示代码中的一段，但是我不知道上面的一段具体在定义什么？？
gnatix
[第5楼] 发帖时间 2004年06月21日 04时33分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用 (jiangshen @ 2004年06月20日 18时13分)
[Code]
var
MyProgChecked: Boolean;
MyProgCheckResult: Boolean;
FinishedInstall: Boolean;
这是安装提示代码中的一段，但是我不知道上面的一段具体在定义什么？？

这只是定义了三个变量而已，和你定义 x，y，z 没有区别，你不告诉真正的代码，光知道这三个变量有什么用？它们只是三个变量的名称，它们本身什么都没有定义。
另外：如果你没有编程基础（特别是 Delphi），建议你不要去写 [Code] 段里面的代码。

user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3240 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


[求助] 还是关于Inno Setup的问题

> [求助] 还是关于Inno Setup的问题
muzi | [楼主] 发帖时间 2003年05月09日 23时10分
骑士 * * 组别： 用户 帖子数量： 57 用户编号： 850 注册时间： 2002年01月25日 Member 离线 | 如何让安装程序校验已安装目录之中的文件？ 假设：C：\a\b.exe文件存在，那么安装程序就自动停止安装？ 还有Inno Setup制作的安装程序，可不可以对已安装目录中的文件进行备份？
jby | [第1楼] 发帖时间 2003年05月10日 10时30分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 8197 注册时间： 2002年12月08日 Member 离线 | 请看一下这里的学习资料： http://member.netease.com/~limpo/is/islearn.htm 要对文件进行操作，我觉得你应该关注[files]段的相关内容。
曾半仙 | [第2楼] 发帖时间 2003年05月10日 11时05分
版主 * * * * * * 组别： 认证用户 帖子数量： 1133 用户编号： 2219 注册时间： 2002年05月17日 Member 离线 | 这位兄弟作Q的安装程序? 不能这样,我们是贫下中农,是社会的主人! user posted image
西风狂诗曲 | [第3楼] 发帖时间 2003年05月10日 15时23分
圣骑士 * * * 组别： 认证用户 帖子数量： 213 用户编号： 3829 注册时间： 2002年07月31日 Member 离线 | :cwm33: 这个帖子已被 西风狂诗曲 于 2003年05月14日 19时24分 编辑
jby
[第4楼] 发帖时间 2003年05月10日 20时26分

侠客
*

组别： 用户
帖子数量： 49
用户编号： 8197
注册时间： 2002年12月08日

Member 离线

看看这里：
这个段是可选的，但对于大多数安装程序来说是必不可少的。在这里定义了安装程序需要复制到用户的系统当中的全部文件。
在安装期间，卸载程序和数据被自动的复制到应用程序的目录当中去，因此你不必手工的将它们添加到 [Files] 段。
这是一个 [Files] 段的示例：
[Files]
Source: "CTL3DV2.DLL"; DestDir: "{sys}"; CopyMode: onlyifdoesntexist; Flags: uninsneveruninstall
Source: "MYPROG.EXE"; DestDir: "{app}"
Source: "MYPROG.HLP"; DestDir: "{app}"
Source: "README.TXT"; DestDir: "{app}"; Flags: isreadme
下面列出了支持的参数：
Source （必需的）
说明：
“源文件”的名称，如果没有提供全程路径时编译器会根据安装程序的源目录的路径预先设定号路径。
允许通配符，根据通配符可以在一项里面简单的指定一组文件。当使用了通配符的时候，所有匹配的文件使用相同的可选项。
当标记（flag） external 被指定的时候，Source 必须是一个在发布介质或用户的系统中已经存在的文件（或带有通配符）的全程路径。（例如“{src}\license.ini”）.
示例：
Source: "MYPROG.EXE"
DestDir （必需的）
说明：
这个是文件将要被安装到用户的系统当中去的目录。它几乎总是以一个目录常量开始的。如果指定的路径不存在于用户的系统中，它将会被自动的创建。
示例：
DestDir: "{app}"
DestName
说明：
这个常数为将要安装到用户的系统中的文件指定一个新的名字。在默认的情况下，安装程序使用的是同 Source 参数一样的文件名，因此在多数情况下不需要指定该参数。
示例：
DestName: "MYPROG2.EXE"
CopyMode
默认：
normal
说明：
“复制模式”，指定文件复制的规则，必须是下列规则之一。
normal
这是最常使用的选项。如果文件已经存在于用户的系统当中并且比要复制的文件的版本更新时（由文件的版本信息决定），安装程序将会向用户提出询问是否要替换掉已经存在的文件。如果已经存在的文件不包含文件的版本信息，它将会被覆盖而不会向用户询问。
参见这个标题下面的注意中关于版本检查的重要说明。
onlyifdoesntexist
只有当用户的系统中的文件不存在时才复制文件。
alwaysoverwrite
总是覆盖已经存在的文件，甚至如果已经存在的文件比被安装的文件的版本更新的情况下也是如此。对于共享的系统文件永远也不要这样做！
alwaysskipifsameorolder
类似于 normal, 不同之处是如果遇到已经存在的文件不会向用户提出询问。当这个模式被使用时，更新的一经存在的文件时从来不会被替换的。
示例：
CopyMode: normal
Attribs
说明：
为文件指定附加的“属性”，它可以包括一个或多个属性，它们是：readonly, hidden, system. 如果没有指定这个参数，安装程序不会给文件指派任何特殊的属性。
示例：
Attribs: hidden system
FontInstall
说明：
告诉安装程序需要被安装的文件是一个字体文件，该值是被保存到注册表或 WIN.INI 文件中的字体名称，这个名称必须严格地和在资源管理器中双击字体文件看到的名称相对应。注意，安装程序会自动的在字体名称的末尾加上“（TrueType）”。
如果这个字体文件不是一个 TrueType 字体，你必须在 Flags 参数中指定 fontisnttruetype 标记。
建议在安装字体到 {fonts} 目录的时候使用复制模式参数 onlyifdoesntexist 和标记（flag）参数 uninsneveruninstall.
示例：
Source: "OZHANDIN.TTF"; DestDir: "{fonts}"; FontInstall: "Oz Handicraft BT"; CopyMode: onlyifdoesntexist; Flags: uninsneveruninstall
Flags
说明：
“标记”，这个参数是一个附加的选项集合，可以多个选项共同使用，使用空格分开多个选项。下面列出了被支持的选项：
comparetimestampalso
（专门用途） 如果要被复制到用户系统的文件已经存在于用户的系统当中并且它们具有相同的版本信息，告诉安装程序进行时间戳（文件的日期时间属性）的比较。 在正常情况下安装程序不会覆盖已经存在的文件，但是当使用了这个标记的时候， 如果已存在的文件的时间戳比它的版本信息还要旧，安装程序在安装文件时就会覆盖它。当复制模式不是 normal 或 alwaysskipifsameorolder 这两者之一时该标记不起作用。
confirmoverwrite
当文件已经存在每个文件在复制之前始终向用户提出询问。
deleteafterinstall
告诉安装程序象平常一样复制文件，但是当安装程序结束（或被中止）之后将这个文件删除。如果释放脚本的 [Run] 段所执行的程序所需要的临时的数据时这个选项是很有用的。
此标记不能和下列标记在一起组合使用： isreadme, regserver, regtypelib, restartreplace, sharedfile, uninsneveruninstall.
external
此标记告诉 Inno Setup 不要将由 Source 参数指定的文件编译进安装程序文件中，在复制文件的时候由发布介质或用户的系统中已经存在文件代替。要获得更多详细的信息请参见 Source 参数的说明。
fontisnttruetype
如果 FontInstall 参数指定的是一个 非 TrueType 字体则使用此标记。
isreadme
该文件是“自述（README）”文件，安装程序中只有一个文件能够使用此参数。当有一个文件使用了这个参数时，用户将被询问是否愿意在安装程序结束时查看自述文件，如果选择了是，安装程序将会根据文件的类型用默认的程序打开这个文件，基于这个原因，自述文件应该具有象 .txt, .wri 或 .doc. 这样的扩展名。
注意如果安装程序要重新启动用户的计算机（比如安装了一个带有 restartreplace 参数的文件或在 [Setup] 段中的 AlwaysRestart
关键字的值为 yes），安装程序就不会向用户询问是否要查看自述文件。
overwritereadonly
始终覆盖一个只读 （read-only） 文件，如果没有这个参数，当一个已存在的只读文件要被覆盖时安装程序将会询问用户。
regserver
注册 OLE 服务器 （或称作 ActiveX 控件）。如果设置了此标记，安装程序将查找并执行 DLL/OCX 的 DllRegisterServer 输出，卸载程序调用 DllUnregisterServer. 当结合 sharedfile 标记一起使用，只有参照技术器的值归零时 DLL/OCX 才可能百取消登记 （unregistered）.
要获得更多的详细信息请参见此标题最后的 注意。
regtypelib
注册类型库 （.tlb）. 卸载程序将会取消注册类型库 （除非指定了 uninsneveruninstall 标记）. 就像 regserver 标记那样，如果结合 sharedfile 标记一起使用，这个文件只有参照计数器的值归零时才可能被卸载。
要获得更多的详细信息请参见此标题最后的 注意。
restartreplace
此标记通常用于替换系统核心文件。如果文件已经预先存在并发现它已经被锁定结果导致安装程序无法替换该文件，安装程序就会注册此文件（对于 Windows 和 Windows NT 分别使用 WININIT.INI 和函数 MoveFileEx）在下次启动系统时被替换。当遇到这种情况，在安装过程结束时用户将被提示重新启动计算机。
要保持 Windows95/98 和 3.1 的兼容性，使用了此标记的项不应该使用长文件名，只能支持“8.3”格式的文件名。（Windows NT 和 2000 则没有此限制。）
重要提示：在 Windows NT/2000 下只有当用户具有管理员权限时使用 restartreplace 标记才可以成功的替换使用中的文件。如果用户没有管理员权限，将会显示如下的信息：“RestartReplace failed: MoveFileEx failed; code 5.”，因此，当使用 restartreplace 标记时强烈建议让你的安装程序需要管理员权限，在 [Setup] 段里面设置 "AdminPrivilegesRequired=1"。
sharedfile
（仅 Windows 95/NT 4+） 使用 Windows 的共享文件计数功能 （位于注册表的 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs）. 这样会使应用程序之间能够共享一个文件，不用担心在不注意的情况下会删除文件。在每次安装共享文件的时候，与这个文件相对应的“参照计数器”的值就会加一，而每次应用程序被卸载的时候，参照计数器的值就会减一，如果参照计数器的值归零的时候，该共享文件就会被删除（在用户确认的情况下）。
绝大多数被安装到 Windows 系统目录下的文件都应当使用这个标记，包括 .OCX 和 .DPL （Delphi 3 package） 文件。不使用这个标记的仅有的一个例外是 MFC DLLs. 作为替代，应该在复制模式中使用 onlyifdoesntexist ，并结合 uninsneveruninstall 标记，或者是如果安装单独发布的 MFC DLL 的最近的版本，则使用复制模式 alwaysskipifsameorolder ，并结合使用标记 uninsneveruninstall 和 restartreplace.
当安装程序被运行在一个 NT 3.51 系统时，被安装的带有此标记的文件就再也不会被删除了。
skipifsourcedoesntexist
只有当 external 标记也使用了的时候这个标记才会有用。它会告诉安装程序如果源文件不存在的话则无任何提示的（静静的）跳过该项，如果没有使用这个标记则会显示一个错误消息。
uninsneveruninstall
从来不会卸载这个文件。此标记应当被保守地使用，而且通常它是和复制模式 onlyifdoesntexist 在一起结合使用。意思是用于安装一个特别公共的共享文件，就像 CTL3DV2.DLL 或者一个 MFC DLL, 你不应该用卸载程序去删除这个文件的原因是以后其它的应用程序也要使用到它。
示例：
Flags: isreadme
公共参数
注意
如果安装程序正在安装一个已经存在于用户的系统当中的 16 位的 DLL 或者 EXE 文件，两个文件的版本信息是不会相比较的，已存在的文件将始终被覆盖（除非当复制模式的参数是 onlyifdoesntexist），这是由一个 Windows 的限制决定的，32 位的程序就像 Inno Setup 只能读取 32 位可执行文件的版本信息。
在安装程序的最后一步安装程序会注册所有的带有 regserver 或 regtypelib 标记的文件。然而，如果 [Setup] 段关键字 AlwaysRestart 的值是 yes, 或如果有文件带有 restartreplace 标记，全部的文件将会在下次启动的时候注册（在 Windows 注册表的 RunOnce 创建一项）。
当带有 .HLP 扩展名（Windows 的帮助文件）的文件被卸载的时候，其对应的 .GID 和 .FTS 文件同样会被自动删除。
muzi | [第5楼] 发帖时间 2003年05月10日 21时18分
骑士 * * 组别： 用户 帖子数量： 57 用户编号： 850 注册时间： 2002年01月25日 Member 离线 | 备份文件搞定了，就是第一个问题比较难呀。 你们有没有试过新出的Inno Setup 4？
西风狂诗曲 | [第6楼] 发帖时间 2003年05月10日 21时47分
圣骑士 * * * 组别： 认证用户 帖子数量： 213 用户编号： 3829 注册时间： 2002年07月31日 Member 离线 | 不能中止，，，只能安装时跳过那个文件 想用中止的话，，还是WISE比较好吧
muzi | [第7楼] 发帖时间 2003年05月11日 14时15分
骑士 * * 组别： 用户 帖子数量： 57 用户编号： 850 注册时间： 2002年01月25日 Member 离线 | 试了一下Inno Setup 4，支持编码了，很好用的，希望尽快有汉化
jby | [第8楼] 发帖时间 2003年05月12日 13时06分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 8197 注册时间： 2002年12月08日 Member 离线 | 有INNO 4了？哪有下的？
muzi | [第9楼] 发帖时间 2003年05月12日 13时35分
骑士 * * 组别： 用户 帖子数量： 57 用户编号： 850 注册时间： 2002年01月25日 Member 离线 | http://www.jrsoftware.org/is4.php
morphine
[第10楼] 发帖时间 2003年05月12日 17时17分

新手上路
*

组别： 用户
帖子数量： 2
用户编号： 10340
注册时间： 2003年01月22日

Member 离线

引用
下面引用由muzi在 2003/05/09 11:10pm 发表的内容：
Inno Setup制作的安装程序，可不可以对已安装目录中的文件进行备份？
可以备份的，比如c:\program files\yourfile.exe想备份，这样写：
Source: "c:\program files\yourfile.exe"; Destdir: "{app}\backup"; flag:......
看起来比较麻烦，呵呵。
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3578 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


【问题】innounp怎样删除安装运行后的补丁文件？

> 【问题】innounp怎样删除安装运行后的补丁文件？, innounp怎样删除安装运行后的补丁文件？
订阅此主题 | 邮寄此主题 | 打印此主题
askformore | [楼主] [image] 发帖时间 2004年08月18日 16时35分
新手上路 * 组别： 用户 帖子数量： 7 用户编号： 27039 注册时间： 2004年06月23日 Member 离线 | 如题：innounp（莫名汉化的那个版本）怎样删除补丁文件a.exe呢：如我想分原版和补丁版安装，补丁版设定a.exe在[Run]段，则当安装运行到安装完成向导页时，会提供一个运行a.exe选项（注：a.exe安装在安装目录），运行补丁后，我想马上将其设成自动删除，这一步该怎样写脚本呀？
做人要厚道 | [第1楼] 发帖时间 2004年08月18日 17时10分
侠客 * 组别： 用户 帖子数量： 11 用户编号： 27472 注册时间： 2004年07月03日 Member 离线 | ;安装后删除 [Files] Source: a.exe; DestDir: {tmp}; Flags: deleteafterinstall
askformore | [第2楼] 发帖时间 2004年08月20日 08时07分
新手上路 * 组别： 用户 帖子数量： 7 用户编号： 27039 注册时间： 2004年06月23日 Member 离线 | 谢谢“做人要厚道”兄提点！ 另外，我想问补丁程序a.exe的运行选项不出现在“安装完成向导页”页面上，而是直接运行（前提：被补丁程序必须已安装才可运行补丁a.exe），有办法吗？
gnatix
[第3楼] 发帖时间 2004年08月20日 13时40分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2667
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (askformore @ 2004年08月20日 08时07分)
谢谢“做人要厚道”兄提点！

另外，我想问补丁程序a.exe的运行选项不出现在“安装完成向导页”页面上，而是直接运行（前提：被补丁程序必须已安装才可运行补丁a.exe），有办法吗？

把 [Run] 中 Flags 里面的那个 postinstall 删除。

user posted image
Tervetuloa!
askformore | [第4楼] 发帖时间 2004年08月22日 08时57分
新手上路 * 组别： 用户 帖子数量： 7 用户编号： 27039 注册时间： 2004年06月23日 Member 离线 | 试了，gnatix真是一语中的，非常谢谢，果然是这问题！
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.2978 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


用 Inno Setup 怎么设定文件随 windows 启动？

> 用 Inno Setup 怎么设定文件随 windows 启动？
订阅此主题 | 邮寄此主题 | 打印此主题
OFA | [楼主] 发帖时间 2003年12月26日 16时39分
天使 * * * * * * 组别： 认证用户 帖子数量： 1418 用户编号： 13575 注册时间： 2003年04月13日 Member 在线 | 请教用 Inno Setup 怎么设定文件随 windows 启动？ 要求只在注册表的 Run 中添加相应文件，而不是把文件快捷方式复制到程序菜单的启动组里。 如果利用 Inno Setup 的本身 [Registry] 功能，必须知道文件的具体路径才能将其添加至 Run。那么是否有一个 Flags 可以设定某个文件随 Windows 启动呢？ user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
蓝色网际 | [第1楼] 发帖时间 2003年12月26日 18时28分
精灵王 * * * * 组别： 认证用户 帖子数量： 392 用户编号： 3348 注册时间： 2002年07月08日 Member 离线 | {app} 做一件东西如果不能把它做到最好，我就不做
OFA | [第2楼] 发帖时间 2003年12月26日 18时31分
天使 * * * * * * 组别： 认证用户 帖子数量： 1418 用户编号： 13575 注册时间： 2003年04月13日 Member 在线 | 你的意思是说还是采用 [Registry]，但是路径使用 {app} 作为变量？ user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
mimizero | [第3楼] 发帖时间 2003年12月26日 22时31分
版主 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1376 用户编号： 995 注册时间： 2002年02月10日 Member 离线 | 脚本里面的 {app} 就代表程序的安装路径，注册表部分用{app}安装的时候就会替换成程序路径了 精品路线，会汉化的猫哟～～！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3341 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


请教一个关于Inno Setup 4.1.5的问题～～～

> 请教一个关于Inno Setup 4.1.5的问题～～～
Macross | [楼主] 发帖时间 2004年02月20日 12时29分
新手上路 * 组别： 用户 帖子数量： 5 用户编号： 18866 注册时间： 2003年11月13日 Member 离线 | 我用原版的QQ和珊瑚虫的外挂，整理了一个自己用的QQ～～不过因为QQ文件夹里有太多的dll文件，所以我就习惯性的把这些文件的属性改为“隐藏”。可是在用Inno Setup 4.1.5对QQ文件夹进行打包制作安装文件时，尽管我添加了QQ文件夹，可是在测试最后编译出来的安装文件时，发现那些被改成“隐藏”属性的dll文件并没有被Inno Setup 4.1.5编译进安装文件里，请问这是为什么？？如果解决？？？谢谢～～
gnatix | [第1楼] 发帖时间 2004年02月20日 14时42分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 指定文件属性，比如： Attribs: hidden system user posted image
刘波 | [第2楼] 发帖时间 2004年02月21日 12时36分
版主 * * * * * 组别： 认证用户 帖子数量： 624 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 在制作安装程序时不要把文件隐藏，而是在安装程序中制定文件的属性为隐藏，这样安装程序释放出的文件就可以自动隐藏了。 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载或者查看此主题的不同格式的可打印版本。
[ 程序执行时间： 0.3854 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


Inno Setup 制作安装程序时遇到的问题

> Inno Setup 制作安装程序时遇到的问题
kof | [楼主] 发帖时间 2002年05月19日 02时54分
圣骑士 * * * 组别： 用户 帖子数量： 149 用户编号： 1602 注册时间： 2002年04月18日 Member 离线 | 用了之后感觉这个不错，但遇到一个问题，在程序中好像不可以添加一个文件夹，我指的是添加一个文件夹（当然包括其下面的文件），而不是只添加文件夹下的文件，请问到底可不可以添加文件夹？
小恐龙 | [第1楼] 发帖时间 2002年05月19日 22时51分
版主 * * * * * 组别： 认证用户 帖子数量： 784 用户编号： 709 注册时间： 2001年12月30日 Member 离线 | 你看看！ 附图 附图 user posted image 有人说恐龙是恐怖的,其实恐龙是可爱的; 有人说恐龙是冷血的,其实恐龙是热情的; 有人说恐龙是残忍的,其实恐龙是善良的.
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.2912 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


还是inno

(2) 2 ( 转到首个未读帖子 )

> 还是inno
订阅此主题 | 邮寄此主题 | 打印此主题
jiangshen | [楼主] 发帖时间 2004年06月24日 22时20分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 怎么能让下载程序在文件安装之后～finished页面之前出来？？？ 也就是说文件安装完了出现下载页面，下载安装完了再出现finished页面？？
jiangshen
[第1楼] 发帖时间 2004年06月25日 05时36分
*

组别： 用户
帖子数量： 74
用户编号： 24005
注册时间： 2004年04月27日

Member 离线

或者把下载文件下载到{app}文件夹怎么实现？？

function NextButtonClick(CurPage: Integer): Boolean;
var
hWnd: Integer;
sFileName: String;
sTasks: String;
nCode: Integer;
begin
Result := true;

if CurPage =wpReady then begin
hWnd := StrToInt(ExpandConstant('{wizardhwnd}'));

sTasks := WizardSelectedTasks(false);

isxdl_ClearFiles;

if Pos('ipdownload',sTasks)>0 then begin
sFileName := ExpandConstant('{app}\Ipsetup.exe');
isxdl_AddFile(url1,sFileName);
end;
if isxdl_DownloadFiles(hWnd) <> 0 then begin
sFileName := ExpandConstant('{app}\Ipsetup.exe');
if FileExists(sFileName) then InstExec(sFileName,'','',true,false,0,nCode)
end else
Result := false;

end;
end;

这是我现在的代码，运行时他提示找不到app文件夹，能不能想办法在下载之前创建app文件夹呢？？？
最好能用楼上贴出的方法解决问题？？
gnatix | [第2楼] 发帖时间 2004年06月25日 19时01分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 又没有完成作业：） （在以前的帖子中已经回答过这个问题的） {app} 文件夹还没有创建，所以不能下载到那里，先创建这个文件夹，用： CreateDir(ExpandConstant('{app}')); user posted image
jiangshen | [第3楼] 发帖时间 2004年06月25日 19时05分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 这句话具体应该怎么写呢？？？？？
gnatix | [第4楼] 发帖时间 2004年06月25日 19时10分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 添加到第16行的地方如何？ BTW: Does your vocabulary have a word like 'thank you' ? user posted image
jiangshen | [第5楼] 发帖时间 2004年06月25日 19时18分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 我得意思是这段完整代码具体应该怎么写？？ 有这类代码的示例么？？ 谢谢
gnatix
[第6楼] 发帖时间 2004年06月25日 19时27分

天使
* * * * * *

组别： 超级版主
帖子数量： 2406
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (jiangshen @ 2004年06月25日 19时18分)
我得意思是这段完整代码具体应该怎么写？？
有这类代码的示例么？？
谢谢

你不是已经有代码了吗？把那个语句添加进去就行了。
程序自己有示例的。

user posted image
jiangshen | [第7楼] 发帖时间 2004年06月25日 19时28分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 问题1：我如果升级程序直接用带密码FTP来连接，会不会用破解软件查处准确地址？？？ 2：怎样能制作一个类似补丁的文件，不显示任何欢迎或开始的确定页面。 3：怎样在安装结束后检查某个文件是否存在，如果存在则自动删除
jiangshen | [第8楼] 发帖时间 2004年06月25日 22时21分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 问题1：我如果升级程序直接用带密码FTP来连接，会不会用破解软件查处准确地址？？？ 2：怎样能制作一个类似补丁的文件，不显示任何欢迎或开始的确定页面。 3：怎样删除安装过程中的垃圾文件
gnatix
[第9楼] 发帖时间 2004年06月26日 13时56分

天使
* * * * * *

组别： 超级版主
帖子数量： 2406
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用
1：我如果升级程序直接用带密码FTP来连接，会不会用破解软件查处准确地址？？？

这个可能性估计很大。

引用

2：怎样能制作一个类似补丁的文件，不显示任何欢迎或开始的确定页面。

什么信息都不显示，是不可能的。作者为了防止被滥用，所以有意禁止后台运行模式。如果只是希望不显示启动时出现的提示，可以用：
[Setup]
DisableStartupPrompt=yes

引用
3：怎样删除安装过程中的垃圾文件

安装程序会自动删除临时文件。不知道你说的垃圾文件指什么。

user posted image
jiangshen | [第10楼] 发帖时间 2004年06月26日 13时59分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 就是说安装完成后删除下载在app文件夹里的安装包 那你说inno制作的安装包下载更新文件后，自动安装就没有任何提示
gnatix | [第11楼] 发帖时间 2004年06月26日 14时13分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 为什么不把文件下载到{tmp}，这样安装结束后就自动删除了。 Inno 制作的安装文件只是下载和运行某个（些）文件，运行模式可以设置，参看 InstExec() 的参数设置。 user posted image
jiangshen | [第12楼] 发帖时间 2004年06月26日 18时41分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 那个对于我来说太复杂，请你告诉我怎么在安装后自动判断否个文件是否存在，如果存在则删除
gnatix
[第13楼] 发帖时间 2004年06月26日 23时29分

天使
* * * * * *

组别： 超级版主
帖子数量： 2406
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (jiangshen @ 2004年06月26日 18时41分)
那个对于我来说太复杂，请你告诉我怎么在安装后自动判断否个文件是否存在，如果存在则删除

既然使用了脚本，总是比较复杂的。

判断文件是否存在然后删除的指令可以参看：
http://bbs.hanzify.org/index.php?showtopic=22314

请把你的整个脚本文件帖出来，否则没法具体帮助你的。

user posted image
jiangshen | [第14楼] 发帖时间 2004年06月26日 23时35分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 这个是在安装前检查，如果要在安装后检查应该怎么写呢 [Code] function InitializeSetup(): Boolean; begin If FileExists('C:\ABCD\123.exe') Then DeleteFile('C:\ABCD\123.exe'); 还有，为什么软件只要在安装时选择下载安装更新，安装完就不能卸载？？？
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项 (2) 2

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3913 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


还是inno

(2) 1 ( 转到首个未读帖子 )

> 还是inno
订阅此主题 | 邮寄此主题 | 打印此主题
gnatix | [第15楼] 发帖时间 2004年06月27日 03时21分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 安装后再删除文件： procedure CurStepChanged(CurStep: Integer); begin if CurStep = csFinished then if FileExists(ExpandConstant('{app}\abcd.txt')) Then DeleteFile(ExpandConstant('{app}\abcd.txt')); end; user posted image
jiangshen | [第16楼] 发帖时间 2004年06月27日 10时39分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 因为空间不支持exe文件下载，所以我只能把更新文件先改名为rar 如果我下载这个rar到app目录，下载完成后自动将他改名为exe，在运行，这个怎么实现？？？
gnatix | [第17楼] 发帖时间 2004年06月27日 13时13分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 在前面告诉你的那个帖子中就有两个例子：如何删除文件以及如何更名文件，为什么只看如何删除文件，其它的就不看一眼呢，这个不是正确的学习方法吧：（ user posted image
jiangshen
[第18楼] 发帖时间 2004年06月27日 15时41分
*

组别： 用户
帖子数量： 74
用户编号： 24005
注册时间： 2004年04月27日

Member 离线

function NextButtonClick(CurPage: Integer): Boolean;
var
hWnd: Integer;
sFileName: String;
sTasks: String;
nCode: Integer;
begin
Result := true;

if CurPage =wpReady then begin
hWnd := StrToInt(ExpandConstant('{wizardhwnd}'));

sTasks := WizardSelectedTasks(false);

isxdl_ClearFiles;

CreateDir(ExpandConstant('{app}'));

if Pos('ipdownload',sTasks)>0 then begin
sFileName := ExpandConstant('{app}\setup.rar');
isxdl_AddFile(url1,sFileName);
end;

If FileExists('{app}\setup.rar') Then RenameFile('{app}\setup.rar','{app}\setup.exe');
Result := True;
end;

if isxdl_DownloadFiles(hWnd) <> 0 then begin
sFileName := ExpandConstant('{app}\setup.exe');
if FileExists(sFileName) then InstExec(sFileName,'','',true,false,0,nCode)
end else
Result := false;
end;
这个就是我写进去的一段代码，可以编译，但是安装时出错！！！
gnatix | [第19楼] 发帖时间 2004年06月27日 16时32分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 这句不对： If FileExists('{app}\setup.rar') Then RenameFile('{app}\setup.rar','{app}\setup.exe'); 参看一下： if FileExists(ExpandConstant('{app}\abcd.txt')) Then DeleteFile(ExpandConstant('{app}\abcd.txt')); 另外： 里面有些代码很乱，光看一小段代码，不能具体测试，帮你改正了一个地方可能另外一个我不知道的地方还会有问题，这样太没有效率了。你能否把整个脚本文件 *.iss 作为附件帖上来，一次搞定。否则我不准备继续回这个帖子了，抱歉。 user posted image
gnatix
[第20楼] 发帖时间 2004年06月27日 19时59分

天使
* * * * * *

组别： 超级版主
帖子数量： 2406
用户编号： 377
注册时间： 2001年10月17日

Member 离线

下面是修改后的代码，我这里测试没有问题。
注意：为了保护你的“秘密”，下面把你的网站地址用 XXXXX 屏蔽掉了。

代码
[Code]
const
url1 = 'http://XXXXX.com/download/setup.rar';

function NextButtonClick(CurPage: Integer): Boolean;
var
hWnd: Integer;
sFileName: String;
sTasks: String;
nCode: Integer;
begin
Result := true;
if CurPage =wpReady then begin
hWnd := StrToInt(ExpandConstant('{wizardhwnd}'));

sTasks := WizardSelectedTasks(false);

isxdl_ClearFiles;

CreateDir(ExpandConstant('{app}'));

if Pos('download',sTasks)>0 then begin
sFileName := ExpandConstant('{app}\setup.exe');
isxdl_AddFile(url1,sFileName);
end;

if isxdl_DownloadFiles(hWnd) <> 0 then begin
if FileExists(sFileName) then InstExec(sFileName,'','',true,false,0,nCode)
end else
Result := false;
end;
end;

procedure AboutButtonOnClick(Sender: TObject);
begin
MsgBox('广告位招商中...', mbInformation, mb_Ok);
end;

procedure URLLabelOnClick(Sender: TObject);
var
Dummy: Integer;
begin
InstShellExec('http://www.XXXXX.com', '', '', SW_SHOWNORMAL, Dummy);
end;

procedure InitializeWizard();
var
AboutButton, CancelButton: TButton;
URLLabel: TNewStaticText;
begin
CancelButton := WizardForm.CancelButton;

AboutButton := TButton.Create(WizardForm);
AboutButton.Left := WizardForm.ClientWidth - CancelButton.Left - CancelButton.Width;
AboutButton.Top := CancelButton.Top;
AboutButton.Width := CancelButton.Width;
AboutButton.Height := CancelButton.Height;
AboutButton.Caption := '广告(&A)...';
AboutButton.OnClick := @AboutButtonOnClick;
AboutButton.Parent := WizardForm;

URLLabel := TNewStaticText.Create(WizardForm);
URLLabel.Top := AboutButton.Top + AboutButton.Height - URLLabel.Height - 2;
URLLabel.Left := AboutButton.Left + AboutButton.Width + 20;
URLLabel.Caption := '进入丐帮在线';
URLLabel.Font.Style := URLLabel.Font.Style + [fsUnderLine];
URLLabel.Font.Color := clBlue;
URLLabel.Cursor := crHand;
URLLabel.OnClick := @URLLabelOnClick;
URLLabel.Parent := WizardForm;
end;

procedure CurStepChanged(CurStep: Integer);
begin
if CurStep = csFinished then
if FileExists(ExpandConstant('{app}\setup.exe')) Then DeleteFile(ExpandConstant('{app}\setup.exe'));
end;

user posted image
jiangshen | [第21楼] 发帖时间 2004年06月27日 20时18分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 你太好了，亲一个，爱死你了
jiangshen | [第22楼] 发帖时间 2004年06月27日 20时24分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 还是有个错误，如果下载安装更新，则写在程序时显示无法识别，不能卸载
gnatix | [第23楼] 发帖时间 2004年06月27日 20时40分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 因为不是通过安装程序安装的，所以当然不能自动卸载（否则不是坏事了）。但是你可以用 [UninstallDelete] 指定卸载这类文件的。 user posted image
jiangshen | [第24楼] 发帖时间 2004年06月27日 21时09分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 但是官方做的安装也有下载，为什么就能卸载呢？？
gnatix | [第25楼] 发帖时间 2004年06月27日 21时18分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 没有说不能卸载啊，你只要添加这个就行了： [UninstallDelete] Type: files; Name: "{app}\QQwry.dat" 如果你要删除整个文件夹，就用： [UninstallDelete] Type: filesandordirs; Name: "{app}" user posted image
jiangshen | [第26楼] 发帖时间 2004年06月27日 21时29分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 你可能理解错了，现在是主文件不能卸载呀，而且有个怪毛病，安装第一次不能卸载，如果再安装覆盖一编，就能卸载了
gnatix | [第27楼] 发帖时间 2004年06月28日 13时32分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 卸载时不能识别卸载文件格式的原因我估计（99％肯定）是你把原版安装时所产生的卸载程序（名称是 unins000.exe）也打包到你的安装文件中去了，而原版的安装程序可能是用旧的 Inno Setup 版本制作的，所以与你的安装文件所产生的卸载数据文件（名称是 unins000.dat）不相容。所以打包前你要先把原版的卸载文件（unins000.exe 和 unins000.dat）删除。 user posted image
jiangshen | [第28楼] 发帖时间 2004年06月28日 17时00分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 你太伟大了，解决了，多亏了你的帮助，太感谢了，我一定要好好学习！！！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项 (2) 1

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 2.4958 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


请教关于“Inno Setup”的问题

> 请教关于“Inno Setup”的问题
jdlb | [楼主] 发帖时间 2002年02月22日 15时29分
侠客 * 组别： 用户 帖子数量： 13 用户编号： 180 注册时间： 2001年08月11日 Member 离线 | 斑竹：“Inno Setup”是贵站的安装制作工具。我在使用中，无法加入文件夹，只能加入文件，但我要制作的setup.exe中，既有文件，又有文件夹，请教：如何把文件夹打包进去？谢谢！
炎之川 | [第1楼] 发帖时间 2002年02月22日 17时38分
最近比较烦哪！ * * * * * * * * 组别： 管理员 帖子数量： 6095 用户编号： 3 注册时间： 2001年06月15日 Member 离线 | 很简单,这样写脚本 [Files] 段: [Files] Source: "x:\xxxx\*.*"; DestDir: "{app}"; CopyMode: alwaysoverwrite Source: "x:\xxxx\xxx\*.*"; DestDir: "{app}\xxx"; CopyMode: alwaysoverwrite 看明白了吗?稍微变通一下就ok了^^ 不要只用软件的向导,那个向导写不出好的脚本的~~~~~~ user posted image 访问 炎之川的blog
jdlb | [第2楼] 发帖时间 2002年02月23日 09时15分
侠客 * 组别： 用户 帖子数量： 13 用户编号： 180 注册时间： 2001年08月11日 Member 离线 | 谢谢炎之川炎大哥，我成功了，真的，谢谢！！我是一个菜鸟，想再请教：哪一个安装制作工具，利用向导就可以了？既简单，又方便，而且制作出来的界面又漂亮，速度快，打包后的执行文件有最小？（对不起，是不是要求太高了：)）。
炎之川 | [第3楼] 发帖时间 2002年02月23日 21时06分
最近比较烦哪！ * * * * * * * * 组别： 管理员 帖子数量： 6095 用户编号： 3 注册时间： 2001年06月15日 Member 离线 | 只能说各有所长,现在我用的最多的就是 INNO 了,因为写好一个脚本了,以后稍微修改名称什么的就可以了^^ 人懒嘛~~:) user posted image 访问 炎之川的blog
jdlb | [第4楼] 发帖时间 2002年02月24日 09时02分
侠客 * 组别： 用户 帖子数量： 13 用户编号： 180 注册时间： 2001年08月11日 Member 离线 | 谢谢炎大哥的指点！我也试过几个，最喜欢的就是INNO了，不过虽然我成功地把文件夹打包进去了，但觉得比较麻烦，要一个一个写脚本。举个例子：我正在打包的程序（MySetup)下，有8个文件夹，其中两个文件夹下又各有3个和6个子文件夹，这样要写近20句脚本，眼睛都花了，能不能用一二句脚本就可以全部包括进去？（我太菜了，实在不好意思）
小恐龙 | [第5楼] 发帖时间 2002年02月25日 00时19分
版主 * * * * * 组别： 认证用户 帖子数量： 784 用户编号： 709 注册时间： 2001年12月30日 Member 离线 | SetupBuilder 中文版,符合前几个条件,只是文件有点大. user posted image 有人说恐龙是恐怖的,其实恐龙是可爱的; 有人说恐龙是冷血的,其实恐龙是热情的; 有人说恐龙是残忍的,其实恐龙是善良的.
jdlb | [第6楼] 发帖时间 2002年02月25日 19时03分
侠客 * 组别： 用户 帖子数量： 13 用户编号： 180 注册时间： 2001年08月11日 Member 离线 | 我还是喜欢INNO,希望炎大哥教教我！
炎之川 | [第7楼] 发帖时间 2002年02月25日 21时32分
最近比较烦哪！ * * * * * * * * 组别： 管理员 帖子数量： 6095 用户编号： 3 注册时间： 2001年06月15日 Member 离线 | 很多目录只能慢慢写了吧!:( 其实INNO有一些辅助软件的,饿死向导模式,但作出来的脚本会比inno自己的向导完整很多~ ISS Creator 1.10,ISTool 1.1.11,去google搜索一下哪里有下载吧~ user posted image 访问 炎之川的blog
jdlb | [第8楼] 发帖时间 2002年02月26日 09时00分
侠客 * 组别： 用户 帖子数量： 13 用户编号： 180 注册时间： 2001年08月11日 Member 离线 | 谢谢炎大哥：真心得谢谢！我用您介绍的ISS Creator 1.10真的方便多了，再一次感谢您！今后可能还要麻烦您，希望得到您的多多指教！:)
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3389 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


【问题】inno setup 的2个问题

> 【问题】inno setup 的2个问题
大番茄 | [楼主] 发帖时间 2004年06月25日 17时32分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 问题; 1.请问怎么才能在安装完成选择提示重新启动计算机! 2.请问,要对所存在的文件改名应该怎么写? 3.如何在安装之前搜索指定目录,然后删除目标目录中的某个文件? 不知道可以不可以啊`! 谢谢大家看看! 番茄花园: http://tomatolei.com
gnatix
[第1楼] 发帖时间 2004年06月25日 18时52分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用
1.请问怎么才能在安装完成选择提示重新启动计算机!

[Setup]
AlwaysRestart=Yes

引用
2.请问,要对所存在的文件改名应该怎么写?
3.如何在安装之前搜索指定目录,然后删除目标目录中的某个文件?

[Code]
function InitializeSetup(): Boolean;
begin
//检查文件并删除 123.exe
If FileExists('C:\ABCD\123.exe') Then DeleteFile('C:\ABCD\123.exe');
//更名文件 456.exe 为 654.exe
If FileExists('C:\ABCD\456.exe') Then RenameFile('C:\ABCD\456.exe','C:\ABCD\654.exe');
Result := True;
end;

user posted image
大番茄 | [第2楼] 发帖时间 2004年06月25日 19时37分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 谢谢楼上的大老虎!! 你真好啊~!!!! 原来脚本用了一个Boolean判断!! 番茄花园: http://tomatolei.com
大番茄
[第3楼] 发帖时间 2004年06月27日 23时06分

圣骑士
* * *

组别： 认证用户
帖子数量： 127
用户编号： 15345
注册时间： 2003年06月05日

Member 离线

引用 (gnatix @ 2004年06月25日 18时52分)
引用
1.请问怎么才能在安装完成选择提示重新启动计算机!

[Setup]
AlwaysRestart=Yes

引用
2.请问,要对所存在的文件改名应该怎么写?
3.如何在安装之前搜索指定目录,然后删除目标目录中的某个文件?

[Code]
function InitializeSetup(): Boolean;
begin
//检查文件并删除 123.exe
If FileExists('C:\ABCD\123.exe') Then DeleteFile('C:\ABCD\123.exe');
//更名文件 456.exe 为 654.exe
If FileExists('C:\ABCD\456.exe') Then RenameFile('C:\ABCD\456.exe','C:\ABCD\654.exe');
Result := True;
end;

我试过了
很好用
但是我有个想法,没有实现!!

就是搜索文件的时候,你上面的代码是固定的地址('C:\ABCD\123.exe')

如果那个文件在windows目录下!
如果系统分区可能C盘,可能在D盘
那么要 "系统" 目录该用什么关键字呢?

我试过几个都没有成功 !

1.%windir%
2. %systemroot%
3.{sys}
4.{win}

===========================
麻烦大老虎斑竹了呀!!!

番茄花园:
http://tomatolei.com
bcff2002 | [第4楼] 发帖时间 2004年06月28日 11时14分
骑士 * * 组别： 认证用户 帖子数量： 55 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 也想知道。 输入法大全 http://www.bcff2002.com
cbhhch | [第5楼] 发帖时间 2004年06月28日 11时48分
侠客 * 组别： 用户 帖子数量： 15 用户编号： 24855 注册时间： 2004年05月17日 Member 离线 | 用1.%windir% 2. %systemroot% 3.{sys} 4.{win} 不行?我没有试过
gnatix
[第6楼] 发帖时间 2004年06月28日 12时45分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用 (大番茄 @ 2004年06月27日 23时06分)
我试过了
很好用
但是我有个想法,没有实现!!

就是搜索文件的时候,你上面的代码是固定的地址('C:\ABCD\123.exe')

如果那个文件在windows目录下!
如果系统分区可能C盘,可能在D盘
那么要 "系统" 目录该用什么关键字呢?

我试过几个都没有成功 !

1.%windir%
2. %systemroot%
3.{sys}
4.{win}

===========================
麻烦大老虎斑竹了呀!!!

//检查文件并删除 123.exe （在系统目录中）
If FileExists(ExpandConstant('{sys}\123.exe')) Then DeleteFile(ExpandConstant('{sys}\123.exe'));

Windows 目录是 {win}
程序的安装目录是 {app}
其它变量请看帮助文件

user posted image
gnatix
[第7楼] 发帖时间 2004年06月28日 12时48分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用 (cbhhch @ 2004年06月28日 11时48分)
用1.%windir%
2. %systemroot%
3.{sys}
4.{win}
不行?我没有试过

警告：请不要在论坛灌水！

user posted image
大番茄
[第8楼] 发帖时间 2004年06月28日 18时47分

圣骑士
* * *

组别： 认证用户
帖子数量： 127
用户编号： 15345
注册时间： 2003年06月05日

Member 离线

我都试过了,只能用固定的真实地址

引用
[Code]
function InitializeSetup(): Boolean;
begin
//检查文件并删除
If FileExists('{win}\system32\dllcache\uxtheme.dll') Then DeleteFile('{win}\system32\dllcache\uxtheme.dll');
Result := True;
end;

以上的地址:{win}\system32\dllcache\uxtheme.dll无效,
只能用固定地址:'C:\WINDOWS\system32\uxtheme.dll'

也就是这段代码中间(begin-end)对inno的代码（{win}，{sys}）都不承认，
另外对windows代码（%windir%,%systemroot%）也无效！

不知道有没有办法了！

我的目的就是要打开程序时候搜索'C:\WINDOWS\system32\uxtheme.dll并且删除！
用固定地址打开安装程序时候就删除了，很好用，但是用{win}\system32\dllcache\uxtheme.dll就不行了！！！

番茄花园:
http://tomatolei.com
刘波 | [第9楼] 发帖时间 2004年06月28日 19时10分
版主 * * * * * 组别： 认证用户 帖子数量： 786 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | C:\WINDOWS\system32\uxtheme.dll 这个文件操作系统不是会对它进行保护的么？用安装程序能自动删除掉么？ 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
大番茄
[第10楼] 发帖时间 2004年06月28日 20时43分

圣骑士
* * *

组别： 认证用户
帖子数量： 127
用户编号： 15345
注册时间： 2003年06月05日

Member 离线

引用 (刘波 @ 2004年06月28日 19时10分)
C:\WINDOWS\system32\uxtheme.dll 这个文件操作系统不是会对它进行保护的么？用安装程序能自动删除掉么？

绝对可以删除!!

用固定地址就可以
其实不是哪个文件的问题

随便什么文件好了

只要能够用什么关键字能指到系统分区,或WIN目录或STSTEM32目录都可以!

但是目前都试过,都无效!!

番茄花园:
http://tomatolei.com
gnatix
[第11楼] 发帖时间 2004年06月29日 01时09分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

既然用真实地址可以删除，那么用变量的地址一定也的可以删除的。问题是你不能直接把变量放到路径中去，而是要先把变量转换成实际路径，这个用来转换的函数叫 ExpandConstant()。所以你上面的例子应该是：

If FileExists(ExpandConstant('{win}\system32\dllcache\uxtheme.dll')) Then DeleteFile(ExpandConstant('{win}\system32\dllcache\uxtheme.dll'));

或者：

If FileExists(ExpandConstant('{sys}\dllcache\uxtheme.dll')) Then DeleteFile(ExpandConstant('{sys}\dllcache\uxtheme.dll'));

user posted image
大番茄 | [第12楼] 发帖时间 2004年06月29日 17时31分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 太好了,谢谢了!! 大老虎斑竹厉害!!!! 番茄花园: http://tomatolei.com
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3361 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


关于导入注册表的几种方法

(3) 1 3 ( 转到首个未读帖子 )

> 关于导入注册表的几种方法
订阅此主题 | 邮寄此主题 | 打印此主题
刘波
[第21楼] 发帖时间 2004年01月07日 13时37分

版主
* * * * *

组别： 认证用户
帖子数量： 623
用户编号： 691
注册时间： 2001年12月27日

Member 离线

引用 (大番茄 @ 2003年11月06日 16时33分)
用INNO做的安装程序,想把REG文件做进去,请问要怎么弄呢?
我最近自己做了一个CS,把所有的地图,人物武器的皮肤都换了,并且把CDKEY和所有设置都从注册表导出了,我想用年年inno做压缩的时候同时把导出的REG文件一起加入,有谁知道怎么编写呢?

在脚本的 [registry] 区段中写入需要添加的注册表内容。具体语法参看帮助文件。当然最简单的就是用 ISTool 来做安装脚本。他可以直接导入注册表文件并将其转化为 Inno 可以认识的脚本语句。

欢迎来到汉化新世纪论坛之分论坛游戏天地
user posted image
gnatix
[第22楼] 发帖时间 2004年01月07日 14时30分

天使
* * * * * *

组别： 超级版主
帖子数量： 2407
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (大番茄 @ 2003年11月06日 16时33分)
用INNO做的安装程序,想把REG文件做进去,请问要怎么弄呢?
我最近自己做了一个CS,把所有的地图,人物武器的皮肤都换了,并且把CDKEY和所有设置都从注册表导出了,我想用年年inno做压缩的时候同时把导出的REG文件一起加入,有谁知道怎么编写呢?

在 [Registry] 区段里添加类似以下的语句：
[Registry]
Root: HKCU; Subkey: "SOFTWARE\YourProgram"; ValueType: string; ValueName: "RegCode"; ValueData: "123456"; Flags: uninsdeletekey

Flags: uninsdeletekey 表示卸载时自动删除注册表中的条目

有兴趣的话可以参考一下我用 Inno 做的 Attribute Changer 安装脚本文件。

附件 ( 下载次数: 11 )
附件 setup.iss
user posted image
gnatix | [第23楼] 发帖时间 2004年01月07日 14时40分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 本人认为用 Inno 的一个好处是卸载时可以把写入到注册表的东西一并全部删除掉。可能其它方式也行，但是没有试过。 user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项 (3) 1 3

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.7997 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


请教。如何用Inno Setup导入一个注册表文件？

> 请教。如何用Inno Setup导入一个注册表文件？
订阅此主题 | 邮寄此主题 | 打印此主题
FreeHH | [楼主] 发帖时间 2004年04月30日 08时05分
新手上路 * 组别： 用户 帖子数量： 3 用户编号： 24051 注册时间： 2004年04月28日 Member 离线 | 我有一个注册表文件，比如 Free.reg ，现在要求用安装程序将其导入到注册表，并且导入时不出现诸如“是否要将XXX导入注册表”的提示，而是安静运行。 Free.reg大约有94K，如果不想手动逐条添加，请问该怎么做？ 最好是用Inno Setup实现。
刘波 | [第1楼] 发帖时间 2004年04月30日 09时34分
版主 * * * * * 组别： 认证用户 帖子数量： 623 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 可以使用教本编辑工具：ISTool 直接导入。当然也可以用调用 Regedit 的参数的方式。不过不推荐这样！因为直接用 Regedit 导入的卸载时不会删除相应项目。而直接写进教本里可以控制在卸载中是否删除注册表项目 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
FreeHH | [第2楼] 发帖时间 2004年04月30日 11时56分
新手上路 * 组别： 用户 帖子数量： 3 用户编号： 24051 注册时间： 2004年04月28日 Member 离线 | 承蒙指教，万分感谢！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3057 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


如何使用Inno Setup？？？？？

> 如何使用Inno Setup？？？？？, Inno Setup的问题！！！！！
订阅此主题 | 邮寄此主题 | 打印此主题
mueCN | [楼主] 发帖时间 2004年01月05日 21时35分
新手上路 * 组别： 用户 帖子数量： 5 用户编号： 17956 注册时间： 2003年10月09日 Member 离线 | 请问如何在Inno Setup中加入.REG文件，实现程序安装过程中实现注册，我不知道怎么做，请教高手
OFA | [第1楼] 发帖时间 2004年01月05日 21时44分
天使 * * * * * * 组别： 认证用户 帖子数量： 1418 用户编号： 13575 注册时间： 2003年04月13日 Member 在线 | 捆绑，释放到任意目录(比如安装目录或者temp目录)，然后编写脚本在[run] section 写入Filename: "*.reg"; flags: shellexec user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
刘波 | [第2楼] 发帖时间 2004年01月05日 22时33分
版主 * * * * * 组别： 认证用户 帖子数量： 624 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 用不着那么小题大做吧。直接写到它的脚本中的 [registry] 区段就行了啊。如果怕麻烦的话用 ISTool 直接导入就行！ 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.7676 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


请莫名大虾过来看看

> 请莫名大虾过来看看, 关于 INnoSetup
softsword
[楼主] 发帖时间 2004年03月02日 19时16分

精灵王
* * * *

组别： 认证用户
帖子数量： 356
用户编号： 17697
注册时间： 2003年09月28日

Member 离线

莫名大虾：

小弟想请问您，您的这个功能是怎么实现的。就是从注册表里面读取键值，小弟以前装过 4.1.5，现在装 4.1.8 的时候，发现了这个问题：为什么您的程序可以读取键值，小弟的就不行呢？那么具体在 Inno 里面如何实现呢？

这里的路径： C:\Program Files\InnoSetup 是我以前版本的安装路径（而不是 InnoSetup 的默认路径），但是它就是可以识别出来，为什么？

请指教，谢谢！

附图
附图

夏天来了，天气热了，一群“BT”往北飞，一会儿排成“B”字，一会儿排成“T”字 ……

user posted image
孔子东游，遇二小儿辩斗，问其故。
    一小儿曰：我以日本生自山东，故属东。
    一小儿曰：夕阳西下，日本归山西也明矣，是以属西。
    孔子不能决，后以问老子（本人也）。
    老子笑曰：孰为汝多知乎？日本无根基，岂能算东西 ！
user posted image
yagas | [第1楼] 发帖时间 2004年03月02日 21时27分
侠客 * 组别： 认证用户 帖子数量： 38 用户编号： 21498 注册时间： 2004年02月21日 Member 离线 | {reg:HKLM\Software\Microsoft\windows\CurrentVersion\Uninstall\Inno Setup 4_is1,Inno Setup: App Path|{pf}\inno setup 4}
gnatix | [第2楼] 发帖时间 2004年03月03日 02时44分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 再具体一点： [Setup] DefaultDirName={reg:HKLM\Software\Microsoft\windows\CurrentVersion\Uninstall\Inno Setup 4_is1,Inno Setup: App Path|{pf}\inno setup 4} user posted image
softsword | [第3楼] 发帖时间 2004年03月03日 10时58分
精灵王 * * * * 组别： 认证用户 帖子数量： 356 用户编号： 17697 注册时间： 2003年09月28日 Member 离线 | 哦，这样啊！ 非常感谢两位！ 夏天来了，天气热了，一群“BT”往北飞，一会儿排成“B”字，一会儿排成“T”字 …… user posted image 孔子东游，遇二小儿辩斗，问其故。 一小儿曰：我以日本生自山东，故属东。 一小儿曰：夕阳西下，日本归山西也明矣，是以属西。 孔子不能决，后以问老子（本人也）。 老子笑曰：孰为汝多知乎？日本无根基，岂能算东西 ！ user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3309 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


【求助】关于Inno setup读取注册表信息

> 【求助】关于Inno setup读取注册表信息
youth9999 | [楼主] 发帖时间 2004年07月20日 15时50分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 偶想在安装某软件时将注册表中的一些信息读取出来，并在{app}下保存成.reg文件（当然要保持格式正确，以后能点击导入）！但苦思良久不得其法，还望大家指教！如果在用InnoSetup制作安装包时实现这样的功能呢？
刘波 | [第1楼] 发帖时间 2004年07月20日 17时47分
版主 * * * * * 组别： 认证用户 帖子数量： 786 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 好像不行吧。你这个等于说让INNOSETUP将数据写入一个文件。好像没这个功能吧。 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
youth9999
[第2楼] 发帖时间 2004年07月20日 17时54分

侠客
*

组别： 用户
帖子数量： 26
用户编号： 19572
注册时间： 2003年12月10日

Member 离线

引用 (刘波 @ 2004年07月20日 17时47分)
好像不行吧。你这个等于说让INNOSETUP将数据写入一个文件。好像没这个功能吧。

写入文件是可以的，如ini，但如何写Reg文件，偶就无知了！
刘波
[第3楼] 发帖时间 2004年07月20日 20时23分

版主
* * * * *

组别： 认证用户
帖子数量： 786
用户编号： 691
注册时间： 2001年12月27日

Member 离线

引用 (youth9999 @ 2004年07月20日 17时54分)
引用 (刘波 @ 2004年07月20日 17时47分)
好像不行吧。你这个等于说让INNOSETUP将数据写入一个文件。好像没这个功能吧。

写入文件是可以的，如ini，但如何写Reg文件，偶就无知了！

我知道可以写入INI文件。我的意思是说要让其创建一个新文件并将数据写入这个功能好像还没有。

欢迎来到汉化新世纪论坛之分论坛游戏天地
user posted image
gnatix | [第4楼] 发帖时间 2004年07月21日 01时31分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 这个只能在 [CODE] 段才能实现。 user posted image
gnatix | [第5楼] 发帖时间 2004年07月21日 04时53分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 写了一个脚本，应该可以满足楼主的需要。 脚本的用途：在安装软件前将注册表中某个子键中的所有内容保存到安装目录中的一个 .reg 文件中。红色部分可以根据具体情况加以调整。 [Code] procedure InitializeWizard(); var iResultCode: Integer; appDir, regFileName, keyName: String; begin appDir:=ExpandConstant('{pf}\Abc'); //安装目录 abc，设置和 [Setup] 中的 DefaultDirName 一样 regFileName:= appDir+'\backup.reg'; //注册表备份文件名 backup.reg keyName:= 'HKEY_CURRENT_USER\Software\HDCleaner'; //要备份的注册表子键 HKEY_CURRENT_USER\Software\HDCleaner CreateDir(appDir); InstExec('regedit','/E "'+regFileName+'" "'+keyName+'"', '', true, false, 0, iResultCode); end; user posted image
xihua | [第6楼] [image] 发帖时间 2004年07月21日 09时44分
精灵王 * * * * 组别： 认证用户 帖子数量： 343 用户编号： 17836 注册时间： 2003年10月05日 Member 在线 | gnatix 兄太强了！！！ 山河大地，已属微尘；血肉身躯，且归泡影；非上上智，无了了心。
youth9999 | [第7楼] 发帖时间 2004年07月21日 11时07分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 谢谢老虎板，偶现在有点崇拜你了，哈哈！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3245 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


Setup Factory 求助！

> Setup Factory 求助！, 如何删除win2000/xp的注册表键值。
订阅此主题 | 邮寄此主题 | 打印此主题
linux | [楼主] 发帖时间 2003年09月19日 17时23分
新手上路 * 组别： 用户 帖子数量： 3 用户编号： 17530 注册时间： 2003年09月19日 Member 离线 | 请问各位大侠，用Setup Factory制作的安装程序如何删除win2000/xp的注册表中需要设置权限才能删除的键值？ 比如删除SystemCurrentControlSet下某个键值，在2000中必须用regedt32来设置完全权限才能删除，在xp下也必须用注册表编辑器regedit设置完全的权限才能删除，请问有没有什么方法可以直接通过安装程序来删除？（我用系统管理员身份登陆系统的。） 先谢谢各位了。
思忆 | [第1楼] 发帖时间 2003年09月19日 19时29分
侠客 * 组别： 用户 帖子数量： 29 用户编号： 1456 注册时间： 2002年04月05日 Member 离线 | Setup Factory 用的很少，如果你的安装程序不需要太多的功能的话， Inno Setup 4 应该可以解决你的问题。 用 Inno Setup 4 编写的注册表健值可以在卸载时删除，具体如下： Root: HKCR; Subkey: "InnoSetupScriptFile"; ValueType: string; ValueName: ""; ValueData: "Inno Setup 脚本"; Flags: uninsdeletekey 红色部分是卸载时安装程序执行的操作，具体帮助有说明。
linux | [第2楼] 发帖时间 2003年09月23日 12时27分
新手上路 * 组别： 用户 帖子数量： 3 用户编号： 17530 注册时间： 2003年09月19日 Member 离线 | 对不起，如果是在安装之前要删除键值呢？手动删除的话，必须分配给那个键值高级权限才能删除。
思忆 | [第3楼] 发帖时间 2003年09月26日 16时30分
侠客 * 组别： 用户 帖子数量： 29 用户编号： 1456 注册时间： 2002年04月05日 Member 离线 | Flags: deletekey 安装前删除键值 Flags: deletevalue 安装前清除键值数据
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.7903 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


关于用Inno Setup 3制作安装程序的问题？

(3) 2 3 ( 转到首个未读帖子 )

> 关于用Inno Setup 3制作安装程序的问题？
订阅此主题 | 邮寄此主题 | 打印此主题
jby | [楼主] 发帖时间 2003年04月27日 12时01分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 8197 注册时间： 2002年12月08日 Member 离线 | 在使用Inno Setup 3制作安装程序时，我想让程序安装后能随windows一起启动，我该怎么写这个代码？？？？？？ 还有其它的安装程序制作工具能做到这一点吗？
西风狂诗曲 | [第1楼] 发帖时间 2003年04月27日 12时17分
圣骑士 * * * 组别： 认证用户 帖子数量： 213 用户编号： 3829 注册时间： 2002年07月31日 Member 离线 | 写入注册表(HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run) 或将快捷方式放入开始菜单里的启动目录({userstartup} 或 {commonstartup}变量)里就行了 这个帖子已被 西风狂诗曲 于 2003年04月28日 00时22分 编辑
jby | [第2楼] 发帖时间 2003年04月27日 15时31分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 8197 注册时间： 2002年12月08日 Member 离线 | 具体代码怎么写？能说清楚点吗？
西风狂诗曲 | [第3楼] 发帖时间 2003年04月27日 19时07分
圣骑士 * * * 组别： 认证用户 帖子数量： 213 用户编号： 3829 注册时间： 2002年07月31日 Member 离线 | 用ISTool好了，，，INNO脚本向导生成工具 前两天我汉化完传上去了，，，昨天新世纪数据库被黑了，，，过两天大概会再更新上 附图 附图
西风狂诗曲 | [第4楼] 发帖时间 2003年04月27日 19时08分
圣骑士 * * * 组别： 认证用户 帖子数量： 213 用户编号： 3829 注册时间： 2002年07月31日 Member 离线 | 附图 附图
jby | [第5楼] 发帖时间 2003年04月29日 09时27分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 8197 注册时间： 2002年12月08日 Member 离线 | 谢谢 新世纪一放上来我就下，试试看
jby | [第6楼] 发帖时间 2003年05月03日 22时35分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 8197 注册时间： 2002年12月08日 Member 离线 | 西风狂诗曲: 我指的是在安装程序中出现一个如“随windows一起启动”这样的可选项，让用户能自己决定软件是否随系统一起启动!我找了好久也没有找到，当然你上面的图中是在注册表中直接加入启动键值，这也是可以实现的，但用户却没有的选择权了!
莫名 | [第7楼] 发帖时间 2003年05月03日 23时12分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1328 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 你还需要编辑脚本，在任务段加入任务，例如： [Tasks] Name: "startup"; startup: "随 windwos 启动"; GroupDescription: "添加启动选项：" 然后在脚本的有关写入注册表内容后面添加: ; Tasks: startup 安装时就会出现选项，随便举个例子，可能不太准确。
jby | [第8楼] 发帖时间 2003年05月04日 12时18分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 8197 注册时间： 2002年12月08日 Member 离线 | 谢谢莫名大侠，我试试看，如果还不行，我还要向你请教的!
jby | [第9楼] 发帖时间 2003年05月08日 09时12分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 8197 注册时间： 2002年12月08日 Member 离线 | 莫名大侠: “startup”不是有效的参数名，所以我改成了以下的代码： [Tasks] Name: "startup"; Description: "随 windwos 启动"; GroupDescription: "添加启动选项：" [Icons] Name: {userappdata}\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run\fileBX; Filename: {app}\fileBX.exe; Tasks: startup 但还是不行。。。
莫名 | [第10楼] 发帖时间 2003年05月08日 10时04分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1328 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 感觉你写入注册表方法不对呀,参考以下链接学习 http://member.netease.com/~limpo/is/islearn2.htm 写入注册表应该是 Root: HKLM; Subkey: "Software\My Company\My Program"; ValueType: string; ValueName: "InstallPath"; ValueData: "{app}"
西风狂诗曲 | [第11楼] 发帖时间 2003年05月08日 12时59分
圣骑士 * * * 组别： 认证用户 帖子数量： 213 用户编号： 3829 注册时间： 2002年07月31日 Member 离线 | 不是感觉不对，，，是根本不对。。。
jby
[第12楼] 发帖时间 2003年05月09日 12时49分

侠客
*

组别： 用户
帖子数量： 49
用户编号： 8197
注册时间： 2002年12月08日

Member 离线

引用
下面引用由jby在 2003/05/03 10:35pm 发表的内容：
西风狂诗曲:
我指的是在安装程序中出现一个如“随windows一起启动”这样的可选项，让用户能自己决定软件是否随系统一起启动!我找了好久也没有找到，当然你上面的图中是在注册表中直接加入启动键值，这也是可 ...

在ISTool中怎样设置或在ISS中怎样写这个代码？我非常急用，先谢啦!
莫名 | [第13楼] 发帖时间 2003年05月09日 20时55分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1328 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 按以下写: ISTool不是万能的 [Tasks] Name: "startup"; Description: "随 windwos 启动"; GroupDescription: "添加启动选" [Registry] Root: HKCU; SubKey: Software\Microsoft\Windows\CurrentVersion\Run; valueType: string; valueName: "fileBX"; valueData: "{app}\fileBX.exe";Flags: uninsdeletevalue; Tasks: startup 注意写入注册表的项目要放置的[Registry]段,不能放在[Icons]
jby | [第14楼] 发帖时间 2003年05月10日 10时25分
侠客 * 组别： 用户 帖子数量： 49 用户编号： 8197 注册时间： 2002年12月08日 Member 离线 | 感谢莫名大侠，我昨天参照你给的学习链接进行了学习，已成功解决了问题，谢啦!
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项 (3) 2 3

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.4961 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


Inno Setup 写注册表的问题

> Inno Setup 写注册表的问题
OFA | [楼主] 发帖时间 2004年05月23日 17时15分
天使 * * * * * * 组别： 认证用户 帖子数量： 1417 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | 近日汉化 EZ Flash Save 这个软件，安装时软件需要在 IE 工具栏添加一按钮。 用 Inno Setup 向注册表中写入相应信息，相应的值项为 Root: HKLM; Subkey: "SOFTWARE\Microsoft\Internet Explorer\Extensions\{5699BDDB-A771-4E54-ACBB-BE86921D7892}"; ValueType: string; ValueName: "ButtonText"; ValueData: "用 EZ Save Flash 显示 Flash 列表"; Flags: uninsdeletekey Root: HKLM; Subkey: "SOFTWARE\Microsoft\Internet Explorer\Extensions\{5699BDDB-A771-4E54-ACBB-BE86921D7892}"; ValueType: string; ValueName: "CLSID"; ValueData: "{1FBA04EE-3024-11d2-8F1F-0000F87ABD16}"; Flags: uninsdeletekey 等等... 其中大括号在编译时出错，提示“如果你要加入单个"{"并且它不是一个常量，请使用两个连续的"{"字符”，加了一个"{"后可以正常编译。 请问一下各位这个"{"中的一长串数字是随机的吗？其作用和意义是什么？如果我按照上面的那串数字编译，在别人的电脑中是否能正常运行？ user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
gnatix | [第1楼] 发帖时间 2004年05月23日 19时39分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 好像不是随机的。在其它机器上应该能够正常运行。至少我遇到过的情况是这样。 user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.2885 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


【求助】InnoSetup写入注册表的问题

> 【求助】InnoSetup写入注册表的问题
youth9999 | [楼主] 发帖时间 2004年07月06日 22时51分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 偶想在Inno创建的安装包中实现如下功能： 在安装向导窗口中选择写入/不写入注册表信息，通过一个复选框控制（像要不要创建桌面图标一样）！但偶深浅无知，请各位指教！ 偶在[Task]段加入了：Name: "asstext"; Description: "关联文本文件(&A)"; GroupDescription: "系统选项设定:"; Flags: unchecked 但不知道在[Registry]或其它段加入什么相应的信息才能实现这样的功能！ 先谢过了！
莫名 | [第1楼] 发帖时间 2004年07月06日 23时13分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1328 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 在有关注册表句子后面写上 ; Tasks: asstext
youth9999 | [第2楼] 发帖时间 2004年07月06日 23时14分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 谢谢莫名兄，偶先试试！ 还想问个问题，就是在Inno中怎样注册Dll文件？偶怎么注册不成功呢？难道只能用Regsvr32？
OFA
[第3楼] 发帖时间 2004年07月07日 03时58分

天使
* * * * * *

组别： 认证用户
帖子数量： 1443
用户编号： 13575
注册时间： 2003年04月13日

Member 离线

Inno 中注册 dll、ocx 等文件请使用 Flags: regserver
例如:
代码
[File]
Source: "C:\Example\MyDll.dll"; DestDir: "{app}"; Flags: regserver

user posted image
愿为汉化事业贡献自己的一份微薄之力。
欢迎您访问我的净土 http://www.cokemouse.com
youth9999 | [第4楼] 发帖时间 2004年07月07日 07时47分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 再次感谢，马上试呀！ 楼上的，请问注册成功后如何获得该DLL文件的CLSID值呢？ 继续提问，大家千万不要烦啊！ 如果在安装时修改了注册表内容，如何在卸载时将修改的内容再还原呢？请指教！
gnatix
[第5楼] 发帖时间 2004年07月07日 14时23分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用
如果在安装时修改了注册表内容，如何在卸载时将修改的内容再还原呢？请指教！

这个比较难，因为要读取和保存原来的注册表内容。一个可能的途径是：
安装前读取注册表内容，将它们保存到一个 old.reg 文件。这个步骤可能只有通过 Code 脚本才能实现。
在安装脚本中添加：
[UninstallRun]
Filename: "regedit.exe"; Parameters: "/s {app}\old.reg"

user posted image
youth9999 | [第6楼] 发帖时间 2004年07月07日 16时27分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 谢谢老虎板板，偶上面问的关于注册DLL文件后如何获取其CLSID值，有没有办法实现？
gnatix
[第7楼] 发帖时间 2004年07月09日 06时36分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用 (youth9999 @ 2004年07月07日 16时27分)
谢谢老虎板板，偶上面问的关于注册DLL文件后如何获取其CLSID值，有没有办法实现？

注册的是什么 DLL 文件，要在什么时候要用到这个 CLSID ？

user posted image
youth9999 | [第8楼] 发帖时间 2004年07月09日 08时31分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 这种情况很多啊，比如说Emeditor安装后如果在右键加入Emeditor后会在注册表中加入HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\EmEditor\{DFA0CC7F-D36B-47D1-8EF5-415C1DA53F57}式样内容！此处的{DFA0CC7F-D36B-47D1-8EF5-415C1DA53F57}不就是X:\EmEditor\emedshl.dll文件注册后生成的CLSID吗？偶想要得到的就是安装程序自动注册Dll文件后生成的这个Clsid！不知道能不能实现呢？
gnatix | [第9楼] 发帖时间 2004年07月09日 17时43分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 我这方面不是太懂，但是这个 CLSID 应该不是注册时所产生的，而是编写 DLL 时作者给定的。因此这个 CLSID 应该在所有的机器上都一样，你在自己机器上看看是什么 CLSID 就知道了，没有必要再让安装程序去读取出来。 我不能肯定我说的是否对，所以希望有懂编程的朋友出来证实或者纠正。 user posted image
kenhy | [第10楼] 发帖时间 2004年07月09日 20时27分
侠客 * 组别： 用户 帖子数量： 29 用户编号： 23897 注册时间： 2004年04月24日 Member 离线 | 哗咔咔，刚刚还想上来发帖问更多关于Inno Setup 编译器的问题哩，现在看来都不发了，哈哈。
kenhy
[第11楼] [image] 发帖时间 2004年07月09日 20时30分

侠客
*

组别： 用户
帖子数量： 29
用户编号： 23897
注册时间： 2004年04月24日

Member 离线

引用 (OFA @ 2004年07月07日 03时58分)
Inno 中注册 dll、ocx 等文件请使用 Flags: regserver
例如:
代码
[File]
Source: "C:\Example\MyDll.dll"; DestDir: "{app}"; Flags: regserver

Source: "D:\目录名\Msvbvm60.dll"; DestDir: "{sys}"; Flags: restartreplace uninsneveruninstall sharedfile regserver
应该用这句好过吧？
youth9999 | [第12楼] 发帖时间 2004年07月10日 07时52分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 谢谢楼上多位，现在基本有点明白了！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3715 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


[求助]如何在注册表中添加汉化包的设置？

> [求助]如何在注册表中添加汉化包的设置？
订阅此主题 | 邮寄此主题 | 打印此主题
snowfrog
[楼主] 发帖时间 2003年05月14日 22时34分

精灵王
* * * *

组别： 认证用户
帖子数量： 393
用户编号： 3516
注册时间： 2002年07月16日

Member 离线

近来汉化了一个语言包类型的软件Secure Copy 2，在官方下载了英文语言包，并将其汉化了。但制作安装程序时不能如何添加注册表处的语言包设置。原英文语言包是用Inno Setup 3.0.6制作的！不过我想用WINrar制作安装程序。如何编写脚本？ 下面的地方是关键处。
HKEY_LOCAL_MACHINE\Software\PinedaNET\SreCopy\V2\Language\English: "C:\Program Files\Pinedanet\Secure Copy 2\Languages\english.scl"
我想将其写入为：
HKEY_LOCAL_MACHINE\Software\PinedaNET\SreCopy\V2\Language\Chinese: "C:\Program Files\Pinedanet\Secure Copy 2\Languages\CHS.scl"
请问如何编写Winrar的安装脚本？用Inno Setup又要如何编写？
下面是REGSHOT记录文件
----------------------------------
添加主键:3
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\English Language Pack_is1
HKEY_LOCAL_MACHINE\Software\PinedaNET\SreCopy\V2
HKEY_LOCAL_MACHINE\Software\PinedaNET\SreCopy\V2\Language
添加键值:12
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\English Language Pack_is1\Inno Setup: Setup Version: "3.0.6"
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\English Language Pack_is1\Inno Setup: App Path: "C:\Program Files\Pinedanet\Secure Copy 2\Languages"
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\English Language Pack_is1\Inno Setup: Icon Group: "English Language Pack"
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\English Language Pack_is1\Inno Setup: User: "007"
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\English Language Pack_is1\DisplayName: "pineda:net SecuRE|copy English Language Pack"
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\English Language Pack_is1\UninstallString: ""C:\Program Files\Pinedanet\Secure Copy 2\Languages\unins000.exe""
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\English Language Pack_is1\DisplayVersion: "1.0"
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\English Language Pack_is1\Publisher: "pineda:net"
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\English Language Pack_is1\URLInfoAbout: "http://www.pinedanet.com"
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\English Language Pack_is1\HelpLink: "http://www.pinedanet.com"
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\English Language Pack_is1\URLUpdateInfo: "http://www.pinedanet.com"
HKEY_LOCAL_MACHINE\Software\PinedaNET\SreCopy\V2\Language\English: "C:\Program Files\Pinedanet\Secure Copy 2\Languages\english.scl"
添加文件:3
C:\Program Files\Pinedanet\Secure Copy 2\Languages\unins000.dat
C:\Program Files\Pinedanet\Secure Copy 2\Languages\unins000.exe
C:\Program Files\Pinedanet\Secure Copy 2\Languages\english.scl
修改文件:1
C:\WINDOW\WIN386.SWP
添加目录:6
C:\Program Files\Pinedanet\Secure Copy 2
C:\Program Files\Pinedanet\Secure Copy 2\.
C:\Program Files\Pinedanet\Secure Copy 2\..
C:\Program Files\Pinedanet\Secure Copy 2\Languages
C:\Program Files\Pinedanet\Secure Copy 2\Languages\.
C:\Program Files\Pinedanet\Secure Copy 2\Languages\..
总计:25

【SnowFrog/盛华】
电邮地址：SnowFrog@ToM.CoM
QQ:1237183

【精灵软件工作室测试人员】
我们的网站:精灵软件工作室

最新发布语音朗读精灵(SmartRead) V0.52、中文女声语音库 1.8和语音朗读掌上版[SmartRead Pocket]！

学好外语很重要，学好国语更重要！
gnatix | [第1楼] 发帖时间 2003年05月14日 22时52分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2667 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 用 Inno Setup 的例子： [Registry] Root: HKLM; Subkey: "Software\PinedaNET\SreCopy\V2\Language"; ValueName: "Chinese"; ValueType: string; ValueData: "{app}\Languages\CHS.scl" user posted image Tervetuloa!
snowfrog | [第2楼] 发帖时间 2003年05月14日 23时20分
精灵王 * * * * 组别： 认证用户 帖子数量： 393 用户编号： 3516 注册时间： 2002年07月16日 Member 离线 | 用WINRAR如何写入？？ 【SnowFrog/盛华】 电邮地址：SnowFrog@ToM.CoM QQ:1237183 【精灵软件工作室测试人员】 我们的网站:精灵软件工作室 最新发布语音朗读精灵(SmartRead) V0.52、中文女声语音库 1.8和语音朗读掌上版[SmartRead Pocket]！ 学好外语很重要，学好国语更重要！
xxoo | [第3楼] 发帖时间 2003年05月15日 00时19分
精灵王 * * * * 组别： 认证用户 帖子数量： 404 用户编号： 5580 注册时间： 2002年09月28日 Member 离线 | 建立一个 x.reg 文件包含你要添加注册标的内容...注意内容中不能包含可变的值或者项. 然后用 rar 自解压脚本写 setup=regedit /s x.reg //导入注册表(不提示) setup=%ComSpec% /c "del x.reg /f" //删除 x.reg(不提示)
simon
[第4楼] 发帖时间 2003年05月15日 00时56分

版主
* * * * * *

组别： 认证用户
帖子数量： 2271
用户编号： 658
注册时间： 2001年12月19日

Member 离线

引用
下面引用由xxoo在 2003/05/15 00:19am 发表的内容：
建立一个 x.reg 文件包含你要添加注册标的内容...注意内容中不能包含可变的值或者项.
然后用 rar 自解压脚本写
setup=regedit /s x.reg //导入注册表(不提示)
setup=%ComSpec% /c "del x.reg /f" //删 ...

setup=regedit /s 也可以写成 setup=regedit -s
另外也可以写一个批处理文件来完成这些事情。
RAR脚本中加入：
setup=Reg.bat
BAT大致内容(用记事本编辑，存为 bat 文件)：
@ECHO OFF
regedit -s REG.reg (设 REG.reg 是你已写好的 .reg 文件)
echo.
del *.reg
echo.
@scopy.exe (运行主程序，假设主程序名为 scopy.exe)
del *.bat
cls

不过不建议你用 WinRAR 来完成这些事情，因为定会有用户发现它实际上是自解压的 RAR 包，若自行解压而不进行安装的话，你的煞费苦心也就白费了
simon | [第5楼] 发帖时间 2003年05月15日 01时08分
版主 * * * * * * 组别： 认证用户 帖子数量： 2271 用户编号： 658 注册时间： 2001年12月19日 Member 离线 | 又看了一下你的帖子，如果只有一个几 Kb 大小的语言文件倒还是可以考虑用 WinRAR 的。我上面的 Bat 文件运行的效果是——先把打进包内事先写好的 Reg.reg 文件导入注册表（静默方式，不会有提示）；然后删掉这个注册表文件；接下来是自动运行主程序，这时应该已经是显示中文界面了；最后是删掉自己这个 Bat 文件，以保持神秘感。 另外推荐你使用吕达嵘老大汉化的 SFX-Factory ，也就是 WinACE 的自解压制作程序，功能要强大的多，支持修改注册表
snowfrog | [第6楼] 发帖时间 2003年05月15日 14时45分
精灵王 * * * * 组别： 认证用户 帖子数量： 393 用户编号： 3516 注册时间： 2002年07月16日 Member 离线 | 已把语言包发给作者了！相信作者会把它搞好的！谢谢大家了！希望大家都做出简体中文版的软件来！ 【SnowFrog/盛华】 电邮地址：SnowFrog@ToM.CoM QQ:1237183 【精灵软件工作室测试人员】 我们的网站:精灵软件工作室 最新发布语音朗读精灵(SmartRead) V0.52、中文女声语音库 1.8和语音朗读掌上版[SmartRead Pocket]！ 学好外语很重要，学好国语更重要！
« 上一个主题 | Windows 软件汉化 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 1.2223 秒 ] [ 数据库查询： 14 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


【问题】如何能用INNOSETUP注册WINDOWS组件？

> 【问题】如何能用INNOSETUP注册WINDOWS组件？, 应该可以吧？
订阅此主题 | 邮寄此主题 | 打印此主题
leyan22 | [楼主] 发帖时间 2004年07月26日 18时12分
骑士 * * 组别： 认证用户 帖子数量： 51 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | 比如我要在%SYSTEMDIR%注册一个XXXXX.ax或XXXX.ocx应该怎么编写代码？ 打个比方 木子的QQ 就是在c:\windows\system32\里面注册了一个REALXXX 才能用QQ播放REAL 的 我想问一下怎么写这段代码实现上面的功能？
gnatix | [第1楼] 发帖时间 2004年07月26日 18时47分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 搜索旧帖。。。 http://bbs.hanzify.org/index.php?showtopic=19197 user posted image
leyan22 | [第2楼] 发帖时间 2004年07月26日 18时52分
骑士 * * 组别： 认证用户 帖子数量： 51 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | 老虎问一下 Filename: "{sys}\regsvr32.exe"; Parameters: "/s xxx.dll" Source: "file\System\MPEGCOM.dll"; DestDir: "{sys}";Flags: regserver 有什么不一样？ Parameters:有什么用？
gnatix | [第3楼] 发帖时间 2004年07月26日 18时59分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | Filename: "{sys}\regsvr32.exe"; Parameters: "/s xxx.dll" 运行某个程序文件 Source: "file\System\MPEGCOM.dll"; DestDir: "{sys}";Flags: regserver 复制文件时同时注册文件 另外： Filename 只能是程序文件名 Parameters 是程序运行的参数 user posted image
leyan22 | [第4楼] 发帖时间 2004年07月26日 19时00分
骑士 * * 组别： 认证用户 帖子数量： 51 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | 谢谢老虎斑竹了呵呵！
刘波 | [第5楼] 发帖时间 2004年07月27日 08时04分
版主 * * * * * 组别： 认证用户 帖子数量： 786 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 需要注意的是： Filename: "{sys}\regsvr32.exe"; Parameters: "/s xxx.dll" 上面这个在卸载时如果不专门添加代码的话是不会自动解除注册的。 而 Source: "file\System\MPEGCOM.dll"; DestDir: "{sys}";Flags: regserver 在卸载的时候会自动解除注册。 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
sinker | [第6楼] 发帖时间 2004年07月27日 08时49分
天使 * * * * * * 组别： 认证用户 帖子数量： 1174 用户编号： 3227 注册时间： 2002年07月02日 Member 离线 | DestDir基本算是以一个目录常量开始的,用这个变量卸载很干净 SomBEr MOoN PReFers tO SInK DoWn pERfEctlY raTHEr tHaN pOUr iTs SHinE dOWN oN THe EiFFel TowER
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3151 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


Inno Setup注册主件的问题~

> Inno Setup注册主件的问题~
zjj1988101 | [楼主] 发帖时间 2004年03月28日 19时58分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | Inno Setup注册组件的脚本示例我在帮助里找了很常时间找不到~ 请高手指点一下~ 麻烦了！
yagas | [第1楼] 发帖时间 2004年03月28日 22时06分
侠客 * 组别： 认证用户 帖子数量： 38 用户编号： 21498 注册时间： 2004年02月21日 Member 离线 | 放在[RUN]里的 Filename: "{sys}\regsvr32.exe"; Parameters: "/s xxx.dll" Filename: "{sys}\regsvr32.exe"; Parameters: "/s xxx.ocx"
莫名 | [第2楼] 发帖时间 2004年03月28日 22时23分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1322 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | Source: "file\System\MPEGCOM.dll"; DestDir: "{sys}";Flags: regserver 注意后面的 Flags: regserver
zjj1988101 | [第3楼] 发帖时间 2004年03月29日 15时42分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 谢谢！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。
[ 程序执行时间： 0.3218 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


【求助】还是Inno问题,大大们帮忙指导下

> 【求助】还是Inno问题,大大们帮忙指导下, 未何定义的组件类型不能正确安装
snakey
[楼主] 发帖时间 2004年05月29日 00时00分

侠客
*

组别： 认证用户
帖子数量： 35
用户编号： 21437
注册时间： 2004年02月20日

Member 离线

定义了三个安装模式
完全安装
主程序安装
辅助程序安装
自定义
不管使用哪个模式,安装程序都安装了所有文件,这是怎么回事?脚本如下:
[Types]
Name: "full"; Description: "完全安装"
Name: "compactgame"; Description: "安装运行必须程序"
Name: "compactsave"; Description: "安装记录以及帮助文件"
Name: "compactbak"; Description: "安装1.09版返回文件包"
Name: "custom"; Description: "自定义安装"; Flags: iscustom
;Name为类型的内部名字 用于定义 [Components] 段中组件参数 告诉安装程序组件属于哪个类型
;Description为类型的描述
;Flags为参数额外选项设置 Flags: iscustom 当用户改变安装组件时 告诉安装程序定义到自定义安装类型

[Components]
Name: "game"; Description: "游戏运行必须程序"; Types: full compactgame custom
Name: "save"; Description: "游戏记录以及帮助文件"; Types: full compactsave custom
Name: "bak"; Description: "返回1.09版的文件"; Types: full compactbak custom
;ExtraDiskSpaceRequired用于告诉程序安装这个组件需要多少磁盘空间
;Types为参数full compact 时 此组件被选中相关安装类型时必须安装
;Flags为参数fixed时 告诉安装程序这个组件不能在安装期间被最终用户手动选择或取消选择
;Flags为参数exclusive时 告诉安装程序这个组件与它的也使用 exclusive 标记的同级组件是互相排斥的

[Tasks]
Name: "desktopicon"; Description: "{cm:CreateDesktopIcon}"; GroupDescription: "{cm:AdditionalIcons}"; Flags: unchecked

[Files]
Source: "E:\Program Files\D2nd 1.10s\*"; DestDir: "{app}"; Flags: ignoreversion
Source: "E:\Program Files\D2nd 1.10s\ListFiles\*"; DestDir: "{app}\ListFiles"; Flags: ignoreversion recursesubdirs
Source: "E:\Program Files\D2nd 1.10s\D2CN\*"; DestDir: "{app}\D2CN"; Flags: ignoreversion recursesubdirs
Source: "E:\Program Files\D2nd 1.10s\D2X110.files\*"; DestDir: "{app}\D2X110.files"; Flags: ignoreversion recursesubdirs
Source: "E:\Program Files\D2nd 1.10s\MapHack\*"; DestDir: "{app}\MapHack"; Flags: ignoreversion recursesubdirs
Source: "E:\Program Files\D2nd 1.10s\save\*"; DestDir: "{app}\save"; Flags: ignoreversion recursesubdirs uninsneveruninstall
Source: "E:\Program Files\D2nd 1.10s\support\*"; DestDir: "{app}\support"; Flags: ignoreversion recursesubdirs
Source: "E:\Program Files\D2nd 1.10s\109 Backup\*"; DestDir: "{app}\109 Backup"; Flags: ignoreversion recursesubdirs
;Source为来源文件的路径
;DestDir文件安装到用户系统中的目录 如果不存在安装程序将建立
;Flags参数为onlyifdoesntexist 则仅在用户系统中不存在时安装文件
;Flags参数为uninsneveruninstall 则不卸载这个文件 多数用于需要共享的DLL
;Flags参数为isreadme 则表示为自述文件 用于安装程序结束后询问用户是否察看

user posted image
刘波 | [第1楼] 发帖时间 2004年05月29日 06时50分
版主 * * * * * 组别： 认证用户 帖子数量： 623 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 好像文件也得加上组件标记吧？ 等我试试再说 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
刘波 | [第2楼] 发帖时间 2004年05月29日 07时13分
版主 * * * * * 组别： 认证用户 帖子数量： 623 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | [Types] Name: Full; Description: Full Install; Flags: iscustom [Components] Name: Main_Program; Description: Main Program; Types: Full [Files] Source: C:\Program Files\ISTool 4\Hungarian.lng; DestDir: {pf}; Components: Main_Program 这个是 ISTool 自动生成的。看看吧。在文件后面也加上了组件的标记的！ 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
莫尼卡 | [第3楼] 发帖时间 2004年05月29日 11时06分
圣骑士 * * * 组别： 认证用户 帖子数量： 217 用户编号： 4599 注册时间： 2002年08月26日 Member 离线 | 文件上也要加上组件标志。 I love you! (you=emulator) user posted image
snakey | [第4楼] 发帖时间 2004年06月07日 01时12分
侠客 * 组别： 认证用户 帖子数量： 35 用户编号： 21437 注册时间： 2004年02月20日 Member 离线 | 知道了,谢谢 (为什么我总是要漏掉一点)- - user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3267 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


Inno Setup高手帮帮忙！！

> Inno Setup高手帮帮忙！！
订阅此主题 | 邮寄此主题 | 打印此主题
jiangshen | [楼主] 发帖时间 2004年06月07日 12时38分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 怎么实现这个功能： 在安装过程中弹出对话框，询问是否安装XXX，选“是”则安装，选“否”则继续装后面的内容？？？
gnatix | [第1楼] 发帖时间 2004年06月07日 12时48分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 如果说是在安装之前吧，那么软件本来就有这样的提示的。 如果说是安装过程中，那么就是按取消按钮了。 你能否说得具体一点？你想在什么时候和什么情况下要自动弹出那个对话框？ user posted image
gnatix | [第2楼] 发帖时间 2004年06月07日 12时51分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 再有： 按“是”则安装：安装什么？ 选“否”则继续装后面的内容：难道不也是安装吗？ 费解。。。 user posted image
jiangshen | [第3楼] 发帖时间 2004年06月07日 12时56分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 就是在安装过城中询问，如果是，就安装指定文件夹后继续后面的安装，选否，则直接安装后面的文件。
jiangshen | [第4楼] 发帖时间 2004年06月07日 13时03分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 这样把，能否告诉我进行选择安装，例如，安装前可选多个要安装的组件，通过打勾的方式决定安装什么
gnatix | [第5楼] 发帖时间 2004年06月07日 13时24分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 先定义组件名称，比如： [Components] Name: "installprogram"; Description: "程序文件"; Types: full custom compact; Flags: fixed Name: "installcompiler"; Description: "帮助编译器"; Types: full custom Name: "installsample"; Description: "示例文件"; Types: full custom Name: "installdictionaries"; Description: "拼写检查字典(美国英语)"; Types: full custom Name: 后面的名称你自己给的，比如 installsample。 Description: 后面的描述你自己给，比如 拼写检查字典(美国英语) 然后把要安装的文件与组件名称建立联系，比如： [Files] Source: "F:\files\sample\*.*"; DestDir: "{app}\示例"; Flags: ignoreversion recursesubdirs; components: installsample user posted image
jiangshen | [第6楼] 发帖时间 2004年06月07日 13时53分
* 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 能否＋我QQ34839249,要详细请教你
莫尼卡
[第7楼] 发帖时间 2004年06月07日 18时40分

圣骑士
* * *

组别： 认证用户
帖子数量： 217
用户编号： 4599
注册时间： 2002年08月26日

Member 离线

我来发一段组件安装的示范吧~仔细看下软件的帮助你就会找到答案了。

; 脚本用 Inno Setup 脚本向导生成。
; 查阅文档获取创建 INNO SETUP 脚本文件详细资料!

[Setup]
AppName=ePSXe
AppVerName=ePSXe 1.6.0
AppPublisher=莫尼卡
AppPublisherURL=http://wise.emuchina.net/
AppSupportURL=http://wise.emuchina.net/
AppUpdatesURL=http://wise.emuchina.net/
DefaultDirName={pf}\ePSXe
DefaultGroupName=ePSXe
AllowNoIcons=yes
InfoAfterFile=D:\new\ePSXe\请读我.txt
Compression=lzma
SolidCompression=yes
AppCopyright=版权所有 2004 Wise Studio
AppVersion=1.6.0
AppId=ePSXe
VersionInfoCompany=Wise Studio
VersionInfoVersion=0.0.0.3
UsePreviousAppDir=yes
UsePreviousGroup=yes
UsePreviousSetupType=yes
UsePreviousTasks=yes
UninstallLogMode=overwrite
Uninstallable=yes
UninstallDisplayIcon={app}\ePSXe.exe
SetupIconFile=e:\Files\Picture\ePSXe.ico

[Messages]
BeveledLabel=ePSXe 1.6.0 安装程序

[Types]
Name: "full"; Description: "完全安装"
Name: "custom"; Description: "自定义安装"; Flags: iscustom

[Components]
Name: "main"; Description: "ePSXe 1.6.0"; Types: full custom; Flags: fixed
Name: "bios"; Description: "BIOS"; Types: full custom
Name: "plugins"; Description: "插件"; Types: full custom
Name: "plugins\video"; Description: "视频插件"; Types: full custom
Name: "plugins\video\pete"; Description: "Pete's GPU 1.75"; Types: full custom
Name: "plugins\video\peops"; Description: "PE.Op.S Soft Driver 1.16"; Types: full custom
Name: "plugins\audio"; Description: "音频插件"; Types: full custom
Name: "plugins\audio\peopsa"; Description: "PE.Op.S Dsound Audio Driver 1.8"; Types: full custom
Name: "plugins\audio\eternal"; Description: "Eternal Spu 1.41"; Types: full custom
Name: "plugins\cd"; Description: "光驱插件"; Types: full custom
Name: "plugins\cd\peopscd"; Description: "PE.Op.S CDR Driver 1.4"; Types: full custom
Name: "plugins\cd\mooby"; Description: "CDR Mooby 2.8 "; Types: full custom
Name: "plugins\network"; Description: "网络插件"; Types: full custom
Name: "plugins\network\Cyberpad"; Description: "CyberPAD 1.4"; Types: full custom

[Files]
Source: "D:\new\ePSXe\ePSXe.exe"; DestDir: "{app}"; Components: main; Flags: ignoreversion
Source: "D:\new\ePSXe\请读我.txt"; DestDir: "{app}"; Components: main; Flags: ignoreversion
Source: "D:\new\ePSXe\burutter.dll"; DestDir: "{app}"; Components: main; Flags: ignoreversion
Source: "D:\new\ePSXe\cyberpad.chm"; DestDir: "{app}"; Components: plugins\network\Cyberpad; Flags: ignoreversion
Source: "D:\new\ePSXe\ePSXe.chm"; DestDir: "{app}"; Components: main; Flags: ignoreversion
Source: "D:\new\ePSXe\kailleraclient.dll"; DestDir: "{app}"; Components: plugins\network\Cyberpad; Flags: ignoreversion
Source: "D:\new\ePSXe\plugins\gpupeteD3D.dll"; DestDir: "{app}\plugins"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\gpupeteDX6D3D.dll"; DestDir: "{app}\plugins"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\gpupeteOpenGL.dll"; DestDir: "{app}\plugins"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\gpuPeopsSoft.dll"; DestDir: "{app}\plugins"; Components: plugins\video\peops; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\spuPeopsDSound.dll"; DestDir: "{app}\plugins"; Components: plugins\audio\peopsa; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\spuEternal.dll"; DestDir: "{app}\plugins"; Components: plugins\audio\eternal; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\cdrpeops.dll"; DestDir: "{app}\plugins"; Components: plugins\cd\peopscd; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\cdrmooby2.dll"; DestDir: "{app}\plugins"; Components: plugins\cd\mooby; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\cdrpeops.dll"; DestDir: "{app}\plugins"; Components: plugins\cd\peopscd; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\cpka.dll"; DestDir: "{app}\plugins"; Components: plugins\network\Cyberpad; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\bios\*"; DestDir: "{app}\bios"; Components: bios; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\cheats\*"; DestDir: "{app}\cheats"; Components: main; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\ePSXe_en.txt"; DestDir: "{app}\docs"; Components: main; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\ePSXe_sp.txt"; DestDir: "{app}\docs"; Components: main; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\gpuPeteFAQ.txt"; DestDir: "{app}\docs"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\Pete's PSX GPUs FAQ 中文翻译.txt"; DestDir: "{app}\docs"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\pete_d3d_readme_1_75.txt"; DestDir: "{app}\docs"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\pete_ogl_readme_1_75.txt"; DestDir: "{app}\docs"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\pete_ogl_d3d_version_1_75.txt"; DestDir: "{app}\docs"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\peops_soft_readme_1_16.txt"; DestDir: "{app}\docs"; Components: plugins\video\peops; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\peops_soft_version_1_16.txt"; DestDir: "{app}\docs"; Components: plugins\video\peops; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\readme_1_8.txt"; DestDir: "{app}\docs"; Components: plugins\audio\peopsa; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\version_1_8.txt"; DestDir: "{app}\docs"; Components: plugins\audio\peopsa; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\readme(e).txt"; DestDir: "{app}\docs"; Components: plugins\audio\eternal; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\notes.txt"; DestDir: "{app}\docs"; Components: plugins\cd\mooby; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\readme_1_4.txt"; DestDir: "{app}\docs"; Components: plugins\cd\peopscd; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\version_1_4.txt"; DestDir: "{app}\docs"; Components: plugins\cd\peopscd; Flags: ignoreversion recursesubdirs
; 注意: 不要在任何共享系统文件中使用“Flags: ignoreversion”

[Dirs]
Name: "{app}\memcards"; Components: main; Flags: uninsalwaysuninstall
Name: "{app}\patches"; Components: main; Flags: uninsalwaysuninstall
Name: "{app}\snap"; Components: main; Flags: uninsalwaysuninstall
Name: "{app}\sstates"; Components: main; Flags: uninsalwaysuninstall

[Tasks]
; 注意: 下面的条目包含一个中文用语 (“创建桌面快捷方式”和“添加快捷方式”)。如果需要你可以翻译为其它语言。
Name: "desktopicon"; Description: "创建桌面快捷方式"; GroupDescription: "添加快捷方式:"; Flags: unchecked

[Icons]
Name: "{group}\ePSXe"; Filename: "{app}\ePSXe.exe"; WorkingDir: "{app}"
; 注意: 下面的条目包含一个中文用语 (“卸载”)。如果需要你可以翻译为其它语言。
Name: "{group}\ePSXe 帮助"; Filename: "{app}\ePSXe.chm"; WorkingDir: "{app}"
Name: "{group}\卸载 ePSXe"; Filename: "{uninstallexe}"
Name: "{userdesktop}\ePSXe"; Filename: "{app}\ePSXe.exe"; WorkingDir: "{app}"; Tasks: desktopicon

[Run]
; 注意: 下列条目包含一个中文用语 (“运行”)。如果需要你可以翻译为其它语言。
Filename: "{app}\ePSXe.exe"; Description: "运行 ePSXe"; Flags: nowait postinstall skipifsilent

I love you! (you=emulator)

user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3053 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


还是inno setup的问题

> 还是inno setup的问题
bcff2002 | [楼主] 发帖时间 2004年06月07日 17时11分
骑士 * * 组别： 认证用户 帖子数量： 55 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 我在安装程序中，有两个安装组件，要求是：安装A则不安装B，安装B则不安装A，二者必选其一。这样的效果如何实现呢。 输入法大全 http://www.bcff2002.com
jiangshen | [第1楼] 发帖时间 2004年06月07日 17时40分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 你可以参考一下Components.iss这个脚本示例
gnatix | [第2楼] 发帖时间 2004年06月07日 19时09分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 在 [Components] 的语句中使用 Flags: exclusive 这样出来的是单选框，而不是复选框，看例子： 附图 附图 user posted image
bcff2002 | [第3楼] 发帖时间 2004年06月07日 21时01分
骑士 * * 组别： 认证用户 帖子数量： 55 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 感谢各位，问题已经解决了。 输入法大全 http://www.bcff2002.com
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3091 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


新的Inno Setup使用问题！望高手帮忙！

> 新的Inno Setup使用问题！望高手帮忙！, 谢谢了！
订阅此主题 | 邮寄此主题 | 打印此主题
zjj1988101 | [楼主] 发帖时间 2004年03月06日 16时50分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 请问对文件进行自定义安装的脚本是怎么样的？具体该怎么设置！还有就是如何设置打包好后的文件信息（就是点击该文件可以在状态栏里看见的名字版本号~大小等内容） 谢谢了！期待中！
OFA | [第1楼] 发帖时间 2004年03月06日 19时10分
天使 * * * * * * 组别： 认证用户 帖子数量： 1418 用户编号： 13575 注册时间： 2003年04月13日 Member 在线 | 请你再说具体一点。文件的自定义安装范围太广了，具体要实现什么功能？ 还有你说的文件信息是生成文件的时候就定下来的，比如生成一个100K的文件，这个信息都是固定的，不是想改就能改的。 user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
zjj1988101 | [第2楼] 发帖时间 2004年03月06日 19时20分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 我是想要就是自定义想装的文件~ 比如一个软件有各种插件再安装的时候可以选择安装哪几种插件
OFA
[第3楼] 发帖时间 2004年03月06日 20时47分

天使
* * * * * *

组别： 认证用户
帖子数量： 1418
用户编号： 13575
注册时间： 2003年04月13日

Member 在线

那叫自定义安装组件。
具体请查看 Inno Setup 帮助文件关于 [Components] section 一章的内容，里面写的很详细。

This section is optional. It defines all of the components Setup will show on the Select Components page of the wizard for setup type customization.

By itself a component does nothing: it needs to be 'linked' to other installation entries. See Components and Tasks Parameters.

Here is an example of a [Components] section:

[Components]
Name: "main"; Description: "Main Files"; Types: full compact; Flags: fixed
Name: "help"; Description: "Help Files"; Types: full
Name: "help\english"; Description: "English"; Types: full
Name: "help\dutch"; Description: "Dutch"; Types: full

The example above generates four components: A "main" component which gets installed if the end user selects a type with name "full" or "compact" and a "help" component which has two child components and only gets installed if the end user selects the "full" type.

The following is a list of the supported parameters:

Name (Required)
Description:
The internal name of the component.
The total number of \ or / characters in the name of the component is called the level of the component. Any component with a level of 1 or more is a child component. The component listed before the child component with a level of 1 less than the child component, is the parent component. Other components with the same parent component as the child component are sibling components.

A child component can't be selected if its parent component isn't selected. A parent component can't be selected if none of it child components are selected and it doesn't install anything itself.
If sibling components have the exclusive flag, only one of them can be selected.
Example:
Name: "help"
Description (Required)
Description:
The description of the component, which can include constants. This description is shown to the end user during installation.

Example:
Description: "Help Files"
Types
Description:
A space separated list of types this component belongs to. If the end user selects a type from this list, this component will be installed.
If the fixed flag isn't used (see below), any custom types (types using the iscustom flag) in this list are ignored by Setup.
Example:
Types: full compact
ExtraDiskSpaceRequired
Description:
The extra disk space required by this component, similar to the ExtraDiskSpaceRequired directive for the [Setup] section.

Example:
ExtraDiskSpaceRequired: 0
Flags
Description:
This parameter is a set of extra options. Multiple options may be used by separating them by spaces. The following options are supported:

exclusive
Instructs Setup that this component is mutually exclusive with sibling components that also have the exclusive flag.
fixed
Instructs Setup that this component can not be manually selected or unselected by the end user during installation.
restart
Instructs Setup to ask the user to restart the system if this component is installed, regardless of whether this is necessary (for example because of [Files] section entries with the restartreplace flag). Like AlwaysRestart but per component.

disablenouninstallwarning
Instructs Setup not to warn the user that this component will not be uninstalled after he/she deselected this component when it's already installed on his/her machine.
Depending on the complexity of your components, you can try to use the [InstallDelete] section and this flag to automatically 'uninstall' deselected components.

Example:
Flags: fixed

user posted image
愿为汉化事业贡献自己的一份微薄之力。
欢迎您访问我的净土 http://www.cokemouse.com
zjj1988101 | [第4楼] 发帖时间 2004年03月06日 21时13分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 知道了大致上的脚本~ 请问具体该怎么设置？
OFA | [第5楼] 发帖时间 2004年03月06日 21时26分
天使 * * * * * * 组别： 认证用户 帖子数量： 1418 用户编号： 13575 注册时间： 2003年04月13日 Member 在线 | 为什么不自己动手试试呢？ user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
zjj1988101 | [第6楼] 发帖时间 2004年03月06日 21时34分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 555技术时间都有限哦~ 那我试试看哦~555
bcff2002 | [第7楼] 发帖时间 2004年03月07日 18时26分
侠客 * 组别： 认证用户 帖子数量： 49 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 看不懂啊，我想应该有一个汉化的说明了。 输入法大全 http://www.bcff2002.com
莫名
[第8楼] 发帖时间 2004年03月07日 21时10分

天使
* * * * * *

组别： 汉化新世纪成员
帖子数量： 1322
用户编号： 1716
注册时间： 2002年04月24日

Member 离线

这个段是可选的。它定义安装程序向导的选择组件页中显示的所有组件，以便于用户定制安装类型。

光用它一个组件不会做任何事情: 它需要“链接”到其它安装条目。请查阅组件和任务参数。

这里是一个 [Components] 段的示例:

[Components]
Name: "main"; Description: "主文件"; Types: full compact; Flags: fixed
Name: "help"; Description: "帮助文件"; Types: full
Name: "help\english"; Description: "English"; Types: full
Name: "help\dutch"; Description: "简体中文"; Types: full

上面的示例生成四种组件: “main”组件在最终用户选择一个名为“full”和“compact”的类型时都将安装。带有两个子组件的“help”组件类型仅在最终用户选择“full”类型时安装。

下列是所支持的参数列表:

Name (必需)

描述:
组件的内部名字。

在组件名字中的 \ 或 / 字符合计数是调用组件的层次。任何在层次 1 或更高层次的组件是子组件。在子组件前列出的小于子组件一个层次的组件是上级组件。其它有相同上级组件的组件之间是同级组件。

如果上级组件未选定，则不能选定一个它的子组件。如果所有的子组件均未选定，则上级组件也不能选定，不会安装任何它所包含的东西。

如果同级组件已经标有 exclusive 标记，那么它们之中只有一个可选。

示例:
Name: "help"

Description (必需)

描述:
组件的描述，可以包含常量。这个描述用于在安装期间显示给最终用户参考。

示例:
Description: "帮助文件"

Types

描述:
用空格隔开所属组件的类型列表。如果最终用户从这个列表中选择了一个类型，这个组件将被安装。

如果未使用 fixed 标记 (看下面)，这个列表中的任何自定义类型 (使用 iscustom 标记的类型) 均被安装程序忽略。

示例:
Types: full compact

ExtraDiskSpaceRequired

描述:
这个组件所需要的额外磁盘空间，类似于 [Setup] 段中的 ExtraDiskSpaceRequired。

示例:
ExtraDiskSpaceRequired: 0

Flags

描述:

这个参数是额外选项设置。多个选项可以使用空格隔开。支持下面的选项:

exclusive

告诉安装程序这个组件与它的也使用 exclusive 标记的同级组件是互相排斥的。

fixed

告诉安装程序这个组件不能在安装期间被最终用户手动选择或取消选择。

restart

告诉安装程序如果用户安装了这个组件，将询问用户重新启动系统，不管它是不是需要 (例如，因为 [Files] 段条目用了 restartreplace 标记)。有点象 AlwaysRestart，但不是每个组件。

disablenouninstallwarning

如果这个组件已经安装在用户机器中，重新安装时在用户取消这个组件选择后，这条标记告诉安装程序不警告用户不卸载该组件。

考虑到你的组件的复杂性，你可以尝试使用 [InstallDelete] 段和这个标记为自动“卸载”取消选定的组件。

示例:
Flags: fixed

公共参数
bcff2002
[第9楼] 发帖时间 2004年03月08日 19时27分

侠客
*

组别： 认证用户
帖子数量： 49
用户编号： 22017
注册时间： 2004年03月06日

Member 离线

引用 (莫名 @ 2004年03月07日 21时10分)
这个段是可选的。它定义安装程序向导的选择组件页中显示的所有组件，以便于用户定制安装类型。

光用它一个组件不会做任何事情: 它需要“链接”到其它安装条目。请查阅组件和任务参数。

这里是一个 [Components] 段的示例:

[Components]
Name: "main"; Description: "主文件"; Types: full compact; Flags: fixed
Name: "help"; Description: "帮助文件"; Types: full
Name: "help\english"; Description: "English"; Types: full
Name: "help\dutch"; Description: "简体中文"; Types: full

上面的示例生成四种组件: “main”组件在最终用户选择一个名为“full”和“compact”的类型时都将安装。带有两个子组件的“help”组件类型仅在最终用户选择“full”类型时安装。

下列是所支持的参数列表:

Name (必需)

描述:
组件的内部名字。

在组件名字中的 \ 或 / 字符合计数是调用组件的层次。任何在层次 1 或更高层次的组件是子组件。在子组件前列出的小于子组件一个层次的组件是上级组件。其它有相同上级组件的组件之间是同级组件。

如果上级组件未选定，则不能选定一个它的子组件。如果所有的子组件均未选定，则上级组件也不能选定，不会安装任何它所包含的东西。

如果同级组件已经标有 exclusive 标记，那么它们之中只有一个可选。

示例:
Name: "help"

Description (必需)

描述:
组件的描述，可以包含常量。这个描述用于在安装期间显示给最终用户参考。

示例:
Description: "帮助文件"

Types

描述:
用空格隔开所属组件的类型列表。如果最终用户从这个列表中选择了一个类型，这个组件将被安装。

如果未使用 fixed 标记 (看下面)，这个列表中的任何自定义类型 (使用 iscustom 标记的类型) 均被安装程序忽略。

示例:
Types: full compact

ExtraDiskSpaceRequired

描述:
这个组件所需要的额外磁盘空间，类似于 [Setup] 段中的 ExtraDiskSpaceRequired。

示例:
ExtraDiskSpaceRequired: 0

Flags

描述:

这个参数是额外选项设置。多个选项可以使用空格隔开。支持下面的选项:

exclusive

告诉安装程序这个组件与它的也使用 exclusive 标记的同级组件是互相排斥的。

fixed

告诉安装程序这个组件不能在安装期间被最终用户手动选择或取消选择。

restart

告诉安装程序如果用户安装了这个组件，将询问用户重新启动系统，不管它是不是需要 (例如，因为 [Files] 段条目用了 restartreplace 标记)。有点象 AlwaysRestart，但不是每个组件。

disablenouninstallwarning

如果这个组件已经安装在用户机器中，重新安装时在用户取消这个组件选择后，这条标记告诉安装程序不警告用户不卸载该组件。

考虑到你的组件的复杂性，你可以尝试使用 [InstallDelete] 段和这个标记为自动“卸载”取消选定的组件。

示例:
Flags: fixed

公共参数

请问如何链接呢。

输入法大全
http://www.bcff2002.com
bcff2002 | [第10楼] 发帖时间 2004年03月10日 06时15分
侠客 * 组别： 认证用户 帖子数量： 49 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | dd 输入法大全 http://www.bcff2002.com
大番茄 | [第11楼] 发帖时间 2004年03月10日 19时32分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 建议配合ISTOOL和7ZIP使用 这会更方便! 番茄花园: http://tomatolei.com
bcff2002
[第12楼] 发帖时间 2004年03月12日 16时27分

侠客
*

组别： 认证用户
帖子数量： 49
用户编号： 22017
注册时间： 2004年03月06日

Member 离线

引用 (大番茄 @ 2004年03月10日 19时32分)
建议配合ISTOOL和7ZIP使用
这会更方便!

能不能给一个具体的例子呢。

输入法大全
http://www.bcff2002.com
bcff2002
[第13楼] 发帖时间 2004年03月12日 16时39分

侠客
*

组别： 认证用户
帖子数量： 49
用户编号： 22017
注册时间： 2004年03月06日

Member 离线

;ebinst.iss;;;

[Setup]
DisableProgramGroupPage=true
AppendDefaultDirName=yes
SetupIconFile=jd.ico
Compression=lzma
AppName=二笔
AppVerName=二笔输入法
PrivilegesRequired=admin
CreateAppDir=true
DefaultGroupName=二笔
DefaultDirName={pf}\极点二笔
InfoBeforeFile=license.txt
DisableFinishedPage=true
UsePreviousUserInfo=false
UserInfoPage=false
DefaultUserInfoSerial=123456789
RestartIfNeededByRun=false
ShowLanguageDialog=false
AlwaysShowComponentsList=false
[Languages]
Name: chs; Messagesfile: Simple Chinese.isl

[Files]
Source: Program Files\freewb\*.*; DestDir: {app}
Source: Program Files\freewb\skin\*.*; DestDir: {app}\skin
Source: Program Files\freewb\mb\二笔标版\*.*; DestDir: {app}\mb\二笔标版
Source: Program Files\freewb\mb\default\*.*; DestDir: {app}\mb\default
Source: Program Files\freewb\background\*.*; DestDir: {app}\background
;Source: freewbcode.dll; DestDir: {sys}; MinVersion: 4.0.950,0; Flags: restartreplace
Source: 极点说明.chm; DestDir: {group}; Flags: restartreplace
Source: 二笔说明.chm; DestDir: {group}; Flags: restartreplace
;Source: freewbcode.dll; DestDir: {sys}; MinVersion: 0,4.0.1381; Flags: restartreplace; Attribs: hidden
;Source: xp\freewb.dll; DestDir: {app}; MinVersion: 0,4.0.1381; Flags: restartreplace
;Source: 98\freewb.dll; DestDir: {app}; MinVersion: 4.0.950,0; Flags: restartreplace
Source: Program Files\freewb\极点设置.exe; DestDir: {group}; Flags: restartreplace

[Messages]
WelcomeLabel1=&raquo;&para;&Oacute;&shy;&Ecirc;&sup1;&Oacute;&Atilde; &frac14;&laquo;&micro;&atilde;&Ouml;&ETH;&Icirc;&Auml;----&Ccedil;à&Euml;&Eacute;&para;&thorn;±&Ecirc; °&sup2;×°&Iuml;ò&micro;&frac14;
WelcomeLabel2=±&frac34;&sup3;&Igrave;&ETH;ò&frac12;&laquo;&Ocirc;&Uacute;&Auml;&atilde;&micro;&Auml;&frac14;&AElig;&Euml;&atilde;&raquo;ú&Eacute;&Iuml;°&sup2;×°&pound;&ordm;%n%n[name/ver]&iexcl;&pound;%n%n&Iacute;&AElig;&frac14;&ouml;&Auml;&atilde;&Ocirc;&Uacute;&frac14;&Igrave;&ETH;&oslash;&Ouml;&reg;&Ccedil;°&Iuml;&Egrave;&sup1;&Oslash;±&Otilde;&Euml;ù&Oacute;&ETH;&AElig;&auml;&Euml;ü&micro;&Auml;&sup3;&Igrave;&ETH;ò&iexcl;&pound;

[Icons]
Name: {group}\卸载极点二笔; Filename: {uninstallexe}; WorkingDir: {app}
[Code]
function ImmInstallIME(lpszIMEFileName, lpszLayoutText: String): LongInt;
external 'ImmInstallIMEA@imm32.dll stdcall';

procedure CurStepChanged(CurStep: Integer);
begin
if CurStep = csFinished then
begin
ImmInstallIME(expandConstant('{sys}\Freewb.IME'),'极点中文输入法')
end;
end;
[Run]
Filename: {app}\registry.exe
[UninstallDelete]
Type: files; Name: {sys}\freewb.ime

在上面的安装程序中，我想让程序出现选装 1极点说明.chm和2二笔说明.chm和3极点设置.exe怎么才能做到呢。

输入法大全
http://www.bcff2002.com
bcff2002 | [第14楼] 发帖时间 2004年03月12日 19时05分
侠客 * 组别： 认证用户 帖子数量： 49 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | ddddd 输入法大全 http://www.bcff2002.com
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项
下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3253 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


innosetup的组件能不能收起来？

> innosetup的组件能不能收起来？
订阅此主题 | 邮寄此主题 | 打印此主题
ppppppp | [楼主] 发帖时间 2004年07月23日 17时11分
侠客 * 组别： 用户 帖子数量： 20 用户编号： 20157 注册时间： 2004年01月03日 Member 离线 | innosetup做的安装程序的组件好像都是展开的，能不能收起来？如NSIS一样。
pk4321 | [第1楼] 发帖时间 2004年07月23日 20时45分
圣骑士 * * * 组别： 认证用户 帖子数量： 170 用户编号： 770 注册时间： 2002年01月10日 Member 离线 | 想树型展开的就没有，但是不可展开的层次型的就有（如图）。 设置方法（例）： [Components] Name: fix; Description: 必装控件; Types: full mini custom; Flags: fixed Name: fix\COMCTL; Description: ComCtl -- 系统常用公共控件; Types: full mini custom; Flags: fixed Name: fix\COMDLG; Description: ComDlg -- 通用对话框控件; Types: full mini custom; Flags: fixed Name: fix\FLXGRD; Description: FlexGrid -- 简易的灵活表格控件; Types: full mini custom; Flags: fixed 附图 附图
ppppppp | [第2楼] 发帖时间 2004年07月23日 22时27分
侠客 * 组别： 用户 帖子数量： 20 用户编号： 20157 注册时间： 2004年01月03日 Member 离线 | 我希望是做成默认是不展开的，因为组件太多了，如果展开的话会挡住一些选项。点击后才展开。如图。 附图 附图
leyan22
[第3楼] 发帖时间 2004年07月25日 17时10分

骑士
* *

组别： 认证用户
帖子数量： 51
用户编号： 24384
注册时间： 2004年05月06日

Member 离线

引用 (ppppppp @ 2004年07月23日 22时27分)
我希望是做成默认是不展开的，因为组件太多了，如果展开的话会挡住一些选项。点击后才展开。如图。

小弟不才 ，但这个是NSIS做的吧

INNO我也只知道能象第一副图那样

gnatix | [第4楼] 发帖时间 2004年07月25日 17时40分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | Inno 的组件列表不能做成折叠的，也没法通过代码改变。 user posted image
ppppppp | [第5楼] 发帖时间 2004年07月25日 22时04分
侠客 * 组别： 用户 帖子数量： 20 用户编号： 20157 注册时间： 2004年01月03日 Member 离线 | 哦，知道了。谢谢各位的回复！ 我第二楼贴的图是NSIS做的。
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3067 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


Inno Setup 变量的问题

> Inno Setup 变量的问题
莫尼卡 | [楼主] 发帖时间 2004年07月29日 10时01分
圣骑士 * * * 组别： 认证用户 帖子数量： 246 用户编号： 4599 注册时间： 2002年08月26日 Member 离线 | 如果我要把文件复制到系统的安装目录的 System、System32 下要怎么写。是 {sys} 就可以了吗？ I love you! (you=emulator) user posted image
gnatix | [第1楼] 发帖时间 2004年07月29日 13时57分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 是的。 user posted image
pk4321 | [第2楼] 发帖时间 2004年07月31日 10时39分
圣骑士 * * * 组别： 认证用户 帖子数量： 170 用户编号： 770 注册时间： 2002年01月10日 Member 离线 | 我想问一下： 安装脚本中定义了一些的组件，还加了任务想让用户选择将组件安装在系统目录还是程序目录。 目前的实现方法是在脚本中将所有的组件文件复制一次，然后再设置不同的任务。 但是这样在选择安装组件页面时，又显示不出组件的大小。有没有更好的解决办法？ 另外，有人知道如何将安装目录变量{app}中的“\”改成“\\”吗？ 我用下面代码出错了！ [Code] function strAppx(Default: String): String; begin Result :=StringChange( ExpandConstant('{app}') , '\' , '\\' ); end; 还有一点感觉是，如果觉得用InnoSetup的脚本不好实现的东西，可以试试结合Wise 9.02来做。
gnatix
[第3楼] 发帖时间 2004年07月31日 13时40分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用
安装脚本中定义了一些的组件，还加了任务想让用户选择将组件安装在系统目录还是程序目录。
目前的实现方法是在脚本中将所有的组件文件复制一次，然后再设置不同的任务。
但是这样在选择安装组件页面时，又显示不出组件的大小。有没有更好的解决办法？

试试这样：
先将那些文件安装到临时文件夹，然后根据用户的选择再将这些文件复制到程序文件夹或者系统文件夹。
在下面的示例脚本中，如果用户选择了组件“库文件”，将让用户选择是将库文件安装到程序目录还是系统目录。最后根据用户的选择将这些库文件复制到相当的目标。

代码
; 示例脚本 made by gnatix

[Setup]
AppName=test001
AppVerName=test001
DefaultDirName={pf}\test001
DefaultGroupName=test001

[Types]
Name: "full"; Description: "完全安装"; Flags: iscustom
Name: "compact"; Description: "精简安装"
Name: "custom"; Description: "自定义安装"

[Components]
Name: "program"; Description: "主文件（必需）"; Types: full compact custom; Flags: fixed
Name: "manual"; Description: "使用手册"; Types: full compact custom
Name: "sound"; Description: "媒体文件"; Types: full custom
Name: "dll"; Description: "运行库文件"; Types: full custom

[Files]
Source: "C:\test\prog\*.*"; DestDir: "{app}"; Flags: ignoreversion; Components: program
Source: "C:\test\manual\*.*"; DestDir: "{app}"; Flags: ignoreversion; Components: manual
Source: "C:\test\sound\*.*"; DestDir: "{app}\sound"; Flags: ignoreversion; Components: sound
Source: "C:\test\dll\abc.dll"; DestDir: "{tmp}"; Flags: ignoreversion; Components: dll

[Tasks]
Name: "dlltowhere/app"; Description: "程序文件夹"; GroupDescription: "你想要将库文件安装到哪里？"; Flags: exclusive; Components: dll
Name: "dlltowhere/sys"; Description: "系统文件夹"; GroupDescription: "你想要将库文件安装到哪里？"; Flags: unchecked exclusive; Components: dll

[Run]
Filename: "{cmd}"; Parameters: "/c copy ""{tmp}\abc.dll"" ""{app}"""; Description: "复制文件"; Flags: nowait hidewizard runhidden; Tasks: "dlltowhere/app"
Filename: "{cmd}"; Parameters: "/c copy ""{tmp}\abc.dll"" ""{sys}"""; Description: "复制文件"; Flags: nowait hidewizard runhidden; Tasks: "dlltowhere/sys"

user posted image
gnatix
[第4楼] 发帖时间 2004年07月31日 13时50分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用
另外，有人知道如何将安装目录变量{app}中的“\”改成“\\”吗？
我用下面代码出错了！
[Code]
function strAppx(Default: String): String;
begin
Result :=StringChange( ExpandConstant('{app}') , '\' , '\\' );
end;

函数 StringChange(XXX, '\', '\\') 中的 XXX 必须是一个变量，因为它要保存修改后的结果。你现在放入的是一个常量（固定不变的东西），所以出错。

改成这样就没有问题了：
function strAppx(Default: String): String;
begin
Result := ExpandConstant('{app}');
StringChange(Result, '\' , '\\' );
end;

user posted image
pk4321
[第5楼] 发帖时间 2004年07月31日 16时52分

圣骑士
* * *

组别： 认证用户
帖子数量： 170
用户编号： 770
注册时间： 2002年01月10日

Member 离线

引用 (gnatix @ 2004年07月31日 13时40分)
试试这样：
先将那些文件安装到临时文件夹，然后根据用户的选择再将这些文件复制到程序文件夹或者系统文件夹。
在下面的示例脚本中，如果用户选择了组件“库文件”，将让用户选择是将库文件安装到程序目录还是系统目录。最后根据用户的选择将这些库文件复制到相当的目标。

这样还是解决得不够好，如果要安装的文件比较多，这样通过tmp来中转会浪费比较多的时间，而且占用更多的临时空间。

看看能不能通过类似下面的方法来做：
[Tasks]
Name: inapp; Description: 安装在程序目录; Flags: exclusive
Name: insys; Description: 安装在系统目录; Flags: exclusive

[Files]
...
Source: OCX\COMCTL32.OCX; DestDir: {code:usrSelDir|{sys}}; Flags: regserver; Components: oth\ComCtl32;
...

[code]
function usrSelDir(Default: String): String;
begin
if then //“用户选择的Tasks为inapp”的条件语句什么写？
Result :=ExpandConstant('{app}');
else
Result :=ExpandConstant('{sys}');
end;

gnatix | [第6楼] 发帖时间 2004年07月31日 17时35分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 用 Code 代码，实现的可能性当然就多了。 调用函数 WizardSelectedTasks(false) 可以获取用户选择的安装任务。所以你上面的代码可以是： function usrSelDir(Default: String): String; begin if Pos('inapp',WizardSelectedTasks(false))>0 then Result := ExpandConstant('{app}') else Result :=ExpandConstant('{sys}'); end; user posted image
pk4321
[第7楼] 发帖时间 2004年07月31日 19时52分

圣骑士
* * *

组别： 认证用户
帖子数量： 170
用户编号： 770
注册时间： 2002年01月10日

Member 离线

引用 (gnatix @ 2004年07月31日 17时35分)
用 Code 代码，实现的可能性当然就多了。
调用函数 WizardSelectedTasks(false) 可以获取用户选择的安装任务。所以你上面的代码可以是：
function usrSelDir(Default: String): String;
begin
if Pos('inapp',WizardSelectedTasks(false))>0 then
Result := ExpandConstant('{app}')
else
Result :=ExpandConstant('{sys}');
end;

多心赐教！

不嫌弃的话，试试我制作的“VB6精装版”！

12M
http://powerkit.vicp.net/vb6expr.exe
leyan22 | [第8楼] 发帖时间 2004年08月01日 22时36分
骑士 * * 组别： 认证用户 帖子数量： 51 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | VB6 还不错！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3137 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


请问怎样可以让Inno Setup只是在指定目录里添加文件而不会有相关的卸载程序

> 请问怎样可以让Inno Setup只是在指定目录里添加文件而不会有相关的卸载程序
雷骏 | [楼主] 发帖时间 2002年09月20日 21时26分
天使 * * * * * * 组别： 认证用户 帖子数量： 1343 用户编号： 2835 注册时间： 2002年06月12日 Member 离线 | 请问怎样可以让Inno Setup只是在指定目录里添加文件而不会有相关的卸载程序？ 也就是炎之川做的汉化补丁那种！谢谢！ user posted image user posted image user posted image user posted image
炎之川 | [第1楼] 发帖时间 2002年09月20日 22时45分
最近比较烦哪！ * * * * * * * * 组别： 管理员 帖子数量： 6095 用户编号： 3 注册时间： 2001年06月15日 Member 离线 | [Setup] AlwaysCreateUninstallIcon=no Uninstallable=no 看看帮助文件吧!只要找关于"Uninstall"的项目看,即使帮助文件全是英文有什么困难的啊? user posted image 访问 炎之川的blog
雷骏 | [第2楼] 发帖时间 2002年09月21日 12时44分
天使 * * * * * * 组别： 认证用户 帖子数量： 1343 用户编号： 2835 注册时间： 2002年06月12日 Member 离线 | 谢谢！这下Inno Setup的全部功能都会了！ user posted image user posted image user posted image user posted image
kukuasir | [第3楼] 发帖时间 2002年09月21日 13时57分
精灵王 * * * * 组别： 认证用户 帖子数量： 404 用户编号： 4732 注册时间： 2002年08月30日 Member 离线 | 其实它的帮助文件比NSIS简单易懂多了~！ NSIS要是没实例，恐怕我一点都都看不懂~！太乱了，一点条理都没有~！ 你酷,你酷,你喝水在水库,睡觉在古墓,嘴里流瀑布,四肢像枕木,你当你是貂禅吕布,其实你是南极土著
雷骏 | [第4楼] 发帖时间 2002年09月21日 16时49分
天使 * * * * * * 组别： 认证用户 帖子数量： 1343 用户编号： 2835 注册时间： 2002年06月12日 Member 离线 | 也就是！我现在还没弄懂！过一阵子仔细研究！ user posted image user posted image user posted image user posted image
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3277 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


【求助】WISE 及 INNOSETUP 的相关问题

> 【求助】WISE 及 INNOSETUP 的相关问题
trillium | [楼主] 发帖时间 2003年12月24日 11时31分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 3152 注册时间： 2002年06月29日 Member 离线 | 关于WISE：（9.02 汉化版） WISE制作的安装程序如果在 SYSTEM 目录中添加了文件，卸载时好像无法删除这些文件？ 关于InnoSetup：（4.08） 如果在已有的INI文件中添加了某键，卸载时无法删除该键，只能删除其所在区段或INI文件？ 另外，INNO如何搜索注册表，并将搜索到的信息作为安装路径（不限于同种软件的不同版本）？ 望高手赐教，谢谢
大番茄 | [第1楼] 发帖时间 2003年12月24日 14时43分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | WISE：（9.02 汉化版） 1. 如何可以在开始程序菜单中添加卸载的快捷方式? 2. 在安装程序打开的时候,如何插入声音呢? 番茄花园: http://tomatolei.com
mimizero | [第2楼] 发帖时间 2003年12月24日 20时58分
版主 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1376 用户编号： 995 注册时间： 2002年02月10日 Member 离线 | InnoSetup 问题： Inno 卸载时可以卸载 INI 中的键值，在脚本的键值后面加上 Flags: uninsdeleteentry 就可以，最简单的方法就是用 ISTool 编辑脚本，里面有这个功能。 精品路线，会汉化的猫哟～～！
trillium | [第3楼] 发帖时间 2003年12月25日 13时10分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 3152 注册时间： 2002年06月29日 Member 离线 | 谢谢 mimizero 另外，二楼朋友请看这里： 附图 附图
大番茄 | [第4楼] 发帖时间 2003年12月27日 08时28分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | OK 多谢~! 还有一个问题 怎么才可以在安装程序中插入声音 只要一打开出现图片的时候有声音! 我看里面有插入 AVI,我试过可以插入WAV的声音 但是我想在一开始出现WISE的时候插入声音~! 希望高手指教~! 番茄花园: http://tomatolei.com
大番茄 | [第5楼] 发帖时间 2003年12月27日 08时47分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 我用的是wise 9.02 楼上说的那个卸载的快捷方式我实在找不到 可以不可以说的详细一点! 番茄花园: http://tomatolei.com
trillium | [第6楼] 发帖时间 2003年12月29日 08时17分
侠客 * 组别： 用户 帖子数量： 26 用户编号： 3152 注册时间： 2002年06月29日 Member 离线 | 楼上的： 1、切换到脚本编辑器，向导循环，以欢迎屏幕为例： user posted image 看不到图片请点这里 2、还是在脚本编辑器，双击“创建快捷方式”不就行了？ user posted image 若看不到图片请点击这里 创建快捷方式时以我发的上张图片作参考
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3341 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


用 InnoSetup 能否在运行卸载程序前显示弹出式消息？

> 用 InnoSetup 能否在运行卸载程序前显示弹出式消息？
订阅此主题 | 邮寄此主题 | 打印此主题
OFA | [楼主] 发帖时间 2004年05月24日 05时33分
天使 * * * * * * 组别： 认证用户 帖子数量： 1443 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | 用 InnoSetup 能否在运行卸载程序前显示弹出式消息？ user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
gnatix | [第1楼] 发帖时间 2004年05月24日 12时41分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2693 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 标准弹出式消息是这个。你当然可以添加和修改文字。 附图 附图 user posted image
OFA | [第2楼] 发帖时间 2004年05月24日 12时50分
天使 * * * * * * 组别： 认证用户 帖子数量： 1443 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | 我想在显示这个对话框前弹出另一个警告对话框。 好比可以用 [Code] procedure InitializeWizard(); begin msgbox () end; 可以在开始安装前显示一个对话框。 不知道卸载时能否也能实现。 user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
gnatix | [第3楼] 发帖时间 2004年05月24日 12时53分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2693 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 这是稍许个性化了一点的：） 附图 附图 user posted image
gnatix | [第4楼] 发帖时间 2004年05月24日 12时56分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2693 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 我认为你完全可以把警告文字放到上面的对话框中，没有必要另外打开一个窗口。 user posted image
OFA | [第5楼] 发帖时间 2004年05月24日 13时09分
天使 * * * * * * 组别： 认证用户 帖子数量： 1443 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | 因为很多人在卸载程序的时候并不看提示(比如我)，所以我想加一个警告对话框防止不正确的卸载行为——因为如果不按规定的步骤卸载，将可能导致系统异常。 user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
bcff2002
[第6楼] 发帖时间 2004年05月24日 13时25分

骑士
* *

组别： 认证用户
帖子数量： 55
用户编号： 22017
注册时间： 2004年03月06日

Member 离线

引用 (gnatix @ 2004年05月24日 12时53分)
这是稍许个性化了一点的：）

如何做呢?

输入法大全
http://www.bcff2002.com
gnatix
[第7楼] 发帖时间 2004年05月24日 13时34分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2693
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (bcff2002 @ 2004年05月24日 13时25分)
引用 (gnatix @ 2004年05月24日 12时53分)
这是稍许个性化了一点的：）

如何做呢?

把 Default.isl 文件根据自己的需要修改一下就行了。

附图
附图

user posted image
bcff2002 | [第8楼] 发帖时间 2004年05月24日 21时30分
骑士 * * 组别： 认证用户 帖子数量： 55 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 谢谢 输入法大全 http://www.bcff2002.com
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.5159 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


inno setup的安装程序有什么方法可以在卸载时候保留某个文件呢?

> inno setup的安装程序有什么方法可以在卸载时候保留某个文件呢?
订阅此主题 | 邮寄此主题 | 打印此主题
大番茄 | [楼主] 发帖时间 2004年03月10日 20时27分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | inno setup的安装程序 有什么方法可以在卸载时候保留某个文件呢? ============================== 比如,安装一个程序,在system32也需要安装一些DLL文件,但是某一些DLL文件其他的程序也需要使用! 所以想让inno setup卸载时候能保留自定义的文件! 请问有方法吗? 番茄花园: http://tomatolei.com
gnatix | [第1楼] 发帖时间 2004年03月10日 20时42分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 比如： [Files] Source: "CTL3DV2.DLL"; DestDir: "{sys}"; Flags: onlyifdoesntexist uninsneveruninstall onlyifdoesntexist 表示只有当系统中没有这个文件时才安装这个文件 uninsneveruninstall 表示卸载时不卸载这个文件 不是说这两个参数一定要同时使用哦。 这个帖子已被 gnatix 于 2004年03月11日 01时45分 编辑 user posted image
softsword | [第2楼] 发帖时间 2004年03月10日 21时04分
精灵王 * * * * 组别： 认证用户 帖子数量： 356 用户编号： 17697 注册时间： 2003年09月28日 Member 离线 | 你用 IsTool 试试看，他有个“从不卸载”的选项，轻轻松松搞定。 夏天来了，天气热了，一群“BT”往北飞，一会儿排成“B”字，一会儿排成“T”字 …… user posted image 孔子东游，遇二小儿辩斗，问其故。 一小儿曰：我以日本生自山东，故属东。 一小儿曰：夕阳西下，日本归山西也明矣，是以属西。 孔子不能决，后以问老子（本人也）。 老子笑曰：孰为汝多知乎？日本无根基，岂能算东西 ！ user posted image
大番茄 | [第3楼] 发帖时间 2004年03月11日 16时48分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 谢谢楼上的2位 我知道了! 番茄花园: http://tomatolei.com
咦？ | [第4楼] 发帖时间 2004年03月11日 18时14分
精灵王 * * * * 组别： 认证用户 帖子数量： 281 用户编号： 16442 注册时间： 2003年07月31日 Member 离线 | 你的主题有新的了么？？？ 俺是以前的虎皮鲨！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.8320 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


Inno Setup卸载识别错误——求助高手

> Inno Setup卸载识别错误——求助高手
jiangshen | [楼主] 发帖时间 2004年06月20日 00时16分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 我的机器里有2个Inno Setup安装的软件，但是我在卸载其中一个软件的时候，他自动的把另一个也卸载了，请问怎样能加入准确识别卸载？？？
gnatix | [第1楼] 发帖时间 2004年06月20日 00时52分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 如果两个软件使用的是同一个 AppName 和 AppID，那么在注册表中只有同一个卸载记录，卸载一次就没有了。 所以用 Inno Setup 制作安装程序时，最好把版本号也添加到 AppName 中，或者特别指定一个不同的 AppID。 user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.2848 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


Inno Setup 安装程序文件提取工具。

> Inno Setup 安装程序文件提取工具。, 在看雪找到的。这个东东应该有用吧。
订阅此主题 | 邮寄此主题 | 打印此主题
刘波 | [楼主] 发帖时间 2004年03月05日 07时05分
版主 * * * * * 组别： 认证用户 帖子数量： 623 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 用法在里面的网页说明文件中。 附件 ( 下载次数: 172 ) 附件 innounp004.rar 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
OFA | [第1楼] 发帖时间 2004年03月05日 09时58分
天使 * * * * * * 组别： 认证用户 帖子数量： 1417 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | 不错。主要一个好处是可以监视安装程序往系统中写入了哪些文件，而在重新封装的时候不至于遗漏任何文件。 user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
youth9999 | [第2楼] 发帖时间 2004年03月06日 11时58分
侠客 * 组别： 用户 帖子数量： 18 用户编号： 19572 注册时间： 2003年12月10日 Member 离线 | 非常感谢，我急需要这东东~~
Ainuo | [第3楼] 发帖时间 2004年03月08日 03时56分
新手上路 * 组别： 用户 帖子数量： 6 用户编号： 18168 注册时间： 2003年10月15日 Member 离线 | 感谢，很好的东西！
liangjh | [第4楼] 发帖时间 2004年03月10日 16时51分
精灵王 * * * * 组别： 认证用户 帖子数量： 299 用户编号： 11213 注册时间： 2003年02月19日 Member 离线 | 大概对有些inno文件不行，我现在使用wise重新封包，很爽很爽 一尘不染，两袖清风！
ah47sm | [第5楼] 发帖时间 2004年03月12日 19时05分
圣骑士 * * * 组别： 认证用户 帖子数量： 113 用户编号： 15774 注册时间： 2003年07月01日 Member 离线 | 现在 Innoup 已经更新到 v0.06 了，增加了一些新功能 >>> Welcome to My Website China Serials 2000 <<<
mapeng | [第6楼] 发帖时间 2004年03月14日 04时02分
精灵王 * * * * 组别： 认证用户 帖子数量： 297 用户编号： 19595 注册时间： 2003年12月11日 Member 离线 | 请问各位大侠这个怎么用~~~我到作者主页上下载到了Innoup0.06一并送上 附件 ( 下载次数: 63 ) 附件 Innoup0.06.rar 我的外表很传统,我的内心很反叛;我的行动很规矩,我的思想却激进;我的语言很尖刻,我的性情很温柔;我的眼光很挑剔,我的能力却有限;我的理想很伟大,我的现状很平凡;我的头脑很灵活,我的双手却笨拙;我的睡眠很踏实,我的美梦很有限;我的长相很酷毙,我的女友却没影。 user posted image
gnatix | [第7楼] 发帖时间 2004年03月14日 04时40分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 程序的用法 该程序目前还没有图形界面，必须以命令行的方式运行。 这是命令行参数： innounp [命令] [选项] <安装文件> [@文件列表] [文件过滤 ...] 命令: -i 显示各种非文件类信息 (默认) -l 列出安装文件中的文件 -v 详细地列出文件 (包括文件大小和时间戳) -x 将文件从安装文件中解压到目前的目录 -e 解压文件（同上），但是不包括路径 选项: -q 解压时不显示进展 -m 解压内嵌的文件 (比如 decompressor.dll 和 uninstall.exe) 安装文件： 用 Inno Setup 所制作的安装程序文件，通常是 setup.exe。目前支持到 4.18 的版本。 @文件列表： 文件列表是一个文本文件，里面列出了一系列的文件名称。如果这个参数存在，那么操作只限于该列表文件中所列出来的文件。 文件过滤： 可以使用通配符来指定操作中只考虑某些文件，比如 *.exe *.dll *.txt。 示例 1： innounp -v mysetup.exe 显示 mysetup.exe 中的文件信息（详细模式） 示例 2： innounp -x mysetup.exe *.exe 将 mysetup.exe 中的所有可执行文件解压到目前的目录中 附图 附图 user posted image
suny32 | [第8楼] 发帖时间 2004年03月15日 04时40分
侠客 * 组别： 用户 帖子数量： 38 用户编号： 21714 注册时间： 2004年02月27日 Member 离线 | 我得好好向你们学。
mapeng | [第9楼] 发帖时间 2004年03月15日 19时10分
精灵王 * * * * 组别： 认证用户 帖子数量： 297 用户编号： 19595 注册时间： 2003年12月11日 Member 离线 | 谢谢 gnatix斑竹的耐心解答~~~今天才看到你写的Innoup0.06教程~~~我正在学习中，太谢谢你了~！ 我的外表很传统,我的内心很反叛;我的行动很规矩,我的思想却激进;我的语言很尖刻,我的性情很温柔;我的眼光很挑剔,我的能力却有限;我的理想很伟大,我的现状很平凡;我的头脑很灵活,我的双手却笨拙;我的睡眠很踏实,我的美梦很有限;我的长相很酷毙,我的女友却没影。 user posted image
ah47sm | [第10楼] 发帖时间 2004年03月20日 10时11分
圣骑士 * * * 组别： 认证用户 帖子数量： 113 用户编号： 15774 注册时间： 2003年07月01日 Member 离线 | Innounp New Version 0.07 (2004.03.16) : What's New in v0.07: Multiple files with the same name are not overwritten now, instead they are appended with numbers. -c command extracts the compiled Innerfuse Pascal Script code to a file. It can then be 'disassembled' with a separate tool. Get one on the download page. The output of -i option now looks more like .iss script. More data is included. >>> Welcome to My Website China Serials 2000 <<<
ah47sm | [第11楼] 发帖时间 2004年03月20日 10时14分
圣骑士 * * * 组别： 认证用户 帖子数量： 113 用户编号： 15774 注册时间： 2003年07月01日 Member 离线 | Innounp 0.07 下载，刚才发上贴时忘记上传附件了，现在补上 [image] ： 附件 ( 下载次数: 32 ) 附件 innounp007.rar >>> Welcome to My Website China Serials 2000 <<<
gnatix | [第12楼] 发帖时间 2004年03月20日 15时20分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 程序的用法 (版本 0.07) 该程序目前还没有图形界面，必须以命令行的方式运行。 这是命令行参数： innounp [命令] [选项] <安装文件> [@文件列表] [文件过滤 ...] 命令: -i 显示各种非文件类信息 (默认) -c文件名 将编译过的 Pascal 脚本代码写入到一个文件 (新功能) -l 列出安装文件中的文件 -v 详细地列出文件 (包括文件大小和时间戳) -x 将文件从安装文件中解压到目前的目录 -e 解压文件（同上），但是不包括路径 选项: -q 解压时不显示进展 -m 解压内嵌的文件 (比如 decompressor.dll 和 uninstall.exe) 安装文件： 用 Inno Setup 所制作的安装程序文件，通常是 setup.exe。目前支持到 4.18 的版本。 @文件列表： 文件列表是一个文本文件，里面列出了一系列的文件名称。如果这个参数存在，那么操作只限于该列表文件中所列出来的文件。 文件过滤： 可以使用通配符来指定操作中只考虑某些文件，比如 *.exe *.dll *.txt。 示例 1： innounp -v mysetup.exe 显示 mysetup.exe 中的文件信息（详细模式） 示例 2： innounp -x mysetup.exe *.exe 将 mysetup.exe 中的所有可执行文件解压到目前的目录中 user posted image
ah47sm
[第13楼] 发帖时间 2004年04月16日 11时40分

圣骑士
* * *

组别： 认证用户
帖子数量： 113
用户编号： 15774
注册时间： 2003年07月01日

Member 离线

New! Innounp version 0.08 [2004/04/14]

What's new v0.08
引用
Added support for IS version up to 4.2.1.
Added MultiArc settings for Total Commander (thanks to Gnozal).
Fixed a bug in MultiArc settings that prevented shells from displaying file dates and times (thanks to Maxim Ryazanov).
The reconstructed setup script (.iss) is now included together with the 'normal' files. Using -m option it's possible to view/extract other internal files in the same way.

附件 ( 下载次数: 21 )
附件 innounp008.rar
>>> Welcome to My Website China Serials 2000 <<<
? 上一个主题 | 汉化工具 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3882 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


关于 INNO 公共参数

> 关于 INNO 公共参数
做人要厚道 | [楼主] 发帖时间 2004年07月03日 17时30分
侠客 * 组别： 用户 帖子数量： 11 用户编号： 27472 注册时间： 2004年07月03日 Member 离线 | 示例: MinVersion: 4.0,4.0 4.0在前在后有什么区别? 通过ISTool猜测，应分别为最小Win版本，最小WinNT版本 [setup] MinVersion=4.1.1998,4.0.1381 OnlyBelowVersion=4.1.2222,5.0.2195sp3 为何9x下不能安装？提示要高于2K版本。 Source: NT\WINx.IME; DestDir: {sys}; MinVersion: 0,4.0.1381; OnlyBelowVersion: 0,4.0.1381sp6; Flags: restartreplace; 为何NT4下不复制文件？ 这样写有什么错？是不是理解上有误差？
王原 | [第1楼] 发帖时间 2004年07月04日 00时35分
骑士 * * 组别： 认证用户 帖子数量： 92 用户编号： 126 注册时间： 2001年07月15日 Member 离线 | 摘自Inno帮助文件： OnlyBelowVersion For example, if you put 4.1,5.0 and the user is running Windows 95 or NT 4.0 the entry will be processed, but if the user is running Windows 98 (which reports its version as 4.1) or Windows 2000 (which reports its version as NT 5.0), it will not be processed. Putting "0" for one of the versions means there is no upper version limit. 也就是说，实际进行比较的时候是要小于OnlyBelowVersion的，而不是小于等于。
做人要厚道 | [第2楼] 发帖时间 2004年07月04日 02时25分
侠客 * 组别： 用户 帖子数量： 11 用户编号： 27472 注册时间： 2004年07月03日 Member 离线 | 发完帖回去试了多遍，基本猜到，下午已修改。 全是以下教程闹的！引用如下： [Setup]: OnlyBelowVersion 格式： a.bb,c.dd, 这里的 a.bb 是表示 Windows 的版本，c.dd 是表示 Windows NT 的版本。 默认： 0,0 说明： 该关键字让你指定不能运行你的软件的最低的 Windows 或 Windows NT 的版本（亦即高于此版本则无法运行）。指定 0 为其中之一的版本的意思是没有版本上限。版本创建编号（Build numbers）和（或）服务包级别（service pack levels）可以被包括在版本号中。 该关键字实际上是和 MinVersion 恰好相反。
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.5543 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


ISTool Pro 4.2.4

> ISTool Pro 4.2.4, 汉化并集成InnoSetup的安装制作工具
pk4321 | [楼主] 发帖时间 2004年06月23日 19时06分
圣骑士 * * * 组别： 认证用户 帖子数量： 170 用户编号： 770 注册时间： 2002年01月10日 Member 离线 | 本安装包的ISTool主程序是本人自主汉化的 仅汉化了标准资源和简化的语言文件，没有汉化ASCII的弹出提示 而InnoSetup则采用的是莫名汉化的 希望能够给大家带来方便！ ★在此下载★
cbhhch | [第1楼] 发帖时间 2004年06月24日 09时33分
侠客 * 组别： 用户 帖子数量： 15 用户编号： 24855 注册时间： 2004年05月17日 Member 离线 | 好呀，正想要这个呢，能不能把的预处理程序也汉化一下。
大番茄 | [第2楼] 发帖时间 2004年06月24日 12时19分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 这个太好了!! 配合INNO SETUP! 番茄花园: http://tomatolei.com
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.2829 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


【下载】inno setup——ISX_Download.DLL插件汉化完成！

> 【下载】inno setup——ISX_Download.DLL插件汉化完成！
订阅此主题 | 邮寄此主题 | 打印此主题
jiangshen | [楼主] 发帖时间 2004年06月26日 09时25分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | inno setup中的ISX_Download.DLL下载插件，里面包含了安装示例和官方插件包中的所有文件，本人对主文件进行了汉化。 希望莫名能够把里面相关文件添加到inno setup的安装包里！！ 附件 ( 下载次数: 25 ) 附件 ISXDownloadDLL.rar
zjj1988101 | [第1楼] 发帖时间 2004年06月26日 10时54分
圣骑士 * * * 组别： 认证用户 帖子数量： 113 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 以前就有汉化的~在inno setup老汉化版本里
ulij | [第2楼] 发帖时间 2004年06月26日 11时43分
圣骑士 * * * 组别： 认证用户 帖子数量： 208 用户编号： 22258 注册时间： 2004年03月13日 Member 离线 | 这玩意咋用？ 我的优乐园 经历重重打击，依然勇往直前！ user posted image
gnatix
[第3楼] 发帖时间 2004年06月26日 14时18分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用 (ulij @ 2004年06月26日 11时43分)
这玩意咋用？

让 Inno 制作的安装程序可以直接从网上下载文件。用法可以参看程序自带的示例脚本文件。

user posted image
jiangshen | [第4楼] 发帖时间 2004年07月01日 21时55分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 真的没人要么，这个功能很好的
dujuan509 | [第5楼] 发帖时间 2004年07月01日 23时24分
侠客 * 组别： 认证用户 帖子数量： 49 用户编号： 20244 注册时间： 2004年01月06日 Member 离线 | 很好啊，类似于nsis的nsisdl插件，可以制作成liveupdate系统。
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3036 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


如何用 INNO SETUP 查找和替换文本字符串

> 如何用 INNO SETUP 查找和替换文本字符串, 回答 liangjh 的问题
gnatix
[楼主] 发帖时间 2004年08月20日 03时30分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2667
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用
在 inno 中，如果想在安装后替换一个文本文件的内容，是否可以通过脚本实现

比如，文本中有这样一句
C:\aaa
安装后，假设安装目录为 c:\setup
那么希望把所有的 c:\aaa 替换成 c:\setup

理解为你要替换的不是某一行，而是把所有出现的 C:\aaa 替换成软件的安装目录。

以下的脚本是在安装结束时完成该任务。脚本仅供参考：
[Code]
procedure CurStepChanged(CurStep: Integer);
var
IniFile, OldString, NewString: string;
IniFileLines: TArrayOfString;
i: Integer;
begin
if CurStep = csFinished then
begin
IniFile:= ExpandConstant('{app}\myfile.ini'); // 你的 INI 文件名
OldString:='C:\aaa'; // 要替换的旧字符串
NewString:= ExpandConstant('{app}'); // 新字符串

LoadStringsFromFile(IniFile, IniFileLines);
for i:= 0 to GetArrayLength(IniFileLines)-1 do
if (Pos(OldString, IniFileLines[i]) > 0) then
StringChange(IniFileLines[i], OldString, NewString);
SaveStringsToFile(IniFile, IniFileLines, False);
end;
end;

user posted image
Tervetuloa!
liangjh | [第1楼] 发帖时间 2004年08月20日 15时24分
精灵王 * * * * 组别： 认证用户 帖子数量： 360 用户编号： 11213 注册时间： 2003年02月19日 Member 离线 | 谢谢虎兄！ 真是难者不会啊，我昨天还在code段写个批处理文件，然后调用外部程序完成呢，但是太罗嗦了，虎兄的这个，真是强 editplus的语法文件保存在setting.ini里面，替换了一下，实践成功 [Code] procedure CurStepChanged(CurStep: Integer); var IniFile, OldString, NewString: string; IniFileLines: TArrayOfString; i: Integer; begin if CurStep = csFinished then begin IniFile:= ExpandConstant('{app}\setting.ini'); // 你的 INI 文件名 OldString:='C:\Program Files\EditPlus 2\'; // 要替换的旧字符串 NewString:= ExpandConstant('{app}\'); // 新字符串 LoadStringsFromFile(IniFile, IniFileLines); for i:= 0 to GetArrayLength(IniFileLines)-1 do if (Pos(OldString, IniFileLines[i]) > 0) then StringChange(IniFileLines[i], OldString, NewString); SaveStringsToFile(IniFile, IniFileLines, False); end; end; 正在看看是否可以只有在选定对应组件时才执行该操作，看起来好像是通过两个if语句传递参数组件的 uncheck 参数 跟着虎兄学了不少东西 一尘不染，两袖清风！
gnatix
[第2楼] 发帖时间 2004年08月21日 03时47分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2667
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (liangjh @ 2004年08月20日 15时24分)
正在看看是否可以只有在选定对应组件时才执行该操作，看起来好像是通过两个if语句传递参数组件的 uncheck 参数

假如你定义了一个名称为 ModifyIni 的组件并且希望只有在用户选定了该组件时才对 INI 文件进行修改，那么你只要把上面脚本中的语句
if CurStep = csFinished then
改成
if (CurStep = csFinished) and (Pos('ModifyIni',WizardSelectedComponents(false))>0) then
就行了。

假如你定义了一个名称为 ModifyIni 的 Task 并且希望只有在用户选定了该 Task 时才对 INI 文件进行修改，那么你只要把上面脚本中的语句
if CurStep = csFinished then
改成
if (CurStep = csFinished) and (Pos('ModifyIni',WizardSelectedTasks(false))>0) then
就行了。

user posted image
Tervetuloa!
liangjh | [第3楼] 发帖时间 2004年08月21日 08时07分
精灵王 * * * * 组别： 认证用户 帖子数量： 360 用户编号： 11213 注册时间： 2003年02月19日 Member 离线 | 多谢了，虎兄，越来越强了 一尘不染，两袖清风！
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.2915 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


关于 INNO 常量 引用

> 关于 INNO 常量 引用
做人要厚道 | [楼主] [image] 发帖时间 2004年07月03日 17时33分
侠客 * 组别： 用户 帖子数量： 11 用户编号： 27472 注册时间： 2004年07月03日 Member 离线 | {sysuserinfoname} {sysuserinfoorg} Windows 已许可的名字和组织，这个信息从注册表中读取。 如何在向导页中引用? 例如: [Messages] ;欢迎 向导页 WelcomeLabel1=欢迎使用 [name] 安装向导 WelcomeLabel2=本程序将在您的计算机上安装：%n%n“[name/ver]”%n%n推荐您在继续之前先关闭所有其它的程序。
gnatix
[第1楼] 发帖时间 2004年07月03日 19时21分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

不能直接在 [Messages] 段引用常量。但是在
代码
段可以随意更改，比如：

[CODE][Code]
procedure InitializeWizard();
begin
WizardForm.WelcomeLabel1.Caption:= '欢迎使用 Floppy Image 2.2.5 汉化版 安装向导'#13'你的名字: '+ExpandConstant('{sysuserinfoname}')+' 你的组织: '+ExpandConstant('{sysuserinfoorg}');
end;

结果是这样：

附图
附图

user posted image
做人要厚道 | [第2楼] 发帖时间 2004年07月04日 02时29分
侠客 * 组别： 用户 帖子数量： 11 用户编号： 27472 注册时间： 2004年07月03日 Member 离线 | 谢…… 感觉麻烦，放弃了。
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.2991 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


晓文 汉化的 Inno Setup 4.0.2 汉化不完全！！！

> 晓文 汉化的 Inno Setup 4.0.2 汉化不完全！！！
订阅此主题 | 邮寄此主题 | 打印此主题
wide4 | [楼主] 发帖时间 2003年05月21日 15时59分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 1914 注册时间： 2002年05月04日 Member 离线 | 软件名称 Inno Setup 软件版本 4.0.2 软件类别 安装制作 应用平台 WIN9X/WINNT/WIN2K/WINXP 授权形式 免费 软件评级 ★★★★★ 下载次数 12 汉化作者 晓文 上传日期 2003-5-21 附图 附图 我们的BT_MX最伟大!
莫名 | [第1楼] 发帖时间 2003年05月21日 16时24分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1328 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 语言包没定义
思忆 | [第2楼] 发帖时间 2003年05月21日 17时05分
侠客 * 组别： 用户 帖子数量： 29 用户编号： 1456 注册时间： 2002年04月05日 Member 离线 | 需要手动定义，在 [Setup] 部分后加入已下代码： [Languages] Name: "en"; MessagesFile: "compiler:Default.isl" Name: "chs"; MessagesFile: "E:\Program Files\Inno Setup 4\Language\Simple Chinese.isl" Name: "cht"; MessagesFile: "E:\Program Files\Inno Setup 4\Language\Traditional Chinese.isl" 你再试试看。 既然支持多语言，就要体现出来嘛，我是有意没将简体中文设为默认的。 这个帖子已被 思忆 于 2003年05月21日 17时15分 编辑
西风狂诗曲 | [第3楼] 发帖时间 2003年05月22日 16时34分
圣骑士 * * * 组别： 认证用户 帖子数量： 213 用户编号： 3829 注册时间： 2002年07月31日 Member 离线 | 要记得先看WHAT'S NEW，连这界面都没汉化的话，，，世纪怎么会更新上去嘛
« 上一个主题 | 汉化质量问题及测试 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.7867 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


【问题】

> 【问题】, gnatix,Inno Setup 是否支持多语言安装界面可选?
订阅此主题 | 邮寄此主题 | 打印此主题
做人要厚道 | [楼主] [image] 发帖时间 2004年08月21日 05时41分
侠客 * 组别： 用户 帖子数量： 11 用户编号： 27472 注册时间： 2004年07月03日 Member 离线 | 如下图 附图 附图
tracky | [第1楼] 发帖时间 2004年08月21日 11时17分
精灵王 * * * * 组别： 认证用户 帖子数量： 413 用户编号： 21516 注册时间： 2004年02月21日 Member 离线 | 支持，可惜我就只能这样实现多语言安装 还请各位来指导下 看看有什么其他的办法 [Setup] AppName=我的程序 AppVerName=我的程序 1.5 AppPublisher=我的公司 AppPublisherURL=http://www.mycompany.com AppSupportURL=http://www.mycompany.com AppUpdatesURL=http://www.mycompany.com DefaultDirName={pf}\我的程序 DefaultGroupName=我的程序 AllowNoIcons=yes Compression=lzma SolidCompression=yes ShowLanguageDialog=auto LanguageDetectionMethod=none [Languages] Name: en; MessagesFile: compiler:English.isl Name: chs; MessagesFile: compiler:Default.isl ╭∩╮（︶︿︶）╭∩╮
做人要厚道 | [第2楼] 发帖时间 2004年08月21日 16时32分
侠客 * 组别： 用户 帖子数量： 11 用户编号： 27472 注册时间： 2004年07月03日 Member 离线 | 可能是安装版本（汉化版）问题，代码原本也是这样编写。 下午在单位重装了官方英文版的4.2.7，多语言才出现。
做人要厚道 | [第3楼] 发帖时间 2004年08月21日 16时38分
侠客 * 组别： 用户 帖子数量： 11 用户编号： 27472 注册时间： 2004年07月03日 Member 离线 | 但在 [区域选项]-[系统语言设置] 将默认改为繁体 安装包没此选项，就出现下图！难道说不包含此语言选项反而安装不起来了！ 英文应该都支持的吧！ 附图 附图
gnatix | [第4楼] 发帖时间 2004年08月21日 16时54分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2659 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 检查一下你是否在安装包中使用了（简体）中文文件名、文件夹名等等。 user posted image Tervetuloa!
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 1.9694 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


关于INNO的使用

> 关于INNO的使用, 是否支持分卷压缩?
订阅此主题 | 邮寄此主题 | 打印此主题
snakey | [楼主] 发帖时间 2004年05月20日 03时19分
侠客 * 组别： 认证用户 帖子数量： 35 用户编号： 21437 注册时间： 2004年02月20日 Member 离线 | 我想将硬盘版的暗黑2刻到光盘上去,盘的容量是700M,游戏总大小大约1.5G吧,基本音乐语音动画都有了,完美的硬盘版了- - 请问INNO是否支持分卷安装程序??如果支持,是哪个代码段? user posted image
刘波 | [第1楼] 发帖时间 2004年05月20日 06时28分
版主 * * * * * 组别： 认证用户 帖子数量： 623 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 支持！至于具体的代码段记不太清楚了。不过ISTOOL上可以直接设置 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
gnatix | [第2楼] 发帖时间 2004年05月20日 14时07分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | [Setup] DiskSpanning = yes DiskSliceSize= 650000000 数字是每个分盘的大小（单位是字节） user posted image
snakey | [第3楼] 发帖时间 2004年05月20日 15时59分
侠客 * 组别： 认证用户 帖子数量： 35 用户编号： 21437 注册时间： 2004年02月20日 Member 离线 | 谢楼上的,试试去 user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.2896 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


[请教] Inno Setup 的 Script 的问题？

> [请教] Inno Setup 的 Script 的问题？
订阅此主题 | 邮寄此主题 | 打印此主题
joj | [楼主] [image] 发帖时间 2004年05月02日 01时14分
新手上路 * 组别： 用户 帖子数量： 7 用户编号： 22886 注册时间： 2004年03月30日 Member 离线 | 如果想实现安装程序在启动后首先检测本安装光盘驱动器的卷标是否和自定义的一样。是，则继续安装。否，则显示一些自定义信息后退出安装程序该如何实现呢。请知道的大侠指点一下 谢了。（最好给出code段的代码）
刘波 | [第1楼] 发帖时间 2004年05月02日 02时01分
版主 * * * * * 组别： 认证用户 帖子数量： 623 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | ？？？有这个必要么？ 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
OFA | [第2楼] 发帖时间 2004年05月02日 09时43分
天使 * * * * * * 组别： 认证用户 帖子数量： 1417 用户编号： 13575 注册时间： 2003年04月13日 Member 在线 | Inno Setup 估计做不到吧？ 这可能需要 install shield 级别的来实现。 user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
蓝色网际 | [第3楼] 发帖时间 2004年05月02日 12时17分
精灵王 * * * * 组别： 认证用户 帖子数量： 392 用户编号： 3348 注册时间： 2002年07月08日 Member 离线 | NSIS 有个插件好像可以。 做一件东西如果不能把它做到最好，我就不做
gnatix | [第4楼] 发帖时间 2004年05月02日 13时09分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 我理解你的意思为： 你只希望安装程序从某个特定的驱动器运行，比如从 E: 如果我理解对了，那么你只要插入下面的代码就行了： [Code] function InitializeSetup(): Boolean; begin if pos('E:',Uppercase(getCurrentDir))=0 then Begin MsgBox('你只允许从 E: 运行本安装程序！', mbInformation, MB_OK); Result:= False; End else Result:= True; end; user posted image
gnatix | [第5楼] 发帖时间 2004年05月02日 13时18分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 忘记提示一下： 如果要使用我上面给的代码，并更改为其它盘符时，请注意盘符的字母要大写。 user posted image
softsword | [第6楼] 发帖时间 2004年05月02日 15时53分
精灵王 * * * * 组别： 认证用户 帖子数量： 356 用户编号： 17697 注册时间： 2003年09月28日 Member 离线 | 哦？ 看来 gnatix 的 Pascal 学的非常不错哦 ：） 夏天来了，天气热了，一群“BT”往北飞，一会儿排成“B”字，一会儿排成“T”字 …… user posted image 孔子东游，遇二小儿辩斗，问其故。 一小儿曰：我以日本生自山东，故属东。 一小儿曰：夕阳西下，日本归山西也明矣，是以属西。 孔子不能决，后以问老子（本人也）。 老子笑曰：孰为汝多知乎？日本无根基，岂能算东西 ！ user posted image
OFA | [第7楼] 发帖时间 2004年05月02日 16时03分
天使 * * * * * * 组别： 认证用户 帖子数量： 1417 用户编号： 13575 注册时间： 2003年04月13日 Member 在线 | 我想他可能是为了防止别人盗用他的安装程序，把它刻在其他光盘里。 比如定义光盘的卷标为“ABC”，若安装程序检测卷标不为“ABC”，则退出安装。 user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
蓝色网际 | [第8楼] 发帖时间 2004年05月02日 16时08分
精灵王 * * * * 组别： 认证用户 帖子数量： 392 用户编号： 3348 注册时间： 2002年07月08日 Member 离线 | 光盘复制的时候不是可以复制卷标吗 做一件东西如果不能把它做到最好，我就不做
joj
[第9楼] [image] 发帖时间 2004年05月03日 01时51分

新手上路
*

组别： 用户
帖子数量： 7
用户编号： 22886
注册时间： 2004年03月30日

Member 离线

引用 (OFA @ 2004年05月02日 16时03分)
我想他可能是为了防止别人盗用他的安装程序，把它刻在其他光盘里。
比如定义光盘的卷标为“ABC”，若安装程序检测卷标不为“ABC”，则退出安装。

就是这个意思（当然只是很简单的防止随便复制而已）。感谢各位给的提示。已经解决了，从Inno Setup Extensions Knowledge Base的例子中找到了类似的例子稍加修改就可以用了。
yagas | [第10楼] 发帖时间 2004年05月05日 14时31分
侠客 * 组别： 认证用户 帖子数量： 38 用户编号： 21498 注册时间： 2004年02月21日 Member 离线 | Pascal 很不错的
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3777 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


Inno Setup问题

> Inno Setup问题
jiangshen | [楼主] 发帖时间 2004年06月07日 21时45分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | Flags: nowait postinstall skipifsilent Flags: postinstall shellexec skipifsilent 请问这两句有什么区别？？ Flags: unchecked 这句怎么改成默认是选中的？？？
莫名 | [第1楼] 发帖时间 2004年06月07日 23时51分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1328 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 前面两个问题看帮助文件的 [Run] 段，是中文的，很好理解。后一个问题只要去掉这个 Flags: unchecked 就表示默认是选中的。
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3605 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


请求大虾们看看这个问题谁可以解决？

> 请求大虾们看看这个问题谁可以解决？, 关于可以提示换碟的安装程序制作软件。
订阅此主题 | 邮寄此主题 | 打印此主题
wuimagic | [楼主] 发帖时间 2003年09月18日 23时13分
新手上路 * 组别： 用户 帖子数量： 3 用户编号： 17518 注册时间： 2003年09月18日 Member 离线 | 我看到网上有很多朋友写出如何使用制作安装程序的软件。但是我下载并使用后发现有个问题：就是如果我要做成安装程序的文件很多很大，1张cdrom装不下的时候，这些安装程序制作软件就都没有办法了。有没有可以快速上手的制作工具，可以在安装完第一张cd上的内容后，会自动提示“请插入下一张光盘继续安装”的制作软件阿？如果有，请介绍几种简单易上手的可以制作中文安装程序的制作工具吧。这也是很多向我一样的朋友所热切需要的。谢谢啦！
思忆 | [第1楼] 发帖时间 2003年09月19日 20时36分
侠客 * 组别： 用户 帖子数量： 29 用户编号： 1456 注册时间： 2002年04月05日 Member 离线 | Inno Setup 可以实现你换光盘的功能，主要是在脚本[Setup]部分里面加两个参数即可，具体如下： [Setup] ....... DiskSliceSize=1457664 DiskSpanning=yes 注意“1457664”这个数值据软件帮助的说明是该大小为1.44M，你可以自己改数值。
« 上一个主题 | 软件使用 | 下一个主题 »

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 2.1300 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


关于INNO的一个问题？

> 关于INNO的一个问题？, 我找了以前的帖子，但是没有！
订阅此主题 | 邮寄此主题 | 打印此主题
leyan22 | [楼主] [image] 发帖时间 2004年05月08日 14时43分
侠客 * 组别： 认证用户 帖子数量： 39 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | 请问INNO是不是也可以象NSIS一样在安装开始前，弹出一个画面？ 我觉得好象可以，因为在莫名汉化的INNO里，安装开始前不是有一个3721的图片弹出吗！ 我要的就是这个效果！ 如果可以实现，请各位知道的大哥给个语句，个人认为应该是SETUP段的吧……
gnatix | [第1楼] 发帖时间 2004年05月08日 14时47分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 只能使用 BMP 格式的文件，要用 Code 脚本。 user posted image
leyan22 | [第2楼] 发帖时间 2004年05月08日 14时49分
侠客 * 组别： 认证用户 帖子数量： 39 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | 斑竹能说详细点吗？ 给个脚本示例吧！
gnatix | [第3楼] 发帖时间 2004年05月08日 15时10分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 这时我刚做好的一个安装文件脚本，供参考。 附件 ( 下载次数: 25 ) 附件 mysetup.iss user posted image
leyan22 | [第4楼] 发帖时间 2004年05月08日 15时57分
侠客 * 组别： 认证用户 帖子数量： 39 用户编号： 24384 注册时间： 2004年05月06日 Member 离线 | 谢谢，看看先！
gnatix | [第5楼] 发帖时间 2004年05月08日 16时31分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 刚上传的 Ini Translator 的安装文件就是用上面的脚本做的。 user posted image
zjj1988101 | [第6楼] 发帖时间 2004年05月08日 16时53分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 好的~我也看看~
zjj1988101 | [第7楼] 发帖时间 2004年05月08日 17时02分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 如果象NSIS那样有淡入浅出的话就好了` 还有压缩率也没NSIS高~ 这个是我测试过的~ 哎~只是INNO用起来方便~ 希望它做的更完美吧
leyan22
[第8楼] 发帖时间 2004年05月08日 18时46分

侠客
*

组别： 认证用户
帖子数量： 39
用户编号： 24384
注册时间： 2004年05月06日

Member 离线

引用 (zjj1988101 @ 2004年05月08日 17时02分)
如果象NSIS那样有淡入浅出的话就好了`
还有压缩率也没NSIS高~
这个是我测试过的~
哎~只是INNO用起来方便~
希望它做的更完美吧

偶现在还是菜鸟级，还不会NSIS呢
所以只有从INNO开始漫漫来了
呵呵
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3247 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


想在安装时有背景音乐的可用这款安装程序，安装界面中还有音量调节。

(2) 2 ( 转到首个未读帖子 )

> 想在安装时有背景音乐的可用这款安装程序，安装界面中还有音量调节。, 支持 WAV，MID。CFA Installer 就是用它做的.....
订阅此主题 | 邮寄此主题 | 打印此主题
xihua | [楼主] [image] 发帖时间 2004年07月23日 11时57分
精灵王 * * * * 组别： 认证用户 帖子数量： 343 用户编号： 17836 注册时间： 2003年10月05日 Member 在线 | 第 11 楼的 gnatix 兄的脚本，强烈建议大家参考。 不想写脚本的可继续用下面的 Qsetup Installation Suite 。 Qsetup Installation Suite v5.0.0.0 (1.2 MB) Qsetup Installation Suite v4.0.0.4 (1.86 MB) 不需要写脚本。 不足：即使使用 第9级最大压缩，其压缩率也偏小。 Qsetup 和 InstallShield Express 的对比可访问这页... http://www.panta-ray.com/compare.html 山河大地，已属微尘；血肉身躯，且归泡影；非上上智，无了了心。
xihua | [第1楼] [image] 发帖时间 2004年07月23日 12时27分
精灵王 * * * * 组别： 认证用户 帖子数量： 343 用户编号： 17836 注册时间： 2003年10月05日 Member 在线 | 如图： 附图 附图 山河大地，已属微尘；血肉身躯，且归泡影；非上上智，无了了心。
xxd | [第2楼] 发帖时间 2004年07月23日 13时48分
圣骑士 * * * 组别： 认证用户 帖子数量： 133 用户编号： 13172 注册时间： 2003年04月04日 Member 离线 | 不错呀，感谢提供！ 欢迎访问我的个人主页！ 来看看，提提意见吧。 http://softloc.nease.net
ouchangyao | [第3楼] 发帖时间 2004年07月23日 17时47分
侠客 * 组别： 用户 帖子数量： 20 用户编号： 28183 注册时间： 2004年07月21日 Member 离线 | 当安装的软件较小时，音乐岂不是一闪而过？
决斗 | [第4楼] [image] 发帖时间 2004年07月23日 18时26分
精灵王 * * * * 组别： 认证用户 帖子数量： 280 用户编号： 18089 注册时间： 2003年10月12日 Member 离线 | 这个好哇……不过，做出的补丁是否比 patch maker 之类小呢？ 山之颠为峰，我名如峰；路之基为石，志比顽石； 天之涯为界，心中无界；人之本为水，淡泊如水！ ........................................................... 狱火吞天，鬼魅覆地，世风下，心不古，人未老，情堪忧，空悲叹，当长歌，暮天际，四海鸣，一腔壮志，何以言酬，蓦然回首，已空负了我少年头……
xihua
[第5楼] [image] 发帖时间 2004年07月23日 19时14分

精灵王
* * * *

组别： 认证用户
帖子数量： 343
用户编号： 17836
注册时间： 2003年10月05日

Member 在线

引用 (ouchangyao @ 2004年07月23日 17时47分)
当安装的软件较小时，音乐岂不是一闪而过？

的确如此，如果软件太小，甚至音乐还没开始播放，安装程序已经结束。

引用 (决斗 @ 2004年07月23日 18时26分)

这个好哇……不过，做出的补丁是否比 patch maker 之类小呢？

没详细测试，估计比 patch maker 要大。

  山河大地，已属微尘；血肉身躯，且归泡影；非上上智，无了了心。

gnatix | [第6楼] 发帖时间 2004年07月23日 19时22分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 几秒钟就安装好的程序，还要加上音乐背景，不是自找麻烦吗？ user posted image
gnatix | [第7楼] 发帖时间 2004年07月23日 19时25分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 提示： 用 Inno 做的安装文件也是可以加上背景音乐的。效果可以参考我做的 NeatImage 安装程序。 user posted image
决斗 | [第8楼] 发帖时间 2004年07月23日 19时34分
精灵王 * * * * 组别： 认证用户 帖子数量： 280 用户编号： 18089 注册时间： 2003年10月12日 Member 离线 | 也是，虎兄说的有道理，即使不是补丁而是安装程序，一般也没多少秒钟，音乐估计是听不了多少的。呵呵 除非是个很大的安装程序，文件特多，那大概还可以听一会，嘿 山之颠为峰，我名如峰；路之基为石，志比顽石； 天之涯为界，心中无界；人之本为水，淡泊如水！ ........................................................... 狱火吞天，鬼魅覆地，世风下，心不古，人未老，情堪忧，空悲叹，当长歌，暮天际，四海鸣，一腔壮志，何以言酬，蓦然回首，已空负了我少年头……
xihua | [第9楼] [image] 发帖时间 2004年07月23日 19时57分
精灵王 * * * * 组别： 认证用户 帖子数量： 343 用户编号： 17836 注册时间： 2003年10月05日 Member 在线 | Neat Image 4.0 Pro+ 汉化版 的安装程序真强啊！上次安装没开音箱，原来 Inno Setup 就可以做到。 gnatix 兄可否贴一个 Neat Image 4.0 Pro+ 汉化版 的脚本附件上来学习学习？谢谢！ 山河大地，已属微尘；血肉身躯，且归泡影；非上上智，无了了心。
ulij | [第10楼] 发帖时间 2004年07月23日 22时55分
圣骑士 * * * 组别： 认证用户 帖子数量： 208 用户编号： 22258 注册时间： 2004年03月13日 Member 离线 | Qsetup 好软件应该汉化呀！ 我的优乐园 经历重重打击，依然勇往直前！ user posted image
gnatix
[第11楼] 发帖时间 2004年07月24日 00时14分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用 (xihua @ 2004年07月23日 19时57分)
Neat Image 4.0 Pro+ 汉化版 的安装程序真强啊！上次安装没开音箱，原来 Inno Setup 就可以做到。

gnatix 兄可否贴一个 Neat Image 4.0 Pro+ 汉化版 的脚本附件上来学习学习？谢谢！

这是原封未动的脚本文件，献丑了：

代码
; 脚本由 Inno Setup 脚本设计向导 创建。
; 有关创建 INNO SETUP 脚本的详情请查阅帮助文档！

[Setup]
DisableStartupPrompt=yes
AppName=Neat Image 4.0 Pro+ 汉化破解版
AppVerName=Neat Image 4.0 Pro+ 汉化破解版
DefaultDirName={pf}\Neat Image
DefaultGroupName=Neat Image 4.0 Pro+ 汉化版
InfoBeforeFile=F:\汉化\NeatImage 4.0\汉化说明.txt

[Tasks]
Name: "desktopicon"; Description: "桌面快捷方式"; GroupDescription: "添加快捷方式:"
Name: "quicklaunchicon"; Description: "快速运行栏快捷方式"; GroupDescription: "添加快捷方式:"; Flags: unchecked
Name: "sendtoicon"; Description: "发送到快捷方式"; GroupDescription: "添加快捷方式:"

[Files]
Source: "F:\汉化\NeatImage 4.0\\*.*"; DestDir: "{app}"; Flags: ignoreversion recursesubdirs
Source: "F:\汉化\共用文件\tigerlogo.bmp"; DestDir: "{tmp}"; Flags: ignoreversion dontcopy
Source: "F:\汉化\共用文件\music.mid"; DestDir: "{tmp}"; Flags: ignoreversion dontcopy

[Icons]
Name: "{userdesktop}\Neat Image 4.0 Pro+ 汉化版"; Filename: "{app}\NeatImage.exe"; Tasks: desktopicon; workingdir: "{app}"
Name: "{userappdata}\Microsoft\Internet Explorer\Quick Launch\Neat Image 4.0"; Filename: "{app}\NeatImage.exe"; Tasks: quicklaunchicon; workingdir: "{app}"
Name: "{sendto}\Neat Image 4.0"; Filename: "{app}\NeatImage.exe"; Tasks: sendtoicon; workingdir: "{app}"
;
Name: "{group}\运行 Neat Image 4.0 Pro+ 汉化版"; Filename: "{app}\NeatImage.exe"; workingdir: "{app}"
Name: "{group}\卸载 Neat Image 4.0 Pro+ 汉化版"; Filename: "{uninstallexe}"

[Registry]
Root: HKCU; Subkey: "Software\ABSoft\NeatImage"; Flags: deletekey
Root: HKCU; Subkey: "Software\ABSoft\NeatImage"; Flags: uninsdeletekey

[Run]
Filename: "{app}\NeatImage.exe"; Description: "运行 Neat Image 4.0 Pro+ 汉化版"; Flags: nowait postinstall skipifsilent

[Code]
function mciSendString(lpszCommand: String; lpszReturnString: Integer; cchReturnLength: Integer; hwndCallback: Integer): Integer;
external 'mciSendStringA@winmm.dll stdcall';

procedure InitializeWizard();
var
SplashImage: TBitmapImage;
GnatixInfo: TLabel;
SplashForm: TForm;
SplashFileName: String;
I: Integer;
begin
WizardForm.BeveledLabel.Enabled:= True;
WizardForm.BeveledLabel.Font.Color:= $00C59016;
WizardForm.BeveledLabel.Top:= WizardForm.BeveledLabel.Top+3;

SplashFileName := ExpandConstant('{tmp}\tigerlogo.bmp');
ExtractTemporaryFile(ExtractFileName(SplashFileName));
ExtractTemporaryFile(ExtractFileName(ExpandConstant('{tmp}\music.mid')));

SplashForm := TForm.create(nil);
with SplashForm do
begin
BorderStyle := bsNone;
Position := poScreenCenter;
ClientWidth := 250;
ClientHeight := 236;
Color:= $00E7AD29;
end;

SplashImage := TBitmapImage.Create(SplashForm);
GnatixInfo := TLabel.Create(SplashForm);
with SplashImage do
begin
Bitmap.LoadFromFile(SplashFileName);
Stretch := true;
Align := alClient;
Parent := SplashForm;
end;

with GnatixInfo do
begin
Left := 176;
Top := 215;
Caption :='请稍候...';
Parent := SplashForm;
Font.Name:= '宋体';
Font.Height:= -14;
Font.Style:= [fsBold];
Font.Color:= clWhite;
end;

with SplashForm do
begin
Show;
for I := 1 to 6 do
begin
Repaint;
if I mod 2 = 0 then
gnatixinfo.visible:= true
else
gnatixinfo.visible:= false;
Sleep(500);
end;
mciSendString(ExpandConstant('play {tmp}\music.mid'),0,0,0);
Close;
Free;
end;

end;

user posted image
xihua | [第12楼] [image] 发帖时间 2004年07月24日 11时40分
精灵王 * * * * 组别： 认证用户 帖子数量： 343 用户编号： 17836 注册时间： 2003年10月05日 Member 在线 | 感谢 gnatix 兄不吝指教！ 建议大家都改用 inno setup ，超超强！！！ Qsetup Installation Suite 就不必用了.... 山河大地，已属微尘；血肉身躯，且归泡影；非上上智，无了了心。
gnatix
[第13楼] 发帖时间 2004年07月24日 13时11分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用 (xihua @ 2004年07月24日 11时40分)
感谢 gnatix 兄不吝指教！

建议大家都改用 inno setup ，超超强！！！

Qsetup Installation Suite 就不必用了....

不能极端，其它工具也是要用的，因为各有长短。

user posted image
wzx2001 | [第14楼] 发帖时间 2004年07月24日 18时52分
光明使者 * * * * * 组别： 禁止 帖子数量： 671 用户编号： 17235 注册时间： 2003年09月03日 Member 离线 | 我觉得 QSetup 的可视化较适合初学者和偷懒的人.不过功能的确强大,不可小视之. <!--Image http://bbs.hanzify.org/style_images/1/logo.jpg--> user posted image (screen.width*0.95-250)) this.width=(screen.width*0.95-250)'><!--End Image--> 汉化新世纪 ---自由的天空
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项 (2) 2

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3734 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


请问关于Inno Setup的使用~

(3) 2 3 ( 转到首个未读帖子 )

> 请问关于Inno Setup的使用~, 请各位帮忙！
订阅此主题 | 邮寄此主题 | 打印此主题
zjj1988101 | [楼主] 发帖时间 2004年02月22日 12时37分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 我最近觉的Inno Setup这个软件很不错~但是自己技术和英语不够好~所以只能摸索着用~ 目前只基本弄了个脚本~但是还有些不懂~ 请问~ 1 怎么样让安装界面上的一条线上有字？比如作者是谁之类的~ 2 请问怎么样选择源文件（就是让复制的文件这个） 能不能就选定一个目录的~谢谢~ 3 如何在安装完成的窗口上有查看说明 启动程序和访问网站等选项！ 4 再请问如何可以把安装包做的更小！ 请指点！谢谢各位高手！ 新问题： 再问一下~怎么样Inno Setup+7zip（就是安装程序启动前会有个7zip的自解压跳出来） 还有标准的移栽代码和添加快截方式到快速启动应该是怎么样的？ 拜托了~
gnatix | [第1楼] 发帖时间 2004年02月22日 13时24分
天使 * * * * * * 组别： 超级版主 帖子数量： 2406 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 问题1： 在 default.isl 中补充一下，比如： ; *** 公共向导文字 ClickNext=单击“下一步”继续，或单击“取消”退出安装程序。 BeveledLabel=汉化新世纪成员 gnatix 汉化作品 问题2： 可以把所有文件以及子目录包括，比如： [Files] Source: "F:\MyHH\MyProg\MyFiles\*.*"; DestDir: "{app}"; Flags: ignoreversion recursesubdirs 问题3： [Run] Filename: "{app}\MyProgFile.EXE"; Description: "运行汉化后的软件";Flags: nowait postinstall skipifsilent Filename: "{app}\README.TXT"; Description: "阅读 README"; Flags: postinstall shellexec skipifsilent unchecked Filename: "{app}\MyWWW.url"; Description: "访问我的网站"; Flags: postinstall nowait skipifsilent unchecked 问题4： 作者正在努力中，所以频频出新版：） user posted image
zjj1988101 | [第2楼] 发帖时间 2004年02月22日 14时09分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 万分感谢！
zjj1988101 | [第3楼] 发帖时间 2004年02月22日 14时11分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 再问一下~怎么样Inno Setup+7zip（就是安装程序启动前会有个7zip的自解压跳出来） 还有标准的移栽代码和添加快截方式到快速启动应该是怎么样的？ 拜托了~
zjj1988101 | [第4楼] 发帖时间 2004年02月22日 17时59分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 请再次指点！
gnatix
[第5楼] 发帖时间 2004年02月22日 19时55分

天使
* * * * * *

组别： 超级版主
帖子数量： 2406
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (zjj1988101 @ 2004年02月22日 17时59分)
请再次指点！

不是用 PM 回答你了吗？

user posted image
zjj1988101 | [第6楼] 发帖时间 2004年02月23日 18时55分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 谢谢~ 我以前看见过一个用Inno Setup打包的程序~好象是木子的QQ 我看了看它解压到临时目录的文件~看见里面有个*.BIN的文件和一个安装程序~ 我想应该是把原来的文件压在*.BIN里~然后再安装之类的吧~ 那请问光用Inno Setup可以做到吗？ 还是需要使用其他的一些软件把文件压到BIN里~再编写一个脚本~ 如果知道的话请指点！谢谢！我很想知道
刘波
[第7楼] 发帖时间 2004年02月24日 14时34分

版主
* * * * *

组别： 认证用户
帖子数量： 623
用户编号： 691
注册时间： 2001年12月27日

Member 离线

引用 (zjj1988101 @ 2004年02月23日 18时55分)
谢谢~
我以前看见过一个用Inno Setup打包的程序~好象是木子的QQ
我看了看它解压到临时目录的文件~看见里面有个*.BIN的文件和一个安装程序~
我想应该是把原来的文件压在*.BIN里~然后再安装之类的吧~
那请问光用Inno Setup可以做到吗？
还是需要使用其他的一些软件把文件压到BIN里~再编写一个脚本~
如果知道的话请指点！谢谢！我很想知道

那个是用 Inno Setup 的一个辅助软件： ISTool 做的。不过现在 Inno Setup 本身的压缩已经可以使用 7Zip 了，压缩率也不错。

欢迎来到汉化新世纪论坛之分论坛游戏天地
user posted image
zjj1988101 | [第8楼] 发帖时间 2004年02月24日 18时48分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 可以说说方法吗？我是初学者哦~
zjj1988101 | [第9楼] 发帖时间 2004年02月26日 18时00分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 那再请问标准的移栽代码是怎么样的？ 我的文件在20M左右~我希望可以打包到最小~请详细指点啊~谢谢~
OFA | [第10楼] 发帖时间 2004年02月26日 18时57分
天使 * * * * * * 组别： 认证用户 帖子数量： 1417 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | 你用新的Inno Setup 4.1.5以上版本都可以通过编辑脚本直接实现7zip格式压缩。 在[setup]段，添加: SolidCompression=yes Compression=LZMA 建议下载最新的Inno Setup 4.1.8版，默认压缩就是LZMA，而不用手动编辑脚本。 user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
zjj1988101 | [第11楼] 发帖时间 2004年02月26日 19时38分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 谢谢指点~那请问标准的移栽代码应该是什么样的？
OFA | [第12楼] 发帖时间 2004年02月26日 22时03分
天使 * * * * * * 组别： 认证用户 帖子数量： 1417 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | 什么叫“标准的移栽代码”？ user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
大番茄 | [第13楼] 发帖时间 2004年02月27日 16时38分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 2个问题,谢谢斑竹,等待,,,,, 1.请问木子QQ也是用inno setup做的吧? 打开木子QQ的时候会解压缩,请问这个怎么做的呢? 2.用inno setup 可以不可以在安装过程中写注册表呢?或者导入注册表*.reg,就像wise可以的! 番茄花园: http://tomatolei.com
OFA | [第14楼] 发帖时间 2004年02月27日 21时34分
天使 * * * * * * 组别： 认证用户 帖子数量： 1417 用户编号： 13575 注册时间： 2003年04月13日 Member 离线 | 1. 上面写了是用7-zip压的，实际上这应该是利用7-zip的脚本功能，而非Inno Setup所为。PS: 新版的inno setup支持7-zip(即lzma)压缩。 2. 建议你阅读inno setup的帮助文件，里面写得很清楚。实际上inno setup的向导仅提供最基本的功能。大多数复杂的功能都是通过脚本实现的。 user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项 (3) 2 3

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 1.3941 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


请问关于Inno Setup的使用~

(3) 1 3 ( 转到首个未读帖子 )

> 请问关于Inno Setup的使用~, 请各位帮忙！
订阅此主题 | 邮寄此主题 | 打印此主题
zjj1988101 | [第15楼] 发帖时间 2004年02月27日 22时21分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 基本明白了~有时候还是会有些问题~主要技术不如人啊~
大番茄 | [第16楼] 发帖时间 2004年02月28日 08时02分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 谢谢啊`!! 番茄花园: http://tomatolei.com
weidong | [第17楼] 发帖时间 2004年02月28日 10时51分
侠客 * 组别： 用户 帖子数量： 11 用户编号： 20841 注册时间： 2004年01月30日 Member 离线 | 不错，看了以后有收获。
gnatix | [第18楼] 发帖时间 2004年02月28日 14时43分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 压缩方式的设置： [Setup] Compression=XXX XXX 表示压缩方式，目前的版本支持以下的压缩方式： zip ; 相当于 zip/7，是软件默认的压缩方式 zip/1 ; Zip 格式，压缩率最低，速度最快，耗内存最少 ...... zip/9 ; Zip 格式，压缩率最高，速度最慢，耗内存最大 bzip ; 相当于 bzip/9 bzip/1 ; BZip2 格式（压缩率高于 Zip 格式），压缩率最低，速度最快，耗内存最少 ...... bzip/9 ; BZip2 格式，压缩率最高，速度最慢，耗内存最大 lzma ; 相当于 lzma/max lzma/fast ; 7-Zip LZMA 格式（压缩率高于 Zip 和 BZip2 格式），压缩率低，速度快 lzma/normal ;7-Zip LZMA 格式，压缩率一般，速度一般 lzma/max ;7-Zip LZMA 格式，压缩率高，速度慢 lzma/ultra ;7-Zip LZMA 格式，超级压缩（谨慎使用，特别耗内存！！） none ;不压缩 user posted image
gnatix | [第19楼] 发帖时间 2004年02月28日 14时54分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 因为有人来 PM 询问，所以在这里贴出本人的一个脚本文件，供初学者参考： 附图 附图 user posted image
gnatix | [第20楼] 发帖时间 2004年02月28日 14时54分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 这里是脚本文件。 附件 ( 下载次数: 27 ) 附件 muster.iss user posted image
xihua
[第21楼] [image] 发帖时间 2004年02月28日 16时05分

精灵王
* * * *

组别： 认证用户
帖子数量： 272
用户编号： 17836
注册时间： 2003年10月05日

Member 在线

引用 (gnatix @ 2004年02月28日 14时54分)
这里是脚本文件。

感谢莫名兄汉化！感谢 gnatix 兄指点！
莫名 | [第22楼] 发帖时间 2004年02月28日 16时35分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1322 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 可是时间不是很多，要不将帮助文件也汉化了。
gnatix
[第23楼] 发帖时间 2004年02月28日 16时54分

天使
* * * * * *

组别： 超级版主
帖子数量： 2407
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (莫名 @ 2004年02月28日 16时35分)
可是时间不是很多，要不将帮助文件也汉化了。

帮忙文件全部翻译可能量太大了，但是如果能翻译有关安装脚本段的部分就好了。能否几个人分工一下？我也可以帮一点忙。

user posted image
zjj1988101 | [第24楼] 发帖时间 2004年02月28日 18时06分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 实在太谢谢您了~给了我这么多的指点
OFA | [第25楼] 发帖时间 2004年02月28日 19时10分
天使 * * * * * * 组别： 认证用户 帖子数量： 1417 用户编号： 13575 注册时间： 2003年04月13日 Member 在线 | 网上有个Inno Setup中文帮助手册，但是版本比较老了。最新的功能没有写进去。 user posted image 愿为汉化事业贡献自己的一份微薄之力。 欢迎您访问我的净土 http://www.cokemouse.com
莫名 | [第26楼] 发帖时间 2004年02月28日 21时51分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1322 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 整个帮助文件 270 K 纯文本，用什么软件写帮助文件比较好一点，我试了一下Help & Manual，功能挺强，就是不支持中文输入。 附图 附图
gnatix | [第27楼] 发帖时间 2004年02月28日 21时55分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 用 FastHelp 不错。 user posted image
gnatix | [第28楼] 发帖时间 2004年02月28日 21时59分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 不过 FastHelp 不支持从 HLP 文件导入。而 HelpScribble 则支持从 HPJ 导入，值得试一试。 user posted image
刘波 | [第29楼] 发帖时间 2004年02月28日 22时00分
版主 * * * * * 组别： 认证用户 帖子数量： 623 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | 我也来一个带注册表操作的脚本。具体用法还是看帮助吧。能学到很多东西！ 附件 ( 下载次数: 23 ) 附件 ISTool 3.0.6.2.iss 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项 (3) 1 3

下载或者查看此主题的不同格式的可打印版本。
[ 程序执行时间： 3.0743 秒 ] [ 数据库查询： 13 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


请问关于Inno Setup的使用~

(3) 1 2 ( 转到首个未读帖子 )

> 请问关于Inno Setup的使用~, 请各位帮忙！
订阅此主题 | 邮寄此主题 | 打印此主题
zjj1988101 | [第30楼] 发帖时间 2004年02月28日 23时00分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 谢谢楼上的高手~ 希望莫名大哥加油！
大番茄 | [第31楼] 发帖时间 2004年02月29日 10时06分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 希望早点有中文的帮助! 很喜欢innosetup打包的东西~! 番茄花园: http://tomatolei.com
zjj1988101 | [第32楼] 发帖时间 2004年02月29日 10时58分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 对！我也是！高手加油啊
大番茄 | [第33楼] 发帖时间 2004年03月06日 17时30分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 麻烦斑竹看看,为什么我安装完了要运行"访问我的网站"会出现错误! 附图 附图 番茄花园: http://tomatolei.com
大番茄 | [第34楼] 发帖时间 2004年03月06日 17时38分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 我下载了前面的脚本 原来还要加一行 [INI] Filename: "{app}\leilei.url"; Section: "InternetShortcut"; Key: "URL"; String: "http://bbs.tomato.ac.pn" [Run] Filename: "{app}\leilei.url"; Description: "访问番茄花园主页"; Flags: postinstall shellexec skipifsilent unchecked ============================================= 但是请问,如何默认情况最后都选择好呢? 番茄花园: http://tomatolei.com
莫名 | [第35楼] 发帖时间 2004年03月06日 18时23分
天使 * * * * * * 组别： 汉化新世纪成员 帖子数量： 1322 用户编号： 1716 注册时间： 2002年04月24日 Member 离线 | 把 unchecked 去掉试试
大番茄 | [第36楼] 发帖时间 2004年03月06日 19时02分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 谢谢 莫名 大侠 ! 我今天下载了7ZP和ISTOOL,觉得配合inno setuo真的太好了! 另外我用的是XP 没装其他软件前,使用最新的inno setup4.1.8正常! 但是装了很多软件和补丁以后 inno setup4.1.8就出现错误信息"按零分割" inno setup4.1.6和inno setup4.1.7都这样 后来我再试了inno setup4.1.5,就没问题了! 真搞不懂是什么程序和inno setup4.1.8有冲突! ============================================ 另外一个问题: 就是用inno setup制作的程序,可以不可以和WISE9.02一样,可以打开安装程序时候出现一个启动画面? 番茄花园: http://tomatolei.com
zjj1988101 | [第37楼] 发帖时间 2004年03月06日 19时04分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 嘿嘿~这个我知道
zjj1988101 | [第38楼] 发帖时间 2004年03月06日 19时07分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | http://www.hanzify.org/index.php?Go=Show::List&ID=4011 看这个
gnatix | [第39楼] 发帖时间 2004年03月06日 19时08分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | Filename: "{app}\leilei.url"; Description: "访问汉化新世纪主页"; Flags: postinstall shellexec skipifsilent unchecked 去掉 unchecked 表示默认是选中 去掉 postinstall 则表示自动运行，根本不给用户选择的余地。PS: 本人强烈反对这样做！ user posted image
大番茄 | [第40楼] 发帖时间 2004年03月06日 20时50分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 第一,谢谢zjj1988101推荐的Splasher3.0,这个东西我刚刚用一下,强啊~!!!!! 第二,谢谢大老虎斑竹,你的知识好丰富,让我学了不少,谢谢!! 番茄花园: http://tomatolei.com
zjj1988101 | [第41楼] 发帖时间 2004年03月06日 21时35分
圣骑士 * * * 组别： 认证用户 帖子数量： 108 用户编号： 17968 注册时间： 2003年10月09日 Member 离线 | 呵呵
chenmy
[第42楼] 发帖时间 2004年03月07日 20时06分

天使
* * * * * *

组别： 超级版主
帖子数量： 1381
用户编号： 1794
注册时间： 2002年04月28日

Member 离线

引用 (大番茄 @ 2004年03月06日 17时38分)
我下载了前面的脚本
原来还要加一行

[INI]
Filename: "{app}\leilei.url"; Section: "InternetShortcut"; Key: "URL"; String: "http://bbs.tomato.ac.pn"
[Run]

Filename: "{app}\leilei.url"; Description: "访问汉化新世纪主页"; Flags: postinstall shellexec skipifsilent unchecked
=============================================
但是请问,如何默认情况最后都选择好呢?

你这样做不对吧！

名为“访问汉化新世纪主页”，实际指向“http://bbs.tomato.ac.pn”。
我爱自然之家！—我爱汉化！
user posted image
user posted image
我是中国人·最爱是中文！
user posted image
大番茄 | [第43楼] 发帖时间 2004年03月08日 07时29分
圣骑士 * * * 组别： 认证用户 帖子数量： 127 用户编号： 15345 注册时间： 2003年06月05日 Member 离线 | 我不是要访问 访问汉化新世纪主页 我只是做一个测试可以安装结束访问网站! 楼上的误会了! 番茄花园: http://tomatolei.com
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项 (3) 1 2

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3343 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


Inno Setup高级使用求助

> Inno Setup高级使用求助
jiangshen | [楼主] 发帖时间 2004年06月14日 21时14分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 能不能实现安装包链接到服务器，可以进行正版验证 也就是说在安装程序中加入一个按钮，点击后通过链接到服务器能够自动判断是否为原版？？？
jiangshen | [第1楼] 发帖时间 2004年06月14日 21时33分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | gnatix在不在，我很崇拜你呀，你对Inno Setup很了解
gnatix | [第2楼] 发帖时间 2004年06月15日 01时26分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 能否具体一些？难道你自己的安装程序还不是原版？ user posted image
jiangshen | [第3楼] 发帖时间 2004年06月15日 05时41分
骑士 * * 组别： 用户 帖子数量： 74 用户编号： 24005 注册时间： 2004年04月27日 Member 离线 | 我得意思是链接到服务器进行MD5码验证，因为我做的软件有人冒充发布假的
gnatix | [第4楼] 发帖时间 2004年06月15日 12时58分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 软件可以假冒。但是那个你做好的（准备去验证 MD5 的）安装程序一定不会是假冒的吧，用它去验证当然肯定通过。而别人假冒了你的软件，但是他做的安装程序当然不会去验证你的 MD5，除非他是傻瓜。 验证安装程序本身的 MD5 没有意义，最多只是知道安装程序被人家修改了。如果是我要假冒你的软件，我才不修改你的安装程序呢（又能够修改什么呢），我会先运行你的安装程序（即使你有 MD5 验证，也是会通过的，因为我是正常安装啊），然后我再把安装好的文件重新打包做成安装程序（如果你是用 Inno 做的安装程序，那么我肯定会做得和你的一样）。所以验证安装程序的 MD5 毫无意义。 请你还是考虑一下你的想法逻辑上有没有错误。 user posted image
bcff2002 | [第5楼] 发帖时间 2004年06月16日 19时25分
骑士 * * 组别： 认证用户 帖子数量： 55 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | inno是怎样实现输入序列号才能安装的 输入法大全 http://www.bcff2002.com
gnatix
[第6楼] 发帖时间 2004年06月17日 02时44分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用 (bcff2002 @ 2004年06月16日 19时25分)
inno是怎样实现输入序列号才能安装的

使用：
[Setup]
password=123456
后面加的当然是你要设置的密码。

如果想要增加别人解密的难度，可以再加上一句：
Encryption=yes
但是你必须下载下面的附加模块，并复制到 Inno Setup 的安装目录中：
http://www.xs4all.nl/~mlaan2/iscrypt/ISCrypt.dll

user posted image
yagas | [第7楼] 发帖时间 2004年06月17日 21时43分
侠客 * 组别： 认证用户 帖子数量： 38 用户编号： 21498 注册时间： 2004年02月21日 Member 离线 | 用 inno 作用序列号？？ 你还不如用专业点的工具呢
yagas | [第8楼] 发帖时间 2004年06月17日 21时50分
侠客 * 组别： 认证用户 帖子数量： 38 用户编号： 21498 注册时间： 2004年02月21日 Member 离线 | 用 inno 作用序列号？？ 你还不如用专业点的工具呢
yagas | [第9楼] 发帖时间 2004年06月17日 21时51分
侠客 * 组别： 认证用户 帖子数量： 38 用户编号： 21498 注册时间： 2004年02月21日 Member 离线 | 用 inno 作用序列号？？ 你还不如用专业点的工具呢
gnatix
[第10楼] 发帖时间 2004年06月18日 04时03分

精灵使
* * * * * * *

组别： 超级版主
帖子数量： 2695
用户编号： 377
注册时间： 2001年10月17日

Member 在线

引用 (yagas @ 2004年06月17日 21时51分)
用 inno 作用序列号？？
你还不如用专业点的工具呢

能否具体一点？

user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3249 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


问一个inno制作安装程序的问题

> 问一个inno制作安装程序的问题
bcff2002 | [楼主] 发帖时间 2004年07月08日 18时17分
骑士 * * 组别： 认证用户 帖子数量： 55 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 如何实现下面的功能：选择安装两个相同名字的文件，如aa.ocx，（其中一个文件功能受限制，另外一个文件全功能）在安装的时候默认安装其中一个受限文件，另一个全功能文件文件要想安装的话需要输入法密码或序列号。 输入法大全 http://www.bcff2002.com
bcff2002 | [第1楼] 发帖时间 2004年07月08日 21时25分
骑士 * * 组别： 认证用户 帖子数量： 55 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | tt 输入法大全 http://www.bcff2002.com
gnatix | [第2楼] 发帖时间 2004年07月09日 20时02分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 没有什么意义，因为打包到安装程序中的文件，一般都是可以解开的。如果真想要保护你的软件，还是想别的办法吧。 user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.2946 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


浅谈Inno Setup的一些小技巧

> 浅谈Inno Setup的一些小技巧, Inno Setup
snow365
[楼主] 发帖时间 2004年04月17日 15时03分

侠客
*

组别： 用户
帖子数量： 28
用户编号： 23611
注册时间： 2004年04月16日

Member 离线

小弟学习Inno Setup不久，有空的时候也到论坛来转转，现在把一些自己的小技巧整理出来，内容肤浅还请多指导：）

一、关于7-Zip的自解压后运行安装程序。在目前最新版本的Inno Setup中可以直接支持7-Zip，至于有些朋友问图一的压缩进程是如何制作的，其实很简单，它使用了ISTool 4.13，早期的Inno Setup不能直接支持7-Zip压缩，因此通过使用7-Zip的自解压实现，具体方法是在ISTool的Options-Complier-Compression中选择7-Zip方式，然后编译脚本就可以了。（注意：脚本中不可以有其他压缩的语句，使用该方式要保证计算机的内存在128M以上。推荐使用ISTool 4.13和晓文汉化的Inno Setup 4.0.10配合使用，太新的版本就不兼容了，ISTool如果下载不到4.13可以下载汉化新世纪的4.0.8汉化版，不过需要自己设置参数了，还需要下载7-Zip，新世纪有刘继华汉化的最新3.13版本）

user posted image

二、如何在下方分界线左边增加“XX工作室出品”的字样，如图二的红色方框内的字。这个问题曾经也捆饶了小弟很长时间，在帮助的[Setup]段中找遍了也没找到，后来问了刘波大哥，实际上非常简单，在[Messages]段中使用“BeveledLabel=你要的文字”就可以实现了，正所谓难者不会会者不难啊，呵呵！因此大家还是要多看帮助文件，特别是莫名大哥已经把帮助文件全汉化成了中文，真的很感谢！

user posted image

三、制作的安装程序在安装的时候实现下载。例如在木子版的QQ安装程序中，就可以在安装的时候实现下载最新的IP数据库，实现办法是通过ISX Download DLL做到的，这个DLL可以在官方站点下载，并有样本脚本供参考，里面说的很详细，小弟就不多罗嗦了。

四、Inno Setup生成制作程序的外观（图三）。一般默认情况下都是标准的界面，如果想定制个性界面，还要花点工夫，例如增加安装背景，使用自定义的安装图片，增加“关于”按钮，增加闪屏（Splash）等等。安装背景可以在BackColor、BackColor2、BackColorDirection、BackSolid多个语句中实现；使用自定义的安装图片最简单的办法是替换Inno Setup安装目录中WizModernImage.bmp和WizModernSmallImage.bmp两个文件；增加“关于”按钮请参见Example目录下的CodeClasses.iss样本脚本；至于闪屏的制作，目前还没有发现比较好的工具，汉化新世纪是通过3721的工具实现的，我想应该也有其他工具可以做到的，只是小弟目前还没有发现，如果大家找到了记得通知小弟一声哦：）

user posted image

最后给刚学习Inno Setup的朋友一点小建议，刚开始的时候最好使用Inno脚本向导，看看生成的最简单的脚本，多看看样本脚本和帮助文件。熟悉一点之后使用ISTool，该软件也自带简体中文，很好用（可惜汉化的不全也不太好，最好哪位大哥汉化一下最新版本，呵呵），可以掌握更多进阶脚本的使用。平时遇到问题多向别人请教，多到论坛转转，当然，最好自己先试着解决。相信很快你就能掌握Inno Setup这个优秀的工具。

感谢晓文，刘波，莫名制作的汉化版本，小弟也是在不断学习中，希望能得到大峡们的指点，也希望能和我一样学习中的朋友多多交流，我的E-mail是netwg@21cn.com。不过最近忙着毕业找工作，可能回信慢一点，见谅：）

附上相关站点：
1、Inno Setup 官方站点 -- www.innosetup.com
2、ISTool 官方站点 -- www.istool.org
3、Inno Setup 处理程序站点 -- ispp.sourceforge.net
4、Inno Setup Pascal 脚本站点 -- www.carlo-kok.com/ifps3.php
5、7-Zip 官方站点 -- www.7-zip.org

雪季射手/snow365

user posted image
bcff2002 | [第1楼] 发帖时间 2004年04月17日 15时22分
侠客 * 组别： 认证用户 帖子数量： 49 用户编号： 22017 注册时间： 2004年03月06日 Member 离线 | 谢谢 输入法大全 http://www.bcff2002.com
chenmy | [第2楼] 发帖时间 2004年04月17日 16时47分
天使 * * * * * * 组别： 超级版主 帖子数量： 1380 用户编号： 1794 注册时间： 2002年04月28日 Member 离线 | 最新的版本，已经默认使用 7-Zip 压缩了（内置）。 我爱自然之家！—我爱汉化！ user posted image user posted image 我是中国人·最爱是中文！ user posted image
刘波 | [第3楼] 发帖时间 2004年04月17日 18时35分
版主 * * * * * 组别： 认证用户 帖子数量： 623 用户编号： 691 注册时间： 2001年12月27日 Member 离线 | Splasher 3.0 可以添加闪屏，世纪有下载的。 欢迎来到汉化新世纪论坛之分论坛游戏天地 user posted image
HYQ9 | [第4楼] 发帖时间 2004年04月17日 19时42分
精灵王 * * * * 组别： 认证用户 帖子数量： 517 用户编号： 22209 注册时间： 2004年03月12日 Member 离线 | 嗯，看样子不错！ 中国人，用中文，做中文程序！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.3084 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


如何使用“Inno Setup” 制作屏保的安装程序？

> 如何使用“Inno Setup” 制作屏保的安装程序？
订阅此主题 | 邮寄此主题 | 打印此主题
Sonny-Girl | [楼主] [image] 发帖时间 2004年03月26日 11时43分
圣骑士 * * * 组别： 认证用户 帖子数量： 117 用户编号： 17385 注册时间： 2003年09月11日 Member 离线 | 如何使用“Inno Setup” 制作的屏保安装程序，在安装完成后能够调出“显示属性”设置啊？ 附图 附图 保护钓鱼岛是每个中国人应尽的义务！ 抵制日货是每个中国公民的神圣职责！ user posted image
gnatix | [第1楼] 发帖时间 2004年03月26日 13时28分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 安装完后运行： Rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1 就行了。比如： [Run] Filename: "Rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1"; Description: "启动屏幕保护设置程序"; Flags: nowait postinstall skipifsilent user posted image
Sonny-Girl | [第2楼] 发帖时间 2004年03月29日 13时12分
圣骑士 * * * 组别： 认证用户 帖子数量： 117 用户编号： 17385 注册时间： 2003年09月11日 Member 离线 | 谢谢啦。。。！我试试看。。。 保护钓鱼岛是每个中国人应尽的义务！ 抵制日货是每个中国公民的神圣职责！ user posted image
gnatix | [第3楼] 发帖时间 2004年03月30日 14时57分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 〖纠正〗 脚本语句应该是： [Run] Filename: "Rundll32.exe"; Parameters: "shell32.dll,Control_RunDLL desk.cpl,,1"; Description: "启动屏幕保护设置程序"; Flags: nowait postinstall skipifsilent user posted image
Sonny-Girl | [第4楼] 发帖时间 2004年03月31日 10时50分
圣骑士 * * * 组别： 认证用户 帖子数量： 117 用户编号： 17385 注册时间： 2003年09月11日 Member 离线 | 版主您纠正的脚本语句我还没有试过，不过您前面的语句存在问题？按“Win+R”运行“Rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1”可调出屏保的设置属性窗口，但是在“Inno Setup 4”中加此脚本语句却会出现一个错误窗口，提示如下： 未能执行文件：Rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1 CreateProcess 失败；代码 2 系统找不到指定的文件。 有些屏保安装程序在安装完成后，调出此窗口时的“屏幕保护程序”选择窗口所选中的正好是所安装的屏保，我在用“Win+R”运行“Rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1”此代码所选中的是空白，是不是要指定屏保文件的完整路径啊？ 保护钓鱼岛是每个中国人应尽的义务！ 抵制日货是每个中国公民的神圣职责！ user posted image
Sonny-Girl | [第5楼] 发帖时间 2004年03月31日 10时55分
圣骑士 * * * 组别： 认证用户 帖子数量： 117 用户编号： 17385 注册时间： 2003年09月11日 Member 离线 | 顺便问一下版主，在个人签名中可否使用.swf格式的文件啊？如何加入？ 谢谢。。。！ 保护钓鱼岛是每个中国人应尽的义务！ 抵制日货是每个中国公民的神圣职责！ user posted image
gnatix
[第6楼] 发帖时间 2004年03月31日 13时26分

天使
* * * * * *

组别： 超级版主
帖子数量： 2407
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (Sonny-Girl @ 2004年03月31日 10时50分)
版主您纠正的脚本语句我还没有试过，不过您前面的语句存在问题？按“Win+R”运行“Rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1”可调出屏保的设置属性窗口，但是在“Inno Setup 4”中加此脚本语句却会出现一个错误窗口，提示如下：

未能执行文件：Rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1
CreateProcess 失败；代码 2
系统找不到指定的文件。

有些屏保安装程序在安装完成后，调出此窗口时的“屏幕保护程序”选择窗口所选中的正好是所安装的屏保，我在用“Win+R”运行“Rundll32.exe shell32.dll,Control_RunDLL desk.cpl,,1”此代码所选中的是空白，是不是要指定屏保文件的完整路径啊？

在 Inno Setup 脚本中必须把命令行的程序名和参数分开来写。
按照修正后的格式写，应该没有问题。

另外：这个命令只是启动系统的屏保设置程序（你提的问题就是这个 [image] ），并不是帮你选择某个屏幕保护程序。如果你希望安装后自动把屏保程序选定为你所安装的那个，可以用以下方法（全用 Inno Setup 实现）。

user posted image
gnatix | [第7楼] 发帖时间 2004年03月31日 14时16分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 要自动选定你自己安装的屏保，可以使用： [Registry] Root: HKCU; Subkey: "Control Panel\Desktop"; ValueName: "SCRNSAVE.EXE"; ValueType: string; ValueData: "{sys}\YourScrnSaver.scr" user posted image
Sonny-Girl | [第8楼] 发帖时间 2004年04月02日 10时06分
圣骑士 * * * 组别： 认证用户 帖子数量： 117 用户编号： 17385 注册时间： 2003年09月11日 Member 离线 | 非常谢谢版主您。。。感谢啦。。。。！ ：-） 保护钓鱼岛是每个中国人应尽的义务！ 抵制日货是每个中国公民的神圣职责！ user posted image
Sonny-Girl
[第9楼] 发帖时间 2004年04月04日 09时53分

圣骑士
* * *

组别： 认证用户
帖子数量： 117
用户编号： 17385
注册时间： 2003年09月11日

Member 离线

引用 (gnatix @ 2004年03月31日 14时16分)
要自动选定你自己安装的屏保，可以使用：

[Registry]
Root: HKCU; Subkey: "Control PanelDesktop"; ValueName: "SCRNSAVE.EXE"; ValueType: string; ValueData: "{sys}YourScrnSaver.scr"

版主。。。您说全用“Inno Setup 4”的此脚本，可是没有用啊？

我试用过一点反应也没有啊？我把屏保文件安装到{win}中，同时脚本注册值中也指向{win}也没有用啊？可能是什么问题呀！

说明一点：YourScrnSaver.scr=我要安装的屏保文件名，这里我也已改！

有没有可能与操作系统有关系啊？我安装的是 Windows 2000 Pro 版本。期望版主能给予帮助。。。！谢谢。。。！

保护钓鱼岛是每个中国人应尽的义务！
抵制日货是每个中国公民的神圣职责！
user posted image
gnatix
[第10楼] 发帖时间 2004年04月04日 13时28分

天使
* * * * * *

组别： 超级版主
帖子数量： 2407
用户编号： 377
注册时间： 2001年10月17日

Member 离线

引用 (Sonny-Girl @ 2004年04月04日 09时53分)
我试用过一点反应也没有啊？我把屏保文件安装到{win}中，同时脚本注册值中也指向{win}也没有用啊？可能是什么问题呀！

说明一点：YourScrnSaver.scr=我要安装的屏保文件名，这里我也已改！

有没有可能与操作系统有关系啊？我安装的是 Windows 2000 Pro 版本。期望版主能给予帮助。。。！谢谢。。。！ [/color]

那个注册表设置只是选定你的默认屏保，对外是看不出有什么反应的。你检查一下默认屏保是否真的被更改就知道了。如果你要打开那个“显示属性”的设置程序，那么还是要用[Run]里面的那个语句。

user posted image
gnatix | [第11楼] 发帖时间 2004年04月04日 15时43分
天使 * * * * * * 组别： 超级版主 帖子数量： 2407 用户编号： 377 注册时间： 2001年10月17日 Member 离线 | 又测试了一下。通过注册表选定默认屏保后，启动“显示属性”时会显示“无”，虽然屏保的确是更改了。 目前还不知道为什么是这样。 user posted image
Sonny-Girl | [第12楼] 发帖时间 2004年04月05日 09时57分
圣骑士 * * * 组别： 认证用户 帖子数量： 117 用户编号： 17385 注册时间： 2003年09月11日 Member 离线 | 在运行中添加下列语句，启动“显示属性”的同时会选定“无”......？ [Run] Filename: "Rundll32.exe"; Parameters: "shell32.dll,Control_RunDLL desk.cpl,,1"; Description: "启动屏幕保护设置程序"; Flags: nowait postinstall skipifsilent 但在注册表中添加下列语句，并配合上面的“运行”脚本语句，能启动“显示属性”，但不会指向所安装的屏保？ 不会是“Inno Setup 4”不支持此功能吧？ [Registry] Root: HKCU; Subkey: "Control PanelDesktop"; ValueName: "SCRNSAVE.EXE"; ValueType: string; ValueData: "{sys}YourScrnSaver.scr" 版主，您对“Inno Setup ”的了解，肯定多过我很多，还是很希望您有时间的话，帮忙研究一下。。。！解决这个问题。。。好吗。。。？ 谢谢。。。！ 保护钓鱼岛是每个中国人应尽的义务！ 抵制日货是每个中国公民的神圣职责！ user posted image
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.9654 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


如何用 Inno Setup 制做输入法安装包？

> 如何用 Inno Setup 制做输入法安装包？
订阅此主题 | 邮寄此主题 | 打印此主题
chengbing | [楼主] [image] 发帖时间 2004年03月23日 16时30分
新手上路 * 组别： 用户 帖子数量： 4 用户编号： 12931 注册时间： 2003年03月30日 Member 离线 | 输入法本身的相关文件已经完成。 希望使用inno制做安装包 希望实现输入法安装完成后，不需要重启机器，就能使用该输入法！ 有没有编过输入法的大侠提供inno脚本借鉴一下！
pk4321 | [第1楼] 发帖时间 2004年03月23日 17时22分
圣骑士 * * * 组别： 认证用户 帖子数量： 151 用户编号： 770 注册时间： 2002年01月10日 Member 离线 | 我也想知道！
liangjh | [第2楼] 发帖时间 2004年03月23日 20时06分
精灵王 * * * * 组别： 认证用户 帖子数量： 299 用户编号： 11213 注册时间： 2003年02月19日 Member 离线 | 我没有做过，不过给你一个建议，找一个输入法，比如拼音加加，用wise install system监视安装，改一改就可能搞定 一尘不染，两袖清风！
briankuo
[第3楼] 发帖时间 2004年03月24日 09时37分

侠客
*

组别： 用户
帖子数量： 14
用户编号： 22320
注册时间： 2004年03月15日

Member 离线

在[Code]片段中加入以下的脚本:
[Code]
function InstallIME(sIMEFileName, sIMELayoutText: String): LongInt;
external 'ImmInstallIMEA@imm32.dll stdcall';
{定义一个InstallIME的函数，实际上是把ImmInstallIMEA这个WINDOWS API封装起来
其中IMEFileName参数是指*.ime文件的路径，IMELayoutText你所安装的输入法的名称}

{以下的过程讲会在你按下"上一步","下一步"按钮，切换当前步骤时发生}
procedure CurStepChanged(CurStep: Integer);
begin
if CurStep = csFinished then //如果当前步骤是"完成"则执行下面的动作
begin
InstallIME(expandConstant('{sys}\abc.IME'),'ABC输入法')
end;
end;
pk4321 | [第4楼] 发帖时间 2004年03月24日 10时00分
圣骑士 * * * 组别： 认证用户 帖子数量： 151 用户编号： 770 注册时间： 2002年01月10日 Member 离线 | 多谢楼上的指点！
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.6339 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 ? 汉化新世纪

IPB中文HyPER版 ? 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 ? 2003 IPS, Inc.


请教inno setup的问题

> 请教inno setup的问题
NeRd | [楼主] 发帖时间 2004年07月13日 20时19分
新手上路 * 组别： 用户 帖子数量： 5 用户编号： 27841 注册时间： 2004年07月13日 Member 离线 | 安装完成后强制重启动，或选择重启动还有强制注销和选择注销的脚本是什么啊？ AlwaysRestart=yes 询问是否重启找到了，怎么样强制重启或注销呢
gnatix | [第1楼] 发帖时间 2004年07月14日 13时43分
精灵使 * * * * * * * 组别： 超级版主 帖子数量： 2695 用户编号： 377 注册时间： 2001年10月17日 Member 在线 | 询问用户是否要重启动不是很好吗？ 如果一定要在安装完成后重启动机器，可以在 [RUN] 段加入相应的命令。98 下运行 RUNDLL32.EXE SHELL32.DLL,SHExitWindowsEx 就行了，在 2000 和 XP 一般要使用微软的外部命令程序 SHUTDOWN.exe 或者许多第三方软件。 user posted image
yxl0 | [第2楼] 发帖时间 2004年07月16日 20时00分
侠客 * 组别： 用户 帖子数量： 10 用户编号： 27961 注册时间： 2004年07月15日 Member 离线 | ding ☆爱 ║.....╔╬╗...◢◣◢◣ ☆ ★║★ ╚╬╝..【LOVE你】 ☆语 ╝....═╩═╝.◥██◤ ........︸︸﹊︸︸﹊︸ ◥◤ QQ 64890833
? 上一个主题 | 软件使用 | 下一个主题 ?

主题选项

下载/打印此主题
下载或者查看此主题的不同格式的可打印版本。

[ 程序执行时间： 0.2807 秒 ] [ 数据库查询： 12 次 ] [ GZIP 开启 ]

版权所有 © 汉化新世纪

IPB中文HyPER版 © 2003 FreeIPB.COM
Powered by Invision Power Board(U) v1.2 © 2003 IPS, Inc.


; 汉化新世纪论坛原文件地址：
; http://bbs.hanzify.org/index.php?showtopic=23507&hl=editplus
; 脚本用 Inno Setup 脚本向导生成。
; 查阅文档获取创建 INNO SETUP 脚本文件详细资料!

[Setup]
AppName=Editplus 2.12 build 97
AppVerName=Editplus 2.12 build 97
AppPublisher=www
AppPublisherURL=http://www.Editplus.com
AppSupportURL=http://www.Editplus.com
AppUpdatesURL=http://www.Editplus.com
DefaultDirName={pf}\Editplus 2
DefaultGroupName=Editplus 2
Compression=lzma
SolidCompression=yes
OutputBaseFilename=Editplus2.12
LicenseFile=汉化说明.txt
[Tasks]
; 注意: 下面的条目包含一个中文用语 (“创建桌面快捷方式”和“添加快捷方式”)。如果需要你可以翻译为其它语言。
Name: "desktopicon"; Description: "创建桌面快捷方式"; GroupDescription: "添加快捷方式:"; Flags: unchecked
; 注意: 下面的条目包含一个中文用语 (“创建快速运行栏快捷方式”和“添加快捷方式”)。如果需要你可以翻译为其它语言。
Name: "quicklaunchicon"; Description: "创建快速运行栏快捷方式"; GroupDescription: "添加快捷方式:"; Flags: unchecked

[Files]
Source: "d:\Editplus 2\EDITPLUS.EXE"; DestDir: "{app}"; Flags: ignoreversion
Source: "d:\Editplus 2\*"; DestDir: "{app}"; Flags: restartreplace ignoreversion overwritereadonly recursesubdirs
; 注意: 不要在任何共享系统文件中使用“Flags: ignoreversion”
Source: "d:\Editplus 2\editplus.ini"; DestDir: "{app}"; Flags: promptifolder confirmoverwrite

[Icons]
Name: "{group}\Editplus 2"; Filename: "{app}\EDITPLUS.EXE"
Name: "{group}\卸载Editplus 2"; Filename: "{uninstallexe}"
Name: "{userdesktop}\Editplus 2"; Filename: "{app}\EDITPLUS.EXE"; Tasks: desktopicon
Name: "{userappdata}\Microsoft\Internet Explorer\Quick Launch\Editplus 2"; Filename: "{app}\EDITPLUS.EXE"; Tasks: quicklaunchicon

[Run]
; 注意: 下列条目包含一个中文用语 (“运行”)。如果需要你可以翻译为其它语言。
Filename: "{app}\EDITPLUS.EXE"; Description: "运行 Editplus 2"; Flags: nowait postinstall skipifsilent

[Messages]
BeveledLabel=www.Editplus.com

[Registry]
Root: HKCR; Subkey: *\shellex\ContextMenuHandlers\EditPlus; ValueType: string;ValueName: ""; ValueData: {{63AFBDFB-5EF8-4791-AF79-9A3C0DE48974}; Flags: uninsdeletekey
Root: HKCR; Subkey: .htm\OpenWithList\EditPlus 2; ValueType: string; ValueName: "";ValueData: EditPlus 2; Flags: uninsdeletekey
Root: HKCR; Subkey: .htm\OpenWithList\EditPlus 2\shell\edit\command; ValueType: string; ValueName: "";ValueData: "{app}\EDITPLUS.EXE  ""%%1 """; Flags: uninsdeletekey
Root: HKCR; Subkey: .htm\OpenWithList\EditPlus 2\shell\edit\ddeexec; ValueType: string; ValueName: "";ValueData: "[open(""%1"")]"; Flags: uninsdeletekey
Root: HKCR; Subkey: CLSID\{{63AFBDFB-5EF8-4791-AF79-9A3C0DE48974}\InProcServer32; ValueType: string; ValueName: "";ValueData: {app}\eppshell.dll; Flags: uninsdeletekey
Root: HKCR; Subkey: CLSID\{{63AFBDFB-5EF8-4791-AF79-9A3C0DE48974}\InProcServer32; ValueType: string; ValueName: ThreadingModel;ValueData: Apartment; Flags: uninsdeletekey
Root: HKCR; Subkey: CLSID\{{63AFBDFB-5EF8-4791-AF79-9A3C0DE48974}; ValueType: string; ValueName: "";ValueData: EditPlus Context Menu Handler; Flags: uninsdeletekey

Root: HKLM; SubKey: SOFTWARE\ES-Computing\EditPlus 2\Install; ValueType: dword; ValueName: Install 2.1; ValueData: $000008db
Root: HKLM; SubKey: SOFTWARE\ES-Computing\EditPlus 2\Install; ValueType: binary; ValueName: License; ValueData: db 89 29 18 01 5e 0c 5e 78 9c e3 74 2b 4a 4d 55 28 2d 4e 2d 92 35 35 b3 30 73 d1 35 34 32 b1 34 d0 75 76 0e b2 30 d0 75 35 f1 37 b7 d0 75 34 0e 72 76 05 00 d9 c5 0a 1e
Root: HKCU; SubKey: Software\ES-Computing\EditPlus 2\Install; ValueType: binary; ValueName: License; ValueData: db 89 29 18 01 5e 0c 5e 78 9c e3 74 2b 4a 4d 55 28 2d 4e 2d 92 35 35 b3 30 73 d1 35 34 32 b1 34 d0 75 76 0e b2 30 d0 75 35 f1 37 b7 d0 75 34 0e 72 76 05 00 d9 c5 0a 1e


; 汉化新世纪论坛原文件地址：
; http://bbs.hanzify.org/index.php?showtopic=17878&st=15
; 脚本由 Inno Setup 脚本设计向导 创建。
; 有关创建 INNO SETUP 脚本的详情请查阅帮助文档！

[Setup]
DisableStartupPrompt=yes
Compression=lzma/max
SolidCompression=yes
;
AppName=TNT Screen Capture 2.01 汉化版
AppVerName=TNT Screen Capture 2.01 汉化版
DefaultDirName={pf}\TNT
DefaultGroupName=EC Software
InfoBeforeFile=F:\MyHanzify\TNT 2.01\upload\files\汉化说明.txt

[Tasks]
Name: "desktopicon"; Description: "创建桌面快捷方式(&D)"; GroupDescription: "添加快捷方式:"
Name: "quicklaunchicon"; Description: "创建快速运行栏快捷方式(&Q)"; GroupDescription: "添加快捷方式:"; Flags: unchecked

[Files]
Source: "F:\我的汉化\TNT 2.01\安装制作\文件\*.*"; DestDir: "{app}"; Flags: ignoreversion recursesubdirs

[INI]
Filename: "{app}\hanzify.url"; Section: "InternetShortcut"; Key: "URL"; String: "http://www.hanzify.org"

[Icons]
Name: "{userdesktop}\TNT 屏幕捕捉"; Filename: "{app}\TNT.exe"; Tasks: desktopicon
Name: "{userappdata}\Microsoft\Internet Explorer\Quick Launch\TNT 屏幕捕捉"; Filename: "{app}\TNT.exe"; Tasks: quicklaunchicon
Name: "{group}\TNT 屏幕捕捉"; Filename: "{app}\TNT.exe"
Name: "{group}\TNT 网页"; Filename: "{app}\TNT.url"
Name: "{group}\TNT 在线帮助(本地)"; Filename: "{app}\TNT.chm"
Name: "{group}\卸载 TNT Screen Capture 2.01 汉化版"; Filename: "{uninstallexe}"

[Run]
Filename: "{app}\TNT.exe"; Description: "运行 TNT Screen Capture 2.01 汉化版"; Flags: nowait postinstall skipifsilent
Filename: "{app}\hanzify.url"; Description: "访问汉化新世纪主页"; Flags: postinstall shellexec skipifsilent unchecked

[UninstallDelete]
Type: files; Name: "{app}\hanzify.url"


; 汉化新世纪论坛原文件地址：
; http://bbs.hanzify.org/index.php?showtopic=24046&hl=ultraedit
; 脚本用 Inno Setup 脚本向导生成。
; 查阅文档获取创建 INNO SETUP 脚本文件详细资料!

[Setup]
AppName=UltraEdit 8.20
AppVerName=UltraEdit 8.20
AppPublisher=IDM Co.ltd
AppPublisherURL=http://www.idm.com
AppSupportURL=http://www.idm.com
AppUpdatesURL=http://www.idm.com
DefaultDirName={pf}\UltraEdit
DefaultGroupName=UltraEdit
Compression=lzma
SolidCompression=yes
OutputBaseFilename=UEdit8.20

[Tasks]
; 注意: 下面的条目包含一个中文用语 (“创建桌面快捷方式”和“添加快捷方式”)。如果需要你可以翻译为其它语言。
Name: "desktopicon"; Description: "创建桌面快捷方式"; GroupDescription: "添加快捷方式:"; Flags: unchecked
; 注意: 下面的条目包含一个中文用语 (“创建快速运行栏快捷方式”和“添加快捷方式”)。如果需要你可以翻译为其它语言。
Name: "quicklaunchicon"; Description: "创建快速运行栏快捷方式"; GroupDescription: "添加快捷方式:"; Flags: unchecked

[Files]
Source: "D:\UltraEdit\Uedit32.exe"; DestDir: "{app}"; Flags: ignoreversion
Source: "D:\UltraEdit\*"; DestDir: "{app}"; Flags: replacesameversion overwritereadonly recursesubdirs
Source: "D:\UltraEdit\Uedit32.ini"; DestDir: "{app}"; Flags: promptifolder confirmoverwrite
Source: "D:\UltraEdit\wordfile.txt"; DestDir: "{app}"; Flags: promptifolder confirmoverwrite
; 注意: 不要在任何共享系统文件中使用“Flags: ignoreversion”

[Icons]
Name: "{group}\UltraEdit-32"; Filename: "{app}\Uedit32.exe"
Name: "{group}\卸载UltraEdit"; Filename: "{uninstallexe}"
Name: "{userdesktop}\UltraEdit"; Filename: "{app}\Uedit32.exe"; Tasks: desktopicon
Name: "{userappdata}\Microsoft\Internet Explorer\Quick Launch\UltraEdit"; Filename: "{app}\Uedit32.exe"; Tasks: quicklaunchicon

[Run]
; 注意: 下列条目包含一个中文用语 (“运行”)。如果需要你可以翻译为其它语言。
Filename: "{app}\Uedit32.exe"; Description: "运行 UltraEdit"; Flags: nowait postinstall skipifsilent

[Registry]
Root: HKCR; Subkey: *\shellex\ContextMenuHandlers\UltraEdit-32; ValueType: string;ValueName: ""; ValueData: {{b5eedee0-c06e-11cf-8c56-444553540000}; Flags: uninsdeletekey
Root: HKCR; Subkey: .htm\OpenWithList\UltraEdit 32; ValueType: string; ValueName: "";ValueData: UltraEdit-32; Flags: uninsdeletekey
Root: HKCR; Subkey: .htm\OpenWithList\UltraEdit 32\shell\edit\command; ValueType: string; ValueName: "";ValueData: "{app}\Uedit32.exe  ""%%1 """; Flags: uninsdeletekey
Root: HKCR; Subkey: .htm\OpenWithList\UltraEdit-32 Professional Text/HEX Editor\shell\edit\command; ValueType: string; ValueName: "";ValueData: "{app}\UEDIT32.EXE ""%1"""; Flags: uninsdeletekey
Root: HKCR; Subkey: .htm\OpenWithList\UltraEdit-32 Professional Text/HEX Editor\shell\edit\ddeexec; ValueType: string; ValueName: "";ValueData: "[open(""%1"")]"; Flags: uninsdeletekey
Root: HKCR; Subkey: .htm\OpenWithList\UltraEdit-32 Professional Text/HEX Editor\shell\edit\ddeexec\Application; ValueType: string; ValueName: "";ValueData: UEDIT32; Flags: uninsdeletekey
Root: HKCR; Subkey: .htm\OpenWithList\UltraEdit-32 Professional Text/HEX Editor\shell\edit\ddeexec\topic; ValueType: string; ValueName: "";ValueData: System; Flags: uninsdeletekey
Root: HKCR; Subkey: CLSID\{{b5eedee0-c06e-11cf-8c56-444553540000}\InProcServer32; ValueType: string; ValueName: "";ValueData: {app}\ue32ctmn.dll; Flags: uninsdeletekey
Root: HKCR; Subkey: CLSID\{{b5eedee0-c06e-11cf-8c56-444553540000}\InProcServer32; ValueType: string; ValueName: ThreadingModel;ValueData: Apartment; Flags: uninsdeletekey
Root: HKCR; Subkey: CLSID\{{b5eedee0-c06e-11cf-8c56-444553540000}; ValueType: string; ValueName: "";ValueData: UltraEdit; Flags: uninsdeletekey


; 汉化新世纪论坛原文件地址：
; http://bbs.hanzify.org/index.php?showtopic=20630&hl=translator
; 脚本由 Inno Setup 脚本设计向导 创建。
; 有关创建 INNO SETUP 脚本的详情请查阅帮助文档！

[Setup]
DisableStartupPrompt=yes
AppName=Ini Translator 1.7.0.3 + 官方简体中文语言文件
AppVerName=Ini Translator 1.7.0.3
DefaultDirName={pf}\Ini Translator
DefaultGroupName=Ini Translator
InfoBeforeFile=F:\MyHanzify\Ini Translator\upload\files\汉化说明.txt

[Tasks]
Name: "desktopicon"; Description: "创建桌面快捷方式"; GroupDescription: "添加快捷方式:"
Name: "quicklaunchicon"; Description: "创建快速运行栏快捷方式"; GroupDescription: "添加快捷方式:"; Flags: unchecked
Name: "LNGASSOCIATE"; Description: "关联 .LNG 文件"; GroupDescription: "添加文件关联:"
Name: "ISLASSOCIATE"; Description: "关联 .ISL 文件"; GroupDescription: "添加文件关联:"; Flags: unchecked
Name: "INIASSOCIATE"; Description: "关联 .INI 文件"; GroupDescription: "添加文件关联:"; Flags: unchecked

[Files]
Source: "F:\Ini Translator\upload\files\*.*"; DestDir: "{app}"; Flags: ignoreversion recursesubdirs
Source: "F:\MyLogoImage\tigerlogo.bmp"; DestDir: "{tmp}"; Flags: ignoreversion dontcopy

[INI]
Filename: "{app}\translator.ini"; Section: "Files"; Key: "LanguageFile"; String: "{app}\languages\Chinese.lng"
Filename: "{app}\translator.ini"; Section: "Files"; Key: "HelpFile"; String: "{app}\help\translator.chm"

[Icons]
Name: "{userdesktop}\Ini Translator"; Filename: "{app}\translator.exe"; WorkingDir: "{app}"; Tasks: desktopicon
Name: "{userappdata}\Microsoft\Internet Explorer\Quick Launch\Ini Translator"; Filename: "{app}\translator.exe"; WorkingDir: "{app}" ;Tasks: quicklaunchicon
Name: "{group}\运行 Ini Translator"; Filename: "{app}\translator.exe"; WorkingDir: "{app}"
Name: "{group}\Ini Translator 在线帮助"; Filename: "{app}\help\translator.chm"
Name: "{group}\卸载 Ini Translator"; Filename: "{uninstallexe}"

[Registry]
Root: HKCR; ValueType: String; Subkey: ".LNG"; ValueData: "LNGFILE"; Tasks: "LNGASSOCIATE"; Flags: uninsdeletekey
Root: HKCR; ValueType: String; Subkey: "LNGFILE"; ValueData: "语言文件"; Tasks: "LNGASSOCIATE"; Flags: uninsdeletekey
Root: HKCR; ValueType: String; Subkey: "LNGFILE\Shell\Open\Command"; ValueData: "{app}\translator.exe ""%1"""; Tasks: "LNGASSOCIATE"; Flags: uninsdeletekey
Root: HKCR; ValueType: String; Subkey: "LNGFILE\DefaultIcon"; ValueData: "{app}\translator.exe,0"; Tasks: "LNGASSOCIATE"; Flags: uninsdeletekey
Root: HKCR; ValueType: String; Subkey: ".ISL"; ValueData: "ISLFILES"; Tasks: "ISLASSOCIATE"; Flags: uninsdeletekey
Root: HKCR; ValueType: String; Subkey: "ISLFILES"; ValueData: "Inno Setup 语言文件"; Tasks: "ISLASSOCIATE"; Flags: uninsdeletekey
Root: HKCR; ValueType: String; Subkey: "ISLFILES\Shell\Open\Command"; ValueData: "{app}\translator.exe ""%1"""; Tasks: "ISLASSOCIATE"; Flags: uninsdeletekey
Root: HKCR; ValueType: String; Subkey: "ISLFILES\DefaultIcon"; ValueData: "{app}\translator.exe,0"; Tasks: "ISLASSOCIATE"; Flags: uninsdeletekey
Root: HKCR; ValueType: String; Subkey: ".INI"; ValueData: "INIFILES"; Tasks: "INIASSOCIATE"; Flags: uninsdeletekey
Root: HKCR; ValueType: String; Subkey: "INIFILES"; ValueData: "INI 设置文件"; Tasks: "INIASSOCIATE"; Flags: uninsdeletekey
Root: HKCR; ValueType: String; Subkey: "INIFILES\Shell\Open\Command"; ValueData: "{app}\translator.exe ""%1"""; Tasks: "INIASSOCIATE"; Flags: uninsdeletekey
Root: HKCR; ValueType: String; Subkey: "INIFILES\DefaultIcon"; ValueData: "{app}\translator.exe,0"; Tasks: "INIASSOCIATE"; Flags: uninsdeletekey

[Run]
Filename: "{app}\translator.exe"; WorkingDir: "{app}"; Description: "运行 Ini Translator 1.7.0.3"; Flags: nowait postinstall skipifsilent

[Code]
procedure InitializeWizard();
var
  SplashImage: TBitmapImage;
  SplashForm: TForm;
  SplashFileName: String;
  I : Integer;
begin

  SplashFileName := ExpandConstant('{tmp}\tigerlogo.bmp');
  ExtractTemporaryFile(ExtractFileName(SplashFileName));

  SplashForm := TForm.create(nil);
  with SplashForm do
   begin
    BorderStyle := bsNone;
    Position := poScreenCenter;
    ClientWidth := 250;
    ClientHeight := 236;
   end;

  SplashImage := TBitmapImage.Create(SplashForm);
  with SplashImage do
    begin
    Bitmap.LoadFromFile(SplashFileName);
    Stretch := true;
    Align := alClient;
    Parent := SplashForm;
    end;

  with SplashForm do
   begin
     Show;
     for I := 1 to 2 do
      begin
       Repaint;
       Sleep(1000);
      end;
     Close;
     Free;
   end;
end;


; 汉化新世纪论坛原文件地址：
; http://bbs.hanzify.org/index.php?showtopic=23229
; 脚本由 Inno Setup 脚本设计向导 创建。
; 有关创建 INNO SETUP 脚本的详情请查阅帮助文档！

[Setup]
DisableStartupPrompt=yes
AppName=Neat Image 4.0 Pro+ 汉化破解版
AppVerName=Neat Image 4.0 Pro+ 汉化破解版
DefaultDirName={pf}\Neat Image
DefaultGroupName=Neat Image 4.0 Pro+ 汉化版
InfoBeforeFile=F:\汉化\NeatImage 4.0\汉化说明.txt

[Tasks]
Name: "desktopicon"; Description: "桌面快捷方式"; GroupDescription: "添加快捷方式:"
Name: "quicklaunchicon"; Description: "快速运行栏快捷方式"; GroupDescription: "添加快捷方式:"; Flags: unchecked
Name: "sendtoicon"; Description: "发送到快捷方式"; GroupDescription: "添加快捷方式:"

[Files]
Source: "F:\汉化\NeatImage 4.0\\*.*"; DestDir: "{app}"; Flags: ignoreversion recursesubdirs
Source: "F:\汉化\共用文件\tigerlogo.bmp"; DestDir: "{tmp}"; Flags: ignoreversion dontcopy
Source: "F:\汉化\共用文件\music.mid"; DestDir: "{tmp}"; Flags: ignoreversion dontcopy

[Icons]
Name: "{userdesktop}\Neat Image 4.0 Pro+ 汉化版"; Filename: "{app}\NeatImage.exe"; Tasks: desktopicon; workingdir: "{app}"
Name: "{userappdata}\Microsoft\Internet Explorer\Quick Launch\Neat Image 4.0"; Filename: "{app}\NeatImage.exe"; Tasks: quicklaunchicon; workingdir: "{app}"
Name: "{sendto}\Neat Image 4.0"; Filename: "{app}\NeatImage.exe"; Tasks: sendtoicon; workingdir: "{app}"
;
Name: "{group}\运行 Neat Image 4.0 Pro+ 汉化版"; Filename: "{app}\NeatImage.exe"; workingdir: "{app}"
Name: "{group}\卸载 Neat Image 4.0 Pro+ 汉化版"; Filename: "{uninstallexe}"

[Registry]
Root: HKCU; Subkey: "Software\ABSoft\NeatImage"; Flags: deletekey
Root: HKCU; Subkey: "Software\ABSoft\NeatImage"; Flags: uninsdeletekey

[Run]
Filename: "{app}\NeatImage.exe"; Description: "运行 Neat Image 4.0 Pro+ 汉化版"; Flags: nowait postinstall skipifsilent

[Code]
function mciSendString(lpszCommand: String; lpszReturnString: Integer; cchReturnLength: Integer; hwndCallback: Integer): Integer;
external 'mciSendStringA@winmm.dll stdcall';

procedure InitializeWizard();
var
 SplashImage: TBitmapImage;
 GnatixInfo: TLabel;
 SplashForm: TForm;
 SplashFileName: String;
 I: Integer;
begin
 WizardForm.BeveledLabel.Enabled:= True;
 WizardForm.BeveledLabel.Font.Color:= $00C59016;
 WizardForm.BeveledLabel.Top:= WizardForm.BeveledLabel.Top+3;

 SplashFileName := ExpandConstant('{tmp}\tigerlogo.bmp');
 ExtractTemporaryFile(ExtractFileName(SplashFileName));
 ExtractTemporaryFile(ExtractFileName(ExpandConstant('{tmp}\music.mid')));

 SplashForm := TForm.create(nil);
 with SplashForm do
  begin
   BorderStyle := bsNone;
   Position := poScreenCenter;
   ClientWidth := 250;
   ClientHeight := 236;
   Color:= $00E7AD29;
  end;

 SplashImage := TBitmapImage.Create(SplashForm);
 GnatixInfo := TLabel.Create(SplashForm);
 with SplashImage do
   begin
   Bitmap.LoadFromFile(SplashFileName);
   Stretch := true;
   Align := alClient;
   Parent := SplashForm;
   end;

 with GnatixInfo do
   begin
   Left := 176;
   Top := 215;
   Caption :='请稍候...';
   Parent := SplashForm;
   Font.Name:= '宋体';
   Font.Height:= -14;
   Font.Style:= [fsBold];
   Font.Color:= clWhite;
   end;

 with SplashForm do
  begin
    Show;
    for I := 1 to 6 do
     begin
      Repaint;
      if I mod 2 = 0 then
       gnatixinfo.visible:= true
      else
       gnatixinfo.visible:= false;
      Sleep(500);
     end;
    mciSendString(ExpandConstant('play {tmp}\music.mid'),0,0,0);
    Close;
    Free;
  end;

end;


; 脚本由 Inno Setup 脚本设计向导 创建。
; 有关创建 INNO SETUP 脚本的详情请查阅帮助文档！

[Setup]
DisableStartupPrompt=yes
AppName=HelpScribble 7.20 汉化零售版
AppVerName=HelpScribble 7.20 汉化零售版
DefaultDirName={pf}\JGsoft\HelpScribble
DefaultGroupName=HelpScribble 7.20 汉化版
InfoBeforeFile=E:\MyHanzify\HelpScribble 7.20 Retail\upload\files\汉化说明.txt
;LicenseFile=E:\MyHanzify\HelpScribble 7.20 Retail\upload\files\LICENSE.txt

[Tasks]
Name: "desktopicon"; Description: "桌面上创建一个图标(&D)"; GroupDescription: "添加图标："

[Files]
Source: "E:\MyHanzify\HelpScribble 7.20 Retail\upload\files\*.*"; DestDir: "{app}"; Flags: ignoreversion
Source: "E:\MyHanzify\HelpScribble 7.20 Retail\upload\files\compiler\*.*"; DestDir: "{app}\Compiler"; Flags: ignoreversion
Source: "E:\MyHanzify\HelpScribble 7.20 Retail\upload\files\示例\*.*"; DestDir: "{app}\示例"; Flags: ignoreversion recursesubdirs
;Source: "E:\MyHanzify\HelpScribble 7.20 Retail\upload\files\dictionaries\*.*"; DestDir: "{pf}\JGsoft\Dictionaries"; Flags: ignoreversion

[Icons]
Name: "{group}\运行 HelpScribble 7.20 汉化版"; Filename: "{app}\HelpScr.exe"
Name: "{group}\卸载 HelpScribble 7.20 汉化版"; Filename: "{uninstallexe}"
Name: "{userdesktop}\HelpScribble 汉化版"; Filename: "{app}\HelpScr.exe"; Tasks: desktopicon

[Registry]
; Shell for HSC file association
Root: HKCR; Subkey: "hscfile"; ValueType: string; ValueData: "HelpScribble 方案"
Root: HKCR; Subkey: "hscfile\DefaultIcon"; ValueType: string; ValueData: "{app}\HelpScr.exe,0"
Root: HKCR; Subkey: "hscfile\Shell\Open\command"; ValueType: string; ValueData: """{app}\HelpScr.exe"" ""%1"""
Root: HKLM; Subkey: "SOFTWARE\JGsoft\HelpScribble"; ValueType: binary; ValueName: "Key"; ValueData: "65 84 a8 3f 29 e8 28 24 f0 55 2d 26 6d 41 f7 83 a4 c0 88 cd 34 c8 f9 96 2b c5 72 a9 da cb f9 7d c8 60 1a ff 26 c5 f9 ba 9e c3 43 da 2c 52 89 b0 71 01 98 0a a7 93 89 87 b5 b2 8d 0b 73 f2 42 0a 1c ec 14 57 8c f0 f1 f9 96 2e 82 01 40 c7 6d 3d 58 85 a6 40 44 82 b1 d0 74 92 c7 5f bd 59 3e a3 29 14 84 1c 3c e8 4f 04 91 fc d4 81 e4 8a 88 02 9f 6e b0 77 2a 36 2b 7a 19 6d 50 25 86 25 d5 10 7c 6f d6 3c a6 7d de d1 7b 35 53 00 c9 8e 26 8b 96 3b 2a 91 03 2b 3c ce 63 4e b1 16 d8 b6 f9 18 29 8f c4 ee e3 63 85 f3 ba 96 09 6c f1 0d 0b 19 d5 ce 64 ae 47 e3 0a 54 a7 af a4 61 5d be af 10 83 65 8c 95 1a 91 a0 bf b5 da dd 20 61 01 57 9f 4e 0b 95 43 7e 46 97 b4 01 54 fe 48 a9 3f 4f a2 f7 18 75 ad 5f e5 2b a5 e9 f8 fd c8 f3 06 d0 6d 0d 87 86 f9 56 0c 72 f1 e7 60 18 89 b3 b8 1f 02 c3 69 8f 78"
; Dictionaries
;Root: HKLM; Subkey: "SOFTWARE\JGsoft\Dictionaries"; ValueType: dword; ValueName: "Count"; ValueData: "1"
;Root: HKLM; Subkey: "SOFTWARE\JGsoft\Dictionaries"; ValueType: string; ValueName: "Files0"; ValueData: "American.dct"
;Root: HKLM; Subkey: "SOFTWARE\JGsoft\Dictionaries"; ValueType: string; ValueName: "IgnorePrefixes0"; ValueData: ";'"
;Root: HKLM; Subkey: "SOFTWARE\JGsoft\Dictionaries"; ValueType: string; ValueName: "IgnoreSuffixes0"; ValueData: ";';'s"
;Root: HKLM; Subkey: "SOFTWARE\JGsoft\Dictionaries"; ValueType: string; ValueName: "InstallPath"; ValueData: "{pf}\JGsoft\Dictionaries\"
;Root: HKLM; Subkey: "SOFTWARE\JGsoft\Dictionaries"; ValueType: string; ValueName: "Name0"; ValueData: "英语(美国)"
;
Root: HKCU; Subkey: "Software\JGsoft\HelpScribble\Compiler paths"; ValueType: string; ValueName: "HC31"; ValueData: "{app}\Compiler\HCP.EXE"
Root: HKCU; Subkey: "Software\JGsoft\HelpScribble\Compiler paths"; ValueType: string; ValueName: "HC31Sel"; ValueData: "{app}\Compiler\HCP.EXE"
Root: HKCU; Subkey: "Software\JGsoft\HelpScribble\Compiler paths"; ValueType: string; ValueName: "HC95"; ValueData: "{app}\Compiler\HCRTF.EXE"
Root: HKCU; Subkey: "Software\JGsoft\HelpScribble\Compiler paths"; ValueType: string; ValueName: "HC95Sel"; ValueData: "{app}\Compiler\HCRTF.EXE"
Root: HKCU; Subkey: "Software\JGsoft\HelpScribble\Compiler paths"; ValueType: string; ValueName: "HCHTML"; ValueData: "{app}\Compiler\HHC.EXE"
Root: HKCU; Subkey: "Software\JGsoft\HelpScribble\Compiler paths"; ValueType: string; ValueName: "HCHTMLSel"; ValueData: "{app}\Compiler\HHC.EXE"
Root: HKCU; Subkey: "Software\JGsoft\HelpScribble\Compiler paths"; ValueType: string; ValueName: "KWGen"; ValueData: ""
; Registry remove
Root: HKCR; Subkey: "hscfile"; Flags: uninsdeletekey
Root: HKLM; Subkey: "SOFTWARE\Classes\hscfile"; Flags: uninsdeletekey
Root: HKCU; Subkey: "Software\JGsoft"; Flags: uninsdeletekey
Root: HKLM; Subkey: "Software\JGsoft"; Flags: uninsdeletekey

[Run]
Filename: "{app}\HelpScr.exe"; Description: "运行 HelpScribble 7.20 汉化版"; Flags: nowait postinstall skipifsilent


; 汉化新世纪论坛原文件地址：
; http://bbs.hanzify.org/index.php?showtopic=18614&hl=番茄花园+stylexp+主题+n+合+1
; 脚本用 Inno Setup Script Wizard生成。
; 查阅文档获取创建 INNO SETUP 脚本文件详细资料!

[Setup]
AppName=番茄花园 StyleXP 主题 N 合 1
AppVerName=番茄花园 StyleXP 主题 N 合 1
AppPublisher=番茄花园
AppPublisherURL=http://bbs.tomato.ac.pn
AppSupportURL=http://bbs.tomato.ac.pn
AppUpdatesURL=http://bbs.tomato.ac.pn
DefaultDirName={pf}\番茄花园 StyleXP 主题13和1
DefaultGroupName=番茄花园 StyleXP 主题 N 合 1
AllowNoIcons=true
CreateAppDir=false
LicenseFile=E:\我的文档\My CDRW\Tomato Autorun\复件 番茄花园软件说明.rtf
InfoBeforeFile=C:\Documents and Settings\大番茄\桌面\ReadMe.rtf
UninstallFilesDir={win}\Resources\Themes
Compression=none
AppCopyright=番茄花园
InfoAfterFile=
Password=tomato
AppVersion=1.0
UninstallDisplayIcon={win}\Resources\Themes\People.ico
UninstallDisplayName=番茄花园 StyleXP 主题 N 合 1

[INI]
Filename: {win}\Resources\Themes\tomato.url; Section: InternetShortcut; Key: URL; String: http://bbs.tomato.ac.pn

[Files]
Source: XP主题系列\Artemis\*.*; DestDir: {win}\Resources\Themes\Artemis; Flags: ignoreversion recursesubdirs; Components: 深灰主题-Artemis
Source: XP主题系列\DameK UltraBlue\*.*; DestDir: {win}\Resources\Themes\DameK UltraBlue; Flags: ignoreversion recursesubdirs; Components: 淡蓝主题-DameKBlue
Source: XP主题系列\FADETO\*.*; DestDir: {win}\Resources\Themes\FADETO; Flags: ignoreversion recursesubdirs; Components: 浅灰主题-FADETO
Source: XP主题系列\OpusOS\*.*; DestDir: {win}\Resources\Themes\OpusOS; Flags: ignoreversion recursesubdirs; Components: OpusOS-灰色（番茄花园XP的主题）
Source: XP主题系列\OpusOSX\*.*; DestDir: {win}\Resources\Themes\OpusOSX; Flags: ignoreversion recursesubdirs; Components: OpusOSX-白色
Source: XP主题系列\PixOS\*.*; DestDir: {win}\Resources\Themes\PixOS; Flags: ignoreversion recursesubdirs; Components: 苹果主题-PIXOS
Source: XP主题系列\Plex Style\*.*; DestDir: {win}\Resources\Themes\Plex Style; Flags: ignoreversion recursesubdirs; Components: Plex_Style（Windows_Long_的2个蓝色主题）
Source: XP主题系列\QQ2004\*.*; DestDir: {win}\Resources\Themes\QQ2004; Flags: ignoreversion recursesubdirs; Components: QQ2004系列（QQ的4种主题）
Source: XP主题系列\RealOne\*.*; DestDir: {win}\Resources\Themes\RealOne; Flags: ignoreversion recursesubdirs; Components: RealOne主题
Source: XP主题系列\Slate\*.*; DestDir: {win}\Resources\Themes\Slate; Flags: ignoreversion recursesubdirs; Components: Slate（Windows_Long_的黑色主题）
Source: XP主题系列\sleekxp\*.*; DestDir: {win}\Resources\Themes\sleekxp; Flags: ignoreversion recursesubdirs; Components: 紫色主题-sleekxp
Source: XP主题系列\Sundaze\*.*; DestDir: {win}\Resources\Themes\Sundaze; Flags: ignoreversion recursesubdirs; Components: 嫩嫩的主题-Sundaze（推荐哦）
Source: XP主题系列\Tomato-Aqua\*.*; DestDir: {win}\Resources\Themes\Tomato-Aqua; Flags: ignoreversion recursesubdirs; Components: Aqua系列（4种经典发苹果电脑主题）
Source: tomato\*.*; DestDir: {win}\Cursors\tomato; Flags: ignoreversion recursesubdirs uninsneveruninstall
Source: WallPaper\*.*; DestDir: {win}\Web\Wallpaper; Flags: ignoreversion recursesubdirs uninsneveruninstall
Source: ReadMe.txt; DestDir: {win}\Resources\Themes; Flags: ignoreversion
; 注意: 不要在任何共享系统文件中使用“Flags: ignoreversion”

Source: Themes\深灰主题-Artemis.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: 深灰主题-Artemis
Source: Themes\淡蓝主题-DameKBlue.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: 淡蓝主题-DameKBlue
Source: Themes\浅灰主题-FADETO.Theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: 浅灰主题-FADETO
Source: Themes\Longhorn Plex M4 ICE.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: Plex_Style（Windows_Long_的2个蓝色主题）
Source: Themes\Longhorn Plex M4.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: Plex_Style（Windows_Long_的2个蓝色主题）
Source: Themes\longhorn-Slate-秋天.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: Slate（Windows_Long_的黑色主题）
Source: Themes\longhorn-Slate-春天.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: Slate（Windows_Long_的黑色主题）
Source: Themes\OpusOSX-白色.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: OpusOSX-白色
Source: Themes\OpusOS-灰色.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: OpusOS-灰色（番茄花园XP的主题）
Source: Themes\苹果主题-PIXOS.Theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: 苹果主题-PIXOS
Source: Themes\QQ 2004-黑色.Theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: QQ2004系列（QQ的4种主题）
Source: Themes\QQ 2004-金黄.Theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: QQ2004系列（QQ的4种主题）
Source: Themes\QQ 2004-蓝青.Theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: QQ2004系列（QQ的4种主题）
Source: Themes\QQ 2004-蓝色.Theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: QQ2004系列（QQ的4种主题）
Source: Themes\RealOne主题.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: RealOne主题
Source: Themes\紫色主题-sleekxp.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: 紫色主题-sleekxp
Source: Themes\嫩嫩的主题-Sundaze.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: 嫩嫩的主题-Sundaze（推荐哦）
Source: Themes\苹果主题-灰色.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: Aqua系列（4种经典发苹果电脑主题）
Source: Themes\苹果主题-金属灰色.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: Aqua系列（4种经典发苹果电脑主题）
Source: Themes\苹果主题-金属蓝色.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: Aqua系列（4种经典发苹果电脑主题）
Source: Themes\苹果主题-蓝色.theme; DestDir: {win}\Resources\Themes; Flags: ignoreversion; Components: Aqua系列（4种经典发苹果电脑主题）
Source: People.ico; DestDir: {win}\Resources\Themes; Flags: ignoreversion
Source: OEM\*.*; DestDir: {win}\system32; Flags: ignoreversion recursesubdirs; Components: OEM信息

Source: 桌面天气预报\*.*; DestDir: {win}\Resources\Themes\桌面天气预报; Flags: ignoreversion recursesubdirs; Components: 桌面天气预报
[Components]
Name: 桌面天气预报; Description: 桌面天气预报; Types: 完全安装 推荐安装
Name: OEM信息; Description: OEM信息; Types: 完全安装 推荐安装
Name: Aqua系列（4种经典发苹果电脑主题）; Description: Aqua系列（4种经典发苹果电脑主题）; Types: 完全安装 推荐安装
Name: Plex_Style（Windows_Long_的2个蓝色主题）; Description: Plex_Style（Windows Long 的2个蓝色主题）; Types: 完全安装 推荐安装
Name: 深灰主题-Artemis; Description: 深灰主题-Artemis; Types: 完全安装
Name: 淡蓝主题-DameKBlue; Description: 淡蓝主题-DameKBlue; Types: 完全安装
Name: 浅灰主题-FADETO; Description: 浅灰主题-FADETO; Types: 完全安装
Name: OpusOS-灰色（番茄花园XP的主题）; Description: OpusOS-灰色（番茄花园XP的主题）; Types: 完全安装 推荐安装
Name: OpusOSX-白色; Description: OpusOSX-白色; Types: 完全安装
Name: 苹果主题-PIXOS; Description: 苹果主题-PIXOS; Types: 完全安装 推荐安装
Name: QQ2004系列（QQ的4种主题）; Description: QQ2004系列（QQ的4种主题）; Types: 完全安装 推荐安装
Name: RealOne主题; Description: RealOne主题; Types: 完全安装 推荐安装
Name: Slate（Windows_Long_的黑色主题）; Description: Slate（Windows Long 的黑色主题）; Types: 完全安装 推荐安装
Name: 紫色主题-sleekxp; Description: 紫色主题-sleekxp; Types: 完全安装
Name: 嫩嫩的主题-Sundaze（推荐哦）; Description: 嫩嫩的主题-Sundaze（推荐哦）; Types: 完全安装 推荐安装

[Icons]

Name: {group}\StyleXP主题系列说明文件; Filename: {win}\Resources\Themes\ReadMe.txt
; 注意: 这下面程序自动生成的中文字符 "主页" 。如果有需要的话，你可以将其翻译为任意一种语言。
Name: {group}\番茄花园主页; Filename: {win}\Resources\Themes\Tomato.url
; 注意: 这下面程序自动生成的中文字符 "卸载" 。如果有需要的话，你可以将其翻译为任意一种语言。
Name: {group}\卸载 番茄花园 StyleXP 主题13和1; Filename: {uninstallexe}; Components: 深灰主题-Artemis 淡蓝主题-DameKBlue 浅灰主题-FADETO OpusOSX-白色 苹果主题-PIXOS QQ2004系列（QQ的4种主题） RealOne主题 Slate（Windows_Long_的黑色主题） 紫色主题-sleekxp Aqua系列（4种经典发苹果电脑主题） Plex_Style（Windows_Long_的2个蓝色主题） OpusOS-灰色（番茄花园XP的主题） 嫩嫩的主题-Sundaze（推荐哦）
Name: {group}\深灰主题-Artemis; Filename: {win}\Resources\Themes\深灰主题-Artemis.theme; Components: 深灰主题-Artemis
Name: {group}\淡蓝主题-DameKBlue; Filename: {win}\Resources\Themes\淡蓝主题-DameKBlue.theme; Components: 淡蓝主题-DameKBlue
Name: {group}\浅灰主题-FADETO; Filename: {win}\Resources\Themes\浅灰主题-FADETO.Theme; Components: 浅灰主题-FADETO
Name: {group}\OpusOS-灰色（番茄花园XP主题）; Filename: {win}\Resources\Themes\OpusOS-灰色.theme; Components: OpusOS-灰色（番茄花园XP的主题）
Name: {group}\OpusOSX-白色; Filename: {win}\Resources\Themes\OpusOSX-白色.theme; Components: OpusOSX-白色
Name: {group}\苹果主题-PIXOS; Filename: {win}\Resources\Themes\苹果主题-PIXOS.Theme; Components: 苹果主题-PIXOS
Name: {group}\QQ 2004-黑色; Filename: {win}\Resources\Themes\QQ 2004-黑色.Theme; Components: QQ2004系列（QQ的4种主题）
Name: {group}\QQ 2004-金黄; Filename: {win}\Resources\Themes\QQ 2004-金黄.Theme; Components: QQ2004系列（QQ的4种主题）
Name: {group}\QQ 2004-蓝青; Filename: {win}\Resources\Themes\QQ 2004-蓝青.Theme; Components: QQ2004系列（QQ的4种主题）
Name: {group}\QQ 2004-蓝色; Filename: {win}\Resources\Themes\QQ 2004-蓝色.Theme; Components: QQ2004系列（QQ的4种主题）
Name: {group}\RealOne主题; Filename: {win}\Resources\Themes\RealOne主题.theme; Components: RealOne主题
Name: {group}\longhorn-Slate-秋天; Filename: {win}\Resources\Themes\longhorn-Slate-秋天.theme; Components: Slate（Windows_Long_的黑色主题）
Name: {group}\longhorn-Slate春天; Filename: {win}\Resources\Themes\llonghorn-Slate-春天.theme; Components: Slate（Windows_Long_的黑色主题）
Name: {group}\紫色主题-sleekxp; Filename: {win}\Resources\Themes\紫色主题-sleekxp.theme; Components: 紫色主题-sleekxp
Name: {group}\嫩嫩的主题-Sundaze（推荐）; Filename: {win}\Resources\Themes\嫩嫩的主题-Sundaze.theme; Components: 嫩嫩的主题-Sundaze（推荐哦）
Name: {group}\苹果主题-灰色; Filename: {win}\Resources\Themes\苹果主题-灰色.theme; Components: Aqua系列（4种经典发苹果电脑主题）
Name: {group}\苹果主题-金属灰色; Filename: {win}\Resources\Themes\苹果主题-金属灰色.theme; Components: Aqua系列（4种经典发苹果电脑主题）
Name: {group}\苹果主题-金属蓝色; Filename: {win}\Resources\Themes\苹果主题-金属蓝色.theme; Components: Aqua系列（4种经典发苹果电脑主题）
Name: {group}\苹果主题-蓝色; Filename: {win}\Resources\Themes\苹果主题-蓝色.theme; Components: Aqua系列（4种经典发苹果电脑主题）
Name: {group}\Longhorn Plex M4 ICE; Filename: {win}\Resources\Themes\Longhorn Plex M4 ICE.theme; Components: Plex_Style（Windows_Long_的2个蓝色主题）
Name: {group}\Longhorn Plex M4; Filename: {win}\Resources\Themes\Longhorn Plex M4.theme; Components: Plex_Style（Windows_Long_的2个蓝色主题）
Name: {group}\桌面天气预报; Filename: {win}\Resources\Themes\桌面天气预报\XDeskWeather.exe; Components: 桌面天气预报

[Run]
Filename: {win}\Resources\Themes\tomato.url; Description: 访问 番茄花园; Flags: postinstall shellexec skipifsilent
Filename: {win}\Resources\Themes\ReadMe.txt; Description: 阅读 说明文件; Flags: postinstall shellexec skipifsilent
Filename: {win}\Resources\Themes\嫩嫩的主题-Sundaze.theme; Description: 运行 嫩嫩的主题（推荐）; Flags: postinstall shellexec skipifsilent; Components: 嫩嫩的主题-Sundaze（推荐哦）
Filename: {win}\Resources\Themes\桌面天气预报\XDeskWeather.exe; Description: 运行 桌面天气预报; WorkingDir: {win}\Resources\Themes\桌面天气预报; Flags: postinstall shellexec skipifsilent; Components: 桌面天气预报

[_ISTool]
Use7zip=true

[Types]
Name: 推荐安装; Description: 推荐安装
Name: 完全安装; Description: 完全安装
Name: 自定义安装; Description: 自定义安装; Flags: iscustom

[UninstallDelete]
Name: {win}\Resources\Themes\tomato.url; Type: files

[Registry]
Root: HKCR; SubKey: CLSID\{{2559a1f6-21d7-11d4-bdaf-00c04f60b9f0}; ValueType: string; ValueName: ; ValueData: 欢迎使用番茄花园软件; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKCR; SubKey: CLSID\{{2559a1f6-21d7-11d4-bdaf-00c04f60b9f0}; ValueType: string; ValueName: InfoTip; ValueData: 番茄花园支持信息; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKCR; SubKey: CLSID\{{2559a1f6-21d7-11d4-bdaf-00c04f60b9f0}; ValueType: string; ValueName: 　; ValueData: ; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKCR; SubKey: CLSID\{{2559a1f6-21d7-11d4-bdaf-00c04f60b9f0}\DefaultIcon; ValueType: string; ValueName: ; ValueData: OemLinkIcon.ico; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKCR; SubKey: CLSID\{{2559a1f6-21d7-11d4-bdaf-00c04f60b9f0}\DefaultIcon; ValueType: string; ValueName: 　; ValueData: ; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKCR; SubKey: CLSID\{{2559a1f6-21d7-11d4-bdaf-00c04f60b9f0}\Instance\InitPropertyBag; ValueType: string; ValueName: Command; ValueData: 番茄花园支持信息; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKCR; SubKey: CLSID\{{2559a1f6-21d7-11d4-bdaf-00c04f60b9f0}\Instance\InitPropertyBag; ValueType: string; ValueName: Param1; ValueData: sysdm.cpl; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKCR; SubKey: CLSID\{{2559a1f6-21d7-11d4-bdaf-00c04f60b9f0}\Instance\InitPropertyBag; ValueType: string; ValueName: 　; ValueData: ; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKLM; SubKey: SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\StartMenu\StartPanel\ShowOEMLink; ValueType: dword; ValueName: NoOEMLinkInstalled; ValueData: $00000000; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKLM; SubKey: SOFTWARE\Microsoft\Internet Explorer\Extensions\{{6096E38F-5AC1-4391-8EC4-75DFA92FB32F}; ValueType: string; ValueName: CLSID; ValueData: {{1FBA04EE-3024-11D2-8F1F-0000F87ABD16}; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKLM; SubKey: SOFTWARE\Microsoft\Internet Explorer\Extensions\{{6096E38F-5AC1-4391-8EC4-75DFA92FB32F}; ValueType: string; ValueName: Default Visible; ValueData: Yes; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKLM; SubKey: SOFTWARE\Microsoft\Internet Explorer\Extensions\{{6096E38F-5AC1-4391-8EC4-75DFA92FB32F}; ValueType: string; ValueName: ButtonText; ValueData: 番茄花园; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKLM; SubKey: SOFTWARE\Microsoft\Internet Explorer\Extensions\{{6096E38F-5AC1-4391-8EC4-75DFA92FB32F}; ValueType: string; ValueName: Exec; ValueData: http://bbs.tomato.ac.pn; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKLM; SubKey: SOFTWARE\Microsoft\Internet Explorer\Extensions\{{6096E38F-5AC1-4391-8EC4-75DFA92FB32F}; ValueType: string; ValueName: HotIcon; ValueData: %windir%\system32\oemlinkicon.ico; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty
Root: HKLM; SubKey: SOFTWARE\Microsoft\Internet Explorer\Extensions\{{6096E38F-5AC1-4391-8EC4-75DFA92FB32F}; ValueType: string; ValueName: Icon; ValueData: %windir%\system32\oemlinkicon.ico; Components: OEM信息; Flags: uninsdeletevalue uninsdeletekeyifempty


; 汉化新世纪论坛原文件地址：
; http://bbs.hanzify.org/index.php?showtopic=21739&hl=脚本
; 脚本用 Inno Setup 脚本向导生成。
; 查阅文档获取创建 INNO SETUP 脚本文件详细资料!

[Setup]
AppName=ePSXe
AppVerName=ePSXe 1.6.0
AppPublisher=莫尼卡
AppPublisherURL=http://wise.emuchina.net/
AppSupportURL=http://wise.emuchina.net/
AppUpdatesURL=http://wise.emuchina.net/
DefaultDirName={pf}\ePSXe
DefaultGroupName=ePSXe
AllowNoIcons=yes
InfoAfterFile=D:\new\ePSXe\请读我.txt
Compression=lzma
SolidCompression=yes
AppCopyright=版权所有 2004 Wise Studio
AppVersion=1.6.0
AppId=ePSXe
VersionInfoCompany=Wise Studio
VersionInfoVersion=0.0.0.3
UsePreviousAppDir=yes
UsePreviousGroup=yes
UsePreviousSetupType=yes
UsePreviousTasks=yes
UninstallLogMode=overwrite
Uninstallable=yes
UninstallDisplayIcon={app}\ePSXe.exe
SetupIconFile=e:\Files\Picture\ePSXe.ico

[Messages]
BeveledLabel=ePSXe 1.6.0 安装程序

[Types]
Name: "full"; Description: "完全安装"
Name: "custom"; Description: "自定义安装"; Flags: iscustom

[Components]
Name: "main"; Description: "ePSXe 1.6.0"; Types: full custom; Flags: fixed
Name: "bios"; Description: "BIOS"; Types: full custom
Name: "plugins"; Description: "插件"; Types: full custom
Name: "plugins\video"; Description: "视频插件"; Types: full custom
Name: "plugins\video\pete"; Description: "Pete's GPU 1.75"; Types: full custom
Name: "plugins\video\peops"; Description: "PE.Op.S Soft Driver 1.16"; Types: full custom
Name: "plugins\audio"; Description: "音频插件"; Types: full custom
Name: "plugins\audio\peopsa"; Description: "PE.Op.S Dsound Audio Driver 1.8"; Types: full custom
Name: "plugins\audio\eternal"; Description: "Eternal Spu 1.41"; Types: full custom
Name: "plugins\cd"; Description: "光驱插件"; Types: full custom
Name: "plugins\cd\peopscd"; Description: "PE.Op.S CDR Driver 1.4"; Types: full custom
Name: "plugins\cd\mooby"; Description: "CDR Mooby 2.8 "; Types: full custom
Name: "plugins\network"; Description: "网络插件"; Types: full custom
Name: "plugins\network\Cyberpad"; Description: "CyberPAD 1.4"; Types: full custom

[Files]
Source: "D:\new\ePSXe\ePSXe.exe"; DestDir: "{app}"; Components: main; Flags: ignoreversion
Source: "D:\new\ePSXe\请读我.txt"; DestDir: "{app}"; Components: main; Flags: ignoreversion
Source: "D:\new\ePSXe\burutter.dll"; DestDir: "{app}"; Components: main; Flags: ignoreversion
Source: "D:\new\ePSXe\cyberpad.chm"; DestDir: "{app}"; Components: plugins\network\Cyberpad; Flags: ignoreversion
Source: "D:\new\ePSXe\ePSXe.chm"; DestDir: "{app}"; Components: main; Flags: ignoreversion
Source: "D:\new\ePSXe\kailleraclient.dll"; DestDir: "{app}"; Components: plugins\network\Cyberpad; Flags: ignoreversion
Source: "D:\new\ePSXe\plugins\gpupeteD3D.dll"; DestDir: "{app}\plugins"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\gpupeteDX6D3D.dll"; DestDir: "{app}\plugins"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\gpupeteOpenGL.dll"; DestDir: "{app}\plugins"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\gpuPeopsSoft.dll"; DestDir: "{app}\plugins"; Components: plugins\video\peops; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\spuPeopsDSound.dll"; DestDir: "{app}\plugins"; Components: plugins\audio\peopsa; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\spuEternal.dll"; DestDir: "{app}\plugins"; Components: plugins\audio\eternal; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\cdrpeops.dll"; DestDir: "{app}\plugins"; Components: plugins\cd\peopscd; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\cdrmooby2.dll"; DestDir: "{app}\plugins"; Components: plugins\cd\mooby; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\cdrpeops.dll"; DestDir: "{app}\plugins"; Components: plugins\cd\peopscd; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\plugins\cpka.dll"; DestDir: "{app}\plugins"; Components: plugins\network\Cyberpad; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\bios\*"; DestDir: "{app}\bios"; Components: bios; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\cheats\*"; DestDir: "{app}\cheats"; Components: main; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\ePSXe_en.txt"; DestDir: "{app}\docs"; Components: main; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\ePSXe_sp.txt"; DestDir: "{app}\docs"; Components: main; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\gpuPeteFAQ.txt"; DestDir: "{app}\docs"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\Pete's PSX GPUs FAQ 中文翻译.txt"; DestDir: "{app}\docs"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\pete_d3d_readme_1_75.txt"; DestDir: "{app}\docs"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\pete_ogl_readme_1_75.txt"; DestDir: "{app}\docs"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\pete_ogl_d3d_version_1_75.txt"; DestDir: "{app}\docs"; Components: plugins\video\pete; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\peops_soft_readme_1_16.txt"; DestDir: "{app}\docs"; Components: plugins\video\peops; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\peops_soft_version_1_16.txt"; DestDir: "{app}\docs"; Components: plugins\video\peops; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\readme_1_8.txt"; DestDir: "{app}\docs"; Components: plugins\audio\peopsa; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\version_1_8.txt"; DestDir: "{app}\docs"; Components: plugins\audio\peopsa; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\readme(e).txt"; DestDir: "{app}\docs"; Components: plugins\audio\eternal; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\notes.txt"; DestDir: "{app}\docs"; Components: plugins\cd\mooby; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\readme_1_4.txt"; DestDir: "{app}\docs"; Components: plugins\cd\peopscd; Flags: ignoreversion recursesubdirs
Source: "D:\new\ePSXe\docs\version_1_4.txt"; DestDir: "{app}\docs"; Components: plugins\cd\peopscd; Flags: ignoreversion recursesubdirs
; 注意: 不要在任何共享系统文件中使用“Flags: ignoreversion”

[Dirs]
Name: "{app}\memcards"; Components: main; Flags: uninsalwaysuninstall
Name: "{app}\patches"; Components: main; Flags: uninsalwaysuninstall
Name: "{app}\snap"; Components: main; Flags: uninsalwaysuninstall
Name: "{app}\sstates"; Components: main; Flags: uninsalwaysuninstall

[Tasks]
; 注意: 下面的条目包含一个中文用语 (“创建桌面快捷方式”和“添加快捷方式”)。如果需要你可以翻译为其它语言。
Name: "desktopicon"; Description: "创建桌面快捷方式"; GroupDescription: "添加快捷方式:"; Flags: unchecked

[Icons]
Name: "{group}\ePSXe"; Filename: "{app}\ePSXe.exe"; WorkingDir: "{app}"
; 注意: 下面的条目包含一个中文用语 (“卸载”)。如果需要你可以翻译为其它语言。
Name: "{group}\ePSXe 帮助"; Filename: "{app}\ePSXe.chm"; WorkingDir: "{app}"
Name: "{group}\卸载 ePSXe"; Filename: "{uninstallexe}"
Name: "{userdesktop}\ePSXe"; Filename: "{app}\ePSXe.exe"; WorkingDir: "{app}"; Tasks: desktopicon

[Run]
; 注意: 下列条目包含一个中文用语 (“运行”)。如果需要你可以翻译为其它语言。
Filename: "{app}\ePSXe.exe"; Description: "运行 ePSXe"; Flags: nowait postinstall skipifsilent


; 汉化新世纪论坛原文件地址：
; http://bbs.hanzify.org/index.php?showtopic=14706&hl=关于导入注册表的几种方法
; 脚本由 Inno Setup 脚本设计向导 创建。
; 有关创建 INNO SETUP 脚本的详情请查阅帮助文档！

[Setup]
DisableStartupPrompt=yes
AppName=Attribute Changer 5.21 汉化版
AppVerName=Attribute Changer 5.21 汉化版
DefaultDirName={pf}\Attribute Changer 汉化版
DefaultGroupName=Attribute Changer 5.21 汉化版
InfoBeforeFile=E:\MyHanzify\Attribute Changer 5.21\upload\files\汉化说明.txt

[Files]
Source: "E:\MyHanzify\Attribute Changer 5.21\upload\files\*.*"; DestDir: "{app}"; Flags: ignoreversion recursesubdirs uninsrestartdelete

[Icons]
Name: "{group}\Attribute Changer 帮助"; Filename: "{app}\help\ac.chm"
Name: "{group}\卸载 Attribute Changer 5.21 汉化版"; Filename: "{uninstallexe}"

[Registry]
Root: HKLM; Subkey: "SOFTWARE\Classes\*\shellex\ContextMenuHandlers\ACShell"; ValueType: string; ValueData: "{{D3F9A525-8824-497A-BE36-B23E22F141FC}"; Flags: uninsdeletekey

Root: HKLM; Subkey: "SOFTWARE\Classes\acshell.ACShell\Clsid"; ValueType: string; ValueData: "{{D3F9A525-8824-497A-BE36-B23E22F141FC}"
Root: HKLM; Subkey: "SOFTWARE\Classes\acshell.ACShell"; ValueType: string; ValueData: "Attribute Changer Shell Extension"; Flags: uninsdeletekey

Root: HKLM; Subkey: "SOFTWARE\Classes\CLSID\{{D3F9A525-8824-497A-BE36-B23E22F141FC}"; ValueType: string; ValueData: "Attribute Changer Shell Extension"; Flags: uninsdeletekey
Root: HKLM; Subkey: "SOFTWARE\Classes\CLSID\{{D3F9A525-8824-497A-BE36-B23E22F141FC}\InprocServer32"; ValueType: string; ValueData: "{app}\acshell.dll"
Root: HKLM; Subkey: "SOFTWARE\Classes\CLSID\{{D3F9A525-8824-497A-BE36-B23E22F141FC}\InprocServer32"; ValueType: string; ValueName: "ThreadingModel"; ValueData: "Apartment"
Root: HKLM; Subkey: "SOFTWARE\Classes\CLSID\{{D3F9A525-8824-497A-BE36-B23E22F141FC}\ProgID"; ValueType: string; ValueData: "acshell.ACShell"

Root: HKLM; Subkey: "SOFTWARE\Classes\Directory\shellex\ContextMenuHandlers\ACShell"; ValueType: string; ValueData: "{{D3F9A525-8824-497A-BE36-B23E22F141FC}"; Flags: uninsdeletekey

Root: HKLM; Subkey: "SOFTWARE\Classes\Drive\shellex\ContextMenuHandlers\ACShell"; ValueType: string; ValueData: "{{D3F9A525-8824-497A-BE36-B23E22F141FC}"; Flags: uninsdeletekey

Root: HKLM; Subkey: "SOFTWARE\Classes\InternetShortCut\shellex\ContextMenuHandlers\ACShell"; ValueType: string; ValueData: "{{D3F9A525-8824-497A-BE36-B23E22F141FC}"; Flags: uninsdeletekey

Root: HKLM; Subkey: "SOFTWARE\Classes\lnkfile\shellex\ContextMenuHandlers\ACShell"; ValueType: string; ValueData: "{{D3F9A525-8824-497A-BE36-B23E22F141FC}"; Flags: uninsdeletekey

Root: HKLM; Subkey: "SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved"; ValueType: string; ValueName: "{{D3F9A525-8824-497A-BE36-B23E22F141FC}"; ValueData: "Attribute Changer Shell Extension"; Flags: uninsdeletekey

Root: HKLM; Subkey: "SOFTWARE\Microsoft\Windows\Help"; ValueType: string; ValueName: "ac.chm"; ValueData: "{app}"; Flags: uninsdeletekey
Root: HKLM; Subkey: "SOFTWARE\Microsoft\Windows\Help"; ValueType: string; ValueName: "acui.hlp"; ValueData: "{app}"; Flags: uninsdeletekey


; 汉化新世纪论坛原文件地址：
; http://bbs.hanzify.org/index.php?s=6955b60a7de241cf123a1c2e24f88d24&showtopic=17878
; 脚本由 Inno Setup 脚本向导 生成。
; 查看帮助文档以获取创建 Inno Setup 脚本的详细资料！

[Setup]
AppName=ISTool
AppVerName=ISTool 3.0.6.2
AppPublisher=Bj鴕nar Henden
AppPublisherURL=http://www.istool.org/
AppSupportURL=http://www.istool.org/
AppUpdatesURL=http://www.istool.org/
DefaultDirName={pf}\ISTool
DefaultGroupName=ISTool
InfoBeforeFile=D:\ISTool\汉化说明.txt

[Tasks]
Name: desktopicon; Description: 创建一个桌面图标(&D); GroupDescription: 添加图标：
Name: quicklaunchicon; Description: 创建一个快速启动栏图标(&Q); GroupDescription: 添加图标：; Flags: unchecked
Name: addreg; Description: 将 .iss 文件和 ISTool 关联; GroupDescription: 创建关联：

[Files]
Source: D:\ISTool\ISTool.exe; DestDir: {app}; Flags: ignoreversion
Source: D:\ISTool\*.*; DestDir: {app}; Flags: ignoreversion
Source: D:\ISTool\include\*.*; DestDir: {app}\include; Flags: ignoreversion
Source: D:\ISTool\isxdl\*.*; DestDir: {app}\isxdl; Flags: ignoreversion
; 注意：不要使用“Flags: ignoreversion”在任何共享的系统文件上

[INI]
Filename: {app}\ISTool.url; Section: InternetShortcut; Key: URL; String: http://www.istool.org/

[Icons]
Name: {group}\ISTool; Filename: {app}\ISTool.exe
Name: {group}\ISTool 网站; Filename: {app}\ISTool.url
Name: {group}\卸载 ISTool; Filename: {uninstallexe}
Name: {userdesktop}\ISTool; Filename: {app}\ISTool.exe; Tasks: desktopicon; Comment: ISTool; IconIndex: 0
Name: {userappdata}\Microsoft\Internet Explorer\Quick Launch\ISTool; Filename: {app}\ISTool.exe; Tasks: quicklaunchicon; IconIndex: 0
Name: {group}\汉化说明; Filename: {app}\汉化说明.txt

[Run]
Filename: {app}\ISTool.exe; Description: 运行 ISTool; Flags: nowait postinstall skipifsilent

[UninstallDelete]
Type: files; Name: {app}\ISTool.url
Name: {app}; Type: filesandordirs

[_ISTool]
EnableISX=false

[Messages]
AboutSetupNote=ISTool 3.0.6.2
BeveledLabel=ISTool

[Registry]
Root: HKCR; SubKey: .iss; ValueType: string; ValueData: InnoSetupScriptFile; Tasks: addreg
Root: HKCR; SubKey: InnoSetupScriptFile; ValueType: string; ValueData: Inno Setup 脚本; Tasks: addreg
Root: HKCR; SubKey: InnoSetupScriptFile\DefaultIcon; ValueType: string; ValueData: {app}\ISTool.exe,0; Tasks: addreg
Root: HKCR; SubKey: InnoSetupScriptFile\shell\OpenWithISTool; ValueType: string; ValueData: 用 ISTool 打开(&I); Flags: uninsdeletekey; Tasks: addreg
Root: HKCR; SubKey: InnoSetupScriptFile\shell\OpenWithISTool\command; ValueType: string; ValueData: "{app}\ISTool.exe ""%1"""; Flags: uninsdeletekey; Tasks: addreg
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Settings; ValueType: dword; ValueName: FrameStatus; ValueData: $00000001
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Settings; ValueType: dword; ValueName: FrameTop; ValueData: $00000006
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Settings; ValueType: dword; ValueName: FrameLeft; ValueData: $00000000
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Settings; ValueType: dword; ValueName: FrameBottom; ValueData: $00000236
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Settings; ValueType: dword; ValueName: FrameRight; ValueData: $00000320
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Settings; ValueType: binary; ValueName: LVx02Columns; ValueData: 0a 00 b4 80 b4 00 b4 80 96 00 96 80 96 00 50 00 50 00 64 00 64 00
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Settings; ValueType: binary; ValueName: LVx02Order; ValueData: 00 00 00 00 01 00 00 00 02 00 00 00
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: binary; ValueName: EditorFont; ValueData: f3 ff ff ff 00 00 00 00 00 00 00 00 00 00 00 00 90 01 00 00 00 00 00 00 03 02 01 31 d0 c2 cb ce cc e5 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: ReplaceCopy; ValueData: $00000001
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: AutoComponentSelect; ValueData: $00000000
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: TestCompiledSetup; ValueData: $00000001
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: FilesAsList; ValueData: $00000001
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: IconsAsList; ValueData: $00000001
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: RegistryAsList; ValueData: $00000001
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: IgnoreDefaults; ValueData: $00000000
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: DefaultISX; ValueData: $00000000
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: OverwriteMessages; ValueData: $00000000
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: string; ValueName: InnoFolder; ValueData:
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: string; ValueName: ExtFolder; ValueData:
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: string; ValueName: ScriptFolder; ValueData:
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: ToolBar; ValueData: $00000001
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: StatusBar; ValueData: $00000001
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: SectionPanel; ValueData: $00000001
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: OpenLastProject; ValueData: $00000000
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: ShowNewWizard; ValueData: $00000001
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: StartupSection; ValueData: $00008051
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: string; ValueName: LanguageFile; ValueData: {app}\Chinese(GB).lng
Root: HKCU; SubKey: Software\Bjornar Henden\ISTool\Prefs; ValueType: dword; ValueName: SplitterPos; ValueData: $000000a4
Root: HKCU; Subkey: Software\Bjornar Henden\ISTool; ValueType: none


关于汉化新世纪

` 关于汉化新世纪 汉化新世纪 | 汉化新世纪论坛
  • 关于汉化新世纪

        汉化新世纪是一个非商业性质的自由合作站点，世纪最根本的目的是为了推动我国计算机使用的普及，为我中华计算机事业尽一份绵薄之力，希望通过我们的世纪站点，能为更多的朋友学习计算机，使用计算机提供方便之门。同时，也为所有有志于软件中文化的自由汉化人提供一个交流、学习的场地。网站目前主要以收集整理简体中文汉化程序、汉化教学和即时交流平台为主。

    • 　　汉化新世纪创建于千禧年(2000年)2月1日，将近三年的发展历程中，我们得到了无数朋友的关心和支持，在我们最困难的时候，始终有很多朋友在关注、支持着汉化新世纪，我们感到非常的欣慰，正因为有了大家的无私奉献，我们才能一步一步的向前走。汉化新世纪提供的所有资源，仅限于个人及教育用途，决非为任何商业目的。如果说我们的努力能然更多的用户步入计算机的殿堂，那么我们将不遗余力地坚持到底。在今后的某一天，当我们再次回顾汉化新世纪的成长时，真心希望我们的汉化新世纪已经没有存在的意义，因为那时候，中华的IT事业已经处于世界的颠峰！

        所有汉化新世纪成员遵循着同一个宗旨：“汉化补丁是自由的，汉化技术是自由的，我们拒绝任何垄断的行为！”
  • 联系我们
            •

        汉化新世纪: http://www.hanzify.org/
        汉化新世纪论坛: http://bbs.hanzify.org/
        联系邮件: webmaster@hanzify.org
    汉化月刊/汉化教学站: http://www.hhteach.org/

    ©2000-2003 www.hanzify.org All rights reserved.
    By     Hanzify Team 2002.11